Jump to content

Installer gnome sur FreeBSD


Recommended Posts

Bonsoir

Bon j'ai finis par graver les images des 2 cd de la derniere version de freebsd , j'installe , tout se passe bien .

Lorsque elle est fini je suis en mode console , je mets startx, une interface avec un fond gris et 3 fenetre apparait , je me documentes pour lancer gnome ou kde , il faut installer xorg , ok je regarde ici

http://www.fr.freebsd.org/doc/fr_FR.ISO885.../x-install.html

.

Donc en console je tape :" # cd /usr/ports/x11/xorg" la ok puis

"# make install clean" mais la ca mets un tas de ligne puis il ya ecris un truc par rapport a dri " error 1 "

Merci de m'aider pour installer Xorg .

J'ai édité le titre pour une meilleure comprehension .

Link to comment
Share on other sites

En effet, ton Xorg à l'air d'être installé... Je te conseil de regader les tutoriaux de PCI sur FreeBSD c'est une véritable mine d'or d'informations :eeek2:

Les compils de Gnome ou de KDE ça met son temps aussi, préfère peut-être des WM plus légers.

Bon courage !

Link to comment
Share on other sites

:cartonjaune: Toujours un probleme , en effet je viends de faire ca :

Editez le fichier .xinitrc . Il doit contenir les informations sur le gestionnaire de bureau à démarrer.
CODE

%vi .xinitrc  
~
~
~
~
~
~

~
~
~
~
.xinitrc: unmodified: line 1

Il est vide? alors c'est normal de ne pas démarrer Gnome2 il faut le renseigner.
CODE

i										   passez en mode insertion
exec gnome-session			renseignez le fichier avec l'executable qui démarrera lorsque vous lancerez le X
:wq!									   ecrivez le fichier et quittez.

ensuite vous allez tuer le processus X 2 méthodes:
CODE

%su -
%password:
§top

repérez le numéro du processus du X.
Chaque processus s'affiche par ligne, sur les colonnes les renseignements permettent de connaitre un certain nombre d'informations. Recherchez la colonne PID
CODE

last pid: 55253;  load averages:  0.07,  0.03,  0.04	up 0+23:50:08  23:50:58
53 processes:  2 running, 50 sleeping, 1 zombie
CPU states: 23.0% user,  0.0% nice,  8.2% system,  1.9% interrupt, 66.9% idle
Mem: 351M Active, 431M Inact, 171M Wired, 41M Cache, 111M Buf, 3036K Free
Swap: 2023M Total, 108K Used, 2023M Free

PID USERNAME PRI NICE   SIZE	RES STATE	TIME   WCPU	CPU COMMAND
55221 cccc	 20	0 19836K 14580K kserel   0:06 10.16% 10.16% gnome-termina
479 cccc	 78	0   170M 78392K select 105:19  3.91%  3.91% Xorg
419 root	  77	0  1300K   700K select   5:52  1.56%  1.56% moused
608 cccc	 76	0 64400K 58740K select  30:32  0.00%  0.00% opera
43765 cccc	 20	0 15432K 10524K kserel  10:42  0.00%  0.00% gftp-gtk
9925 cccc	 76	0   123M 83992K select   9:25  0.00%  0.00% soffice.bin
787 cccc	 76	0 22132K 14596K select   8:56  0.00%  0.00% python
517 cccc	 76	0 12868K  9252K select   1:58  0.00%  0.00% metacity
560 cccc	 76	0 16708K 11508K select   1:01  0.00%  0.00% wnck-applet
544 cccc	 20	0 31748K 25152K kserel   0:55  0.00%  0.00% nautilus
542 cccc	 76	0 26056K 20000K select   0:45  0.00%  0.00% gnome-panel
546 cccc	 76	0 15684K  9168K select   0:33  0.00%  0.00% mixer_applet2
506 cccc	 76	0  3236K  2092K select   0:31	0.00%  0.00% xscreensaver
491 cccc	 76	0  7380K  3924K select   0:21  0.00%  0.00% gnome-smproxy
493 cccc	 76	0 17620K 10108K select   0:19  0.00%  0.00% gnome-setting
482 cccc	 76	0 15780K  9700K select   0:13  0.00%  0.00% gnome-session


ici Xorg a un PID 479.
entrez simplement k -9 479 et votre serveur X s'arrêtera.
vous vous retrouvez donc en console.

Une autre solution consiste à revenir sur la première console:
CTRL+ALT+F1
Sur cette console, le X fonctionne, donc vous n'avez pas l'invite de commande, mais vous voyez un etat de fonctionnement du X.
entrez simplement CTRL+C pour tuer le processus X.
ensuite vous avez la main.

Mais je ne demarre quand meme pas sur gnome , meme si je tape exec gnome , exec gnome-session ,start gnome ,startgnome, et je viends de remarquer que meme si j'enregistre , la ligne s'efface apres .

Merci de m'aider

Link to comment
Share on other sites

salut,

as tu bien mis à jour tes ports via portsnap : http://www.freebsd.org/doc/fr_FR.ISO8859-1...k/portsnap.html ?

Pourquoi n'utilises tu pas un gestionnaire de connexion, style gdm : x11/gdm (gdm installe un script de démarrage dans /usr/local/etc/rc.d/gdm.sh, il suffit de mettre gdm_enable="YES" dans /etc/rc.conf pour que gdm se lance au démarrage de la machine)

si tu ne veux pas compiler tes softs mais utiliser des packages plus récent que lors de la release 6.1 met cette variable d'environnement : setenv PACKAGESITE "ftp://ftp.fr.freebsd.org/pub/FreeBSD/ports/i386/packages-current/Latest/"

(cf le site : http://imil.net/docs/sexy-FreeBSD.txt)

A+

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...