Jump to content

Configurer wpa_supplicant et madwifi


Recommended Posts

Salut à tous! :transpi:

J'a récement installé Linux fedora core 5 sur mon pc. Mais je rencontre quelques problèmes pour configurer le wifi avec une ip fixe et le cryptage wpa-psk.

Ma carte wifi est une D-link Dwk-g520 avec un dongle atheros AR5212.

J'ai donc mis à jour le depot livna et lancé yum install madwifi. Jusque là tout se passe bien. Quand je tape la commande iwconfig j'obtient:

ath0 IEEE 802.11g ESSID:""

Mode:Managed Channel:0 Access Point: Not-Associated

Bit Rate:0 kb/s Tx-Power:18 dBm Sensitivity=0/3

Retry:off RTS thr:off Fragment thr:off

Encryption key:off

Power Management:off

Link Quality=0/94 Signal level=-95 dBm Noise level=-95 dBm

Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0

Tx excessive retries:0 Invalid misc:0 Missed beacon:0

Je lance les commandes pour paramétrer l'ip l'ssid la passerelle etc... :

ifconfig ath0 192.168.0.2 netmask 255.255.255.0

route add default gw 192.168.0.1 ath0

iwconfig ath0 essid neho

iwconfig ath0 channel 6

j'ai donc tenté de configurer wpa_supplicant j'y ait donc rentré lesinfos suivantes:

ctrl_interface=/var/run/wpa_supplicant

network={

ssid="NEHO"

scan_ssid=1

proto=WPA

key_mgmt=WPA-PSK

psk="ma clé"

}

Je tente d'initialiser avec la commande:

wpa_supplicant -i ath0 -D madwifi -c /etc/wpa_supplicant/wpa_supplicant.conf

mais la le pc me retourne:

ICE default IO error handler doing an exit(), pid = 2804, errno = 0

Trying to associate with 00:11:95:2e:22:30 (SSID='NEHO' freq=2437 MHz)

ioctl[iEEE80211_IOCTL_SETMLME]: Invalid argument

Association request to the driver failed

Associated with 00:11:95:2e:22:30

WPA: Key negotiation completed with 00:11:95:2e:22:30 [PTK=TKIP GTK=TKIP]

CTRL-EVENT-CONNECTED - Connection to 00:11:95:2e:22:30 completed (auth)

Impossible de trouver d'ou vient le problème...

De plus quand je reboot le pc, les paramètres rentrés avec les commandes suivantes sont perdus:

ifconfig ath0 192.168.0.2 netmask 255.255.255.0

route add default gw 192.168.0.1 ath0

iwconfig ath0 essid neho

iwconfig ath0 channel 6

Si quelqu'un pouvait m'aider!

Merci

Link to comment
Share on other sites

En gros tous les fichiers pour résumer(theoriquement je n'ai pas de commande à taper pour que tout se lance au demarrage du pc?):

-iwconfig donne tout de suite apres le demarrage:

th0 IEEE 802.11g ESSID:"NEHO" Nickname:"localhost.localdomain"

Mode:Managed Channel:0 Access Point: Not-Associated

Bit Rate:0 kb/s Tx-Power:18 dBm Sensitivity=0/3

Retry:off RTS thr:off Fragment thr:off

Encryption key:off

Power Management:off

Link Quality=0/94 Signal level=-95 dBm Noise level=-95 dBm

Rx invalid nwid:169 Rx invalid crypt:0 Rx invalid frag:0

Tx excessive retries:0 Invalid misc:0 Missed beacon:

-test de la commande wpa_supplicant -iath0 -Dmadwifi -c/etc/wpa_supplicant.conf qui ne change rien:

Trying to associate with 00:11:95:2e:22:30 (SSID='NEHO' freq=2437 MHz)

ioctl[iEEE80211_IOCTL_SETMLME]: Invalid argument

Association request to the driver failed

Associated with 00:11:95:2e:22:30

WPA: Key negotiation completed with 00:11:95:2e:22:30 [PTK=TKIP GTK=TKIP]

CTRL-EVENT-CONNECTED - Connection to 00:11:95:2e:22:30 completed (auth)

CTRL-EVENT-TERMINATING - signal 2 received

-wpa_supplicant.conf

ctrl_interface=/var/run/wpa_supplicant

network={

ssid="NEHO"

scan_ssid=1

proto=WPA

key_mgmt=WPA-PSK

psk="ma cle"

}

- contenu de /etc/sysconfig/network-scripts/ifcfg-ath0

DEVICE=ath0

BOOTPROTO=none

ONBOOT=yes

IPADDR=192.168.0.7

NETMASK=255.255.255.0

NETWORK=192.168.0.0

BROADCAST=192.168.0.255

MII_NOT_SUPPORTED=yes

# Wifi

MODE=Managed

ESSID=NEHO

CHANNEL=6

WPA=yes # Utilisez-vous le cryptage des donn�s de type WPA-PSK ?

TYPE=Wireless

HWADDR=00:13:46:8a:8a:68

USERCTL=no

IPV6INIT=no

PEERDNS=yes

GATEWAY=192.168.0.1

RATE=Auto

Je ne sais pas trop quoi mettre dans

NETWORK=192.168.0.0

BROADCAST=192.168.0.255

USERCTL=no

IPV6INIT=no

PEERDNS=yes

RATE=Auto

-/etc/default/wpasupplicant:

# /etc/default/wpasupplicant

# WARNING! Make sure you have a configuration file!

ENABLED=1

# Useful flags:

# -D <driver> Wireless Driver

# -i <ifname> Interface (required, unless specified in config)

# -c <config file> Configuration file

# -d Debugging (-dd for more)

# -w Wait for interface to come up

OPTIONS="-w -Dmadwifi -iath0 -d"

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...