Jump to content

[PROBLEME] Apache + PHP5 + MySQL + FTP


Recommended Posts

Bonjour,

J'ai un petit problème actuellement. J'ai passé un peu de temps ce matin a installer sur ma machine un serveur Apache 2.2.2, configuré pour fonctionner de pair avec PHP 5.14 et MySQL5. J'ai également installé FileZilla server, pour faire bon poids. Le tout tourne windows (Oui, je sais, c'est contre nature).

Tout c'est bien passé, juste le firewall windows était un peu récalcitrant, mais bon. J'ai en vitesse mis CMS Made Simple, pour voir, tout marchait bien.

La je viens de tenter de poursuivre mon exploration de CMS Made Simple, et plus moyen de lancer la page, que ce soit en localhost, avec l'adresse IP de ma machine ou encore via le petit DynDNS que j'ai créé en même temps. Le serveur est apparement TREEEEEES lent à répondre (timeout que ce soit en local ou via dyndns). MySQL est lancé, Apache aussi, et le Server-Status donne une réponse normale. Ah oui, je parviens a me connecter sur le serveur FTP (Filezilla) mais uniquement en local (127.0.0.1), pas via le DynDNS.

Donc voilà, si quelqu'un a une idée de ce qui aurait pu changer.

Voici les trucs auquel j'ai déjà pensé :

- La machine n'avait pas été rebootée depuis l'install du serveur quand les problémes sont apparus. J'ai donc rebooté et tenté de relancer MySQL + Apache.

- Mon FAI (Belgacom Skynet) a changé mon IP (DynDNS est à jour niveau IP, pas de probléme de ce coté là)

- L'IP de mon ordinateur n'a pas changé sur le réseau.

- Une désactivation du firewall ne change rien.

- En local, je parviens a accéder à de petit fichiers, ou encore faire un PHP Info. Donc PHP marche bien. Par contre timeout via le DynDNS toujours.

Voilà, donc helpeu ...

Si il faut plus d'infos, n'hésitez pas a demander

Link to comment
Share on other sites

La je viens de tenter de poursuivre mon exploration de CMS Made Simple, et plus moyen de lancer la page, que ce soit en localhost, avec l'adresse IP de ma machine ou encore via le petit DynDNS que j'ai créé en même temps. Le serveur est apparement TREEEEEES lent à répondre (timeout que ce soit en local ou via dyndns). MySQL est lancé, Apache aussi, et le Server-Status donne une réponse normale. Ah oui, je parviens a me connecter sur le serveur FTP (Filezilla) mais uniquement en local (127.0.0.1), pas via le DynDNS.

bonsoir,

tu utilises bien dynDNS pour résoudre ton serveur ?

tu t'es inscrit sur www.dyndns.org je suppose :-D

quelle est la configuration de ton réseau ?

est-ce que c'est juste le PC relié au modem de ton FAI qui te permet d'aller sur Internet ?

ou est-ce que tu utilises un équipement réseau type switch ou routeur ethernet entre ton modem et Internet ?

as-tu essayé de redémarrer complètement ta machine ?

Donc voilà, si quelqu'un a une idée de ce qui aurait pu changer.

Voici les trucs auquel j'ai déjà pensé :

- La machine n'avait pas été rebootée depuis l'install du serveur quand les problémes sont apparus. J'ai donc rebooté et tenté de relancer MySQL + Apache.

- Mon FAI (Belgacom Skynet) a changé mon IP (DynDNS est à jour niveau IP, pas de probléme de ce coté là)

- L'IP de mon ordinateur n'a pas changé sur le réseau.

- Une désactivation du firewall ne change rien.

- En local, je parviens a accéder à de petit fichiers, ou encore faire un PHP Info. Donc PHP marche bien. Par contre timeout via le DynDNS toujours.

très bonnes démarches pour débugger :D

déjà à première lecture, tous tes services fonctionnent correctement que ce soit PHP, MySQL ou Apache

est-ce que pour le dynDNS c'est ton FAI qui gère ça ?

est-ce qu'un de tes amis arrivent à se connecter sur ton FTP ou ton serveur Web via le nom de domaine dynDNS ?

tiens nous au courant de tes investigations

bon courage

sunfun

Link to comment
Share on other sites

Alors, lors du reboot ce matin j'ai plusieurs nouveaux éléments.

- Je suis en effet derriére un routeur-modem avec NAT, les ports 80 et 21 sont fowardés vers ma machine (mon PC a une IP fixe).

- Lorsque je tente de lancer la page, il me demande le mot de passe de mon routeur (SMC Barricade 7904BRA). Puis aprés 3 minutes, ca marche correctement. Curieux.

Ce qui me perturbe surtout c'est que une fois ca marche, une fois ca marche pas.

Link to comment
Share on other sites

Bonjour,

En fait si tu n'arrives pas à pointer sur ton adresse dyndns.org depuis l'intérieur de ton réseau c'est normal. A cause du NAT ta requête DNS te revoie sur ton routeur.

Le seul moyen que tu es (et il est superflu) c'est d'ajouter la correspondance entre l'ip de ton serveur (privé donc) et ton adresse dyndns.org dans le fichiers host de ta machine (ainsi tu chuinte la requete DNS).

Link to comment
Share on other sites

Bonjour,

En fait si tu n'arrives pas à pointer sur ton adresse dyndns.org depuis l'intérieur de ton réseau c'est normal. A cause du NAT ta requête DNS te revoie sur ton routeur.

Le seul moyen que tu es (et il est superflu) c'est d'ajouter la correspondance entre l'ip de ton serveur (privé donc) et ton adresse dyndns.org dans le fichiers host de ta machine (ainsi tu chuinte la requete DNS).

Merci bien de ta réponse. Cela dit j'arrive trés correctement a pointer mon DynDNS depuis l'intérieur de mon réseau. Pour accéder à mon serveur Apache, j'ai 3 adresse possibles : le localhost, l'ip de ma machine, l'ip de mon réseau (autrement dit, mon DynDNS).

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...