Jump to content

[debian] grosse boulette


Recommended Posts

salut a tous

ce matin j'ai fait un aptitude upgrade et fait un peu de menage dans mes appli.

ce qu'il s'est passé est etonnant c la premiere fois que ca me fait ca.

tous le systeme a ete mis en vrac. kde xorg openoffice et j'en passe se sont desinstallé

heureusement un petit coup de aptitude kde etc... et c'est reparti sauf pour le driver nvidia impossible de le remettre

j'ai essayé de reinstaller le driver impossible.

alors si quelqu'un a la soluce merci

lsmod :

Module Size Used by

nls_iso8859_1 4032 2

nls_cp437 5696 2

vfat 11968 2

fat 46428 1 vfat

isofs 33400 0

udf 74628 0

appletalk 32752 0

ax25 49816 0

ipx 25452 0

smbfs 57848 3

binfmt_misc 10632 1

ipv6 222976 10

button 6544 0

ac 4740 0

battery 9476 0

sk98lin 142304 0

dm_mod 51576 0

nvidia_agp 7260 0

agpgart 31496 1 nvidia_agp

sr_mod 16420 0

sbp2 21380 0

ide_generic 1216 0 [permanent]

eth1394 18696 0

i2c_nforce2 6336 0

i2c_core 19408 1 i2c_nforce2

snd_emu10k1 97252 3

snd_mpu401 6344 0

snd_mpu401_uart 6656 1 snd_mpu401

snd_ac97_codec 82528 1 snd_emu10k1

snd_pcm 77704 4 snd_emu10k1,snd_ac97_codec

snd_timer 21444 2 snd_emu10k1,snd_pcm

snd_ac97_bus 2112 1 snd_ac97_codec

usblp 11648 0

snd_rawmidi 22688 2 snd_emu10k1,snd_mpu401_uart

snd_seq_device 8012 2 snd_emu10k1,snd_rawmidi

snd_page_alloc 9992 2 snd_emu10k1,snd_pcm

snd_util_mem 4352 1 snd_emu10k1

analog 10400 0

snd_hwdep 8480 1 snd_emu10k1

snd 48740 13 snd_emu10k1,snd_mpu401,snd_mpu401_uart,snd_ac97_codec,snd_pcm,snd_timer,snd_rawmidi,snd_seq_device,snd_hwdep

emu10k1_gp 3520 0

rtc 11508 0

parport_pc 32324 0

parport 31880 1 parport_pc

soundcore 8992 1 snd

pcspkr 1732 0

gameport 14024 3 analog,emu10k1_gp

psmouse 32516 0

serio_raw 6596 0

joydev 8960 0

evdev 8896 2

mousedev 10592 1

ext3 118664 2

jbd 48724 1 ext3

mbcache 8516 1 ext3

usbhid 32608 0

sd_mod 17360 2

ide_cd 36804 0

cdrom 33568 2 sr_mod,ide_cd

ide_disk 15936 5

usb_storage 65408 0

sata_nv 8836 1

ehci_hcd 29064 0

ohci_hcd 17860 0

usbcore 113924 6 usblp,usbhid,usb_storage,ehci_hcd,ohci_hcd

amd74xx 12892 0 [permanent]

generic 4356 0 [permanent]

ide_core 112928 6 ide_generic,ide_cd,ide_disk,usb_storage,amd74xx,generic

forcedeth 20228 0

sata_sil 8964 0

libata 51724 2 sata_nv,sata_sil

scsi_mod 126120 5 sr_mod,sbp2,sd_mod,usb_storage,libata

ohci1394 30452 0

ieee1394 89208 3 sbp2,eth1394,ohci1394

skge 33936 0

thermal 13512 0

processor 22976 1 thermal

fan 4676 0

nvidia installer

nvidia-installer log file '/var/log/nvidia-installer.log'

creation time: Sat Jun 10 12:12:52 2006

option status:

license pre-accepted : false

update : false

force update : false

expert : false

uninstall : false

driver info : false

no precompiled interface: false

no ncurses color : false

query latest driver ver : false

OpenGL header files : true

no questions : false

silent : false

no backup : false

kernel module only : false

sanity : false

add this kernel : false

no runlevel check : false

no network : false

no ABI note : false

no RPMs : false

force tls : (not specified)

force compat32 tls : (not specified)

X install prefix : /usr/X11R6

OpenGL install prefix : /usr

compat32 install prefix : (not specified)

installer install prefix: /usr

utility install prefix : /usr

kernel name : (not specified)

kernel include path : (not specified)

kernel source path : (not specified)

kernel output path : (not specified)

kernel install path : (not specified)

proc mount point : /proc

ui : (not specified)

tmpdir : /tmp

ftp mirror : ftp://download.nvidia.com

RPM file list : (not specified)

Using: nvidia-installer ncurses user interface

-> License accepted.

-> There appears to already be a driver installed on your system (version: 1.0-

8756). As part of installing this driver (version: 1.0-8762), the existing

driver will be uninstalled. Are you sure you want to continue? ('no' will a

bort installation) (Answer: Yes)

-> No precompiled kernel interface was found to match your kernel; would you li

ke the installer to attempt to download a kernel interface for your kernel f

rom the NVIDIA ftp site (ftp://download.nvidia.com)? (Answer: No)

-> No precompiled kernel interface was found to match your kernel; this means

that the installer will need to compile a new kernel interface.

-> Performing CC test with CC="cc".

-> Kernel source path: '/usr/src/linux'

-> Kernel output path: '/usr/src/linux'

-> Performing rivafb check.

-> Performing nvidiafb check.

ERROR: Your kernel was configured to include nvidiafb support!

The nvidiafb driver conflicts with the NVIDIA driver, please

reconfigure your kernel and *disable* nvidiafb support, then

try installing the NVIDIA kernel module again.

ERROR: Installation has failed. Please see the file

'/var/log/nvidia-installer.log' for details. You may find suggestions

on fixing installation problems in the README available on the Linux

driver download page at www.nvidia.com.

Link to comment
Share on other sites

Tu n'aurais pas compilé ton kernel avec la gestion du framebuffer nvidia ? si oui, il faut l'enlever.

?? Ou peut-être décharger le module nvidiafb ??

merci pour ton aide

donc j'ai regardé pour le module nvidiafb il ny est pas

framebuffer est acivé en effet, ceci dit c est tout de meme bisare puisque ca fonctionnait bien avant.

enfin je fais une recompil en 2.6.15 et on verra ce que ca donne.

je vous tiens au courant

merci

Link to comment
Share on other sites

salut a tous

suite a mes problemes impossible de relancer le module nvidia.

j'ai fais une recompile

desactivé le frame buffer dans le noyau

desactivé l'agpgart

reinstaller les pilotes nvidia officiel

impossible de lancer le module nvidia il me dit qu'il n'existe pas

donc la je seche total

merci pour votre aide

Link to comment
Share on other sites

est-ce que tu aurais plusieurs version différente des sources du noyaux ?

Il me semble que les drivers nvidia se compile d'après les sources (et leurs fichier .config) situé dans "/usr/src/linux/" qui est en général un lien symbolique vers un répertoire "/usr/src/linux-[numero_de_version]"

Donc si le symlink est mauvais, les drivers seront compilé pour une autre version du noyau.

ls -l /usr/src/

pour vérifier

Link to comment
Share on other sites

est-ce que tu aurais plusieurs version différente des sources du noyaux ?

Il me semble que les drivers nvidia se compile d'après les sources (et leurs fichier .config) situé dans "/usr/src/linux/" qui est en général un lien symbolique vers un répertoire "/usr/src/linux-[numero_de_version]"

Donc si le symlink est mauvais, les drivers seront compilé pour une autre version du noyau.

ls -l /usr/src/

pour vérifier

salut et merrci

mais la j'ai pas tous compris

je met le message

amd64:/home/vinced# ls -l /usr/src/

total 101852

-rw-r--r-- 1 root src 65453 2006-03-06 13:32 config-2.6.15-1-k7

lrwxrwxrwx 1 root src 21 2006-06-11 19:46 linux -> /usr/src/linux-2.6.16drwxrwxrwx 21 root root 4096 2006-06-11 19:07 linux-2.6.16

-rw-r--r-- 1 root src 51128010 2006-06-11 16:23 linux-2.6.16.tar.gz

drwxr-xr-x 18 root root 4096 2006-06-11 09:58 linux-headers-2.6.15-1

drwxr-xr-x 5 root root 4096 2006-06-11 09:58 linux-headers-2.6.15-1-k7

-rw-r--r-- 1 root src 13633054 2006-06-11 19:09 linux-image-2.6.160_1.0_i386.deb

lrwxrwxrwx 1 root src 21 2006-06-11 17:20 linux-OLDVERSION.1150047994 -> /usr/src/linux-2.6.16

drwxr-sr-x 19 root src 4096 2006-06-11 17:16 linux-source-2.6.15

-rw-r--r-- 1 root root 39315716 2006-03-06 12:32 linux-source-2.6.15.tar.bz2

drwxr-xr-x 7 root root 4096 2006-06-09 20:42 rpm

vu les compil et recompil que j'ai faite du coup c'est le bordel

mais je ne comprend pas pourquoi tout a sauté lors d'un aptitude upgrade et qui m'a supprimé la plus par de la distrib

Link to comment
Share on other sites

Hum "/usr/src/linux" pointe sur "/usr/src/linux-2.6.16"

Et au dessus tu a dit avoir recompilé en 2.6.15

Essaye de recompilé la version pointé par "/usr/src/linux" et réinstallé les drivers nvidia.

Il y aussi le README de nvidia, qui donne les éléments à inclure et exclure du noyau avec les drivers ou ICI sur le site nvidia

EDIT: ou tu peux essayer change le symlink "/usr/src/linux" vers la version effectivement utilisée et de réinstallé les drivers nvidia

Link to comment
Share on other sites

Hum "/usr/src/linux" pointe sur "/usr/src/linux-2.6.16"

Et au dessus tu a dit avoir recompilé en 2.6.15

Essaye de recompilé la version pointé par "/usr/src/linux" et réinstallé les drivers nvidia.

Il y aussi le README de nvidia, qui donne les éléments à inclure et exclure du noyau avec les drivers ou ICI sur le site nvidia

EDIT: ou tu peux essayer change le symlink "/usr/src/linux" vers la version effectivement utilisée et de réinstallé les drivers nvidia

je viens de recompiler en effacant les trace des anciens kernel

compilation d'un 2.6.16 tout neuf en prenant mon ancian .config

desactivation du frame buffer nvidia et agpgart autant prendre nvidia_agp

debut de la compile

reinstall des driver nvidia (me dit qu'il existe deja pas grave je continu. il enleve l'ancien et remet le nouveau meme si la version est la meme ca cest pas grave.

vi dans xorg pour configurer ma carte

rechargement du module nvidia

un coup de startx et la c le drame le serveur X ne demarre toujours pas

failed to module nvidia il me dit qu'il n'exite pas.

qu'a cela ne tienne fais un lsmod et qui vois je nvidia

par contre pas de nvidia_agp

amd64:/home/vinced# lsmod

Module Size Used by

nvidia 4548052 0

binfmt_misc 10312 1

ipv6 218656 12

button 6416 0

sk98lin 134560 0

dm_mod 47924 0

sr_mod 15844 0

sbp2 19460 0

ide_generic 1216 0 [permanent]

evdev 8832 2

mousedev 10496 1

tsdev 7296 0

i2c_nforce2 6400 0

snd_emu10k1 99940 3

snd_ac97_codec 82848 1 snd_emu10k1

snd_ac97_bus 2112 1 snd_ac97_codec

eth1394 18372 0

rtc 11444 0

snd_pcm 74504 4 snd_emu10k1,snd_ac97_codec

emu10k1_gp 3520 0

parport_pc 31728 0

parport 32008 1 parport_pc

snd_mpu401 7328 0

snd_mpu401_uart 6656 1 snd_mpu401

snd_page_alloc 9864 2 snd_emu10k1,snd_pcm

snd_util_mem 4352 1 snd_emu10k1

analog 9888 0

snd_rawmidi 22496 2 snd_emu10k1,snd_mpu401_uart

psmouse 34504 0

snd_hwdep 8580 1 snd_emu10k1

gameport 13576 3 emu10k1_gp,analog

serio_raw 6532 0

usbhid 32416 0

usb_storage 62848 0

ide_cd 35680 0

cdrom 32304 2 sr_mod,ide_cd

ide_disk 14720 4

sd_mod 16464 0

sata_nv 8900 0

ohci_hcd 17348 0

sata_sil 9672 0

ehci_hcd 27016 0

libata 53648 2 sata_nv,sata_sil

scsi_mod 122956 5 sr_mod,sbp2,usb_storage,sd_mod,libata

ohci1394 29616 0

ieee1394 86648 3 sbp2,eth1394,ohci1394

skge 33488 0

usbcore 111136 5 usbhid,usb_storage,ohci_hcd,ehci_hcd

amd74xx 12764 0 [permanent]

generic 4228 0 [permanent]

ide_core 111536 6 ide_generic,usb_storage,ide_cd,ide_disk,amd74xx,generic

forcedeth 20676 0

thermal 13128 0

processor 21440 1 thermal

fan 4548 0

ok un coup de modprobe nvidia_agp

amd64:/home/vinced# modprobe nvidia_agp

FATAL: Module nvidia_agp not found.

ou puis je recuperer ce module

merci

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...