Jump to content

[résolu]Problème Xorg 7/Clavier


Recommended Posts

Ne sachant pas quoi faire de ma journée, j'me dit alors "Tiens, et si tu faisais une 'tite mise a jour de ta debian ?"

Je me lance donc, et commence par la mise à jour de mon vieux Xorg...

Je redemarre, réinstalle les drivers Nvidia, et le serveur X demarre du premier coup, nikel !

Je me prépare alors à entrer mon login/password quand, soudain, je m'apperçois que mon ecran change de résolution à chaque fois que j'appuie sur une touche ! Fichtre ! Diantre ! Ventre saint gris !

Je regarde mon Xorg.conf -> pas de changement

Je le remplace par une sauvegarde de ma vielle version de Xorg -> rien

Je désinstalle tout (Xorg) et je réinstalle -> pareille

Je débranche mon clavier usb pour en mettre un en ps/2 -> la même

J'enlève le driver Nvidia propriétaire et passe en NV -> même problème

Je regarde mon Xorg.log, tout ce que je vois sont des "(II) NVIDIA(0): Setting mode "1024x768"" a chaque pression d'une touches ...

Pour info, je suis sur une Debian en Testing avec un noyau en 2.6.15-1-686-smp.

Et voici mon Xorg.log et mon Xorg.conf

Link to comment
Share on other sites

Dans ton xorg.conf, section clavier tu as:

#
Section "InputDevice"
Identifier	 "Generic Keyboard"
Driver		 "keyboard"
Option		 "CoreKeyboard"
Option		 "XkbRules" "xorg"
Option		 "XkbModel" "pc101"
Option		 "XkbLayout" "jp"
Option		 "XkbVariant" "latin9"
EndSection

l'option "XkbLayout" ne devrait pas être "fr" au lieu de "jp", pour un clavier français ?

Link to comment
Share on other sites

l'option "XkbLayout" ne devrait pas être "fr" au lieu de "jp", pour un clavier français ?

Effectivement, pour un clavier français.

Mais vu que j'ai un HHK avec layout japonais/US, ya aucun problème à ce niveau la.

Link to comment
Share on other sites

euh ... le driver, c'est pas kbd au lieu de keyboard ?

- soit c'est un alias

- soit il y a un truc bizarre et tu utilises un vieux driver

PS : je regarderai mieux ce topic ce soir, mais ton xorg.conf m'inquiète un peu ... t'as plusieurs cartes graphiques ?

Link to comment
Share on other sites

ton xorg.conf

 Section "Module"
Load		   "bitmap"
Load		   "dbe"
Load		   "ddc"
Load		   "extmod"
Load		   "freetype"
Load		   "glx"
Load		   "int10" <--- ??? normalement, c'est une option dans la section Device, non ? à réserver aux systèmes multi-cartes ...
Load		   "record"
Load		   "type1"
Load		   "vbe"
EndSection

le mien ...

Section "Module"
Load		   "dbe"		# Double buffer extension
SubSection	 "extmod"
	Option		 "omit xfree86-dga"   # don't initialise the DGA extension
EndSubSection
Load		   "type1"
Load		   "freetype"
Load		   "glx"
EndSection

j'utilise le driver nVidia et non le nv ...

ton xorg.conf, il vient d'où ? fichier généré ? je le trouve un rien surchargé ...

Ensuite, il y a peut-être un bug dans la reconnaissance de ton clavier ... j'ai eu quelques problèmes avec le mien sous Xorg7 ... mais il est moins "exotique" ...

Link to comment
Share on other sites

Au niveau des extension, moi j'en ai juste 4 :

  • ddc : détection de la résolution automatique, même si nvidia le fait déjà
  • dbe : double buffer extension
  • glx
  • extmod : utile pour quelques applis faisant des manipulations sur l'écran comme Quake3

Link to comment
Share on other sites

Merci tsubasaleguedin !

Ca me réconforte de voir que je suis pas le seul avec ce problème ^^

Et en plus ca ma permit de résoudre le problème :

En fait, mon Xorg allait chercher mon fichier XKeysymDB ici /usr/X11R6/lib/X11/

alors que chez moi, il se trouve la /usr/share/X11/ ....

donc un ptit lien et c'est réglé !

Merci, jpeux enfin utilisé mon clavier ^^

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...