Jump to content

aidez moi : amsn sur FC4


Recommended Posts

Bonjour,

Bon voila j'ai un petit probleme pour l'installation d'amsn sous FC4... voila une explication de ce qui m'arrive..

1 - J'ai essayé "yum install amsn"

resultat : No Match for argument : amsn

2 - J'ai downloadé le rpm i386 pour FC4 de asmn

resultat : You can't load TkCximage, this is now needed to run aMSN. Please compile amsn first, instructions on how to compile are located in the file INSTALL

3 - Je telecharge les sources de amsn

./configure

resultat : manque tcl-devel

4 - Installation des lib necessaires (tcl et tk en devel)

./configure a nouveau

make

make install

amsn

amsn se lance !! Youpi ... mais je ne peux pas me connecter : il lui faut TLS il dit qu'il va le telecharger tout seul mais j'obtiens une erreur :

Erreur lors de l'installation du module TLS : couldn't open socket : connection refused

Effectivement si j'essaye via firefox d'accerder à l'adresse qu'il cherche ( http://osdn.dl.sourceforge.net/sourceforge...inux-x86.tar.gz ) connection refusée

5 - Je telecharge les sources de TLS (version 1.5) (http://sourceforge.net/project/showfiles.php?group_id=13248)

./configure

resultat : trouve pas ssl....

6 - yum install openssl*

et ./configure --with-ssl-dir=/usr/

make

make install

je precise dans les preference de asmn ou trouver le .so de tls (/usr/local/lib/)

resultat : ca ne change rien il ne trouve toujours pas tls et continue d'essayer de l'installer...

Sur un forum quelqu'un precise que c'est un probleme avec selinux et qu'il faut taper :

J'ai trouvé aussi cette solution pour "laisser passer" amsn avec SElinux activé. Il faut taper en root:

[root@localhost ~]# chcon -t texrel_shlib_t /usr/share/amsn/utils/TkCximage/TkCximage.so

[root@localhost ~]# chcon -t texrel_shlib_t /home/noee/.amsn/plugins/tls1.4/libtls1.4.so

mais ca ne change rien chez moi......

J'ai aussi essayé setenforce 0 mais ca ne change rien...

Bref quelqu'un a une idée sur ce que je peux encore faire ??

Merci

KahRiboo

Link to comment
Share on other sites

  • 5 weeks later...

Salut!

Erreur lors de l'installation du module TLS : couldn't open socket : connection refused

1) Télécharge TLS1.4 à cet adresse:

http://switch.dl.sourceforge.net/sourcefor...inux-x86.tar.gz

2) Décompresse le ( tar -zxvf tls1.4.1-linux-x86.tar.gz )

3) Déplace (en root) le dossier obtenu dans /usr/share/amsn ( mv tls1.4 /usr/share/amsn )

4) Indique à amsn le chemin de tls dans "Outils" "Préférences" "Avancé" "Autres" ( /usr/share/amsn/tls1.4 )

5) Relance amsn

C'est comme ça que j'ai résolu mon problème!

A plus

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...