Jump to content

Archived

This topic is now archived and is closed to further replies.

Micky

Xorg: problème de synchronisation verticale

Recommended Posts

Bonjour,

Je cherche à résoudre le problème suivant depuis 2 jours sans succès :transpi:.

Sous Xorg 7, lorsque je déplace une fenêtre latéralement ou autre, je vois des coupures plus ou moins horizontal sur l'affichage. Comme pour un jeu non synchronisé avec l'écran. Cela me fait pareil lorsque je regarde un film (sous totem ou mplayer).

Je ne trouve pas la solution pour palier à ce problème et je vous pose donc la question.

Information supplémentaire:

je tourne sous Gentoo (x86_64), avec une ATI 9700 Pro et le driver propriétaire Ati (8.23.7).

J'ai le problème sur xorg 7 et aussi sur xgl. L'accélération 3D fonctionne bien sur les 2 serveurs.

mon fichier xorg.conf:

Section "ServerLayout"

Identifier "Simple Layout"

Screen 0 "aticonfig Screen 0" 0 0

InputDevice "Mouse1" "CorePointer"

InputDevice "Keyboard1" "CoreKeyboard"

EndSection

Section "Files"

#RgbPath "/usr/share/X11/rgb"

FontPath "/usr/share/fonts/misc"

FontPath "/usr/share/fonts/75dpi"

FontPath "/usr/share/fonts/100dpi"

FontPath "/usr/share/fonts/Type1"

EndSection

Section "Module"

Load "ddc"

Load "bitmap"

Load "dbe"

Load "dri"

Load "extmod"

#SubSection "extmod"

# Option "omit xfree86-dga"

#EndSubSection

Load "freetype"

Load "glx"

Load "int10"

Load "record"

Load "speedo"

Load "type1"

Load "vbe"

EndSection

Section "InputDevice"

Identifier "Keyboard1"

Driver "kbd"

Option "AutoRepeat" "500 30"

Option "XkbRules" "xorg"

Option "XkbModel" "pc105"

Option "XkbLayout" "fr"

EndSection

Section "InputDevice"

Identifier "Mouse1"

Driver "mouse"

Option "Protocol" "Auto" # Auto detect

Option "Device" "/dev/input/mice"

Option "ZAxisMapping" "4 5 6 7"

EndSection

Section "Monitor"

Identifier "aticonfig Monitor 0"

Option "DDC"

EndSection

Section "Device"

Identifier "ATI Graphics Adapter 0"

Driver "fglrx"

Option "UseInternalAGPGART" "no"

Option "KernelModuleParm" "agplock=0"

Option "Capabilities" "0x00000800"

#Option "UseFastTLS" "1"

Option "EnablePrivateBackZ" "no"

BusID "PCI:4:0:0"

EndSection

Section "Screen"

Identifier "aticonfig Screen 0"

Device "ATI Graphics Adapter 0"

Monitor "aticonfig Monitor 0"

DefaultDepth 24

SubSection "Display"

Viewport 0 0

Depth 24

Modes "1280x1024"

EndSubSection

EndSection

Section "DRI"

Mode 0666

EndSection

Merci d'avance pour votre aide plus que bienvenue

Share this post


Link to post
Share on other sites

tu as ps activer/desactiver la synchro vertical ?

As tu tester avec les dernier pilotes en provenance du site d'ATI. Chez moi ils marchent nikel sur ma gentoo 64

Share this post


Link to post
Share on other sites

tu as ps activer/desactiver la synchro vertical ?

As tu tester avec les dernier pilotes en provenance du site d'ATI. Chez moi ils marchent nikel sur ma gentoo 64

En fait j'ai juste ajouté aticonfig --vs=on. mais je n'ai fais aucune autre modification (ca n'a rien changé). Je vais tester les derniers pilotes.

Share this post


Link to post
Share on other sites

Je viens de mettre les derniers drivers mais j'ai exactement le même problème.

Quand je fais un glxgears je me retrouve avec plus de 4000fps. la synchro n'est donc pas active ?

Merci d'avance si vous avez d'autres pistes?

Share this post


Link to post
Share on other sites

Salut

j'ai le meme soucis avec les derniers drivers Nvidia .

J'aivais un taux de refresh a 60, c'est a vomir .

j'ai mis cette valeur dans mon fichier de conf

Option		  "UseEdidFreqs" "false"

puis j'ai specifier mois meme les frequences de rafraichissments :

SubSection "Display"
			Depth		   24
			Modes		   "1024x768_85" "800x600" "640x480"
	EndSubSection

Ça regler le probleme .

En esperant te rendre service

Share this post


Link to post
Share on other sites

Salut

j'ai le meme soucis avec les derniers drivers Nvidia .

J'aivais un taux de refresh a 60, c'est a vomir .

j'ai mis cette valeur dans mon fichier de conf

Option		  "UseEdidFreqs" "false"

puis j'ai specifier mois meme les frequences de rafraichissments :

SubSection "Display"
			Depth		   24
			Modes		   "1024x768_85" "800x600" "640x480"
	EndSubSection

Ça regler le probleme .

En esperant te rendre service

Je viens de faire la manipulation. ca n'a malheureusement rien changé pour mon cas :chinois: .

Merci tout de même pour ces infos.

Share this post


Link to post
Share on other sites

Je crois que j'ai trouvé la solution. A l'écran cela semble pas mal mais je prefere avoir votre avis.

J'ai rajouté ceci dans ~/.drirc

<driconf>

<device driver="fglrx">

<application name="all">

<!-- Always synchronize with vertical refresh to avoid tearing -->

<option name="swap_on_vblank" value="true"/>

</application>

</device>

</driconf>

Je n'ai plus de probleme sauf pour les vidéos en fenetré où l'on voit de lègere coupure mais parcontre plus aucun probleme de synchro en plein écran :).

Je voulais savoir si ce fichier est bien normal (et que je l'avais bêtement oublié) ou si normalement ce n'est pas la solution malgrès qu'elle fonctionne et que mon problème doit venir d'ailleurs ?

Merci d'avance

PS: Xgl tourne nikel. c bluffant. vive le monde libre malgrès certain jour de galère.

Share this post


Link to post
Share on other sites

×
×
  • Create New...