Jump to content

[Résolu][mandriva][carte wifi][intel 2200B/G]


Recommended Posts

Bien le bonsoir,

J'ai suivi ce tuto : http://lea-linux.org/cached/index/Utiliser...ess_2200BG.html

A la lettre d'ailleurs... Mais je crois qu'il me manque les sources de mon kernel... Voici ce que j'ai comme erreur lorsque j'execute la commande modprobe ipw2200

[root@localhost ieee80211-1.1.13]# modprobe ipw2200
WARNING: Could not open '/lib/modules/2.6.12-12mdk-i686-up-4GB/kernel/3rdparty/ieee80211/ieee80211_crypt.ko.gz': No such file or directory
WARNING: Could not open '/lib/modules/2.6.12-12mdk-i686-up-4GB/kernel/3rdparty/ieee80211/ieee80211.ko.gz': No such file or directory
FATAL: Error inserting ipw2200 (/lib/modules/2.6.12-12mdk-i686-up-4GB/kernel/3rdparty/ipw2200/ipw2200.ko.gz): Unknown symbol in module, or unknown parameter (see dmesg)

Ce qui fait que ca ne fonctionne pas évidemment...

Un peu d'aide?

Merci d'avance :-D

Link to comment
Share on other sites

Ils semble qu'il manque deux fichiers : ieee80211_crypt.ko.gz et ieee80211.ko.gz (ça peut être utile pour du wifi).

Par ailleurs il te propose d'aller voir le dmesg ce qui chie.

Lorsque je veux installer ieee80211, j'ai ceci :

[tyrann@localhost modules]$ ll
total 12
drwxrwxr-x  4 tyrann tyrann 4096 jan  1  1970 ieee80211-1.1.13/
drwxrwxr-x  4 tyrann tyrann 4096 jan  1  1970 ipw2200/
drwxrwxr-x  2 tyrann tyrann 4096 jan  1  1970 ipw2200-fw-3.0/
[tyrann@localhost modules]$ cd ieee80211-1.1.13/
[tyrann@localhost ieee80211-1.1.13]$ ll
total 236
-rw-r--r--  1 tyrann tyrann  7706 mar 31 11:12 CHANGES
-rw-r--r--  1 tyrann tyrann  1345 mar 31 11:12 GIT_SHA1
-rwxr-xr-x  1 tyrann tyrann   852 mar 31 11:12 idvals*
-rw-r--r--  1 tyrann tyrann  5396 mar 31 11:12 ieee80211_crypt.c
-rw-r--r--  1 tyrann tyrann 12355 mar 31 11:12 ieee80211_crypt_ccmp.c
-rw-r--r--  1 tyrann tyrann 20993 mar 31 11:12 ieee80211_crypt_tkip.c
-rw-r--r--  1 tyrann tyrann  6887 mar 31 11:12 ieee80211_crypt_wep.c
-rw-r--r--  1 tyrann tyrann  5273 mar 31 11:12 ieee80211_geo.c
-rw-r--r--  1 tyrann tyrann  8381 mar 31 11:12 ieee80211_module.c
-rw-r--r--  1 tyrann tyrann 50496 mar 31 11:12 ieee80211_rx.c
-rw-r--r--  1 tyrann tyrann 17800 mar 31 11:12 ieee80211_tx.c
-rw-r--r--  1 tyrann tyrann 24174 mar 31 11:12 ieee80211_wx.c
-rw-r--r--  1 tyrann tyrann  2583 mar 31 11:12 INSTALL
drwxrwxr-x  2 tyrann tyrann  4096 jan  1  1970 in-tree/
-rwxr-xr-x  1 tyrann tyrann 18671 mar 31 11:12 LICENSE*
-rw-r--r--  1 tyrann tyrann  7039 mar 31 11:12 Makefile
drwxrwxr-x  2 tyrann tyrann  4096 jan  1  1970 net/
-rw-r--r--  1 tyrann tyrann  1476 mar 31 11:12 remove-old
[tyrann@localhost ieee80211-1.1.13]$ make
Checking in /lib/modules/2.6.12-12mdk-i686-up-4GB for ieee80211 components...
find: /lib/modules/2.6.12-12mdk-i686-up-4GB/build/: Aucun fichier ou répertoire de ce type
grep: /lib/modules/2.6.12-12mdk-i686-up-4GB/build//.config: Aucun fichier ou répertoire de ce type
grep: /lib/modules/2.6.12-12mdk-i686-up-4GB/build//include/linux/autoconf.h: Aucun fichier ou répertoire de ce type
make -C /lib/modules/2.6.12-12mdk-i686-up-4GB/build M=/usr/src/modules/ieee80211-1.1.13 modules
make: *** /lib/modules/2.6.12-12mdk-i686-up-4GB/build: Aucun fichier ou répertoire de ce type. Arrêt.
make: *** [modules] Erreur 2
[tyrann@localhost ieee80211-1.1.13]$

Et évidemment je ne sais pas trop ce que je dois faire... :chinois:

Link to comment
Share on other sites

Et évidemment je ne sais pas trop ce que je dois faire... :transpi:

Lire un peu les docs ? Apprendre à se servir d'urpmi ?

Allez je t'aide un peu tu branches un RJ45 tu configures la connection, tu vas là >> http://easyurpmi.zarb.org

Tu fais tout ce qu'on te dit et ensuite dans une console en root

urpmi --auto-select kernel-2.6 ipw2200-firmware

Voila c'est pas plus compliqué que ça.

Link to comment
Share on other sites

Et évidemment je ne sais pas trop ce que je dois faire... :D

Lire un peu les docs ? Apprendre à se servir d'urpmi ?

Comme je l'ai dit, j'ai suivi un tuto a la lettre, c'etait pour moi le meilleur a faire....

Allez je t'aide un peu tu branches un RJ45 tu configures la connection, tu vas là >> http://easyurpmi.zarb.org

Ca j'avais deja....

Tu fais tout ce qu'on te dit et ensuite dans une console en root

urpmi --auto-select kernel-2.6 ipw2200-firmware

Voila c'est pas plus compliqué que ça.

La par contre je connaissais pas...

Alors voici ce que ca a fait : trouve pas de kernel-2.6 et a proposé kernel-2.6.12-12mdk.

J'ai choisi cette option, ensuite il m'a dit qu'il devait installler pleins de choses (tout ce qui était deja installé en fait...) et si je réponds "no" ben il s'arrete... Donc j'ai répondu "yes"

Résultat :

Il a installé pleins de trucs, mon pc redémarre plus en mode normal, mais il y a deux nouvelles entrées dans grub... Donc j'en prends une des deux et hop ca démarre.... L'assistant de connexion me dit qu'il connait eth2 (maintenant) et je démarre la config...

Résultat : plantage monstrueu avec impossibilité d'éteindre le pc ou de lancer n'importe qu'elle autre applic (y compris le terminal...)

Donc voila, toujours dans l'impasse, je vais réinstaller mandriva parce que maintenant ca déconne dans tous les sens...

Link to comment
Share on other sites

Bon voila, je me suis dit que j'avais surement déconné quelque part, donc j'ai formaté et réinstallé mandriva... J'ai installé le nouveau kernel, j'ai installé ma carte wifi et elle fonctionne!!!

J'ai mis l'option led=1

Donc je peux capter le réseau, m'y connecter mais je ne suis pas réellement connecté... Le probleme est la...

La led est fixe (donc connectée) le gestionnaire drakroam me dit que je suis connecté mais l'icone dans la barre me dit "le réseau est inactif sur eth2" "cliquez sur Configuration du Réseau"

J'ai beau essayer plein de choses, j'y arrive pas :mad2:

Et quand je clique sur "connecter eth2" ca fait rien :transpi:

Avouez que j'ai bien progressé la quand meme :-D

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...