Jump to content

Problème avec Horde


Recommended Posts

Bonjour les inpactien(nes),

J'ai voulu installer un webmail à mon serveur mail Postfix et courier imap. Le webmail en question est Horde. J'ai donc télécharger l'archive, décompressez dans mon répertoire partagé sur le web...

J'ai interprété le script mysql fourni avec Horde, l'utilisateur horde est bien crée avec le mot de passe que j'avais mis dans le fichier... J'ai rénommer tous les fichiers qui avaient pour extensions .php.dist en .php

Et donc selon les tutos, je devrais aller vers le dossier de horde donc http://ipserveur/horde,et finir avec l'interface web de configuration mais j'ai ce message :mad2: :

Fatal error: Only variables can be passed by reference in /opt/lampp/htdocs/horde/config/registry.php on line 48

A la ligne 48 de ce fameux fichier il se trouve écrit ça :

 $webroot = strstr(dirname(__FILE__), '/' . array_shift(preg_split(';/;', $_SERVER['PHP_SELF'], 2, PREG_SPLIT_NO_EMPTY)));

Si quelqu'un a une idée :D

Merci d'avance à tous ;)

Pour info, j'ai trouvé ce tuto plutot bien fait je trouve à mon gout... Le serveur web tourne sous debian.

Link to comment
Share on other sites

Je pense que tu aurais plus de réponse dans la section programmation.

Si tu souhaite un déplacement, précise le dans un prochain post.

Je ne connais pas bien le php, mais trois trucs que je ferrais si j'avais ce problème :

* Vérifier si php est en safe mode

* Commenter la ligne et vois si ça fonctionne sans (peu probable vu que c'est le root, mais après il est toujours possible de mettre le nom en dur). Bon c'est gauret, mais ça peut dépanner (non pas gauret, gauret)

* séparer tous les éléments de la ligne et les mettre sur des lignes séparées ou alors supprimer des parties jusqu'à trouver celle qui pose problèmes (strstr, __FILE__, $_server, etc...)

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...