Jump to content

bugs IE


Recommended Posts

hello world,

j'ai des petis soucis avec une page XHTML strict 1.0, avec feuille de style, elle est valide selon la W3c, mais evidemment IE ne l'affiche pas correctement.

la page st tout ce qu'il y a de plus classique, conteneur centré, header, menu a gauche, et centre dynamique.

certains blocs au centre "disparaissent", et ne réaparaissent que lorsque je les surligne a la souris, ou bien lorsque je fait defiler la page et que je reviens dessus.

de plus, le bloc central se coupe en deux en plein milieux, laisse un blanc de plusieurs centaines de pixels de haut puis reaparait en bas.....

J'ai vérifié, toutes mes balises sont fermées, y'a pas d'erreurs a apriori.... je pense que cela viens de la css, mais ou?

au secours... Je sais qu'il existent des sites répertoriant les bugs IE et leur solutions... si vous aviez des bonnes adresses...

Link to comment
Share on other sites

Salut

certains blocs au centre "disparaissent", et ne réaparaissent que lorsque je les surligne a la souris, ou bien lorsque je fait defiler la page et que je reviens dessus.

C'est probablement dû au Peekaboo bug de IE 6.

Perso pour le corriger, je donne un width 100% au bloc qui pose problème, mais il y a d'autres méthodes.

Link to comment
Share on other sites

j'ai trouvé (mais pas résolu) le bug

dès que j'affiche un tableau <table class="tablo">, il y un bug.

voila la partie de la css qui concerne le tableau.

.tablo {

width : 100%;

margin-right : 10px;

text-indent:5px;

}

si je vire le width : 100% et que je le remplace par width : 600px, alors le bug disparait... mais la mise en page en souffre.....

quelqun a une idée???

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...