Jump to content

[XP] XP démarre plus - hal.dll - démarre plus du tout!


Cyberus

Recommended Posts

Bonjour j'ai un protable HP qui fonctionnait très bien jusqu'à ce matin ou j'ai essayé de le démarrer et ce message d'erreur s'est affiché à l'écran:

Windows n'as pas pu démarrer car le fichier suivant est manquant ou endommagé:

<Racine Windows>\system32\hal.dll

Veuillez réinstaller une copie du fichier ci-dessus.

Je l'ai déja fais, j'ai copié de fichier depuis le dossier I386 de mon cd de XP Pro et j'ai remplacé celui qui se trouvais dans c:\windows\system32\...

Mais ça n'as pas résolu mon problème... Au démarrage il m'affiche toujours ce message d'erreur...

J'ai cherché sur le net et aussi dans un autre topic sur pcinpact (http://www.pcinpact.com/forum/index.php?sh...6596&hl=hal.dll) j'ai essayé plusieur trucs mais ça ne marche pas...

qq'un aurai une autre solution ou saurai pk ça ne fonctionne tj pas???

Merci d'avance..

Link to comment
Share on other sites

Ton processeurs est-il overclocké ? Si oui, ca peut venir de là. Ton pc démarre en mode sans échec ?

Non mon CPU n'est pas overclocké, et lorsque j'essai de démarrer en mode sans échec il me demande de séléctionner l'os, je le séléctionne et puis il m'affiche de nouveau ce même message d'erreur...

Link to comment
Share on other sites

fais une reparation du systeme

J'ai fais une rép. du boot.ini et la mon pc a démarré.. par contre l'affichage n'est plus comme il étais il ne reconnais plus les phériphériques, on dirais qu'il n'as plus les drivers pour le matos installé dedans...

Mais bon j ai fait un sauveagrde de l'ancien boot.ini, je vais remplacer le hal.dll maintenant et remettre l'ancien boot.in voir ce que ca va donner..

Link to comment
Share on other sites

fais une reparation du systeme

J'ai fais une rép. du boot.ini et la mon pc a démarré.. par contre l'affichage n'est plus comme il étais il ne reconnais plus les phériphériques, on dirais qu'il n'as plus les drivers pour le matos installé dedans...

Mais bon j ai fait un sauveagrde de l'ancien boot.ini, je vais remplacer le hal.dll maintenant et remettre l'ancien boot.in voir ce que ca va donner..

C'vraiment la m.... j'ai remis l'ancien boot.ini et j ai remplacé le hal.dll et la au démarrage ca me fais encore la même erreur..

Link to comment
Share on other sites

fais une reparation du systeme

J'ai fais une rép. du boot.ini et la mon pc a démarré.. par contre l'affichage n'est plus comme il étais il ne reconnais plus les phériphériques, on dirais qu'il n'as plus les drivers pour le matos installé dedans...

Mais bon j ai fait un sauveagrde de l'ancien boot.ini, je vais remplacer le hal.dll maintenant et remettre l'ancien boot.in voir ce que ca va donner..

oui fais sa ou reinstalle tous les pilote des peripherique

Link to comment
Share on other sites

fais une reparation du systeme

J'ai fais une rép. du boot.ini et la mon pc a démarré.. par contre l'affichage n'est plus comme il étais il ne reconnais plus les phériphériques, on dirais qu'il n'as plus les drivers pour le matos installé dedans...

Mais bon j ai fait un sauveagrde de l'ancien boot.ini, je vais remplacer le hal.dll maintenant et remettre l'ancien boot.in voir ce que ca va donner..

oui fais sa ou reinstalle tous les pilote des peripherique

mais arpès avoir fait ça j ai deux systemes dans le boot ini, donc le premier qui ne marche plus je peut le supprimer?? pk ca me sert a rien d avoir un multi boot pour un seul os!!

Link to comment
Share on other sites

Bon j'ai voulu modifier ce boot.in et ca a foutu la merde partout... il demarre plus du tout la...

Voila ce qu'il m'affiche la..

Windows n'a pas pu démarrer en raison d'une erreur dans le logiciel.

Veuillez rendre compte de ce problème comme:

Le programme de chargement a eu besoin de DLL pour le noyau.

Veuillez contacter la personne chargée du support pour l'informer de ce problème

La j'sais plus vraiment ce que je pourrais faire, qq'un sait si il y aurai une solution a ça??

Link to comment
Share on other sites

Copie et boot sur un clé USB .

- Insérer le CD de Windows XP (tout en restant sous Windows).

Démarrer -> Exécuter -> F:\i386\WINNT32 /unattend (en remplaçant F par la lettre de votre lecteur CD)

Windows va réparer l'installation, tout en conservant toutes vos installations de logiciels, configuration etc.

Attention, les pilotes non Microsoft, les mises à jour Windows Update, les services pack, WMP9, doivent être réinstallés.

ps :

actuellement , ton system est bien sur le C ?

Link to comment
Share on other sites

Copie et boot sur un clé USB .

- Insérer le CD de Windows XP (tout en restant sous Windows).

Démarrer -> Exécuter -> F:\i386\WINNT32 /unattend (en remplaçant F par la lettre de votre lecteur CD)

Windows va réparer l'installation, tout en conservant toutes vos installations de logiciels, configuration etc.

Attention, les pilotes non Microsoft, les mises à jour Windows Update, les services pack, WMP9, doivent être réinstallés.

ps :

actuellement , ton system est bien sur le C ?

Ouais mon système est le C, mais la c'est tou ok!!

J'ai fais une dernière tentative la avec le cd de xp.. (la commande que j'ai utilisé: C:\Windows>EXPAND D:\i386\driver.cab /F:hal.dll C:\windows\system32\

Ca fais depuis 10h ce matin que je suis sur ce problème etje vien enfin de réussire a le résoudre... lol j'ai eu le boulles de dévoir formater mon hd!!! J'aurai peté les plombs j ai des documents de deux ans de boulot sur ce pc!!

Merci pour votre aide :eeek2:

____

Snooky tu as msn messenger??

J'aurai deux ou trois question a te poser a propos de osx86... envoie la moi par mp.. merci!

:francais:

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...