Jump to content

Archived

This topic is now archived and is closed to further replies.

percubabs

samba 4 ad aide

Recommended Posts

Bonjour,

 

Je viens d'installer une debian avec samba 4 en suivent ce tuto : http://dev.tranquil.it/wiki/SAMBA_-_Installation_d%27un_AD_Samba4_pour_un_nouveau_domaine

 

Tout c'est bien passé, samba semble répondre au client windows, quand je rentre le mots de passe administrateur pour rentrer dans le domaine j'ai le message suivant,

 

Le domaine spécifié n'a pas pu être contacté.

 

sur le client Windows, j'ai bien accès aux dossiers partagé netlogon et sysvol.

 

merci de votre aide

 

edit: je viens de rajouter cela

 

Domain member : Disable machine account password changes / Membre de domaine : désactive les modification de mot de passe du compte ordinateur = mettre l’option à Enabled/Activé

 

DWORD DomainCompatibilityMode = 1
DWORD DNSNameResolutionRequired = 0

 

idem

Share this post


Link to post
Share on other sites

Le tuto décrit une compilation de samba. Tu as essayé avec le paquet fourni par la distrib ?

Share this post


Link to post
Share on other sites

OK, bon. Mais là pour t'aider on a pas grand chose, comment veux-tu qu'on fasse. On peut avoir au minimun les fichiers de conf (krb5.conf, smb.conf) et les logs ?

 

À tout hasard, le mot de passe administrateur est suffisamment fort ?

Share this post


Link to post
Share on other sites

oui, il me permet de me connecter dessus pour les partages. plus de 8caractères lettres chiffres et caractères spéciaux.

[libdefaults] dns_lookup_realm = true dns_lookup_kdc = true default_realm = LIBERTY.LAN
# Global parameters[global]        workgroup = LIBERTY        realm = LIBERTY.LAN        netbios name = SAMBA        server role = active directory domain controller        dns forwarder = 8.8.8.8[netlogon]        path = /usr/local/samba/var/locks/sysvol/liberty.lan/scripts        read only = No[sysvol]        path = /usr/local/samba/var/locks/sysvol        read only = No# Global parameters[global]        workgroup = LIBERTY        realm = LIBERTY.LAN        netbios name = SAMBA        server role = active directory domain controller        dns forwarder = 8.8.8.8[netlogon]        path = /usr/local/samba/var/locks/sysvol/liberty.lan/scripts        read only = No[sysvol]        path = /usr/local/samba/var/locks/sysvol        read only = No
[2015/01/08 15:13:24.244697,  0] ../source4/smbd/server.c:121(sig_term)  Exiting pid 2617 on SIGTERM[2015/01/08 15:13:24.248697,  0] ../source4/smbd/server.c:121(sig_term)  Exiting pid 2616 on SIGTERM[2015/01/08 15:13:24.252700,  0] ../source4/smbd/server.c:121(sig_term)  Exiting pid 2615 on SIGTERM[2015/01/08 15:13:24.256696,  0] ../source4/smbd/server.c:121(sig_term)  Exiting pid 2614 on SIGTERM[2015/01/08 15:13:24.260708,  0] ../source4/smbd/server.c:121(sig_term)  Exiting pid 2613 on SIGTERM  STATUS=daemon 'samba' finished starting up and ready to serve connectionsSIGTERM: killing children[2015/01/08 15:13:24.267139,  0] ../source4/smbd/server.c:121(sig_term)  Exiting pid 2234 on SIGTERM[2015/01/08 15:13:42.858697,  0] ../source4/smbd/server.c:370(binary_smbd_main)  samba version 4.1.12 started.  Copyright Andrew Tridgell and the Samba Team 1992-2013[2015/01/08 15:13:43.186588,  0] ../source4/smbd/server.c:488(binary_smbd_main)  samba: using 'standard' process model[2015/01/08 15:13:43.193217,  0] ../lib/util/become_daemon.c:136(daemon_ready)[2015/01/08 15:13:24.240696,  0] ../source4/smbd/server.c:121(sig_term)  Exiting pid 2618 on SIGTERM[2015/01/08 15:13:24.244697,  0] ../source4/smbd/server.c:121(sig_term)  Exiting pid 2617 on SIGTERM[2015/01/08 15:13:24.248697,  0] ../source4/smbd/server.c:121(sig_term)  Exiting pid 2616 on SIGTERM[2015/01/08 15:13:24.252700,  0] ../source4/smbd/server.c:121(sig_term)  Exiting pid 2615 on SIGTERM[2015/01/08 15:13:24.256696,  0] ../source4/smbd/server.c:121(sig_term)  Exiting pid 2614 on SIGTERM[2015/01/08 15:13:24.260708,  0] ../source4/smbd/server.c:121(sig_term)  Exiting pid 2613 on SIGTERM  STATUS=daemon 'samba' finished starting up and ready to serve connectionsSIGTERM: killing children[2015/01/08 15:13:24.267139,  0] ../source4/smbd/server.c:121(sig_term)  Exiting pid 2234 on SIGTERM[2015/01/08 15:13:42.858697,  0] ../source4/smbd/server.c:370(binary_smbd_main)  samba version 4.1.12 started.
Copyright Andrew Tridgell and the Samba Team 1992-2013[2015/01/08 15:13:43.595438,  0] ../lib/util/become_daemon.c:136(daemon_ready)  STATUS=daemon 'smbd' finished starting up and ready to serve connectionsUnable to open printcap file /etc/printcap for rea$[2015/01/08 15:26:44.279232,  0] ../source3/printing/print_standard.c:69(std_pcap_cache_reload)  Unable to open printcap file /etc/printcap for read![2015/01/08 15:39:45.058179,  0] ../source3/printing/print_standard.c:69(std_pcap_cache_reload)  Unable to open printcap file /etc/printcap for read![2015/01/08 15:52:45.840426,  0] ../source3/printing/print_standard.c:69(std_pcap_cache_reload)  Unable to open printcap file /etc/printcap for read![2015/01/08 16:05:46.622696,  0] ../source3/printing/print_standard.c:69(std_pcap_cache_reload)  Unable to open printcap file /etc/printcap for read![2015/01/08 16:18:47.346374,  0] ../source3/printing/print_standard.c:69(std_pcap_cache_reload)  Unable to open printcap file /etc/printcap for read![2015/01/08 16:31:48.128557,  0] ../source3/printing/print_standard.c:69(std_pcap_cache_reload)  Unable to open printcap file /etc/printcap for read![2015/01/08 16:44:48.910755,  0] ../source3/printing/print_standard.c:69(std_pcap_cache_reload)  Unable to open printcap file /etc/printcap for read!

voili voulou




			
		

Share this post


Link to post
Share on other sites

Bon, j'ai suivi le guide pour voir ce que ça donne. Pour l'instant je me rend compte qu'il manque la configuration du serveur kerberos. Comment ça s'est passé chez toi ? La commande kinit administrator renvoie quoi ?

 

Edit : en dehors de ça, j'ai dû désactiver l'ipv6 de windows, et bien sûr modifier le serveur dns pour pointer sur le serveur samba. Là, au moment de me connecter, il me demande bien mes identifiants mais au moment de me connecter j'ai le message "format de point final non valide". Alors bon, là je cherche...

Share this post


Link to post
Share on other sites

salut, alors j'ai fini par réussir mais sans faire la partie lié a l'ext 3, étant en ext4, tout semble maintenant fonctionner.

 

Je laisse ouvert, je risque d'avoir d'autre demande sur la suite

 

Merci à toi

Share this post


Link to post
Share on other sites

×
×
  • Create New...