Jump to content

Choix impossible entre l'IGP Intel et le GPU Nvidia


frinz

Recommended Posts

Bonjour à tous,

J'ai un PC portable Dell XPS L502x qui possède deux cartes graphique : une Intel HD Graphic Family et une Nvidia GeForce GT 525M. En passant par le panneau de configuration de Nvidia, je peux choisir la carte graphique avec laquelle je vais lancer tel ou tel programme (panneau de configuration Nvidia -> Paramètres 3D -> Gérer les paramètres 3D -> Paramètres de programme).

Par contre, il est impossible de choisir le processeur graphique à utiliser sur certain programme. Le menu déroulent permettant de sélectionner le GPU est grisé..

831348Sanstitre3.png

J'ai essayé de désactiver la carte graphique Intel dans le gestionnaire des périphériques pour forcer l'utilisation de la GeForce en permanence. Résultat : la résolution est bloqué à 1024*768px et le panneau de configuration Nvidia est inaccessible (Message d'erreur : Les paramètres d'affichage NVIDIA ne sont pas disponibles. Vous n'utilisez pas actuellement d'écran connecté à un processeur graphique NVIDIA).

J'ai également remarqué un schéma dans le panneau de configuration NVIDIA :

396721Sanstitre2.png

Savez vous comment forcer l'utilisation d'un processeur graphique lorsque le menu déroulant est grisé ? Ou savez vous pourquoi je ne peux pas choisir pour certain programme ?

Comment fonctionne exactement ce couple de carte graphique ? Comment sont elles branché ?

Merci d'avance et bonne journée!

Link to comment
Share on other sites

Dans le cas d'optimus (combo intel-nvidia sur laptop), la gestion de la 3D passe par la carte intel qui ensuite demande a la carte Nvidia de calculer.

Pour forcer l'utilisation de la carte geforce, en general cela se fait dans le bios (sur les ordi dell du bureau qu'on utilise pour les demos) ou tu as une option "activer optimus" ou quelque chose dans ce style.

Link to comment
Share on other sites

Merci beaucoup Krenelcoffee, je ne connaissais pas la technologie Optimus.

J'ai fais quelques recherches sur Optimus et sur mon ordinateur portable (Dell XPS L502x), voila ce que j'ai trouvé :

Même avec la dernière MàJ du BIOS, il est impossible de désactiver l'IGP Intel (sur mon pc portable du moins). L'ordinateur ne permute pas entre les deux les cartes graphiques. D'un point de vue matériel, l'IGP Intel s'occupe toujours de la sortie de l'image sur l'écran LCD de l'ordinateur portable. Quand il est actif, le GPU NVIDIA copie les données graphiques dans la mémoire tampon de l'IGP Intel (qui réside dans la mémoire système). La technologie Optimus décide d'elle même ou selon les paramètres de l'utilisateur si le GPU Nvidia ou l'IGP Intel sera utilisé pour les calculs.

Sources :

http://superuser.com/questions/282734/how-to-disable-nvidia-optimus-on-a-dell-xps-15#284348

Par contre, je ne comprend toujours pas pourquoi je ne peux pas forcer l'utilisation du GPU Nvidia sur certaines applications (ex: VLC, itunes, Windows live movie maker). Est ce que le GPU Nvidia ne supporte pas certaines applications ? Dans le post ci-dessus, la personne dit "It currently does not support running the OS desktop compositing on the GPU." mais je ne comprend pas vraiment cette phrase.. Le GPU Nvidia ne supporte pas les élément du bureau ? De quoi parle t-il exactement ? Est ce que les différents logiciels que j'ai cité (VLC, itunes, etc...) utilise ces éléments ? Et pourquoi ne les supporte t-il pas ? Ça me parait bizarre...

Imaginons que je lance un film en super HD de fou avec VLC et que l'IGP Intel ne suit pas. C'est donc le GPU Nvidia qui devra effectuer les calculs. Le ferra t'il ? Ou ne le pourra t-il pas car "apparemment" il ne supporte pas l'application VLC ?

Pour les curieux, voici la page d'Nvidia qui explique la techno Optimus :

http://www.nvidia.fr/object/optimus_technology_fr.html

Link to comment
Share on other sites

Dans le doute j'ai teste sur mon laptop qui a également optimus (Sony Vaio Premium S avec une 640m sous win 8.1 avec les derniers drivers).

J'ai une situation similaire a la tienne : l'option des parametres 3D est gris, mais c'est normal vu que vlc n'est pas un programme 3D, donc le driver ne trouve rien pour y forcer la carte 3D.

Cependant, j'ai un raccourci pour vlc sur mon bureau et j'ai une option dans le menu contextuel (clic-droit sur l’icône) "Exectuer avec le processeur graphique" et la je peux sélectionner ma geforce.

Link to comment
Share on other sites

Oui je peux également lancer VLC avec le GPU Nvidia avec l'option dans le menu contextuel.

Tu as sans doute raison, vu que ce n'est pas une appli 3D, ça semble normale que l'option soit grisé dans les paramètre Nvidia.

Je laisse le sujet ouvert jusqu'à demain soir si quelqu'un a des explications plus précise et sinon je le mettrai en résolu.

Bonne soirée !

Link to comment
Share on other sites

Re bonsoir,

Je viens de découvrir une astuce pour forcer optimus à lancer une application avec le GPU Nvidia !

  1. Si le logiciel est grisé dans le dans la liste des programme 3D Nvidia (Si le logiciel n'est pas dans la liste ajouter le : Bouton droit sur le bureau -> Panneau de configuration Nvidia -> Paramètres 3D -> Gérer les paramètres 3D -> Onglet paramètres de programme -> Bouton "ajouter")
  2. Puis télécharger le logiciel "NVIDIA Inspector" (http://www7.zippyshare.com/v/93516335/file.html).
  3. Fermer le Panneau de configuration Nvidia et lancer le logiciel NVIDIA Inspector.
  4. Cliquer sur le bouton "Driver profile settings" (Petit bouton carré avec un tourne vis et une clef à molette au centre gauche de la fenêtre)
  5. Sélectionner le logiciel "à forcer" dans la liste déroulante en haut à gauche.
  6. Cherche la ligne "enable application optimus option" et changer son paramètre en ""SHIM_RENDERING_MODE_ENABLE".
  7. Cliquer sur "Apply changes" et fermer "NVIDIA Inspector" lorsqu'il a terminé ses modifications.
  8. Ré-ouvrer le Panneau de configuration Nvidia et sélectionner le processeur NVIDIA graphique Hautes performances (si ce n'est pas déjà fait).
  9. Cliquez sur le bouton "Appliquer" et voila !!!

J’espère que cela pourra aider certaines personnes !

Bonne soirée à tous !

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...