Jump to content

Archived

This topic is now archived and is closed to further replies.

Kori

Configuration réseau avec deux routeurs.

Publications recommandées

Ayant une demeure quelque peu hors norme, avec un joli mur porteur de 30cm en plein milieu.

Si les volumes sont sympas, le Wifi n'apprécie pas du tout.

Je possède actuellement deux routeurs TPLink TL-WR1043ND rootés tous deux sous OpenWrt. Cette dernière information ne change pas grand chose, excepté des possibilités de configs plus élevées et donc des super plantages qui vont avec (merci le mode sans échec via telnet, ça sauve la vie).

Cahier des charges :

- Avoir une couverture Wifi complète et de qualité (pour éviter les déconnexions)

- N'avoir au final qu'un seul réseau, où tous les clients pourront communiquer entre eux (serveur, imprimante réseau, dlna)

Détail du réseau :

Routeur 1

WAN : Depuis Freebox ip en 192.168.0.x

Interface LAN Ethernet + WiFi ip fixe en 192.168.1.x /Serveur dhcp activé /Interface WiFi en point d'accès

LAN 1 : Vers PC1

LAN 2 : Vers Serveur

LAN 3 : Vers WAN Routeur 2 => Modifié vers port LAN Routeur 2 voir post#3

LAN 4 : Libre

Routeur 2

WAN : Depuis LAN 3 Routeur 1 ip en 192.168.1.x => Libre voir post#3

Interface LAN Ethernet + WiFi ip fixe en 192.168.1.x /Serveur dhcp désactivé /Même SSID que routeur 1/ Interface WiFi en point d'accès /Canal WiFi différent du routeur 1

LAN 1 : Vers PC2

LAN 2 : (Projet TV dlna)

LAN 3 : Libre => Depuis LAN 3 Routeur 1 voir post#3

LAN 4 : Libre

Fonctionnement actuel

- Possibilité d'accéder à internet, couverture WiFi digne du Nirvana.

- Pas moyen de profiter du dhcp du routeur 1, donc ip fixe et passerelle doit correspondre au routeur 2

- Pas de communication entre clients des différents routeurs, les pings ne renvoient rien.

Et là je sèche pour arriver à obtenir un réseau unique. J'ai parcouru le net, je suis d'ailleurs tombé sur un sujet ici même (le seul digne d'intérêt et à la deuxième page !) datant de juin l'année passée.

Il me confirme mon câblage, mais pour la suite je n'en apprends pas plus.

Voilà j'ai finis mon patay, à vous :chinois:

Partager cette publication


Link to post
Share on other sites

A tu essayer de te servir de ton routeur 2 en répéteur wifi + switch (je sais pas si tu peu régler ça dans tes routeurs), comme ça c'est ton routeur 1 qui gère tout (DHCP...), et le 2 est juste là en renfort.

J'ai également un problème de non communications entre mon routeur est ma box. Moi j'étais en 192.168.1.x (box), et mon routeur en 192.168.2.x (pour mon réseau). J'ai jamais réussi à communiquer entre les 2...

Partager cette publication


Link to post
Share on other sites

A tu essayer de te servir de ton routeur 2 en répéteur wifi + switch (je sais pas si tu peu régler ça dans tes routeurs), comme ça c'est ton routeur 1 qui gère tout (DHCP...), et le 2 est juste là en renfort.

C'est bien tu as compris le titre du topic ;)

Bon j'ai avancé un peu, j'ai déplacé le câble d'arrivé du routeur 2 en LAN. J'avais suivis le modèle de câblage d'un répéteur, or il s'agit ici d'un routeur.

(Note : je pense qu'il peut tout à fait être posssible de laisser sur le WAN, et de créer un bridge entre l'interface WAN & LAN. Le tout en configurant la même ip sur les deux. Inconvénient = plus long à paramétrer / Avantage = récupérer un port LAN au besoin)

Fonctionnement actuel

- Les clients loggués sur des routeurs différents communiquent à présent entre eux

- Me reste à voir pour les connections WiFi, je n'ai pas l'impression que ça bascule naturellement d'un point à l'autre. OK c'est bon.

Edit : J'ai testé en créant des bridges sur les interfaces WAN et LAN, et bien sûr en déplaçant l'arrivée du routeur 1 sur le routeur 2 en WAN. Mais ça ne fonctionne pas...

Au final installation entièrement fonctionnelle, il faut juste s'adapter au matériel lors de la création d'une réseau d'itinérance.

Partager cette publication


Link to post
Share on other sites

OpenWRT me fait chier aussi pour passer un TL-WR841N en simple switch... J'ai pas tout compris ce que tu as fait avec et pour le moment il me permet de séparer deux réseaux (j'ai prêté le routeur pour une maison de vacances où l'internet est partagé entre plusieurs familles, la personne à donc un peu plus de sécurité...). Je le récupère dans 2 semaines je testerai ta méthode mais je suis toujours tombé en échec.

Partager cette publication


Link to post
Share on other sites

Qu'est-ce que tu n'as pas compris ? Si tu veux du détail ou des screens dis moi ce sera avec plaisir ;)

Partager cette publication


Link to post
Share on other sites

Bon je testerai dans 1 ou 2 semaines sur OpenWRT mais en suivant ce Topic sur le Forum D-Link j'ai pu mettre un routeur Linksys (WAG325N) en switch (alors que c'est un modem/routeur), ainsi qu'une LiveBox (Ni le WAG ni la LB ne sont connectés via leur modem interne, c'est une Freebox qui gère la connexion + DHCP en ce moment). La difficulté avec OpenWRT sera d'utiliser le port WAN en port LAN, car avec les firmware stock ils ne veulent pas.

Partager cette publication


Link to post
Share on other sites

On voit bien sur le lien qu'ils n'utilisnet pas le port wan du second routeur (si j'ai bien compris, un switch n'aurait pas d'interface Wan). De mon côté je n'ai pas réussis à faire fonctionner autrement. Mes tests de bridge Wan/ Lan se sont soldés par des échecs.

Pour les firmware stock c'est normal, l'accès aux interfaces est volontairement fermé (quand tu vois la facilité de planter le truc, tu comprends rapidement pourquoi. De mon côté je ne compte plus mes accès en telnet :mdr: )

On en reparle lorsque tu récupères ton routeur, on croisera nos infos à ce moment là ;)

Partager cette publication


Link to post
Share on other sites

De ce que j'ai lu (et pour avoir eu des TL-WA901ND aujourd'hui sous OpenWRT), il ne faut pas chercher à bridge WAN/LAN mais mettre le eth0 en bridge avec eth1 en cassant un VLAN fait par défaut. Chaque port/chaque interface peut servir aussi bien de LAN ou de WAN selon la config (je vais donc essayer le Dual WAN en demandant au voisin son code WiFi un jour prochain :-p).

De la doc en vrac :

http://wiki.openwrt.org/doc/uci/network/switch

http://wiki.openwrt.org/doc/uci/network#switch

(Non ce ne sont pas les mêmes liens même si leurs URL sont identiques à un caractère près ^^)

Partager cette publication


Link to post
Share on other sites

(Re je bosse sur un autre projet en ce moment, donc peu de présence ;) )

Houlà c'est loin d'être, je cherchais où tu trouvais eth1 en fait il faut l'activer...

Un volontaire pour me traduire la doc, je pige pas tout :transpi:

Partager cette publication


Link to post
Share on other sites

J'ai testé hier soir, en fait c'est tout con.

Tu mets une IP statique sur "LAN", coupe le serveur DHCP sur LAN, fout eth0 dans le Bridge LAN et supprime WAN. Et tada !

Partager cette publication


Link to post
Share on other sites

Han j'étais à deux doigts de réussir sans tuto :mad:

Du coup tu récupères une entrée ethernet par rapport à ce que j'ai fait.

Bon couper le dhcp ça c'était obligé, mais au lieu de bridger eth0 j'avais bridgé le wan.

En fait il fallait attaquer un cran au dessus, quel âne je fais ^^

Merci pour le retour :chinois:

Pour la petite histoire, j'ai une tablette sous android qui me casse les noix. Cette andouille ne se log pas forcément sur le meilleur signal.

Résultat j'ai déjà du à deux reprises couper le wifi du plus éloigné, pour forcer la bascule... Tout ça parce que le reboot est long et en général elle n'est pas éteinte mais en veille.

Partager cette publication


Link to post
Share on other sites

Android ™ :transpi:

Bon pour le moment le bridge tient, mais à chaque fois que je regarde j'ai pas de client WiFi connecté dessus (et pas encore d'eth), ils sont pour la plupart en 5GHz et les autres AP 2.4GHz sont plus proches de mon bureau ^^ Je vais changer l'emplacement de ce routeur je pense :dd:

Sinon j'ai une question par rapport à Smoothwall Express et du LAN, va falloir que je fasse un topic...

Partager cette publication


Link to post
Share on other sites

×