Jump to content

ouverture documents word dans ie9 / win7


Exodus

Recommended Posts

Bonjour,

Je suis confronté à un petit bug assez prise de tête: j'ai un pc sous Windows 7 64 bits avec ie9, dessus sont installés OpenOffice 1.1.1 (version obligatoire pour un logiciel métier) et office 2010 famille et petite entreprise.

Word est bien le programme par défaut pour ouvrir les .doc mais quand j'ai un lien qui pointe vers un .doc c'est systématiquement Open Office qui l'ouvre (avec des bugs) dans le navigateur.

Je crois avoir tout essayé (modification du registre, fix de Microsoft, désinstallation de l'OO puis nettoyage du registre, ça remarche mais dès la réinstallation paf, etc..).

J'avais été confronté au même problème sous un xp pro et la ça avait été simple:

  1. Ouvrez le Poste de travail.
  2. Dans le menu Outils (ou le menu Affichage), cliquez sur Options des dossiers (ou sur Options).
  3. Cliquez sur l'onglet Types de fichiers.
  4. Dans la liste Types de fichiers enregistrés, cliquez sur le type de document Office spécifique (par exemple Feuille de calcul Microsoft Excel), puis cliquez sur Avancée (ou sur Modifier).
  5. Dans la boîte de dialogue Modification du type de fichier, désactivez la case à cocher Parcourir dans une même fenêtre (ou Ouvrir les documents Web sur place).
  6. Cliquez sur OK.

http://support.microsoft.com/kb/162059/fr

Je n'ai rien trouvé non plus dans les options d'ie; sur Firefox je n'ai pas le problème et c'est bien Word2010 qui ouvre les .doc mais Firefox n'est pas compatible avec le logiciel métier....

Link to comment
Share on other sites

Si tu ouvre un doc ou un docx ça s'ouvre avec Word si c'est depuis le bureau par exemple et ça merde quand c'est dans le navigateur.

Clique voir à droite dans IE sur l'engrenage -> Gérer les modules complémentaires

Dans la liste tu devrais trouver le module Open Office qui provoque ça, en principe tu as juste à le désactiver:)

Link to comment
Share on other sites

Si tu ouvre un doc ou un docx ça s'ouvre avec Word si c'est depuis le bureau par exemple et ça merde quand c'est dans le navigateur.

Clique voir à droite dans IE sur l'engrenage -> Gérer les modules complémentaires

Dans la liste tu devrais trouver le module Open Office qui provoque ça, en principe tu as juste à le désactiver:)

Malheureusement pas de module complémentaire OpenOffice, même en affichant tout..

Link to comment
Share on other sites

Si tu démarre ie en mode sans échec (le raccourci est en haut du menu démarrer :)) est-ce que ça le fait aussi ?

Quand tu fait démarrer -> programmes par défaut : Word a-t-il toutes ses valeurs par défaut ? (indépendamment de la solution de la kb)

Link to comment
Share on other sites

Si tu démarre ie en mode sans échec (le raccourci est en haut du menu démarrer :)) est-ce que ça le fait aussi ?

Quand tu fait démarrer -> programmes par défaut : Word a-t-il toutes ses valeurs par défaut ? (indépendamment de la solution de la kb)

en mode sans échec je n'ai plus du tout d'affichage des .doc (page blanche avec petite croix rouge), dans les programmes par défaut Word n'apparait pas.

Link to comment
Share on other sites

D'accord, il n'y a donc aucun doute qu'il s'agit d'un problème de shell. :)

De but en blanc j'hésite entre le "lancement rapide d'open office" ou un truc du genre (puisque l'interception est en temps réel). Je regarde sur une machine virtuelle et je reviens vers toi :)

EDIT : tu as bien dis 1.1.1 ??? Je viens de percuter lol.... c'est peut être ça le truc parce que ce qui était valable sous XP ne l'est pas forcément sous 7 => on parle d'un logiciel de 8 ans là :X

Pourquoi n'utilisez vous pas une version plus récente ? (ça marche vraiement pas ton logiciel métier dans ce cas) ?

Parce que en VM j'ai pas de version assez ancienne de open office pour faire un essai lol ^^ Et comme je pense pas rencontrer le bug avec les actuelles

EDIT 2 : la date d'abandon de l'appli est tellement ancienne que je retrouve pas la doc mais du coup je suis sur que le truc est à chercher dans ton vieux open office. Les gestionnaires de téléchargement utilisent aussi une interception des liens pour pouvoir ouvrir un type de fichier donné. Il faut donc que ça soit une appli lancée au moment où ça se produit (donc comme je disais un peu plus haut le launcher ou un truc comme ça)

Link to comment
Share on other sites

je suis en train de chercher, j'avais déjà désactivé le démarrage rapide, je regarde dans les options mais sans y croire

et oui, c'est la 1.1.1 obligatoire....

edit: je n'ai rien trouvé... mais maintenant que j'empeche completement oo de se lancer j'ai le message

"Les données d’installation du programme dans Active Directory sont endommagées" dans ie....

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...