Jump to content

les icones de mon bureau disparaissent


Recommended Posts

Bonjour à tous,

voila je suis sur ubuntu hardy 64 bits.

je désire ajouter un second ecran sur mon poste, alors j'ai choper le contenu du xorg.conf d'un de mes collegues avec qui tout va bien, mais chez moi, ca fait disparaitre toutes les icones de mon bureau (le bureau apparait comme vide, mais quand je navigue dans les dossiers et que je rentre dans le bureau la je les vois).

juste apres l'installation de mon ubuntu, la section screen de mon xorg.conf ressemblait a ca:

Section "Screen"

Identifier "Default Screen"

Monitor "Configured Monitor"

Device "Configured Video Device"

Defaultdepth 24

EndSection

voila les lignes que j'ai rajouter dans mon xorg.conf, et qui ont foutu la merde (les 1er lignes sont celle d'au dessus) :

Section "Screen"

Identifier "Default Screen"

Monitor "Configured Monitor"

Device "Configured Video Device"

Defaultdepth 24

Option "RenderAccel" "True"

Option "TwinView"

Option "TwinViewOrientation" "LeftOf"

Option "MetaModes" "1280×1024 1280×1024"

EndSection

avez vous une idée de pourquoi mon bureau se vide t'il?

merci d'avance

Link to comment
Share on other sites

Bon, comme y'a pas trop de solution, je suis repasser avec mon xorg.conf.

Là je n'ai qu'un ecran "samsung 20 pouces" qui fonctionne tres bien, et mon bureau fonctionne bien lui aussi. Les drivers nvidia sont installés (les derniers)

Là je m'adresse à ceux qui savent configurer le fichier xorg.conf, sachant qu'il faudrait que je rajoute un ecran à gauche de mon samsung. Le samsung doit rester l'écran principale, ca résolution max est de 1680x1050.

L'écran de gauche est un nec 17 pouces avec resolution max 1280x1024.

je met le contenu de mon fichiers xorg.conf :

Section "InputDevice"
	Identifier	  "Generic Keyboard"
	Driver		  "kbd"
	Option		  "XkbRules"	  "xorg"
	Option		  "XkbModel"	  "pc105"
	Option		  "XkbLayout"	 "fr"
	Option		  "XkbVariant"	"oss"
	Option		  "XkbOptions"	"lv3:ralt_switch"
EndSection

Section "InputDevice"
	Identifier	  "Configured Mouse"
	Driver		  "mouse"
	Option		  "CorePointer"
EndSection

Section "Device"
	Identifier	  "Configured Video Device"
	Driver		  "nvidia"
	Option		  "NoLogo"		"True"
EndSection

Section "Monitor"
	Identifier	  "Configured Monitor"
EndSection

Section "Screen"
	Identifier	  "Default Screen"
	Monitor		 "Configured Monitor"
	Device		  "Configured Video Device"
	Defaultdepth	24
EndSection

Section "ServerLayout"
	Identifier	  "Default Layout"
 screen "Default Screen"
EndSection
Section "Module"
Load			"glx"
EndSection

svp aidez moi ca fait des mois que j'ai pas de bureau lol, comment configurer correctement mon xorg.conf????

merci d'avance

Link to comment
Share on other sites

Mon xorg.conf ressemble à ça :

Section "ServerLayout"
   Identifier     "Layout0"
   Screen      0  "Screen0" 0 0
   Screen      1  "Screen1" RightOf "Screen0"
   InputDevice    "Keyboard0" "CoreKeyboard"
   InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
   FontPath        "/usr/share/fonts/100dpi"
   FontPath        "/usr/share/fonts/75dpi"
   FontPath        "/usr/share/fonts/TTF"
   FontPath        "/usr/share/fonts/Type1"
   FontPath        "/usr/share/fonts/cyrillic"
   FontPath        "/usr/share/fonts/local"
   FontPath        "/usr/share/fonts/misc"
EndSection

Section "Module"
   Load           "dbe"
   Load           "extmod"
   Load           "freetype"
   Load           "glx"
EndSection

Section "ServerFlags"
   Option         "Xinerama" "1"
EndSection

Section "InputDevice"
   Identifier     "Mouse0"
   Driver         "mouse"
   Option         "Protocol" "auto"
   Option         "Device" "/dev/input/mice"
   Option         "Emulate3Buttons" "no"
   Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
   Identifier     "Keyboard0"
   Driver         "keyboard"
   Option         "XkbLayout" "be"
EndSection

Section "Monitor"
   Identifier     "Monitor0"
   VendorName     "Samsung"
   ModelName      "SyncMaster 940N"
   HorizSync       30.0 - 81.0
   VertRefresh     56.0 - 75.0
   Option         "DPMS"
EndSection

Section "Monitor"
   Identifier     "Monitor1"
   VendorName     "Samsung"
   ModelName      "SyncMaster 940N"
   HorizSync       30.0 - 81.0
   VertRefresh     56.0 - 75.0
   Option	    "DPMS"
EndSection

Section "Device"
   Identifier     "Device0"
   Driver         "nvidia"
   VendorName     "NVIDIA Corporation"
   BoardName      "GeForce 8800 GT"
   BusID          "PCI:1:0:0"
   Screen          0
EndSection

Section "Device"
   Identifier     "Device1"
   Driver         "nvidia"
   VendorName     "NVIDIA Corporation"
   BoardName      "GeForce 8800 GT"
   BusID          "PCI:1:0:0"
   Screen          1
EndSection

Section "Screen"
   Identifier     "Screen0"
   Device         "Device0"
   Monitor        "Monitor0"
   DefaultDepth    24
   Option         "InitialPixmapPlacement" "2"
   Option         "GlyphCache" "1"
   Option         "PixmapCacheSize" "300000"
   Option         "OnDemandVBlankInterrupts" "true"
   Option         "NoLogo" "True"
   Option         "TwinView" "0"
   Option         "TwinViewXineramaInfoOrder" "CRT-0"
   Option         "metamodes" "CRT-0: nvidia-auto-select +0+0"
   SubSection     "Display"
       Depth       24
   EndSubSection
EndSection

Section "Screen"
   Identifier     "Screen1"
   Device         "Device1"
   Monitor        "Monitor1"
   DefaultDepth    24
   Option         "TwinView" "0"
   Option         "metamodes" "CRT-1: nvidia-auto-select +0+0"
   SubSection     "Display"
       Depth       24
   EndSubSection
EndSection

Tu peux aussi essayer de configurer ton dualscreen avec l'utilitaire de Nvidia (d'ailleurs c'est ce que j'ai fait pour obtenir cette config :transpi: )

Link to comment
Share on other sites

peut tu me dire comment on lance cet utilitaire ?

je n'ai que que "nvidia-xconfig" qui fait quasiment rien.......

merci pour ton aide

sudo nvidia-settings. sudo car il doit écrire dans xorg.conf,

Il te faudra probablement l'installer.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...