Jump to content

copie d'une VM debian sur un autre poste


Recommended Posts

bonjour tout le monde;

voila je vous expose mon soucis.

Actuellement je travaille avec une Debian etch 3 virtualisée sous Vista par Vmware server 1.04.

Récemment j'ai changé de poste, tout ré-installé mais mon soucis est que maintenant sous ma debian je n'ai plus mon interfaces réseau.

j'avais déjà eu ce soucis suite à un autre changement de poste et je me rappel que j'avais due supprimer un ligne dans un fichier sur ma debian.

Dans mes souvenirs le soucis venait du fait que les adresses MAC de mon poste ayant changé, linux est perdu et ne peu plus 'up' les interfaces.

J'ai passé ma matinée à chercher mais je ne trouve plus la solution, alors si quelqu'un à une idée ou alors connait ce soucis, merci :)

quelques screens:

uname.jpg

interfaces.jpg

ifconfig.jpg

merci :)

Link to comment
Share on other sites

  • 2 weeks later...

Salut

Il se peut que vmware ait changé un id, sur lequel l'adresse mac est basée.

Donc tu as changé d'adresse mac.

Le probléme c'est que les périphériques sont gérées par udev.

Il nome les interfaces réseau par une relation entre l'adrese mac et le nom, comme ceci :

<code>

# PCI device 0x1022:0x2000 (pcnet32)

SUBSYSTEM=="net", DRIVERS=="?*", ATTRS{address}=="00:0c:29:70:14:16", NAME="eth0"

</code>

Donc ifconfig -a devrait te montrer une eth1

Tu peut editer le fichier de conf suivant /etc/udev/rules.d/z25_persistent-net.rules

pour corriger le problème

a+

Link to comment
Share on other sites

  • 2 weeks later...

Bonjour,

Quand tu as démarrer ta VM sur l'autre machine, au démarrage VMWare a du te demander s'il fallait créer un nouveau uid. Si tu as ce problème j'imagine que tu as répondu oui.

Pour résoudre ça il suffit de supprimer l'interface eth0 et de la recréer.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...