Jump to content

PC lent après installation xgl pour compiz fusion


Recommended Posts

Bonjour,

J'ai installé compiz fusion, mais pas de cube, après quelques recherche j'install xserver-xgl, je reboot, le cube fonctionne, mais le pc est beaucoup plus lent, quand je dessend une fentre dans firefox ca saccade a mort, me semblait pas que ca le faisait avant...

suis sous un pentium M 1.8Ghz et ati radeon 9600 ou 9800, kubuntu a jour

On m'a dit qu'xgl faisait ralentir mon pc et que je n'en avais po besoin, mais sans je n'arrive pas a faire fonctionner le cube, donc si je désinstalle ca devrait redevenir fluide, mais quid du cube ? :-/

merci par avance :roule:

Link to comment
Share on other sites

AHAH !

Encore une victime d'ubuntu !

Et oui, j'ai beau aimer cette distrib, ils foirent vraiment sur ce coup là !

Donc, tu désinstalles xgl, tu réinstalles xserver-xorg, xserver-xorg-core avec purge et enfin tu installes libgl1-mesa-dri et libgl1-mesa-glx

Dans ton xorg.conf tu mets ati comme driver.

Tu reboot

Tu apprécies :humour:

Link to comment
Share on other sites

Bon suis repartie sur une configuration propre, je viens de réinstaller kde, j'ai fait system => desktop effect personnalisé et j'ai installé le setting manager de compiz, mais rien ne fonctionne, mon xorg est comme ca

# xorg.conf (X.Org X Window System server configuration file)

#

# This file was generated by dexconf, the Debian X Configuration tool, using

# values from the debconf database.

#

# Edit this file with caution, and see the xorg.conf manual page.

# (Type "man xorg.conf" at the shell prompt.)

#

# This file is automatically updated on xserver-xorg package upgrades *only*

# if it has not been modified since the last upgrade of the xserver-xorg

# package.

#

# If you have edited this file but would like it to be automatically updated

# again, run the following command:

# sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"

Identifier "Generic Keyboard"

Driver "kbd"

Option "XkbRules" "xorg"

Option "XkbModel" "pc105"

Option "XkbLayout" "fr"

Option "XkbVariant" "oss"

EndSection

Section "InputDevice"

Identifier "Configured Mouse"

Driver "mouse"

Option "CorePointer"

EndSection

Section "InputDevice"

Identifier "Synaptics Touchpad"

Driver "synaptics"

Option "SendCoreEvents" "true"

Option "Device" "/dev/psaux"

Option "Protocol" "auto-dev"

Option "HorizEdgeScroll" "0"

EndSection

Section "Device"

Identifier "Configured Video Device"

EndSection

Section "Monitor"

Identifier "Configured Monitor"

EndSection

Section "Screen"

Identifier "Default Screen"

Monitor "Configured Monitor"

Device "Configured Video Device"

EndSection

Section "ServerLayout"

Identifier "Default Layout"

Screen "Default Screen"

InputDevice "Synaptics Touchpad"

EndSection

Je dois le mettre ou le ATI, je seche un peu...

Link to comment
Share on other sites

  • 2 weeks later...

Ha oui j'avais oublié. ^^

Il y a moyen qu'on reprenne ici depuis le début ce que je dois faire, car c'est un peu confu pour moi le topic, suis un peu noob, même si je tente d'apprendre...

Là mon kde est a jour tout propre, rien d'installé ni de modifier, meme pas compiz d'installer...

Au demarrage je viens d'avoir une petite icone carte graphique vers l'horloge me disant que l'accelerateur graphique n'etait pas activer, je l'ai pas fait, vais attendre vos conseils, même si là du coup elle a disparu l'icone...

Enfin voila, si vous avez le temps et l'envie de reprendre de 0 les etapes ca serait cool :)

Link to comment
Share on other sites

Enfin voila, si vous avez le temps et l'envie de reprendre de 0 les etapes ca serait cool :)

Pas très dur, surtout si c'est tout frais

Donc, tu désinstalles xgl, tu réinstalles xserver-xorg, xserver-xorg-core avec purge et enfin tu installes libgl1-mesa-dri et libgl1-mesa-glx

Dans ton xorg.conf tu mets ati comme driver.

Tu reboot

Tu apprécies :chinois:

Link to comment
Share on other sites

Les deux sont deja installés a l'origine.

et dans mon xorg j'ai ca

Section "Device"

Identifier "Configured Video Device"

EndSection

il faut que je le mette comment ?

Me semble que j'avais deja testé mais j'avais eu un ecran noir au reboot, et le startx voulait pas, j'avais juste ajouter "driver "ati" "

Link to comment
Share on other sites

Ai ajouté comme tu dis, ca démarre c'est toujours ca, mais toujours rien.

Ai tenté de taper "compiz" en commande et ca me renvoie

tom@tom-laptop:~$ compiz

Checking for Xgl: not present.

Found laptop using ati driver.

aborting and using fallback: /usr/bin/kwin

Je précise que j'ai installé compiz via : K - system - desktop effect

puis le setting compiz via adept.

Link to comment
Share on other sites

J'ai utilisé la deuxième solution, la première etait plus complexe :byebye:

Et ca fonctionne \o/

Merci a vous =)

Par contre pkoi désactiver volontairement les ati dans compiz sur les laptop ?

Et en plus ca a l'air fluide, je sais pas s'il y a des test pour voir si c'est pas mal, mais a première vu ca va =)

Link to comment
Share on other sites

Ha tiens si quelqu'un sait ou se trouve le reglage pour les fenetre qu'ils me le disent, car là j'ai par exemple firefox et par dessus kopete, mais quand je clique sur firefox il ne reviens pas en premier plan, et kopete reste devant, il faut que je clique sur la barre bleu tout en haut de firefox pour qu'il passe en premier plan, un poil chiant ^^

Link to comment
Share on other sites

Effectivement il faut skipper les checks, je ne sais pas pourquoi. J'aurais du te le dire dès le début mais je pensais que c'était réparé... On dirait que non... ati était une bête noire avant mais je ne sais pas si c'était la raison...

Pour ton problème, j'ai un soucis similaire auquel je n'ai pas su apporter de solution. Toi c'est quand tu changes de fenetre c'est ça ? Moi c'est quand je lance une appli. Elle part toujours derriere...

Si tu as une solution n'hésite pas :D

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...