Jump to content

Archived

This topic is now archived and is closed to further replies.

DébutantCoco

[RESOLU] Problème réseau

Recommended Posts

Bonjour,

Je suis actuellement sous Debian et me voila confronté a un problème à priori résolvable mais embêtant ^^

Je vous explique:

Au démarrage de ma machine, je choisi mon système d'exploitation Debian grâce à Grub, et pendant le chargements des différents fichiers voici l'erreur qui apparait:

Could'nt read interfaces file /etc/networks/interface	Failed

J'ai alors analysé les droits de lecture sur ce fichiers.. Tout semblait correct

J'ai tenté la commande "/etc/init.d/networking restart" => Failed

Après de nombreux redémarrage, je me suis dis que j'allait effacer le fichier "etc/networks/interface" et qu'au prochain démarrage, le système régénèrera ce fichier automatiquement.. Mauvaise idée, le système n'a régénéré aucun fichier et je me retrouve sans ce fameux fichier "etc/networks/interface"

Je peux vous préciser également que le service Samba ne se lance pas au démarrage mais je suppose que ce problème est lié avec mon problème ci-dessus.

J'attend vos réponse avec impatience car je me retrouve sans connexion et c'est plutôt embêtant :chinois:

N'hésité pas à me demandé d'autre informations :byebye:

:D

PS: Si quelqu'un pouvais me fournir un fichier "etc/networks/interface" correct ca m'arrangerais :eeek2:

Share this post


Link to post
Share on other sites
PS: Si quelqu'un pouvais me fournir un fichier "etc/networks/interface" correct ca m'arrangerais :francais:

Se fichier existe sous Ubuntu.

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet dhcp

auto eth1
iface eth1 inet dhcp

auto eth2
iface eth2 inet dhcp

auto ath0
iface ath0 inet dhcp

auto wlan0
iface wlan0 inet dhcp

tu te connecte en Ethernet , usb, wifi ?

As tu besoin de rentrer des paramêtres du compte de ton FAI pour établir une connection ?

le daemon dhcpd est il installé et lancé ?

#  ps ax | grep dh

ifconfig te donne quoi ?

Share this post


Link to post
Share on other sites

Tout d'abord Merci pour ta réponse :transpi:

Merci pour ton fichier mais le mien ne ressemblais pas à ça car je ne suis pas en DHCP

Je me connecte en ethernet avec une IP fixe (attribuée manuellement)

Oui j'ai besoin de rentrer les paramètres du compte de ton FAI pour établir une connection :reflechis:

ifconfig me donne 0.0.0.0 comme IP pour eth0, eth1 et eth2

Je ne peux pas vous fournir trop d'informations maintenet car je ne suis pas sur ma machine ^^

Merci de votre aide :transpi:

Pour d'autres informations n'hésité pas à demander :reflechis:

Share this post


Link to post
Share on other sites
Merci pour ton fichier mais le mien ne ressemblais pas à ça car je ne suis pas en DHCP

Je me connecte en ethernet avec une IP fixe (attribuée manuellement)

Se connecter en dhcp est tellement plus simple......

Comme tu l' indique, 0.0.0.0 veut tout simplement dire que ton accès a internet est mal configuré

en 1er il faut savoir tes adresses, IP, masque réseau, passerelle et les DNS

Tu peux essayer de configurer ta connection en IP fixe a partir des outils de Gnome et KDE ( ce qui éviterais des commandes )

pour le configurer tu peux essayé de rentré ça a la main, mais je suis pas sur que le fichier etc/networks/interface serve bien à ça.....

auto eth0
iface eth0 inet  192.168.0.2 netmask 255.255.255.0

Pourquoi ne pas essayer configurer tes adresses static a la main sans passé par se fichier

exemple:

ifconfig eth0 192.168.0.2 netmask 255.255.255.0 broadcast 192.168.0.255 up

la commande route te donne quoi ?

exemple:

]$ route
Kernel IP routing table
Destination	 Gateway		 Genmask		 Flags Metric Ref	Use Iface
82.xxx.xxx.0	*			   255.255.255.0   U	 0	  0		0 eth0
default		 82.xxx.xxx.254  0.0.0.0		 UG	0	  0		0 eth0

et ensuite faire :

exemple:

route add default gw 82.xxx.xxx.254

fait aussi un cat /etc/resolv.conf et post le contenu

le resolv.conf se génère tout seul normalement et c' est lui qui contient les adresse dns

lo ( :Local Loopback ) te montre bien, une adresse 127.0.0.1 avec la commande ifconfig

après des multiples vérifications avec la commande ifconfig

essaye de faire des ping ta passerelle ( si elle veut bien )

et avec des adresse internet

 ping -c4 82.104.xxx.xxx
ping -c4 www.pcimpact.com

man ifconfig pour plus d' infos

q = quitter le man

dhcp est tellement plus simple :transpi:

Share this post


Link to post
Share on other sites

Bonsoir,

Je viens vous dire que mon problème est résolu :keskidit:

Tout d'abord, j'ai recréé mon fichier /etc/networks/interfaces grâce au information que loon m'a fournit

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet dhcp

auto eth1
iface eth1 inet dhcp

auto eth2
iface eth2 inet dhcp

auto ath0
iface ath0 inet dhcp

auto wlan0
iface wlan0 inet dhcp

ensuite j'ai taper en root la commande "/etc/init.d/networking restart"

Cette commande reconfigure les paramètres de mes cartes réseau en envoyant des requetes sur le réseau pour trouvé le serveur DHCP (mon modem/routeur)

Pour finir, un petit "ifconfig" suivi d'un "ping" m'ont permis de constater que tout refonctionnait :reflechis:

Tu a raison loon c'est tellement plus facile en DCHP :chinois:

Bonne soirée et encore merci pour ton aide :chinois:

Share this post


Link to post
Share on other sites

×
×
  • Create New...