Jump to content

patos

INpactien
  • Posts

    366
  • Joined

  • Last visited

Posts posted by patos

  1. Il y a 10 heures, Fab'z a dit :

    Mes bench ont été fait sur du Windows Server 2019. Je sais pas faire de teaming autrement avec une Intel X722.

    Windows server ça change tout.

    Sur ton NAS, tu mets deux IPs sur deux cartes réseaux différentes, les deux joignables en iSCSI. Pas de LACP: des ports normaux (sauf un vlan si besoin est).

    Sur ton serveur, tu dissocies les 2 cartes et leur mets 2 IPs distinctes: pas de LACP pas de teaming. Rien (sauf un vlan si besoin est).

    Sous du Windows Server, il faut activer la fonctionnalité Multipathing I/O (MPIO). Reboot. Ensuite, dans ce module, tu actives le support du iSCSI logiciel. Reboot. Ensuite dans le module iSCSI Software Initiator, tu connectes ton lecteur. Tu vas dans tes cibles favorites et efface tout. Tu retournes là ou tu connectes ton lecteur et sur ton disque, tu ajoute un chemin en cochant "support de chemin multiples". Reboot. Ensuite tu retournes dans l'initiateur iSCSI et tu rajoutes à nouveau des chemins avec les 2 IPs de tes cartes réseaux vers les 2 IPs de ton NAS, à chaque fois en cochant les 2 cases (dont celle qui dit chemin multiples). Tu obtiens donc 5 chemins enregistrés: 4 spécifiques, et 1 avec l'IP source automatique et une des IPs du NAS. Une fois fait, tu retourne dans ton périphérique sur l'intiateur iSCSI dans la gestion des chemins et passe en mode "alterné circulaire".

    Félicitations, tu as possède le débit maximal de ton NAS par rapport à ton poste.

  2. il y a 30 minutes, Fab'z a dit :

    @patos Hello !

    Je te rassure c'est juste pour les chiffres que j'ai essayé l'agrégat 10Gb 😉 Mais j’ai mal lu le protocole de test de Syno, leur bench est fait sur de l’agrégat iSCSI. Donc faut que je recommence avec le MPIO et le MCS pour réussir a réunir les conditions pour atteindre les chiffres annoncés. Je suis juste curieux de savoir si je peux dépasser ces chiffres avec du M.2 NVMe plutôt qu'un RAID de SATA.

    Dans les faits je suis autour des 900€ TTC, cartes réseaux 2x10G switch et fibres. 😄 Après j'avais pas un choix fou pour avoir des cartes certifié Windows ou VMware en mono SFP+...

    Mais je pense que je me plante depuis longtemps. C'est trompeur d'avoir affiché la somme des vitesses des agrégats alors qu'en fait on peu pas avoir un unique transfert à cette vitesse cumulé. Sauf avec quelques tours de passe passe en l’occurrence mais j'ai pas trouvé beaucoup de sites qui parlent de cette fausse idée du LACP. Je l'utilise au boulot pour avoir un lien de secours depuis des switchs d'accès Aruba IO vers des coeurs en Aruba 2930F stacké, je suis pas hyper fan du spanning tree. J'ai suivi les conseils d'un presta... bon. On verra si c'est si chiant que tu le dis.

     

    Dans tous les cas je suis content des perf'. Maintenant j'ai bien 2 tiers de stockage sur le NAS (pour ceux que ça intéresse) ça me permet d'utiliser des SSD en plus alors que les 2 ports M.2 du PC sont déjà occupés. J'utilise les ports SATA du PC pour mes vieux SSD. le double SFP+ me servira quand même, une interface pour accéder au réseau classique et l'autre pour du direct SCSI. Il devrait tout tenir normalement. D'ailleurs les bench' ont fait chauffer le proc' ^^ il a pris 12°C dans les essais. 😛

    Super content 🙂

     

    Le LACP est une bonne idée entre équipements dédiés: switchs du même fabricant (mieux: modèle), équipements testés. Là où c'est une mauvaise idée, c'est quand on s'en sert pour du stockage réseau.

    Le réseau iSCSI possède le protocole MPIO dans le milieu professionnel: il te permet qu'une ou plusieurs IPs soient connectés à une ou plusieurs IPs, ce qui multiplie les chemins comme des petits pains et permet, grâce à la gestion des chemins, d'avoir de la redondance. Windows 10 ne supporte le MPIO qui sur la version Volume Licence (Enterprise je crois). Sinon c'est Windows Server, et là tu peux faire péter les scores ^^

    Quand tu fais du réseau de bâtiment, le LACP est entre équipements qualifiés. Sinon, y'a les liens administratifs qui sont pas mal (deux liens ON entre deux switchs sans spanning tree: un lien est actif l'autre non. En cas de problème, instant up de l'autre et retour à l'original dès que ça le peut. L'avantage est qu'il n'y a pas de LACP à gérer en face !).

    Par contre, le LACP, c'est top sa mère pour le réseau de datacenter par contre. Surtout avec les équipements qui font du MLAG: du LACP entre un équipement d'un côté et deux de l'autre (exemple: DELL S4112T). Redondance totale, débits de cons avec l'utilisation de tous les chemins, etc... J'ai jamais réussi à saturer mes LACP à 4x40GB (pourtant j'y ai mis du coeur ^^ )

  3. Ben dis donc, tu t'emmerdes dans la vie 😄

    Un lien agrégué 20G, c'est une erreur. Pourquoi ?

    -Pour du iSCSI, un coeur CPU tient environ 3,5G de charge en débit fichier, sans accélération matérielle. C'est dû au trafic TCP/UDP qu'il faut gérer (les checksums etc..). Avec une carte accélératrice, tu peux monter à 10G, mais tu viens de perdre 1000€HT. En multithread sans carte, tu peux atteindre 8 à 9G. Tu n'as pas besoin de plus de 10G.

    -2x10G n'est pas plus rapide que 10G. Les paquets mettent le même temps de trajet: tu peux seulement en passer plus à la fois. Pas de bol, ce type de protocole n'est pas à l'aveugle mais a besoin de réponse du client (1G en download prends environ 30M en upload pour le contrôle). Les réponses n'étant pas plus rapides, tu ne gagnes pas en débit. Si tu veux gagner, il faut du 25G. Non, du 40G ne ferait pas mieux l'affaire (car c'est 4x10G dans un SFP).

    -LACP. L'acronyme d'emmerdes en réseau. Pour être relativement tranquille, il faut que ton switch possède une dégradation vers un port réseau classique si le LACP merde. En gros, si un port tombe, le LACP fonctionne toujours, mais si le LACP côté client ou serveur se met en vrac, have fun pour le diagnostic... Avec la dégradation (fallback), tu peux débrancher un câble et comme ça il agit comme un port normal.

    Un port 10G c'est cher. Alors 2 ports 10G pour 10G, c'est naze 😄

     

    Du coup, parlons NAS de merde: tes performances sont excellentes:

    - Q8T1-1M séquentiel = concours de zizi. Dans la vie, on se la tape sur la chaise.

    - Q1T1-1M séquentiel excellent

    - Q32T1-4K random = la vie. Au delà de 100M sur cette statistique, ton matos est bon. Par contre le cache SSD fait tout parce que le Q32T1 force les purges de cache... Donc ton raid5 finit carpette (d'où les performances nazes sans le SSD )

    - Q1T1-4K random = la vie saturée. Il est plus qu'excellent vu le comportement de ce test. N'oublie pas que ce test consiste à vouloir transférer un fichier de 100M par la poste tarif éco.

     

    Bref, y'a des baies à 50K€ qui ont de moins bonnes performances que ton nas (mais elles, les performances sont constantes du premier au dernier Go). Alors soit très content ainsi 😄

     

  4. Il y a 21 minutes, Minikea a écrit :

    non, même comme ça. apparemment la LB n'aime pas du tout les configurations où elle n'est pas le DHCP. mais bon, le jour où j'aurais du temps à perdre j'essaierai de monter tout ça sur le switch avec des vlan qui vont bien.

    Ben moi ça fonctionne bien. T'as dû péter autre chose 😉 (ou t'as trop fait le con sur ta livebox avant)

    (Livebox 4, Pro 4 & 5)

  5. Il y a 7 heures, Minikea a écrit :

    la question n'est pas de savoir si je peux mais si ça fonctionne ensuite. et la réponse est que la LB n'arrive plus à communiquer avec le routeur si je fais ça (me demande pas pourquoi, la LB dès que tu sors du cas standard, tu a 0 support)

    C'est parfaitement normal: il faut ensuite que tu fixes les paramètres IP WAN de ton Linksys par rapport à la livebox. Mais t'as pas besoin de faire ça, le DHCP est très bien.

     

    Je sais que tu as résolu ton souci mais je vais me permettre un éclaircissement.

    Les VLANs sont assez simple: si tu mets un VLAN Untagged, tout ce qui arrive normalement sur le port sera considéré étant du VLAN. Dans ton cas, si tu mettais un VLAN 10 comme te le disais Cryogen sur les ports LAN Livebox & WAN Linksys, seuls eux auraient pu communiquer entre eux... comme un câble !

    Ensuite, tu ne touchais pas au reste du switch et tout était OK.

     

    Si tu étais vraiment radin en porcs, tu aurais pu avoir un seul câble entre le Linksys et le switch.

    Aussi, tu aurais la configuration suivante:

    - Port 1: Livebox côté LAN: VLAN 10 UNTAGGED

    - Port 2: Linksys. WAN sur VLAN 10 TAGGED & LAN sur VLAN 1 UNTAGGED. Le porc switch doit être en access et avec les 2 VLANs configurés correctement.

    - les autres porcs on n'y touche pas.

     

    L'avantage de faire ça:

    - La livebox est une pute et gère pas les VLANs? Le switch le fait pour elle (dans la limite d'un seul VLAN par cochon)

    - Tu grattes un porc. C'est cher les switchs 😄

    - Tu te couches moins bête

    - Tu peux propager. Imagine une configuration en deux switchs: tu pourrais avoir ta livebox dans un coin de la maison, le routeur dans un autre coin (souvent pour le wifi) et le switch au garage, tout en n'ayant pas à tirer des câble à gogo. Par contre oui, c'est plus compliqué 🙂

     

    Egalement, tu peux créer 2 VLANs sur ton routeur, pour avoir deux zones distinctes, faire du routage et protéger ainsi mieux une partie du réseau. Moi je l'ai fait pour mon pc fixe, isolé du reste de mes merdes (philips hue, boitier shield tv connecté gogole, imprimante réseau avec un petit wifi embarqué...). L'avantage est que si le reste du réseau choppe une saleté, t'as de la marge avant que ta machine soit aussi contaminée. C'est pratique en cas d'adolescent présents dans le foyer.

     

    • Merci 1
  6. Bonjour à tous,

     

    Si quelqu'un cherche un switch polyvalent et performant, en voici un à 400€+frais de porc (dans les 20€ en général). Y'en a qu'un hein (c'est un retour client).

    Ce n'est pas un petit switch, mais il est bon, rackable, avec un mode 0db à la con sous 25° et un bug firmware qui affiche la led FAN quand il fait trop froid et qu'il est en mode 0db.

    Je ne prends aucune commission, j'achète pour ma part beaucoup de matériel "produits ouverts" sur ce site. Attention, c'est un VRAI transporteur qui vous livre, le lendemain si la commande est passée avant 16h en général. Laissez bien un numéro de portable et soyez chez vous (haha trop dur en ce moment).

    Et si vous l'achetez et que vous n'êtes pas content, bah je serais désolé pour vous mais n'y serais pour rien!

     

    Bonne soirée,

    ps: le lien est https://www.inmac-wstore.com/produit-ouvert-netgear-m4300-28g-commutateur-28-ports-gere-montable-sur-rack/p28896.htm

  7. Il y a 8 heures, Aloyse57 a écrit :

    Content de voir que pour toi ça a fonctionné. Moi, ça m*rde plein pot. Les cartes sont installées (aucune reconnue nativement par W10) mais les tranceivers que 10GTek que j'ai choisi pourtant recommandés pour mon switch Microtik n'établissent pas la connexion. La led Link est allumée, mais ça ne communique pas. J'ai pris des tranceivers SFP et ceux là fonctionnent (mêmes cartes PCI, même switch, même fibre). J'ai commandé des tranceivers Microtik pour tester (2 tranceivers MTK= 8 tranceivers 10Gtek 😖). Me suis aussi acheté un testeur de fibre, car 1 des trois était erratique (connecteur avec du jeu après test).

    Donnes les marques / modèles exacts de tes SFP stp?

     

    Il y a 59 minutes, Fab'z a écrit :

    J'ai reçu une fibre un pti' peu marqué/écrasé mais elle fonctionne quand même. J'ai pris des LC/LC duplex 50/125 OM2, les 4 ont fonctionné. Pour les SFP+; je me suis embêté à sélectionner des modèles compatible avec le switch et avec la carte Intel. J'en ai pris que 4 au début car je savais pas si l'un ou l'autre marcherai avec la carte Synology. Au final n'importe lequel marche n'importe ou et ça c'est cool. Tout vient de fs.com.

    FS.COM, ça poutre en matos fibre pour 99% des usages. Le % restant est hyper spécifique (longueurs limites, beaucoup de jarretières, etc..)

    Je crois avoir eu un module foireux pour une centaine achetée chez eux.

     

    il y a une heure, Fab'z a écrit :

    J'ai testé aussi des Tranceivers Aruba 1Gb (J4858D) avec un 10Gb à moi (compatible J9150D )et ça marche pas. Théoriquement les 10Gb sont censé encaisser 1/10Gb mais bon c'est pas grave et c'est peu être normal.

    Le port dans lequel tu mets le SFP/SFP+/SFP28 peut s'adapter en termes de vitesse (100/1000/2500/10000/25000 selon ton switch/routeur) mais le SFP lui même ne peut pas. Tu achètes un SFP 10G? Il fait 10G, point. On ne négocie pas dans le monde des fibres.

  8. Pourtant la parité est lue également ^^

    Tu as répondu toi-même à la question de pourquoi j'aime pas les NAS quand tu as dis "j'ai l'espoir qu'avec DSM 7 on puisse utiliser les M.2 en stockage brute".

    Si t'as un Windows, Storage spaces + partage de fichiers / docker+Minio. Si t'as un Linux, LVM+Docker+Minio/SMB réponds à tous les besoins. Mais ce n'est pas clef en main comme un NAS (même si une Centos 8 avec Cockpit activé poutre des mamans ourses pour sa simplicité).

     

    Il y a 2 minutes, imrage a écrit :

    On peut sur les nas Qnap avec  port vga ou hdmi (ou carte graphique si port pcie) . C'est ni plus ni moins qu'un micro serveur, tu a accès au bios et peut faire se que tu veux. 

    Il y a plein de tuto sur les nas Qnap. 

    Je suis raciste, j'aime pas QNAP ^^ (j'en ai jamais été content en fait, malgré que j'en ai eu plusieurs à gérer). Mais merci pour l'info 🙂

  9. Ce sont des perfs à 4 disques cumulés 😉

    Moi je ne ferais pas le NVMe à part mais m'en servirait que en cache. Ca permet de mixer capacité et performance.

    Prends deux 970 evo plus, et tu alloues ce que tu veux en cache d'écriture, sans cache lecture: tu va avoir des vraies performances, y compris pour ton simple "stockage". En plus tu pourras y caler les VMs dessus 😄

    Perso j'aime pas les NAS, donc je ne saurais t'en conseiller la configuration, mais pour faire des HomeNAS, je peux t'assurer que c'est important 😉 Si on pouvait installer un *nux LVM sur un NAS, je m'en prendrais un d'emblée ^^

  10. En raid5, t'as des performances de merde. C'est le cache qui s'est alimenté qui fait que tu as de bonnes performances après.

    Ton seul point noir est le dernier test: le Q31T1 4K random est le plus important des tests. Perso, j'aurais un cache SSD bien configuré, avec un bon ssd, j'aurais 200mo/s en écriture. C'est TRES important: tu prends deux nvme 250go type evo plus et tu les laisse en cache écriture. Là, t'aura un gain.

    Mais je ne sais pas si on peut mettre le SSD qu'on veut, avec Synology.

  11. Oui ne vous inquiétez pas, monsieur +8 est bien connecté (Je monte une dizaine de pcs par an)

    Le i3 fonctionne super bien. C'est pour ça que c'est étonnant (il n'aime pas sans les +8 😄 )

    Le 9600K est marqué comme supporté par des cartes mères concurrentes (MSI par exemple), et je ne vous caches pas que j'aimerais bien éviter de changer une carte mère pour un processeur récupéré 🙂

  12. Bonjour,

    je passe actuellement d'un i3 8100 à un i5 9600K, sur une carte mère Asus rog strix z370-H gaming.

    La carte mère est à jour du bios, mais avec le i5 9600K, les ventilateurs se déclenchent puis s'arrêtent immédiatement. Il n'y a pas de signal à la carte graphique et rien ne se passe...

    Je précise que le bios a été reseté au cas où.

     

    Auriez-vous une idée?

     

    Merci par avance

  13. Je demande un test Le seigneur des anneaux.

    Si on peut regarder le 1er épisode en DVD/Blueray, un Anneau de bronze.

    Si on peut regarder les 2 premiers épisodes en DVD/Blueray, un Anneau d'argent.

    Si on peut regarder les 3 épisodes en DVD/Blueray, un Anneau d'or.

    Sinon, l'idéal serait une thermographie du clavier après le test "Burn": Trop nombreux sont les portables sur lesquels on se brule presque.

    Et la facilité à entrer/sortir de veille (ce qui n'est pas le cas de tous les portables).

×
×
  • Create New...