Jump to content

Archived

This topic is now archived and is closed to further replies.

Soulfly_tribe90

Problème connexion internet

Recommended Posts

Alors voilà je vais déjà vous exposer ma situation : Je suis étudiant et je suis dans une chambre CROUS relié au réseau OSIRIS. Pour se connecter il suffit de se mettre en DHCP, le réseau fournit une adresse IP. Après cette étape, il faut lancer un navigateur web (firefox chez moi), cela va lancer une page special où il faut mettre Login et Password. Une fois l'authentification faite, ca relance le dhcp et on obtient une autre adresse IP et maintenant on a acces au net.

Mon problème c'est que sous linux (Ubuntu 6.06 LTS) je n'arrive pas à obtenir d'adresse IP au niveau de la premiere étape, donc je ne peux pas m'authentifier...

Je précise que cela marche sous Windows sans aucun problème donc ca ne vient pas de mon matériel. J'ai demandé des précisions à l'administrateur mais apparement il est pas capable de me répondre et reste depuis une semaine muet a mes questions...

Donc je me tourne vers vous :byebye:

Merci d'avance a ceux qui prendront le temps de me répondre.

Share this post


Link to post
Share on other sites

Mwé je suis pas expert la dedans, faudrait voir quelle erreur il te donne...

Fait un sudo /etc/init.d/networking restart pour voir quelle erreur il donne et pour en etre certain que ce ne soit pas aussi bete... Es-tu sur d'etre en dhcp?

Share this post


Link to post
Share on other sites

Mwé je suis pas expert la dedans, faudrait voir quelle erreur il te donne...

Fait un sudo /etc/init.d/networking restart pour voir quelle erreur il donne et pour en etre certain que ce ne soit pas aussi bete... Es-tu sur d'etre en dhcp?

Alors oui je suis sûr d'être en DHCP j'ai mon fichier /etc/network/interfaces configuré correctement, j'ai l'habitude et j'ai jamais eu de soucis de ce coté là :byebye:

Sinon j'ai tenté plusieurs /etc/init.d/networking restart et cela ne me renvoie aucune erreur particulière, il envoie des requêtes DHCP dans le vide jusqu'à qu'il me dise qu'il ne trouve personne en gros.

Voilà pour les précision :mdr:

Share this post


Link to post
Share on other sites

Est-ce que sous Windows ça ne configure pas un proxy ?

Je ne vois pas par quelle magie une requête DHCP ferait démarrer ton navigateur sur une page précise.

Tu peux voir quelle est l'URL de cette page ?

Essaie de l'appeler depuis ton firefox sous linux.

Share this post


Link to post
Share on other sites

Est-ce que sous Windows ça ne configure pas un proxy ?

Je ne vois pas par quelle magie une requête DHCP ferait démarrer ton navigateur sur une page précise.

Tu peux voir quelle est l'URL de cette page ?

Essaie de l'appeler depuis ton firefox sous linux.

Pour le proxy je peux pas te répondre précisement mais je crois pas.

Sinon sous firefox je lance à l'adresse 192.168.0.1 voilà voilà...

Je vous met les détails de ipconfig /all avant et après authentification :

Avant authentification :

C:\Documents and Settings\AuraHxC>ipconfig /all

Configuration IP de Windows

	Nom de l'hôte . . . . . . . . . . : rob1a0108li
	Suffixe DNS principal . . . . . . :
	Type de noud . . . . . . . . . . : Inconnu
	Routage IP activé . . . . . . . . : Non
	Proxy WINS activé . . . . . . . . : Non

Carte Ethernet Connexion réseau sans fil:

	Statut du média . . . . . . . . . : Média déconnecté
	Description . . . . . . . . . . . : Intel® PRO/Wireless 2200BG Ne
Connection
	Adresse physique . . . . . . . . .: 00-0E-35-80-C7-98

Carte Ethernet Connexion au réseau local:

	Suffixe DNS propre à la connexion :
	Description . . . . . . . . . . . : Broadcom NetXtreme Gigabit Ethe
	Adresse physique . . . . . . . . .: 00-13-D4-5C-0D-5C
	DHCP activé. . . . . . . . . . . : Oui
	Configuration automatique activée . . . . : Oui
	Adresse IP. . . . . . . . . . . . : 192.168.0.8
	Masque de sous-réseau . . . . . . : 255.255.255.0
	Passerelle par défaut . . . . . . : 192.168.0.1
	Serveur DHCP. . . . . . . . . . . : 192.168.0.1
	Serveurs DNS . . . . . . . . . .  : 192.168.0.1
	Bail obtenu . . . . . . . . . . . : lundi 23 octobre 2006 16:04:12
	Bail expirant . . . . . . . . . . : lundi 23 octobre 2006 16:04:37

Apres Authentification :

C:\Documents and Settings\AuraHxC>ipconfig /all

Configuration IP de Windows

	Nom de l'hôte . . . . . . . . . . : rob1a0108li
	Suffixe DNS principal . . . . . . :
	Type de noud . . . . . . . . . . : Inconnu
	Routage IP activé . . . . . . . . : Non
	Proxy WINS activé . . . . . . . . : Non
	Liste de recherche du suffixe DNS : u-strasbg.fr

Carte Ethernet Connexion réseau sans fil:

	Statut du média . . . . . . . . . : Média déconnecté
	Description . . . . . . . . . . . : Intel® PRO/Wireless 2200BG Networ
Connection
	Adresse physique . . . . . . . . .: 00-0E-35-80-C7-98

Carte Ethernet Connexion au réseau local:

	Suffixe DNS propre à la connexion : u-strasbg.fr
	Description . . . . . . . . . . . : Broadcom NetXtreme Gigabit Ethernet
	Adresse physique . . . . . . . . .: 00-13-D4-5C-0D-5C
	DHCP activé. . . . . . . . . . . : Oui
	Configuration automatique activée . . . . : Oui
	Adresse IP. . . . . . . . . . . . : 130.79.157.103
	Masque de sous-réseau . . . . . . : 255.255.254.0
	Passerelle par défaut . . . . . . : 130.79.157.254
	Serveur DHCP. . . . . . . . . . . : 130.79.200.202
	Serveurs DNS . . . . . . . . . .  : 130.79.200.1
	Bail obtenu . . . . . . . . . . . : lundi 23 octobre 2006 16:07:02
	Bail expirant . . . . . . . . . . : lundi 23 octobre 2006 18:07:02

Share this post


Link to post
Share on other sites

Ok, c'est vrai que je ne pouvais pas évaluer ton niveau de connaissance juste comme ca :yes:

Alors voici ma question :

Quand tu arrives avec un nouveau pc (j'entend par la "inconnu du reseau") tu as juste a brancher et te connecter sur cette page?

Si c'est le cas, je crois savoir comment le manager du reseau fait...

Il doit surement récupérer ta mac adress et apres que tu te sois logué il l'authentifie et la place comme étant connue...

Mais soit c'est fixe et tu ne dois le faire qu'une seule et unique fois, soit c'est temporaire et tous les X temps, lors d'une requete DHCP tu dois refaire la manip... A vrai dire je ne sais pas mais je suppose que ca doit etre comme ca...

A toi de nous en dire plus la dessus :transpi:

Share this post


Link to post
Share on other sites

Ok, c'est vrai que je ne pouvais pas évaluer ton niveau de connaissance juste comme ca :yes:

Alors voici ma question :

Quand tu arrives avec un nouveau pc (j'entend par la "inconnu du reseau") tu as juste a brancher et te connecter sur cette page?

Si c'est le cas, je crois savoir comment le manager du reseau fait...

Il doit surement récupérer ta mac adress et apres que tu te sois logué il l'authentifie et la place comme étant connue...

Mais soit c'est fixe et tu ne dois le faire qu'une seule et unique fois, soit c'est temporaire et tous les X temps, lors d'une requete DHCP tu dois refaire la manip... A vrai dire je ne sais pas mais je suppose que ca doit etre comme ca...

A toi de nous en dire plus la dessus :transpi:

C'est surement pas une histoire d'adresse MAC --> je me connecte sous windows avec le meme ordinateur qui ne se connecte pas sous linux !!!

Et je pense que je pourrais surement (sous windows) me connecter avec un autre ordinateur !!!

Vu qu'il y a une authentification unique (login+password), il avait pas besoin de toute façon de faire un filtrage MAC.

Share this post


Link to post
Share on other sites

je ne peux faire que des suppositions, mais :

1- le premier bail est de 25 secondes, faut pas traîner :yes:

2- as-tu pu identifier (fichier cache de FF, liste des process ou autre) si Windows ne lançait pas un script (un .Exe quelconque qu'il aurait installé une première fois ?) qui fait le changement d'IP? script inexécutable sous Linux ?

Share this post


Link to post
Share on other sites

je ne peux faire que des suppositions, mais :

1- le premier bail est de 25 secondes, faut pas traîner :zarb:

Ca ne m'étonnerait pas effectivement...

2- as-tu pu identifier (fichier cache de FF, liste des process ou autre) si Windows ne lançait pas un script (un .Exe quelconque qu'il aurait installé une première fois ?) qui fait le changement d'IP? script inexécutable sous Linux ?

Très improbable étant donné qu'un exe ne saurait pas etre exécuté comme par magie, donc ce serait un activeX mais ce dernier serait détecté...

De plus, le problème à la base est qu'il n'obtient pas la première IP qui lui permet de se connecter sur la page oueb...

Donc ca vient d'autre part...

Est-ce que tu as déja eu l'occasion de te connecter a un autre réseau via DHCP avec ce meme pc et de recevoir une ip tout a fait normalement?

Share this post


Link to post
Share on other sites

Est-ce que tu as déja eu l'occasion de te connecter a un autre réseau via DHCP avec ce meme pc et de recevoir une ip tout a fait normalement?

Oui chez moi avec mon routeur, cela pose aucun soucis !!!

Share this post


Link to post
Share on other sites

Déja de base tu as la bonne ip ?

Regarde avec ifconfig et dhclient/pump.

Je comprends pas trop !!!

Parce que de base j'ai pas d'IP du tout !!! --> si je fais un ifconfig j'ai pas d'IP et j'aimerais bien qu'il m'en fournisse une :zarb:

Share this post


Link to post
Share on other sites

Alors essaye avec dhclient ou pump.

Je viens d'essayer, et meme avec dhclient, dhclient3 ca fonctionne pas (il me semble avoir deja testé d'ailleurs) par contre pump je n'ai pas cette commande !!!

Share this post


Link to post
Share on other sites

C'est l'un ou l'autre en général.

Tu n'as pas de message d'erreur, rien dans les logs ?

Share this post


Link to post
Share on other sites

C'est l'un ou l'autre en général.

Tu n'as pas de message d'erreur, rien dans les logs ?

Apparement non !!! Il arrive jute pas à trouver le serveur qui va me donner l'adresse IP !!!

Je pense pas que ca soit une histoire de IPV4 et IPV6 logiquement de base il arrive à faire la difference... Parce que le réseau fonctionne uniquement en IPV4 ca c'est sur !!!

Il commence vraiment à m'agacer ce problème !!!!

PS : Tu peux me dire ou je peux trouver tous les logs qui sont interessant j'ai peut être été dans les mauvais log :chinois:

Share this post


Link to post
Share on other sites

Si tu relances ton interface réseau, il retentera une connexion DHCP.

Il serait étonnant que le serveur DHCP ne réponde qu'aux Windows.

Share this post


Link to post
Share on other sites

Si tu relances ton interface réseau, il retentera une connexion DHCP.

Il serait étonnant que le serveur DHCP ne réponde qu'aux Windows.

Relancer l'interface je l'ai deja fait !!!!

Et oui je trouve ca étonnant !!!!

En fait j'ai réussi je crois 3 fois à me connecter au net sans faire quoique ce soit, sans aucune modification!!!!

Explication : Au bout de je sais pas combien de tentative, j'ai reussi a me connecter donc très content me suis dit je vais me deconnecter et retenter et la ben c'est pareil impossible de se connecter !!!!

Donc j'aimerais savoir pourquoi il arrive a se connecter toujours sous windows et sous linux j'ai du réussir au bas mot 3 fois !!!!

PS : Désolé d'avoir oublié de préciser que j'avais reussi 3 fois a me connecter, enfin en 2 mois que j'utilise le réseau c'est pas un ratio enorme lol

Share this post


Link to post
Share on other sites

Salut,

En général le serveur dhcp attribue la meme adresse ip / à une adresse mac .

En configuration statiquement ton adresse ip avec les parametres reseaux, obtenu par windows lors que l' accès à internet fonctionne, ne suffit pas?

Il existe sans doute des adresses disponibles non fournies par dhcp, que tu pourrais peut etre utiliser en connaissant la passerelle necessaire ainsi que les dns.

Share this post


Link to post
Share on other sites

Salut,

En général le serveur dhcp attribue la meme adresse ip / à une adresse mac .

En configuration statiquement ton adresse ip avec les parametres reseaux, obtenu par windows lors que l' accès à internet fonctionne, ne suffit pas?

Il existe sans doute des adresses disponibles non fournies par dhcp, que tu pourrais peut etre utiliser en connaissant la passerelle necessaire ainsi que les dns.

Il me semble que mon adresse IP a chaque connexion est differente !!!

Je vais vérifier pour en etre sûr !!!

Edit : Bon effectivement j'ai une adresse IP differente dans mon exmple en haut j'avais 192.128.0.8 et la j'ai eu 192.168.0.2

Share this post


Link to post
Share on other sites

Le bail de l'ip publique que tu récuperes lorsque internet marche est de 2h.

Bootes sous windows et obtiens ton ip publique,note la dans un coin.

et essaye de l'utiliser sous linux tout de suite apres en la rentrant à la main dans le fichier de configuration réseau de ta distrib.

Le sous avec le navigateur que tu as sous linux, peut eventuellement venir de l'absence de support du javascript, ou java.

as tu essayé avec opera?

Share this post


Link to post
Share on other sites

Et si tu vas dans les options de connexion de Firefox et que tu lui demandes de trouver automatiquement les paramètres de proxy, ça fait quoi ?

Share this post


Link to post
Share on other sites

Je pense pas que ca l'avancera vu qu'il n'a pas d'ip...

Pas d'ip, pas de proxy

Pas de proxy, pas de passerelle

pas de passerelle, pas d'internet

...

Vous connaissez la musique :chinois:

Share this post


Link to post
Share on other sites

Ptet un serveur DHCP Windows qui ne répond qu'à des Windows XP Pro SP2 avec Windows Media et Outlook Express en surfant sous IE ...

Share this post


Link to post
Share on other sites

Ptet un admin windowsien un peu frustré (et très con) qui examie les header des trames.

Share this post


Link to post
Share on other sites

×
×
  • Create New...