Jump to content

[RESOLU]ubuntu - Parition /home


Recommended Posts

Bonsoir à tous !

Je vous previent de suite je suis un grand novice à linux, donc depuis toute j'ai voulus arrêter de me servir d'un LiveCD pour l'installé réellement sur mon Portable.. jusque la tous va bien je garde pour Windows un peu moins de 60Go, et environ 40Go pour Linux...

lors de l'installation, j'ai bien penser à me crée une partition dev/hda2 /swat de 2Go environ

une partition dev/hda3 / 10Go envrion "type ext3"

et enfin une partition dev/hda4 /home 20Go Environ "type ext3"

Jusque la tous va bien l'installe se déroulle sans problème, je relance ubuntu sa fonctionne parfaitement, je fait les MAJ je test des vidéo images etc...

Et je décide de Download un jeux Gratuit "Wolfenstein" et ces la que les problème arrive. Une fois appuyer sur le fichier que j'ai DL, un programme se lance, et un message d'érreur apparait qui me dit impossible d'ouvrir le fichier /home etc... (voir screen plus bas)

alors je comprend pas trop ce que j'ai loupé?

En dessous je vous mes un screen de tous ce que je pense être utile, si jamais il vous faut d'autre renseignement pas de problème, mes penser que je suis un Noob..

9386bl9.png

Alors je ne sait pas j'ai peut-être loupé la création des partition ?

Link to post
Share on other sites

Le prend pas mal, mais ca se vois que t'es novice :

c'est pas swat comme les forces speciales americaine mais swap comme echange.

Ce que je vois dans le screen c'est que tu essaye d'ouvrir l'installeur avec gedit qui est un equivalent au bloc-note de windows, donc tu comprendra qu'il te gueule un peu dessus.

Dans ta console on vois un cd/home , il faut mettre un espace entre la commande et les arguments. cd /home

Sinon pour en revenir au probleme, localise l'endroit ou tu a telecharger le binaire, ca semble etre /home/william/download

et fait un

 
cd ~william
./et-linux-2.60-x86.run

et ca devrait marcher. (Attention j'ai fait a l'oeil la partie qui commence par ./ peut etre que l'orthographe est mauvaise.)

Bon jeu.

Link to post
Share on other sites

non sa va je le prend pas mal, excuser d'avoir mis swat....

Alors je pense avoir reussit à l'installer, il apparait même dans mon bureau.

Mes novice comme je suis, j'avais oublié d'installer mes pilote vidéo, j'ai donc voulus le faire mes j'ai un autre soucis, quand je suis le tuto ubuntu. j'ai un soucis de le début, en voulant sauvegarder le fichier xorg.conf.....

je fait donc :

sudo cp /etc/Xll/xorg.config /etc/Xll/xorg.backup

et la un message me dit aucufichier ou repertoire de se type.

Alors la je comprend pas non plus ce qui faut faire...

Link to post
Share on other sites

mieux que les copier/coller utilise la touche Tab qui permet de completer automagiquement les commandes

que tu tapes avec ce qui existe reellement sur ton systeme.

Tu verra dans moins de 2 jours tu ne pourra plus t'en passer, c'est un regale surtout avec des shells comme

zsh.

Link to post
Share on other sites

Tous d'abord excusez moi d'être aussi mauvais, et merci à vous de vous donner autant de mal... j'ai donc reussit à avancer dans l'installation du pilote Nvidia, mes j'ai un autre soucis,et j'éspère le dernier...

je précise que pour installé ma carte vidéo je me sert du Tuto ubuntu et donc un moment donner je doit modifier manuellement "nv" en "nvidia" dans mon fichier Xorg.conf, mes quand je veut sauvegarder ma modification, j'ai un message qui apparaît et qui me dit :

impossible d'enregistrer le fichier /etc/X11/xorg.conf

Vous n'avez pas les permissions nécessaire pour enregistrer ce fichier

Pour Info si je fait : ALT+F2

gksudo "gedit /etc/X11/xorg.conf"

Xorg.conf s'ouvre bien mes le terminal s'ouvre aussi avec comme message :

While connecting to session manager:

Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed.

donc je pense que ces une erreur de mot de passe, mes je doit mettre lequel.. moi je mis le mot de passe que j'ai utiliser jusque maintenant et celui que j'utilise quand je met en route ubuntu...

Alors que faire, si vous préfèrer me contacter sur msn faite moi sgne je vous donnerai mon adresse...

Et encore merci d'avance

Link to post
Share on other sites

essaye

xhost +
sudo gedit /etc/X11/xorg.conf

ca devrais marcher.

Le probleme est que la console graphique appartient a ton utilisateur, et tu veux que le root affiche la

fenetre de gedit. Ce qu'il n'a pas le droit de faire, car c'est a toi l'ecran. d'ou le xhost pour autoriser le root

a utiliser ton ecran.

Essaye d'utiliser des outil en mode texte quand tu est en root, car avec on a moins de chance de tout

casser. Pour ce faire utilise nano, ou emacs, (ou vim si t'est un warrior) a la place de gedit.

En fait c'est mieux que tu essaye un peu de chercher d'ou vient le probleme que de tout de

suite interroger quelqu'un qui sait.

Bonne chance pour la suite, et c'est bien de perseverer

Link to post
Share on other sites

merci à tous de m'aider...

alors pour arriver à modifier mon fichier j'ai donc fait comme a dit Gnaphron

sudo gedit /etc/X11/xorg.conf

et la mon fichier Xorg ces ouvert et j'ai quoi put le modifier sa a du me donner les droits ?

ensuite j'ai fermer ma session et deviner quoi : le LOGO Nvidia à apparut, donc je pense que sa veut dire que

que je suis sur la bonne vois ?

Si sa se trouve ces même configuré la déjà.

Link to post
Share on other sites

Bah voila tout marche nickel. :craint:

Si t'aime pas le logo au boot du serveur X tu peux ajouter

 Option "NoLogo" "True" 

apres

l'endroit ou tu a mis nvidia dans le fichier /etc/xorg.conf.

Mais bon ca fait quand meme plus classe le logo au boot, surtout quand tu as eu du mal a le mettre :-D

Bon jeux et bonne linuxisation

Link to post
Share on other sites

et bien merci à tous de m'avoir aider....

J'ai donc installer Wolfenstein pour tester, tous ces bien derouler sans problème, aprés je lance le jeux il se lance mes j'ai un dernier soucis, je jeu n'es pas centré sur l'écran,en faite je ne voit que la moitié de l'image quand je suis dans le jeux..

sinon sur le bureau ces nickel....

Je vasi donc continuer à chercher un peu, a moins que l'un de vous est la solution....

en faite ces peut-être parceque je joue sur un portable donc en 1280x800..

Sinon j'ai trouver une soluce en attendant je joue en mode fenêtre, mes il me manque quand même une mini partie mes en bas de l'écran car je voit ma barre ubuntu.. ou sinon je doit me mettre en 800x600 et mode fenêtre mes la sa me fait une toute petite image...

Sinon encore merci à vous de votre aide

Link to post
Share on other sites
Et si tu changes la résolution dans le jeu ca ne change rien?

ben au dessus quand je dit que j'ai tester différente résolution, ces dans le jeux, car dans ubuntu je n'es que une seule résolution de marqué qui es 1280x800, et je ne peut pas la changer

Link to post
Share on other sites

Bah si tu paeux pas la changer c'est parce que ton écran a répondu qu'il voulait pas autre chose que ca... Mais si tu vas le changer dans ton xorg, tu sauras en mettre une autre...

Moi aussi sur mon portable c'est bloqué a 1400x1050 mais suffit de le changer (mais apr contre ca devient flou quand je fais ca)

Quand tu dis que tu as testé différentes résolutions, tu ne précises pas si tu as testé en 1280x800...

Link to post
Share on other sites
Bah si tu paeux pas la changer c'est parce que ton écran a répondu qu'il voulait pas autre chose que ca... Mais si tu vas le changer dans ton xorg, tu sauras en mettre une autre...

Moi aussi sur mon portable c'est bloqué a 1400x1050 mais suffit de le changer (mais apr contre ca devient flou quand je fais ca)

Quand tu dis que tu as testé différentes résolutions, tu ne précises pas si tu as testé en 1280x800...

oui je n'es pas préciser 1280X800 tous simplement, car Wolfenstein ne me la donne pas, j'ai juste les résolution habituel 800x600 ou 1024x768 ou 1200x1024 etc...

Par contre je vais tester de suite du modifier dans mon fichier xorg, pour voir ce que sa donne...

Je vient d'éssayer, et peut-être que j'ai changé au mauvais endroit car je n'es toujours pas eux la possibilité de changer la résolution sur le bureau. En dessous je mes l'endroit ou j'ai fait les changements.

Section "Screen"

Identifier "Default Screen"

Device "NVIDIA Corporation NV17 [GeForce4 420 Mac 32M/GeForce 440 Go 64M]"

Monitor "Écran générique"

DefaultDepth 16

SubSection "Display"

Depth 1

Modes "1280x800"

EndSubSection

SubSection "Display"

Depth 4

Modes "1280x800"

EndSubSection

SubSection "Display"

Depth 8

Modes "1280x800"

EndSubSection

SubSection "Display"

Depth 15

Modes "1280x800"

EndSubSection

SubSection "Display"

Depth 16

Modes "1280x800"

EndSubSection

SubSection "Display"

Depth 24

Modes "1280x800"

EndSubSection

et donc moi j'ai changer un de ceux la en 1024x768 par exemple, et sa n'a rien fait......

Ces bien sa que je doit changer ?

Link to post
Share on other sites

oui il y a l'idée.

Section "Screen"
Identifier	"Default Screen"
Device		"NVIDIA Corporation NV17 [GeForce4 420 Mac 32M/GeForce 440 Go 64M]"
Monitor		"Écran générique"
DefaultDepth	16												  <=cette ligne indique quelle subsection il faudra prendre, ici celle qui a une 
SubSection "Display"													un profondeur de 16 bits
	Depth		1
	Modes		"1280x800"
EndSubSection'
SubSection "Display"
	Depth		4
	Modes		"1280x800"
EndSubSection
SubSection "Display"
	Depth		8
	Modes		"1280x800"
EndSubSection
SubSection "Display"
	Depth		15
	Modes		"1280x800"
EndSubSection
SubSection "Display"
	Depth		16
	Modes		"1280x800"							   <= c'est donc cette ligne qu'il faut changer
EndSubSection
SubSection "Display"
	Depth		24
	Modes		"1280x800"
EndSubSection

Link to post
Share on other sites

Marrant... Pourquoi 16bits par défaut...

On tourne a 24 non?

En plus c'est un portable, donc une dalle TFT donc 24bits...

Enfin je pense...

Pour info, ca ne sert a rien de modifier ton fichier xorg si tu ne redémarres pas ton serveur X (pas sur mais a essayer malgré tout)

Pour cela, tu modifies ton fichier a ton aise, ensuite tu fermes ta session et puis tu utilises la combinaison de touches "CTRL+ALT+RETURN" et ca redémarre le X

Essaye comme ca et tiens nous au courant...

En meme temps, je vois pas en quoi tu serais avancé vu que ton écran est fait pour du 1280x800...

C'est dans le jeu qu'il faudrait pouvoir changer...

Link to post
Share on other sites

Mais le problème c'est que peu être en 1280 il rame un peu aussi. De plus, si tu prends le cas d'un jeu qui utilise le listage de SDL pour les résolutions (en fullscreen a priori) il ne va t'indiquer que celles définies dans ton X. Dans mon cas les jeux me proposaient du 2048*768 lorsqu'ils voulaient bien le gérer ce qui était plutôt marrant (mais pas très jouable au final...) :chinois:

J'ai donc rajouté une entrée 1024*768,NULL dans mon Xorg pour que les jeux me proposent également un affichage un peu plus.. normal on va dire :transpi:

Link to post
Share on other sites

Bonjour tous le monde....

Alors j'ai effectuer les changements comme vous m'avez dit, et je peut donc choisir maintenant différente résolution sur le bureau ubuntu...

Sinon pourquoi ces mis en 16bit par default sa je peut pas vous dire, mes ces vrais que ces bizzare sous windows j peut la mettre en 32bit...

Pour mon problème de centrage de l'image ben j'ai effacer les pilotes et j'ai tous reinstallé, et en faite j'avais fait une erreur pendant l'installation, sur le tuto que j'ai suivit il me disait de ne pas installé le paquet nvidia-settings car il es devenu incompatible avec le paquet nvidia-glx, et sa je ne l'avais pas vus la premier fois et je l'avais installé...

Et donc maintenant mon image et bien centré et si dans le terminal je fait nvidia-settings, ben maintenant j'ai plus d'option que la premier fois, et je peut vraiment configuré ma cart 3D que la dernier fois il n'y avait rien ou presque.

Donc tous et ok, et encore merci beaucoup a vous tous, la prochaine étape et l'instalation du pilote Wifi..

sinon on peut dire que le sujet est résolus

Link to post
Share on other sites
Sinon pourquoi ces mis en 16bit par default sa je peut pas vous dire, mes ces vrais que ces bizzare sous windows j peut la mettre en 32bit...

Sous windows ce qu'ils appellent "32 bits" c'est 24 bits (8 bits par canal de couleur). Avec X aussi tu peux mettre 24.

Link to post
Share on other sites
Sinon pourquoi ces mis en 16bit par default sa je peut pas vous dire, mes ces vrais que ces bizzare sous windows j peut la mettre en 32bit...

Sous windows ce qu'ils appellent "32 bits" c'est 24 bits (8 bits par canal de couleur). Avec X aussi tu peux mettre 24.

Puis toute facon, les écrans TFT savent pas afficher plus de 24bits donc vala....

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...