Jump to content

Archived

This topic is now archived and is closed to further replies.

Quentj

Gros problème suite à l'install de ubuntu dapper

Recommended Posts

Salut tout le monde

J'ai un gros problème.

Suite à l'installation d'ubuntu dapper (en plus d'une FC5), je ne peux plus accéder à ma partition windows :transpi: .

Déjà grub m'a paru bizarre. J'avais seulement les choix de quand j'avais uniquement fedora. Donc je sélectionne windows et là paf je tombe sur un autre menu avec les kernel fedora, les ubuntu et windows. Je me dis bon c'est pas grave ça doit être juste le menu de grub à éditer. Je sélectionne ubuntu et tout se passe bien.

Je redémarre et j'essaie de lancer windows. Et là rien du tout, écran noir et je reviens dans le menu de grub :D .

Je me dis merde ce con m'a effacé le ntdlr... Donc je prends une disquette de démarrage de win mais aucune des dix méthodes proposées ne marche. Le plus souvent ça me dit :

Windows could not start because the following file is missing or corrupt : <Windows root>\system 32\hal.dll

Please re-install a copy of the above file

Après je redémarre, je vais sur la fedora et là au démarrage il me dit qu'il ne peut pas monter la partition windows...

Je précise que j'utilise une partion /boot pour fedora et que je l'ai sélectionnée aussi pour l'install de dapper.

Aussi j'ai deux partions qui sont apparues comme par magie à l'install d'ubuntu (en tout cas je les avais pas vues avant) et dont le format est invisible à g-parted.

Et quand ubuntu m'a proposé de choisir l'emplacement de grub, je l'ai mis sur la pation windows.

EDIT: je viens de voir que ubuntu va chercher windows sur hd0,0 alors qu'il est sur hd1,0 amis je n'arrive pas à sauvegarder ma modif sous grub... comment faire ?

Que faire pour pouvoir accéder à windows ?

Pourquoi dapper a t-il foutu la merde comme ça ?

Merci d'avance pour vos réponses

Link to post
Share on other sites

Faut éditer ton menu.lst ( /boot/grub/menu.lst ) en root, sinon t'arrivera pas à enregistrer.

Chez moi dapper fout pas la merde...

Comment as-tu fait le partitionnement lors de l'installation? Automatique?

Link to post
Share on other sites

Je précise que j'utilise une partion /boot pour fedora et que je l'ai sélectionnée aussi pour l'install de dapper.

Aussi j'ai deux partions qui sont apparues comme par magie à l'install d'ubuntu (en tout cas je les avais pas vues avant) et dont le format est invisible à g-parted.

Tu pourrais envoyé un sudo fdisk -l qu'on voit ta table des partitions? et la détailler un peu.

Et quand ubuntu m'a proposé de choisir l'emplacement de grub, je l'ai mis sur la pation windows.

Heu... pas sur d'avoir bien compris, là... t'as fait quoi?

Link to post
Share on other sites

Je précise que j'utilise une partion /boot pour fedora et que je l'ai sélectionnée aussi pour l'install de dapper.

Aussi j'ai deux partions qui sont apparues comme par magie à l'install d'ubuntu (en tout cas je les avais pas vues avant) et dont le format est invisible à g-parted.

Tu pourrais envoyé un sudo fdisk -l qu'on voit ta table des partitions? et la détailler un peu.

Et quand ubuntu m'a proposé de choisir l'emplacement de grub, je l'ai mis sur la pation windows.

Heu... pas sur d'avoir bien compris, là... t'as fait quoi?

pour fdisk il me dit que la commande n'existe pas...

Et donc quand ubuntu m'a fait choisir l'emplacement de grub, j'ai choisi de le mettre sur la partition windows...

Link to post
Share on other sites

Je précise que j'utilise une partion /boot pour fedora et que je l'ai sélectionnée aussi pour l'install de dapper.

Aussi j'ai deux partions qui sont apparues comme par magie à l'install d'ubuntu (en tout cas je les avais pas vues avant) et dont le format est invisible à g-parted.

Tu pourrais envoyé un sudo fdisk -l qu'on voit ta table des partitions? et la détailler un peu.

Et quand ubuntu m'a proposé de choisir l'emplacement de grub, je l'ai mis sur la pation windows.

Heu... pas sur d'avoir bien compris, là... t'as fait quoi?

pour fdisk il me dit que la commande n'existe pas...

Et donc quand ubuntu m'a fait choisir l'emplacement de grub, j'ai choisi de le mettre sur la partition windows...

En root, le fdisk. Ou "/sbin/fdisk -l".

Heu... et si tu as installé le grub sur la partition windows, ça paraîtrait logique qu'il l'ai effacé. Enfin, je crois. Essaye de la monter sans préciser ntfs: en root "mkdir /mnt/part; mount -t /dev/??? /mnt/part" ou ??? est l'emplacement de ta partition.

Link to post
Share on other sites

En root, le fdisk. Ou "/sbin/fdisk -l".

Heu... et si tu as installé le grub sur la partition windows, ça paraîtrait logique qu'il l'ai effacé. Enfin, je crois. Essaye de la monter sans préciser ntfs: en root "mkdir /mnt/part; mount -t /dev/??? /mnt/part" ou ??? est l'emplacement de ta partition.

Bon voissi le fdisk :

Disk /dev/hda: 80.0 GB, 80026361856 bytes

255 heads, 63 sectors/track, 9729 cylinders

Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System

/dev/hda1 1 6542 52548583+ b W95 FAT32

/dev/hda2 6543 8454 15358140 83 Linux

Disk /dev/sda: 164.6 GB, 164696555520 bytes

255 heads, 63 sectors/track, 20023 cylinders

Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System

/dev/sda1 * 1 9729 78148161 7 HPFS/NTFS

/dev/sda2 9730 9742 104422+ 83 Linux

/dev/sda3 9743 11654 15358140 83 Linux

/dev/sda4 11655 17415 46275232+ 5 Extended

/dev/sda5 11655 12661 8088696 83 Linux

/dev/sda6 12662 12916 2048256 82 Linux swap / Solaris

/dev/sda7 12917 14286 11004493+ 83 Linux

/dev/sda8 14287 16199 15366141 83 Linux

/dev/sda9 16200 17415 9767488+ 83 Linux

Voilà ce que ça me dit quand j'essaie de monter l ap art (j'ai mis defaults dans fstab) :

Usage: mount -V : print version

mount -h : print this help

mount : list mounted filesystems

mount -l : idem, including volume labels

So far the informational part. Next the mounting.

The command is `mount [-t fstype] something somewhere'.

Details found in /etc/fstab may be omitted.

mount -a [-t|-O] ... : mount all stuff from /etc/fstab

mount device : mount device at the known place

mount directory : mount known device here

mount -t type dev dir : ordinary mount command

Note that one does not really mount a device, one mounts

a filesystem (of the given type) found on the device.

One can also mount an already visible directory tree elsewhere:

mount --bind olddir newdir

or move a subtree:

mount --move olddir newdir

A device can be given by name, say /dev/hda1 or /dev/cdrom,

or by label, using -L label or by uuid, using -U uuid .

Other options: [-nfFrsvw] [-o options] [-p passwdfd].

For many more details, say man 8 mount .

Voilà...

Qu'est ce qui se passe ?

Link to post
Share on other sites

df :

Sys. de fich. 1K-blocs Occupé Disponible Capacité Monté sur

/dev/sda3 14877092 3425460 10683728 25% /

/dev/sda2 101105 21708 74176 23% /boot

tmpfs 517964 0 517964 0% /dev/shm

/dev/sda5 7835168 3399236 4031500 46% /home

/dev/hda1 52522912 29083200 23439712 56% /fichiers_fat

/dev/hda2 15116868 168712 14180252 2% /fichiers_ext3

Link to post
Share on other sites

Ya rien d'anormal en fait...

Juste le fait que tu as dégommé windows en installant grub sur le MBR (comme c'est déconseillé sur tous bon tuto)

je crois que win a besoin de son MBR... Mais ce qui est sur c'est que tu risques de t'amuser pour le remettre...

Ca veut dire réinstallation de windows + réinstallation partielle de nux

partielle car tu devras simplement réinstaller grub mais plus sur le MBR cette fois :byebye:

Link to post
Share on other sites

Grub n'a pas besoin du booloader de windows pour booter windows.

Grub c'est le plus fort, il sait booter tous les OS connus tout seul (sur x86 au moins).

hd0,0 et hd0,1, c'est des notations grub, pas ubuntu. Pour modifier ça tu peux taper 'c' ou 'e' lors du boot dans grub.

Exemple :

* boot

* grub

* selection de la ligne windows

* 'e'

* 'e' pour éditer hd0,0

* escape

* 'b' pour booter

(si mes souvenirs sont exacts)

Ensuite une fois que tu as trouvé la bonne ligne à écrire, tu fais la même chose dans /boot/grub/{menu.lst,grub.conf}

Link to post
Share on other sites

Bon quand je modifie grub ça me dit que c'est pas un disque bootable...

Bon je croisque je suis bon pour ressortir le disque d'install de win, faire fixmbr et fixboot. Puis essayer de restaurer grub... Comment faire pour restaurer grub ?

Link to post
Share on other sites
tu démarres sur le live-cd (si t'as la dapper desktop, tu l'as d'office) et tu fais

grub-install /dev/hdX

Voila :transpi:

ok

et pour fedora ?

normalement Grub devrait retrouver toutes tes partitions bootable linux, il te faudra peut être modifier le nom à la main.

Link to post
Share on other sites
tu démarres sur le live-cd (si t'as la dapper desktop, tu l'as d'office) et tu fais

grub-install /dev/hdX

Voila :transpi:

ok

et pour fedora ?

J'avais pas vu pour fedora...

Mais toute façon, c'est le meme...

Et puis il me semble que tu n'as besoin que d'un seul grub non?

Link to post
Share on other sites

Rebonjour

Bon j'ai fais mes manips, j'ai remis windows, fedora mais pas ubuntu. Je me suis dis que j'avais fais des erreurs et j'ai donc réinstallé ubuntu. Mais problème, au redémarrage pendant l'install d'ubuntu, grub plante totalement (ça me met grub partout sur l'écran). Je pense savoir d'où viens l'erreur : j'ai mis grub dans la partition /boot qui est commune à fedora et ubuntu (déjà ça je sais pas si c'est bien)...

Comment réparer mon erreur ? :roll:

Je viens de démarrer sous la live de ubuntu breezy et j'attends vos réponses...

Merci d'avance

Link to post
Share on other sites
Mais problème, au redémarrage pendant l'install d'ubuntu, grub plante totalement (ça me met grub partout sur l'écran). Je pense savoir d'où viens l'erreur : j'ai mis grub dans la partition /boot qui est commune à fedora et ubuntu (déjà ça je sais pas si c'est bien)...

Comment réparer mon erreur ? :keskidit:

Gestionnaire de démarrage

GRUBGRUBGRUB...

Il semblerait que ce message soit causé par une mise à jour non complète de grub.

La solution étant alors de récupérer les stages depuis l'install de grub (par exemple /lib/grub/i386-pc/*stage* ) et de remplacer ceux dans /boot ( /boot/grub ) puis de réinstaller grub dans la MBR

À toi de jouer :transpi:

Link to post
Share on other sites

Bon finalement j'ai réussi à monter la partition (erreur con)

Je l'installe où grub ?

(parce que si je le met dans le mbr je suis encore bon pour restaurer le boot de windows)

Link to post
Share on other sites
Je viens d'essayer mais voilà ce que ça me dit :

/dev/mapper/casper-snapshot does not have any corresponding BIOS drive

Du dm-snapshot ? Pourquoi donc ? :cartonrouge:

Je sais pas mais je viens d'essayer avec une mandriva one (club de juin) et ça me dit :

Could not find device for /boot: Not found or not a block device

Link to post
Share on other sites

×
×
  • Create New...