Jump to content

[Résolu] *OpenGL software


Recommended Posts

Bonjour,

Ma carte graphique étant en panne elle est momentanément remplacée par une Matrox PCI de 1995 (résolution correcte, à l'époque c'était le top).

Mais elle a pas d'accélération 3D donc OpenGl marche pas :fou: .

J'aimerais savoir comment faire pour faire tourner les progs OpenGl avec un rendu software sous Linux Ubuntu.

Merci.

Link to comment
Share on other sites

Je l'ai déja le glx c'est pour ma carte nVidia.

glxinfo donne :

name of display: :0.0

Xlib: extension "GLX" missing on display ":0.0".

Xlib: extension "GLX" missing on display ":0.0".

Xlib: extension "GLX" missing on display ":0.0".

Error: couldn't find RGB GLX visual

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav

id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat

----------------------------------------------------------------------

Xlib: extension "GLX" missing on display ":0.0".

Xlib: extension "GLX" missing on display ":0.0".

0x21 24 tc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None

Erreur de segmentation

Link to comment
Share on other sites

tu peux mettre ton xorg.conf ?

OK :

Section "Files"
FontPath	"/usr/share/X11/fonts/misc"
FontPath	"/usr/share/X11/fonts/cyrillic"
FontPath	"/usr/share/X11/fonts/100dpi/:unscaled"
FontPath	"/usr/share/X11/fonts/75dpi/:unscaled"
FontPath	"/usr/share/X11/fonts/Type1"
FontPath	"/usr/share/X11/fonts/CID"
FontPath	"/usr/share/X11/fonts/100dpi"
FontPath	"/usr/share/X11/fonts/75dpi"
	# paths to defoma fonts
FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
EndSection

Section "Module"
Load	"GLcore"
Load	"i2c"
Load	"bitmap"
# Load	"ddc" #Plug'n play (Voir dans monitor pourquoi)
Load	"dri"
Load	"extmod"
Load	"freetype"
Load	"glx"
Load	"int10"
Load	"type1"
Load	"vbe"
EndSection

Section "InputDevice"
Identifier	"Generic Keyboard"
Driver		"kbd"
Option		"CoreKeyboard"
Option		"XkbRules"	"xorg"
Option		"XkbModel"	"pc105"
Option		"XkbLayout"	"fr"
Option		"XkbVariant"	"latin9"
EndSection

Section "InputDevice"
Identifier	"Configured Mouse"
Driver		"mouse"
Option		"CorePointer"
Option		"Device"		"/dev/input/mice"
Option		"Protocol"		"ImPS/2"
Option		"Emulate3Buttons"	"true"
Option		"ZAxisMapping"		"4 5"
EndSection

Section "Device"
Identifier	"NVIDIA Corporation NV43 [GeForce 6600 GT]" # Ca oublie c'est parsque j'ai configuré en prenant comme exemple l'ancienne carte (enfin pas celle de secours quoi)
Driver		"vesa" # générique
BusID		"PCI:1:6:0"
EndSection

Section "Monitor"
Identifier	"Écran générique"
Option		"DPMS"
HorizSync	28-64
VertRefresh	43-60

# Il arrive pas à me faire du 1280x1024, il y a pas le choix dans la "résolution d'écran" pourtant sous Win ça marche
#j'ai fait cette ligne avec le tuto sur X dans le forum mais rien changé
#en plus les 640x480 et 800x600 font passer la vsync à plus de 60Hz malgré qu'il soit réglé dessus (61 Hz précisément)
Modeline "1280x1024"   108   1280 1328 1440 1688   1024 1025 1028 1066  +hsync +vsync
EndSection

Section "Screen"
Identifier	"Default Screen"
Device		"NVIDIA Corporation NV43 [GeForce 6600 GT]"
Monitor		"Écran générique"
DefaultDepth	24
SubSection "Display"
	Depth		1
	Modes		"1280x1024" "1280x768" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
	Depth		4
	Modes		"1280x1024" "1280x768" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
	Depth		8
	Modes		"1280x1024" "1280x768" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
	Depth		15
	Modes		"1280x1024" "1280x768" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
	Depth		16
	Modes		"1280x1024" "1280x768" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
	Depth		24
	Modes		"1280x1024" "1280x768" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier	"Default Layout"
Screen		"Default Screen"
InputDevice	"Generic Keyboard"
InputDevice	"Configured Mouse"
EndSection

Section "DRI"
Mode	0666
EndSection

Link to comment
Share on other sites

Ok j'ai viré les drivers nvidia :

linux-restricted-modules-*-amd64-generic-nvidia-legacy

nvidia-glx-legacy

nvidia-settings

Ça marche et c'est impressionnant de voir a quel point l'accélération 3D est nécessaire ! 100 petits polygones avec blending : AMD64 3500+ à 100% pour des saccades :roll: .

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...