Jump to content

[Grub] Nombreux ratés et erreurs


ka_nalu

Recommended Posts

Salut,

j'ai quelques ratés depuis quelques temps avec Grub. Il ne veut pas se lancer, en m'affichant "Error 17", "Error 18", ou encore "Error 16". Quand il se lance après avoir eu ce problème, si j'essaie de booter sur Ubuntu ou Windows, il m'affiche des messages du genre "... exceeds maximum supported by BIOS". Il faut que je redémarre à plusieurs reprises pour que ce problème disparaisse. C'est la troisième fois qu'il me le fait, en 1 mois à peu près. :chinois:

D'où ça pourrais venir ? que dois-je faire ?

D'avance merci.

:cartonrouge:

Link to post
Share on other sites

Salut,

j'ai quelques ratés depuis quelques temps avec Grub. Il ne veut pas se lancer, en m'affichant "Error 17", "Error 18", ou encore "Error 16". Quand il se lance après avoir eu ce problème, si j'essaie de booter sur Ubuntu ou Windows, il m'affiche des messages du genre "... exceeds maximum supported by BIOS". Il faut que je redémarre à plusieurs reprises pour que ce problème disparaisse. C'est la troisième fois qu'il me le fait, en 1 mois à peu près. ;)

D'où ça pourrais venir ? que dois-je faire ?

D'avance merci.

:-D

n'aurait tu pas un bios qui a du mal à gérer les partitions de plus 4Go ?

Link to post
Share on other sites

Ah ça je sais vraiment pas.

Comment le savoir ?

Dans ton bios quel taille font tes disques, tailles normales ou limitées à ...

Par contre je crois qu'il y a une option dans grub du genre hdx, mais je sais plus exactement ...

Link to post
Share on other sites

Vu la configue matérielle de ka_nalu, je pense pas que le problème vienne de là.

Cependant si windows pose aussi problème alors il faut peut-être vérifier les connexions internes et même voir si la pile de la carte mère commencerai pas à faiblir.

Pour le bios, regarde la doc de la carte mère et vérifie aussi si tu peux recharger le bios d'origine.

Au fait t'as pas overclocké ?

J'y pense, je sais pas si c'est possible mais il y a les secteurs du MBR qui pourraient être foireux.

Link to post
Share on other sites

Salut

Chose simple et rapide, faire un "load setup default", c'est a dire remettrel e bios au reglage par defaut .

Par contre veirifie bien que le fsb corespond a ta configuration apres et reajuste si necessaire :) .

a+

Link to post
Share on other sites
Je n'ai jamais overclocké mon pc. Tout à l'heure, j'ai cherché à remttre mon BIOS "à zéro" dans les options au démarrage, j'ai pas trouvé. :p

"load bios default" "load default values" ou un truc du genre.

Pour contrôler ton disque tu as smartctl (smartmontools) ; regarde aussi si tu as des erreurs qui semblent relatives aux disques dans tes logs. Mais comme ça je pencherais plutôt pour une erreur de système de fichiers : ça arrive souvent quand on laisse win créer ou formater des partitions. Quand Linux est lancé tu n'as jamais de kernel panic ? (par exemple en regardant un film stocké sur le disque, ou en enregistrant/déplaçant des fichiers) (petit test : fais le md5sum d'un gros fichier, copie le sur une autre partition et refais le md5 pour voir si il correspond ; tu peux faire ce test plusieurs fois).

Link to post
Share on other sites

Il me refait ce genre de crises à chaque fois que je vaisfaire un tour sur windows apparement... :D

Grâce aux incantations de mon très cher ami IAmKGo au bout du fil (c'est assez incroyable, à chaque fois que j'ai ce problème et qu'il décroche, ça se résoud, alors que je l'ai appelé après plusieurs essais :transpi: ), j'ai pu redémarrer pour écire ce message. Il m'a lui aussi conseillé, tout comme chtimbo, d'ouvrir mon PC et de retirer la pile de ma carte mère, puis de la remettre. Non ? parce que je ne trouve toujours pas l'option qui me permettrait de faire ça dans Setup...

Link to post
Share on other sites

Salut

C'est quoi ta carte mére ?

Sinon pas besoin d'ouvrir le PC pour remttre a zero le bios .

On enleve la pile de la carte mére quand ce type de manipulation software ne marche pas :freeposts: .

a+

Link to post
Share on other sites

gset, il faut que j'installe quelque chose ? j'ai téléchargé le .zip sur la page de documentation que tu m'a donné, mais c'est un ROM, je vois pas quoi en faire sur linux; Et puis ça sert à quoi exactement ?

Link to post
Share on other sites

Normalement, tu dois pouvoir décompresser le fichier zip sous linux avec :

unzip le fichierzip

ou alors place le dans ta partition windows.

Normalement, dans le lien tu dois pouvoir trouver la documentation constructeur de ta carte mère avec tous le renseignements nécessaires.....Comment mettre à jour le bios, le remettre dans son état d'origine.....Les touches magiques pour faire ça sans démonter.

Sinon, tu peux aussi aller voir sur le forum "overclocking" Là c'est certain que tu trouveras un gars avec une CM ASUS pour t'aider sur le bios

Link to post
Share on other sites

Salut Ka_nalu,

Dans le lien que je t'ai donné, il faut aller sur l'onglet "Manual" :

http://support.asus.com/download/download....model=P5S800-VM

Je pensais que tu l'aurai vu. C'est pour ça que j'avais donné la page d'acceuil.

Sur le nouveau lien, tu pourra avoir des fichiers pdf

Regarde aussi dans la colonne de gauche, il y a des infos

Le fichier .ROM doit être le nouveau BIOS donc pour l'instant : pas touche!

A+

Link to post
Share on other sites

Je me suis procuré la doc, il me donne 4 manières de mettre à jours le BIOS.

Sinon, j'ai encore eu un problème tout à l'heure. Ma soeur était sur windows depuis environ 1h, le PC était donc assez chaud. Je redémarre, il m'affiche :

Reboot and Select proper boot device

or Insert Boot Media in selected Boot device and press a key_

Je redémarre, ça marche, et alors qu'il est en train de me lancer kdm, il revient en console et m'affiche une série d'erreurs du genre :

kubuntu login : [4294740.554000] Buffer I/0 error on device hda2, logical block 1

avec à la fin de la série :

/usr/sbin/fctStartAdsl : line 131 : /sbin/route : Input/output error

Je tape alors kanalu comme nom d'utilisateur :

[4294923.317000] EXT3-fs error (device hda2) : ext 3_get_inode_loc : unable to read inode block_inode = 345757040, block : 6914054

Je décide alors après de nombreux essais de le laisser reposer 1/4 d'heure. Ça a marché puisque je vous écrit ce message.

Enfin, dans Setup, j'ai trouvé une option "Addon Rom Display Mode", où je peux choisir soit "Force Bios" (qui est actuellement sélectionnée) soir "Keep Current"

;)

Voilà voilà, j'espère que toutes ces petites précisions pourront vous aider à trouver une piste. Dois-je mettre à jour mon BIOS au plus vite ?

Link to post
Share on other sites

Re :oops:

Pour l'instant, il n'est absolument pas question de mettre à jour le bios. Et là j'insiste !

Parmi les pistes données plus haut, quelles sont celles que tu as appliquées ?

Re :zarb:

Pour l'instant, il n'est absolument pas question de mettre à jour le bios. Et là j'insiste !

Parmi les pistes données plus haut, quelles sont celles que tu as appliquées ?

Désolé pour le doublon :transpi:

Link to post
Share on other sites

Encore de novuelles erreurs :yes: . La plus récurrente est celle du "Reboot and select proper boot device...", et il m'a aussi affiché ça à un moment :

GNU GRUB version 0.95 (639K lower / 522432K upper memory)

[Minimal BASH-like line editing is supported. For the first word, TAB lists possible command completions. Anywhere else ATB lists the possible completions of a device/filename.]

grub >

Dois-je tester comme me l'a dit nofun ? que dois-je faire exactement ? déplacer un gros fichier d'une partition, à l'autre ? où sont les logs de mes disques ?

Link to post
Share on other sites

Vraiment bizzare tous ça.

Je pense que tu devrais plus tenir compte des remarques déjà faites plus haut :chinois:

Il n'est pas impossible aussi que :

- le disque dur ait des problèmes

- la température interne du PC soit trop élevée, surtout si après une période de repos le système redémarre sans problème

Je te conseille de vérifier, ou de faire vérifier ton PC. Surtout sauvegarde tes données maintenant.

Je suis vraiment désolé Ka_nalu, mais ton problème n'est pas évident à résoudre à distance. :mdr:

Link to post
Share on other sites

Je comprend bien, mais tu m'aides déjà par l'attention que tu me portes, et je t'en remercie :ouioui:

Je vais acheter des DVD vierges dès demain et sauvegarder mes données. Après c'est toujours embetant de devoir réinstaller tout un système (surtout Ubuntu), mais bon, j'espère ne pas en arriver là.

Je décide de ce qu'il faut faire avec un copain qui s'y connait et je t'en reparle.

:transpi::byebye:

Link to post
Share on other sites

Autre erreur apparue tout à l'heure :

Windows n'a pas pu démarrer car le fichier suivant est manquant ou endommagé :

<Racine Windows>\system32\ntoskrnel.exe

Veuillez réinstaller une copie du fichier ci-dessus.

:francais:

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...