Jump to content

Archived

This topic is now archived and is closed to further replies.

plarot_1

[Wine] Cinema 4D et age of empire 2

Recommended Posts

bonsoir tout le monde !

Je me met à Linux, avec la distribution Ubuntu, l'installation se passe bien, j'installe tous pleins de logiciels, dont Wine, j'ai lu sur cette page que l'installation du logiciel 3D cinema 4D que j'utilise était possible, donc j'essaye de le lancer avec wine, comme indiquer sans l'installer, en reprenant une installe deja présente, j'essaye donc a partir du disque dur windows :

benji@benjamin:~$ sudo wine "\\disques_dur\\c\\logiciels\\maxon\\cinema 4d r9\\cinema 4d.exe"

wine: cannot find '\disques_dur\c\logiciels\maxon\cinema 4d r9\cinema 4d.exe'

===> sans succès

J'essaye ensuite de copier le dossier de cinema 4D dans mes documents, et je reessaye :

benji@benjamin:~$ sudo wine "\\home\\benji\\cinema 4d r9\\cinema 4d.exe"

wine: cannot find '\home\benji\cinema 4d r9\cinema 4d.exe'

===> sans succès

Tout ca ne marche pas alors qu'hier j'avais réussi a avoir le logo de démarrage de cinema 4D (meme si après il se stopait pour une raison inconnue). Je me demande donc si sur ce coup, ce n'est pas Wine qui merde, suite a mon installation de wine tools hier. je desinstalle donc tout, wine et wine tools, je réinstalle wine, et la ca me donne les memes lignes.

Donc la j'aurais besoin d'aide pour faire marcher Cinema 4D, parcque sans cinema 4D que j'utilise tout le temps, ca ne sert à rien que j'utilise Linux ! :chinois:

J'essaye ensuite de lancer mon jeu en réseau fétiche, Age Of empire 2, et la memes résultats, cannot find etc ..

------------------------------------------------

------------------------------------------------

Ensuite, j'ai des petits problèmes par ci par la, que j'aimerais bien résoudre quand meme. Je lance VlC, GAIM, je met de la musique .. je l'entends .. mais je n'entends pas les sons de GAIM ..

AUtre chose : le son de VLC est très médiocre ..

Autre petite chose : les transfert de fichier sous GAIM vont a 5ko/sec (alors que j'ai 5Mega)

Donc si vous avez des idées pour ces problèmes (en priorité Wine), je vous écoute car ca commence a bien me gonfler

Merci beaucoup à vous

:yes:

Share this post


Link to post
Share on other sites

les textes en couleur passent mal sur le skin noir (ca explose les yeux)

du coup j'ai pas lu :(

ca serait bien de mettre de couleurs normales ie, pas de couleur :D

ps : ie ca veut dire "id est" hein :yes: , pas d'idées mal placées :chinois:

Share this post


Link to post
Share on other sites

aucun problème, c'est fait :yes:

Au sujet du son, j'ajoute que par exemple, le son ne fonctionne pas non plus sous Firefox :/

Help me plzzzzzzzzzzzzzzzzzzzzz

Share this post


Link to post
Share on other sites

Faudrai que tu installe tes jeux et programmes, directement dans linux, pas de copie foireuses depuis windows :yes:

Share this post


Link to post
Share on other sites

c'est ce qui était conseillé sur la page donnée plus haut .. m'enfin je vais le faire je perd rien ^^

et donc pour installer un logiciels 'faut faire ca ?

sudo wine "\\chemin\\cinema 4d.exe"

merci de m'aider :yes:

Share this post


Link to post
Share on other sites
benji@benjamin:~$ sudo wine "\\home\\benji\\cinema 4d r9\\cinema 4d.exe"

wine: cannot find '\home\benji\cinema 4d r9\cinema 4d.exe'

Déjà tu doit monter ta partition windows, puis ton chemin windows est incorrect.

Si tu monte ta partition dans /mnt/windows: tu fais sudo wine /mnt/windows.../benji/cinema 4d r9/cinema 4d.exe

Share this post


Link to post
Share on other sites

L'installation est lancée, pour le moment ca marche, j'avais deja essayé ca avec Wine Tool, et ca avait marché aussi, mais le blocage apparait toujours au lancement de cinema 4D .. on va bien voir cette fois ci :)

merci :yes:

Share this post


Link to post
Share on other sites

Dabord tu devrais commencer par configurer wine grace a winetools (tu devrais le trouver facilement ) .

Aussi avec winecfg tu configures spécifiquement ton application avec les bonnes dll ... .

Par exemple Age of empires 2, tu le mets dans un bureau de 640*480 .

(Enfin moi je prefere cela avec gta3 car sinon j ai un bug de la résolution sous Xorg voila)

Aprés quand tout est bien configuré, alors tu vas dans le repertoire du jeu ou de l application puis tu clique dessus.

Normallement on va te dire qu on ne connait l application.tu lui dit de l'ouvrir avec Wine.

La sa devrait marcher.

Share this post


Link to post
Share on other sites

Ca m'interresse ce que tu dis Nvramm, car pour Aoeœ, hier l'erreur qui apparaissait était relative à la résolution. Pourrais tu un peu plus décrire les étapes à partir du début à faire ???

Sinon la je viens de finir d'installer cinema 4D, comment dois-je faire pour le lancer sachant qu'il l'a installé dans c:/program files/maxon/cinema 4d r9/cinema 4d.exe

Share this post


Link to post
Share on other sites

Si j ai bien compris tu as reussi à installer age of empire 2.

Donc tu ouvres une console (konsole gnome-terminal ...) et tu tapes winecfg.

Normallement il y a quelque chose qui apparait .

Dans un des onglets il y a des applications.La tu ajoutes l'executable AoE2.exe.

Et aprés tu selectionne l appli Aoe2.exe et dans un des onglets, il doit y avoir config video un truc comme cela:

tu y vas et tu selectionne bureau virtuel et tu definis une resolution (640*480 par exemple)

Il y a d autres options comme quel gestionnaire de son prendre ( prend ess ou alsa mais pas oss),

quel systeme d'exploitation wine doit il faire croire (winxp win2000 win98 ...).

A priori sa devrait etre bon.

Aussi c'est pas le meme jeu mais y a les menu de winecfg ici

Share this post


Link to post
Share on other sites

ça dépends aussi comment tu configure wine pour les dll, si tu utlise une partition windows ou non, sinon il faut créer une arborecence (basic de) windows dans ton "/"

Je te propose de visiter le site officiel de wine pour savoir comment faire ;)

Share this post


Link to post
Share on other sites

merci pour les explications, jusque la ca marche, et comment je fais ensuite pour lancer une application ajoutée dans la liste ?

merci ;)

Share this post


Link to post
Share on other sites

Moi ce que je fais, je vais dans le repertoire d'installation, puis je clique sur l appli puis, pour moi XFCE (kde ou gnome ca doit etre pareil) me demande avec quelle appli ouvrir: la tu entre wine pour la commande.Voila

Sinon pour cinema 4d il y a cela sur l app database

Share this post


Link to post
Share on other sites

merci pour tes réponses ;)

j'ai 2 erreurs pour cinema 4D et aoe2 ..

pour cinema 4D : ici

pour aoe2 : ici

Donc la comme d'ab', je ne sais pas quoi faire .. une idée ?

Share this post


Link to post
Share on other sites

bah ecoute je pense qu'il manque des dlls pour cinema 4d. installe les dlls indispensable pour windows dans winetools.

Sinon pour age of empire 2 il faudrait que je teste (peut etre un probleme de driver 3d sous xorg mais a priori sa devrait se lancer en rammant).

Sinon ben je vois pas, je vais tenter de lancer age of empire sous ma fedora malgré qu elle est vraiment dans un salle état ( j'ai foiré l update en passant a la Fc 5 mais sa devrait se lancer quand meme avec mon wine)

Share this post


Link to post
Share on other sites

je n'ai pas encore installé tout ce qui est wine tool .. je vais le faire et je vous dit ce qu'il se passe après ;)

Share this post


Link to post
Share on other sites

J ai testé Age of empire 2 avec un crack, ca fonctionne presque bien (leger bug graphique mais c'est jouable, c'est peut etre a cause de mon install de xorg sur ma carte video intel i845 :-D )

Voila je lai configuré pour win 98 avec un bureau virtuel de 640*480 et ca marche.

Pour cinema 4d il faut esperer que wine sache gérer les api qu'il utilise.

Share this post


Link to post
Share on other sites

moi ca ne marche pas pour aoe2 :-D

voila ce que j'ai :

Winecfg

Aoe lancé a partir de l'explorateur

j'ai donc installé tout ce qui me semblait necessaire dans winetool (après si c'est bien ca qu'il fallait installer, je n'en sais rien .. l'erreur vient peu etre d'ici)

j'ai toujours la meme erreur pour cinema 4D ..

j'en ai marre .. :zarb:

Share this post


Link to post
Share on other sites

des nouvelles pour cinema 4D .. il me lance l'interface de début, le moment ou il lance le programme, mais se ferme au moment ou il dit "initializing user interface" (petite capture de la salle bete)

petite lueur d'espoir ou faux espoir ?

EDIT voila ce qu'il me met au passage :

benji@benjamin:~$ wine "c:\\program files\\maxon\\cinema 4d r9\\cinema 4d.exe"

fixme:msvideo:DrawDibDraw wFlags == 0x00001000 not handled

fixme:msvideo:DrawDibDraw wFlags == 0x00001000 not handled

fixme:msvideo:DrawDibDraw wFlags == 0x00001000 not handled

fixme:msvideo:DrawDibDraw wFlags == 0x00001000 not handled

fixme:msvideo:DrawDibDraw wFlags == 0x00001000 not handled

fixme:msvideo:DrawDibDraw wFlags == 0x00001000 not handled

fixme:msvideo:DrawDibDraw wFlags == 0x00001000 not handled

fixme:msvideo:DrawDibDraw wFlags == 0x00001000 not handled

wine: Unhandled exception (thread 000a), starting debugger...

WineDbg starting on pid 0x8

Unhandled exception: page fault on write access to 0x0000002c in 32-bit code (0x007c421d).

In 32 bit mode.

Register dump:

CS:0073 SS:007b DS:007b ES:007b FS:11e7 GS:0033

EIP:007c421d ESP:b7b8e16c EBP:b7b8e2e8 EFLAGS:00010206( - 00 - RIP1)

EAX:00000000 EBX:b5736a2c ECX:b7b8e190 EDX:00000001

ESI:00c71684 EDI:00811b2e

Stack dump:

0xb7b8e16c: 00000000 00000000 00000000 00000000

0xb7b8e17c: 7beb2800 00000000 00000000 00000000

0xb7b8e18c: 00000000 00000000 00000000 00000000

0xb7b8e19c: 00000000 00000000 00000000 00000000

0xb7b8e1ac: 00000000 00000000 00000000 00000000

0xb7b8e1bc: 00000000 00000000 00000000 00000000

023c: sel=11e7 base=b7cae000 limit=00001fff 32-bit rw-

Backtrace:

=>1 0x007c421d in cinema 4d (+0x3c421d) (0xb7b8e2e8)

2 0x007c4f25 in cinema 4d (+0x3c4f25) (0xb7b8e434)

3 0x007c7fea in cinema 4d (+0x3c7fea) (0x00000000)

0x007c421d: movl %edx,0x2c(%eax)

Modules:

Module Address Debug info Name (95 modules)

PE 0x00400000-00d10000 Export cinema 4d

PE 0x65f00000-65fc2000 Deferred ole32

ELF 0x7be87000-7bf00000 Deferred ntdll<elf>

\-PE 0x7bea0000-7bf00000 \ ntdll

ELF 0x7bf00000-7bf03000 Deferred <wine-loader>

ELF 0x7db36000-7db98000 Deferred libgnutls.so.11

ELF 0x7db98000-7dbb5000 Deferred libcups.so.2

ELF 0x7dbc4000-7dc10000 Deferred libgcrypt.so.11

ELF 0x7dc10000-7dc20000 Deferred libtasn1.so.2

ELF 0x7dc5b000-7dc70000 Deferred midimap<elf>

\-PE 0x7dc60000-7dc70000 \ midimap

ELF 0x7dd85000-7dd9e000 Deferred msacm.drv<elf>

\-PE 0x7dd90000-7dd9e000 \ msacm.drv

ELF 0x7dd9e000-7dde1000 Deferred wineoss.drv<elf>

\-PE 0x7ddb0000-7dde1000 \ wineoss.drv

ELF 0x7de25000-7de29000 Deferred libxfixes.so.3

ELF 0x7de29000-7de32000 Deferred libxcursor.so.1

ELF 0x7de32000-7de4f000 Deferred imm32<elf>

\-PE 0x7de40000-7de4f000 \ imm32

ELF 0x7de4f000-7de6b000 Deferred ximcp.so.2

ELF 0x7de6b000-7deed000 Deferred winex11.drv<elf>

\-PE 0x7de80000-7deed000 \ winex11.drv

ELF 0x7deed000-7df0c000 Deferred libexpat.so.1

ELF 0x7df0c000-7df3a000 Deferred libfontconfig.so.1

ELF 0x7df3a000-7df4e000 Deferred libz.so.1

ELF 0x7df4e000-7dfb8000 Deferred libfreetype.so.6

ELF 0x7dfc0000-7dfc4000 Deferred libgpg-error.so.0

ELF 0x7dfc4000-7dfe5000 Deferred iphlpapi<elf>

\-PE 0x7dfd0000-7dfe5000 \ iphlpapi

ELF 0x7dfe5000-7e010000 Deferred ws2_32<elf>

\-PE 0x7dff0000-7e010000 \ ws2_32

ELF 0x7e010000-7e02d000 Deferred wsock32<elf>

\-PE 0x7e020000-7e02d000 \ wsock32

ELF 0x7e02d000-7e0c4000 Deferred opengl32<elf>

\-PE 0x7e070000-7e0c4000 \ opengl32

ELF 0x7e0c4000-7e0ef000 Deferred winspool.drv<elf>

\-PE 0x7e0d0000-7e0ef000 \ winspool.drv

ELF 0x7e0ef000-7e14b000 Deferred shlwapi<elf>

\-PE 0x7e110000-7e14b000 \ shlwapi

ELF 0x7e14b000-7e211000 Deferred shell32<elf>

\-PE 0x7e170000-7e211000 \ shell32

ELF 0x7e211000-7e2a1000 Deferred comdlg32<elf>

\-PE 0x7e220000-7e2a1000 \ comdlg32

ELF 0x7e2a1000-7e2c4000 Deferred msacm32<elf>

\-PE 0x7e2b0000-7e2c4000 \ msacm32

ELF 0x7e2c4000-7e303000 Deferred avifil32<elf>

\-PE 0x7e2d0000-7e303000 \ avifil32

ELF 0x7e303000-7e317000 Deferred lz32<elf>

\-PE 0x7e310000-7e317000 \ lz32

ELF 0x7e317000-7e332000 Deferred version<elf>

\-PE 0x7e320000-7e332000 \ version

ELF 0x7e332000-7e3f1000 Deferred comctl32<elf>

\-PE 0x7e340000-7e3f1000 \ comctl32

ELF 0x7e3f1000-7e416000 Deferred msvfw32<elf>

\-PE 0x7e400000-7e416000 \ msvfw32

ELF 0x7e416000-7e457000 Deferred advapi32<elf>

\-PE 0x7e430000-7e457000 \ advapi32

ELF 0x7e457000-7ed5a000 Deferred gdi32<elf>

\-PE 0x7e4a0000-7ed5a000 \ gdi32

ELF 0x7ed5a000-7ee86000 Deferred user32<elf>

\-PE 0x7ed80000-7ee86000 \ user32

ELF 0x7ee86000-7ef06000 Deferred winmm<elf>

\-PE 0x7ee90000-7ef06000 \ winmm

ELF 0x7f049000-7f807000 Deferred libglcore.so.1

ELF 0x7f807000-7f87d000 Deferred libglu.so.1

ELF 0x7f87d000-7f900000 Deferred libgl.so.1

ELF 0x7f900000-7f9c0000 Deferred libx11.so.6

ELF 0x7f9c0000-7f9d9000 Deferred libice.so.6

ELF 0x7f9d9000-7f9f0000 Deferred glu32<elf>

\-PE 0x7f9e0000-7f9f0000 \ glu32

ELF 0x7faf1000-7fafc000 Deferred libgcc_s.so.1

ELF 0x7fafc000-7fb00000 Deferred libxdmcp.so.6

ELF 0x7fb01000-7fb0e000 Deferred libxext.so.6

ELF 0x7fc95000-7fda0000 Deferred kernel32<elf>

\-PE 0x7fcc0000-7fda0000 \ kernel32

ELF 0x7feb0000-7feb2000 Deferred libnvidia-tls.so.1

ELF 0x7feb2000-7feb5000 Deferred libxau.so.6

ELF 0x7feb5000-7febf000 Deferred libnss_files.so.2

ELF 0x7febf000-7fed4000 Deferred libnsl.so.1

ELF 0x7fed4000-7fedd000 Deferred libnss_compat.so.2

ELF 0x7fedd000-7fee5000 Deferred libxrender.so.1

ELF 0x7fee5000-7fee7000 Deferred xlcutf8load.so.2

ELF 0x7fee9000-7ff0b000 Deferred libm.so.6

ELF 0x7ff0b000-80000000 Deferred libwine_unicode.so.1

ELF 0xb7a46000-b7a4e000 Deferred libxi.so.6

ELF 0xb7a4e000-b7a6f000 Deferred wintab32<elf>

\-PE 0xb7a60000-b7a6f000 \ wintab32

ELF 0xb7a6f000-b7a71000 Deferred iso8859-1.so

ELF 0xb7dd0000-b7dd7000 Deferred libsm.so.6

ELF 0xb7dd8000-b7ddb000 Deferred libdl.so.2

ELF 0xb7ddb000-b7f09000 Deferred libc.so.6

ELF 0xb7f0a000-b7f1c000 Deferred libpthread.so.0

ELF 0xb7f1c000-b7f35000 Deferred libwine.so.1

ELF 0xb7f36000-b7f3f000 Deferred libnss_nis.so.2

ELF 0xb7f44000-b7f5a000 Deferred ld-linux.so.2

Threads:

process tid prio (all id:s are in hex)

00000008 (D) C:\program files\maxon\cinema 4d r9\cinema 4d.exe

0000000a 0 <==

00000009 0

WineDbg terminated on pid 0x8

Share this post


Link to post
Share on other sites

Tu as quoi comme carte video?une nvidia?une ati?

Tu utilises un crack (je sais c'est pas bien mais wine gere mal les protections cd)?

moi je n ai pas coché "permetre ... pixel shader" puis support du vertex shader "none".

Aussi j ai active le double buffering mais je n ai pas de qualité couleur.>>essaye de regarder de ce coté la.

J ai decoché "permettre appli direct x d empecher souris de quitter"

J ai fait croire a wine que j'etais sous win98.

Les logiciels installés par winetools (qui deconne à cause d'une police foireuse) sont :

- toutes les polices de textes

-les dlls mfc

-Msi

-internet explorer 6 (au cas ou :-D )

-dcom

-dlls Visual basic

Voila en gros ce que j ai installé

Pour cinema 4d ca me fait peur, essaye de le lancer avec wine --opengl au cas ou

Share this post


Link to post
Share on other sites

pour les truc à décocher, je vais essayer .. et j'ai une nvidia, et j'ai installé les drivers (j'ai le logo nvidia au démarrage, donc a priori ca veut dire que ca marche)

pour les applis, j'en ai installé quelques une que tu as sité :s je vais les desinstaller ..

je vous tiens au courant

et merci beaucoup de m'aider

EDIT : quand je tape wine --opengl dans la console, ca me met qu'il ne me trouve pas --opengl ..

Share this post


Link to post
Share on other sites

Je ne voudrais pas venir jouer le trouble fête mais il ne faut pas que tu croie que WINE va faire tourner toutes tes aplications windows. Ca fonctionne avec certaines mais pour d'autres (la majorité) ça ne marche pas encore car les API ne sont pas / sont mal implémentées.

Plus l'application est complexe, moins il y a de chance que ça passe.

Share this post


Link to post
Share on other sites

dans mon premier post, jk'ai donné une adresse ou un mec a fait marché cinema 4D .. donc c'est que c'est possible .. et pour age of empire 2, je doute que ce soit l'appli la plus complexe du monde ^^

sinon, j'ai décoché les cases que tu m'as dit Nvramm, et ca n'a rien fait :s

EDIT : je viens de voir que je ne l'avais pas donné justement héhé .. désolé

Share this post


Link to post
Share on other sites
The Maxon Logo splash appears. Finally, but nothing happens. Probably there is a dialog box behind the logo. With

ALT + F3

get the windows dialog and choose 'move'. Move the dialog box so you can see it. Input your serial numbers. If you made a mistake it could be that the box will appear again behind the logo. This time you should be able to see and grab it with the mouse cursor, because this one is larger. After licensing Cineam 4d should start. If not, most probably your problem belongs to the graphic card.

Ca peut peut être aider :-D

Share this post


Link to post
Share on other sites

×
×
  • Create New...