Jump to content

Flash Pour Linux


targa

Recommended Posts

  • Replies 77
  • Created
  • Last Reply

Salut

ils n'ont qu'a lacher le code source ou du moins rendre le format ouvert :chinois: .

Bref, je l'utilise car pour certain truc pas le choix mais ça reste le soucis du soft pas libre .

Quand le soft est libre une recompilation et c'est bon .

Quand il n'est pas libre faut attendre le bon vouloir du fabriquant .

a+

Link to post
Share on other sites
  • 3 months later...

Salut,

Honnêtement, je trouve qu'à l'heure actuelle avoir une distribution 64bits est encore un peu prématuré, vu que le gain de performance ne compense que trop rarement les nombreux problèmes liés à l'incompatibilité des programmes 32bits (qui restent majoritaires).

La solution la plus propre serait d'installer ton navigateur web en version 32bits (mais là encore se repose la question de l'intérêt d'une distribution 64bits !).

Sinon, il y a bien le projet Gnash, qui se veut une alternative libre au flash propriétaire d'adobe. Malheureusement, ce projet n'a pas l'air encore totalement au point.

Link to post
Share on other sites

Les binaires 32 bits marchent, mais pour des plugins il faut avoir du 64bits avec l'appli 64bits et du 32bits avec l'appli 32bits.

Etant donné que le plugin flash closed-source est 32bits, bah la seule solution c'est d'installer le navigateur 32bits.

Sous gentoo c'est simple, avec les autres distributions il doit sûrement falloir se télécharger firefox 32bits à la main...

(j'avais lu que konqueror ne gérait pas les plugins mozilla de la même manière et permettrait d'utiliser des plugins 32bits alors qu'il avait été compilé en 64bits, mais il faudrait vérifier les conditions)

Link to post
Share on other sites
  • 3 months later...

Les binaires 32 bits marchent, mais pour des plugins il faut avoir du 64bits avec l'appli 64bits et du 32bits avec l'appli 32bits.

Etant donné que le plugin flash closed-source est 32bits, bah la seule solution c'est d'installer le navigateur 32bits.

Sous gentoo c'est simple, avec les autres distributions il doit sûrement falloir se télécharger firefox 32bits à la main...

(j'avais lu que konqueror ne gérait pas les plugins mozilla de la même manière et permettrait d'utiliser des plugins 32bits alors qu'il avait été compilé en 64bits, mais il faudrait vérifier les conditions)

La mandriva x86_64 a toujours étée en multilibs donc pas de soucis. Il me semble que nulbuntu va ya venir ou y est déjà passé.

Link to post
Share on other sites

Les binaires 32 bits marchent, mais pour des plugins il faut avoir du 64bits avec l'appli 64bits et du 32bits avec l'appli 32bits.

Etant donné que le plugin flash closed-source est 32bits, bah la seule solution c'est d'installer le navigateur 32bits.

Sous gentoo c'est simple, avec les autres distributions il doit sûrement falloir se télécharger firefox 32bits à la main...

(j'avais lu que konqueror ne gérait pas les plugins mozilla de la même manière et permettrait d'utiliser des plugins 32bits alors qu'il avait été compilé en 64bits, mais il faudrait vérifier les conditions)

La mandriva x86_64 a toujours étée en multilibs donc pas de soucis. Il me semble que nulbuntu va ya venir ou y est déjà passé.

salut

C'est quoi ce troll ?

Ça te pose probleme qu'ubuntu reussise ?

tu es grave sur ce coup là ;)

ça revient au jean kevin qui nous sorte des windaube et autres stupidités du style .

a+

Link to post
Share on other sites

Salut

Le plugin flash fait partie de ces trucs qui me tracasse un peu sous linux .

J'ai deja eu a faire a des sites impossible a consulter car mon plug flash est trop vieux .

De plus, je ne crois pas trop a un nouveau plug flash made in macromedia pour tous de suite .

Le truc qui serait bien c'est qu'adobe decide de faire comme avec le pdf, de lacher les spec .

Apres ça irais plus vite pour un plug flash libre sous linux .

car sans les spec, les dev du libre vont en baver .

L'autre truc que j'aimerais avoir en libre c'est un driver 3d pour carte nvidia .

Un projet existe, mais il va falloir du temps .

a+

ps: la page du projet de dirver 3d libre pour nvidia http://nouveau.freedesktop.org/wiki/

Link to post
Share on other sites

Shockwave ... heu non a vrai dire on s'en fou :byebye:

Pour flash , de plus en plus de site demande la dernière version :francais:

Spa parce que toi tu t'en fout que tout le monde aussi :byebye:

DIsons, que j'aimais bien mon tennis table de miniclip.com :mad2:

Link to post
Share on other sites
  • 2 weeks later...

Quelques infos sup. concernant le developpement de flash 9 sous Linux :

Il devrait utiliser ces API :

* General graphics: X11

* GUI elements (dialog boxes): GTK

* Audio I/O: ALSA

* Camera input: Video4Linux, API version 1

* Threads: POSIX threads

* non-HTTP Networking: BSD sockets

* SSL: OpenSSL

* IME: you know what? I don't think we've settled on this one yet...

Bon ben rien de bien important pour le moment...

Link to post
Share on other sites

Quelques infos sup. concernant le developpement de flash 9 sous Linux :

Il devrait utiliser ces API :

* General graphics: X11

* GUI elements (dialog boxes): GTK

* Audio I/O: ALSA

* Camera input: Video4Linux, API version 1

* Threads: POSIX threads

* non-HTTP Networking: BSD sockets

* SSL: OpenSSL

* IME: you know what? I don't think we've settled on this one yet...

Bon ben rien de bien important pour le moment...

et flash 8 il passe a la trappe ;)

Link to post
Share on other sites

Quelques infos sup. concernant le developpement de flash 9 sous Linux :

Il devrait utiliser ces API :

* General graphics: X11

* GUI elements (dialog boxes): GTK

* Audio I/O: ALSA

* Camera input: Video4Linux, API version 1

* Threads: POSIX threads

* non-HTTP Networking: BSD sockets

* SSL: OpenSSL

* IME: you know what? I don't think we've settled on this one yet...

Bon ben rien de bien important pour le moment...

et flash 8 il passe a la trappe :smack:

En fait il ne devait pas avoir de 8 pour Linux, on devait avoir la 8.5 mais comme tu l as vu RIEN...

Donc maintenant ils promettent une version 9 :craint:

Link to post
Share on other sites

En tout cas, ce n'est pas encore gagné pour un nouveau plugin flash : http://blogs.adobe.com/penguin.swf/2006/07/stoppage_1.html

Stoppage

Things are not going so swell right now, at least for my development tasks. My favored Linux distribution -- which I previously claimed rarely fails me -- failed me. I may need to shop around for another distribution soon (perhaps along the lines of Mac OS X or Windows).

Though we have been diligently working towards getting all of the Linux features in line with the Windows and Mac counterparts, we have been hitting some capability walls. I.e., there are some standard facilities and APIs that Windows and Mac operating systems provide to applications that Linux simply doesn't. To be sure, it's not that Linux can't do XYZ, it's that there are so many ways to do XYZ. And forget about making these different methods interoperate where conducive. To answer anticipated objections, we don't have the prerogative to pick and choose which Flash features go into the Linux version; it's basically all or nothing. To address further objections, "Adobe isn’t open sourcing the Player at this time."

Though many of the Flash 8 and 9 features are in place now, the Linux Flash Player currently crashes. A lot. I have yet to make it through one full minute of a video when I try to partake of the erudite entertainment at YouTube. On the plus side, the pre-crash A/V sync is outstanding.

edit : des précisions sur le flash en 64 bits :craint:

Le plugin 32 bits fonctionne bien sur Konqueror 64 bits, Opera et Firefox 32 bits (normal pour ces deux derniers).

Link to post
Share on other sites
  • 1 month later...

Bonne nouvelle : il va y avoir une version Beta de flash 9 pour Linux, dispo avant sa sortie en debut (?) 2007.

... Yes, we do plan to release a beta version in advance of the final version. However, it will be a beta in the classical software engineering sense-- i.e., a version that we believe to be largely bug-free and submitted to the users in the hopes that the last of the bugs will be found and reported. ...

Link to post
Share on other sites

étant donné que macromedia s'est fait rachetée par adobe et que ce dernier a la bonne attitude, euh habitude ;) de publier les spécifications des formats utilisés par leurs logiciels (pdf, psd ...) , coder un flashplayer en gpl support la v9 ne devrait pas trop poser de problèmes

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.


×
×
  • Create New...