Jump to content

Archived

This topic is now archived and is closed to further replies.

ggbce

VSFTPD - XFERLOG et Webalizer bug...

Recommended Posts

J'ai un problème avec le fichier /var/log/vsftpd.log généré par vsftpd (en mode xferlog). Il ne semble pas totalement compatible pour être utilisé avec Webalizer.

Quand je génère mes rapports Webalizer (configué en mode ftp bien sur) tous les transferts de fichiers, date, provenance, ... est OK ! Sauf les entrées pour le nom des usagers qui ce sont connectés.

Au-lieu d'avoir (ex.: gaston, georges, toto, ...) j'ai a, i, b !!!

Si je regarde une ligne de vsftpd.log c'est comme ça:

Thu Nov 17 08:46:40 2005 1 192.168.0.1 3153 /scripts/ftpsend b _ i a  ftp 0 * c

Si je prends une ligne qui provient d'un xferlog d'un autre serveur avec wu-ftpd, ça donne:

Mon Nov 21 12:20:51 2005 1 192.168.0.2 175944 /home/test/wolcom.zip b _ i g gaston ftp 0 * c

On voit bien que le rapport "supposément standard XFERLOG de vsftpd ne contient pas le nom de l'utilisateur pour le transfert...

NOTE: J'utilise des usagers virtuels avec vsftpd, ce qui pourrait influencer sa façon de générer son LOG file... mais devrait quand même bien inclure le nom de l'usager.

J'ai cherché sur le site de VSFTPD et dans leur forum, mais personne ne parle de ce problème.

Share this post


Link to post
Share on other sites

J'ai trouvé le site web avec l'info de la structure du format XFERLOG

Voir: http://www.wu-ftpd.org/man/xferlog.html

Il est bien évident que VSFTPD ne génère pas correctement les logs, car actuellement il retourne ceci:

Thu Nov 17 08:46:40 2005 1 192.168.0.1 3153 /scripts/ftpsend b _ i a  ftp 0 * c

mais il devrait retourner:

Thu Nov 17 08:46:40 2005 1 192.168.0.1 3153 /scripts/ftpsend b _ i g toto ftp 0 * c

ou au minimum:

Thu Nov 17 08:46:40 2005 1 192.168.0.1 3153 /scripts/ftpsend b _ i a ftp 0 * c

Comme vous pouvez, si un usager est connecté c'est g (guest) ou r (real) et non a (anonymous) avec un nom d'usager spécifié. Actuellement VSFTPD génère un a avec un espace de trop après... ce qui probablement cause tous mes problèmes.

Savez-vous commencer forcer VSFTPD à utiliser un format XFERLOG approprié ?

Share this post


Link to post
Share on other sites

:craint:

Le support de VSFTPD ne semble pas répondre à ma question et leur forum est nul... SVP aidez-moi :smack:

Share this post


Link to post
Share on other sites

:incline:

J'aimerais trouver une solution à ce problème :francais:

Je reprends une explication courte:

(J'ai la version 2.0.3)

1- VSFTPD génère un rapport au format XFERLOG, mais avec une petite erreur de format. Si on regarde la ligne ci-dessous:

Thu Nov 17 08:46:40 2005 1 192.168.0.1 3153 /test.txt b _ i a  ftp 0 * c

Entre le "a" et "ftp" il y a 2 espaces au-lieu de une seule. Lorsque les parseurs tel que Webalizer convertit les données en HTML, les infos des usagers connectés n'est pas valide... il écrit n'importe quoi.

2- VSFTPD en mode "virtual users" n'inscrit pas les usagers virtuels dans le rapport XFERLOG comme étant "guest" ou "real", mais simplement "a" = anonyme.

Un exemple d'un XFERLOG en mode "guest":

Thu Nov 17 08:46:40 2005 1 192.168.0.1 3153 /test.txt b _ i g toto ftp 0 * c

Donc il n'est pas évident de faire des rapports HTML lisible si le XFERLOG n'est pas bon...

=====================================

Mes 2 questions:

Est-ce qu'il y a moyen de corriger cet erreur de création XFERLOG ?

Est-ce qu'en utilisant le mode journal VSFTPD au-lieu XFERLOG, est-ce qu'il existe un logiciel du genre Webalizer qui est capable de lire ces journaux ?

====================================

Merci

Share this post


Link to post
Share on other sites

×
×
  • Create New...