Jump to content

Archived

This topic is now archived and is closed to further replies.

aurielle

[resolu]probleme D'encodage Sous Psi (client Jabber)

Recommended Posts

Bonjour,

Débutante sous ubuntu, je recherche des info sur l'encodage sous psi (j'ai des difficultés à lire les tutos en anglais)

donc lorsque j'écris sous psi mes accents passe mal (éùÃ Ã) .

dans la console j'ai cela muriel@althea:~$ locale

LANG=fr_FR.UTF-8@euro

LC_CTYPE="fr_FR.UTF-8@euro"

LC_NUMERIC="fr_FR.UTF-8@euro"

LC_TIME="fr_FR.UTF-8@euro"

LC_COLLATE="fr_FR.UTF-8@euro"

LC_MONETARY="fr_FR.UTF-8@euro"

LC_MESSAGES="fr_FR.UTF-8@euro"

LC_PAPER="fr_FR.UTF-8@euro"

LC_NAME="fr_FR.UTF-8@euro"

LC_ADDRESS="fr_FR.UTF-8@euro"

LC_TELEPHONE="fr_FR.UTF-8@euro"

LC_MEASUREMENT="fr_FR.UTF-8@euro"

LC_IDENTIFICATION="fr_FR.UTF-8@euro"

LC_ALL=

muriel@althea:~$

Les accents de mes contacts passent très bien (aussi bien avec contact windows avec msn , que contact jabber sous linux avec psi). Il n'y a que mes accents a moi qui posent probleme

Avez vous déjà eu ce problème et si oui comment l'avez vous résolu?

merci d'avance pour votre aide

(ps:merci au first jeudi pour la super soirée de novembre, du coup je me décide à poster ici)

Share this post


Link to post
Share on other sites

Bonjour,

Débutante sous ubuntu, je recherche des info sur l'encodage sous psi (j'ai des difficultés à lire les tutos en anglais)

donc lorsque j'écris sous psi mes accents passe mal (éùÃ Ã) .

dans la console j'ai cela muriel@althea:~$ locale

LANG=fr_FR.UTF-8@euro

LC_CTYPE="fr_FR.UTF-8@euro"

LC_NUMERIC="fr_FR.UTF-8@euro"

LC_TIME="fr_FR.UTF-8@euro"

LC_COLLATE="fr_FR.UTF-8@euro"

LC_MONETARY="fr_FR.UTF-8@euro"

LC_MESSAGES="fr_FR.UTF-8@euro"

LC_PAPER="fr_FR.UTF-8@euro"

LC_NAME="fr_FR.UTF-8@euro"

LC_ADDRESS="fr_FR.UTF-8@euro"

LC_TELEPHONE="fr_FR.UTF-8@euro"

LC_MEASUREMENT="fr_FR.UTF-8@euro"

LC_IDENTIFICATION="fr_FR.UTF-8@euro"

LC_ALL=

muriel@althea:~$

Les accents de mes contacts passent très bien (aussi bien avec contact windows avec msn , que contact jabber sous linux avec psi). Il n'y a que mes accents a moi qui posent probleme

Avez vous déjà eu ce problème et si oui comment l'avez vous résolu?

merci d'avance pour votre aide

(ps:merci au first jeudi pour la super soirée de novembre, du coup je me décide à poster ici)

à mon avis c'est juste l'UTF8.

En effet, les caractères encodés en ISO8859 sont bien lus quand on est en UTF8, mais dans l'autre sens (quand on reçoit de l'UTF8 en étant en ISO)

Moralité : tout passer en "fr_FR@euro".

Share this post


Link to post
Share on other sites

Vous êtes sûrs que ça existe fr_FR.UTF-8@euro ? ça me parait étrange...

Je demande à un pote sous windows (bouhouhouh :eeek2:) comment mes accents rendent chez lui :eeek2:

Je suis en fr_FR.UTF-8 et c'est vrai que sur IRC ça peut poser problème mais j'avoue que je me suis jamais poser la question pour les IM...

Bienvenue sur PCI :francais:

Share this post


Link to post
Share on other sites

Je suis en fr_FR.UTF-8 et c'est vrai que sur IRC ça peut poser problème mais j'avoue que je me suis jamais poser la question pour les IM...

Pour l'irc j'ai pas trop de problème sous xchat c'est facile à configurer sous gaim pas réussi mais ca me gene pas

Moralité : tout passer en "fr_FR@euro".

je vais voir ce que lorinc en pense et ce qu'il peut faire pour moi avec ce conseil donc toi tu enleverais utf8 alors?

Goret si tu es dans les parages hésite pas à rajouter des infos si tu trouves que j'ai pas expliqué le probleme comme il faut

Share this post


Link to post
Share on other sites

J'ai la réponse, apparement il voit correctement mes accents avec MSN 7.0.

Donc je ne sais que penser :reflechis:

J'utilise gaim (en multiprotocole), est-ce que ça pourrait pas venir de là ? Parce que si tu utilises Psi tu dois utiliser les passerelles pour les contacts autres que Jabber.

Ps : tu t'es plantée dans tes quotes :D

Share this post


Link to post
Share on other sites

J'ai la réponse, apparement il voit correctement mes accents avec MSN 7.0.

Donc je ne sais que penser :reflechis:

J'utilise gaim (en multiprotocole), est-ce que ça pourrait pas venir de là ? Parce que si tu utilises Psi tu dois utiliser les passerelles pour les contacts autres que Jabber.

Ps : tu t'es plantée dans tes quotes :D

pour jabber je n'ai de problème d'encodage que sous psi pas sous gaim ni kopete ni jeti ou là j'ai aucun problème tout passe impec :roll: et pourquoi si le probleme venait des passerelles ne pourrais je pas avoir mes accents correct avec la personne sous jabber avec fedora sous psi???

Share this post


Link to post
Share on other sites

Pour info, je vois pas bien ses accents alors que j'utilise PSI sous Fedora, en UTF-8. Je les vois comme si j'étais en latin1.

Par contre elle elle voit bien mes accents.

J'ai l'impression que le texte qu'elle envoie est encodé deux fois en UTF-8, c'est très bizarre.

Je lui ai conseillé de fermer psi, de renommer son dossier de configuration "~/.psi" en "~/.psi.save", de relancer psi et de reconfigurer son compte, pour voir si ça viendrait pas d'une option dans un coin.

Dis-nous si ça marche please :)

Share this post


Link to post
Share on other sites
Pour info, je vois pas bien ses accents alors que j'utilise PSI sous Fedora, en UTF-8. Je les vois comme si j'étais en latin1.

Par contre elle elle voit bien mes accents.

J'ai l'impression que le texte qu'elle envoie est encodé deux fois en UTF-8, c'est très bizarre.

Je lui ai conseillé de fermer psi, de renommer son dossier de configuration "~/.psi" en "~/.psi.save", de relancer psi et de reconfigurer son compte, pour voir si ça viendrait pas d'une option dans un coin.

Dis-nous si ça marche please :)

bien vu, ça a marché.

Du coup ce problème d'encodage reste un mystère (encore que j'ai rechangé les locales en fr_FR.UTF-8 entre temps - donc peut-être qu'en recréant les fichier de conf, il s'est basé sur des locales qui lui plaisaient un peu plus)

:p gauret

et au passage, :francais:

:D

Share this post


Link to post
Share on other sites

Donc c'était la conséquence d'une option de config à la con. Y'a plus qu'à autopsier le fichier de conf, c'est du XML :)

Share this post


Link to post
Share on other sites

×
×
  • Create New...