Jump to content

Archived

This topic is now archived and is closed to further replies.

PhiBee

[RESOLU]Décalage horaire ! Perdu mémoire !

Recommended Posts

Bonjour !

Voilà ! Nouvelle install avec un dual boot XP/Ubuntu (via grub), tout marche à merveille, et en plus, je me rend compte que maintenant, je passe 80% de mon temps sous linux.

MAIS !

Bin vi, même dans ce monde parfait, il y a qques anicroches, rien de mortel mais bon...

1- Sous XP, j'ai ma quantité de mémoire qui est correcte, c.a.d. 1024Mo. Par contre, sous Ubuntu, il ne m'en reste que 885... Attention, je précise que c'est le chiffre de la ram total que Ubuntu reconnait (terminal> top, tout ça...). Y aurait-il un bug ou bien une réserve qui se fait qque part ?

2- L'heure !!! Je m'explique: je boot sous Ubuntu, mon heure est correcte, je boot sous XP, 2 heures de moins... Donc, je me dis, allons de ce pas voir du coté du BIOS. Idem: 2 heures de moins... Je remet la bonne heure dans le BIOS, je sauvegarde et reboot > Ubuntu, ok > reboot >XP, rebelote -2 heures>retour dans le BIOS: -2 heures ! Je précise quand même qu'avant l'installation de Ubuntu, mon XP, tout comme le BIOS, étaient à la bonne heure !

J'en déduis que cela viendrait peut-être de grub, non ?

Une petite idée pour ces deux bidules ?

Précision: noob inside with nunux... Bin vi, y a un début à tout.

Ok, on va me dire " va voir dans le wiki machin et autre help sur le oueb!!"... sauf que je commence par ma communauté préférée :) [mode lèche OFF]

Woala, woala, woala... :transpi:

PS: lorinc, prépare-toi à ce que je te monopolise pour les séquenceurs !!! :ouioui: Rosegarden est méssant avec moi !

Link to post
Share on other sites

Bonjour,

Je ne suis pas très sur de mes réponses, alors si quelqu'un peu me corriger.

1) Tu dis:

Par contre, sous Ubuntu, il ne m'en reste que 885...

Tu dois surement avoir tes 1024 aussi sous ta Ubuntu, mais comme ton système en utilise une partie, alors t'en reste donc 885. Ca parait logique.

2) Regarde au niveau de ton Windows si ta localisation géographique est bien défini en France (Paris si tu en es proche).

Il me semble que sous "Linux" (en général), tu sois en synchronisation du temps via le serveur GMT, c'est pour ca que tu es l'heure. Je pense que ton soucis viens plus de Windows.

A+ :transpi:

Link to post
Share on other sites

furansu, quand tu as 1024 Mb Ram, ça me parait logique qu'il détecte 1024 et pas autre chose non? On parle pas de ce qu'il utilise ou non.

Il s'agit d'un bug dans le kernel sur le 1 Go Ram, il suffit de recompiler le kernel en le patchant et tu auras 1024 Mb :)

Voilà ce qu'on peut lire sur le site de Con Kolivas:

1g lowmem?

Many machines now have exactly 1Gb ram and the standard memory split on i386 does not allow you to use more than 896Mb ram without enabling high memory for at least 4Gb. The problem is that this incurs an overhead whereas we can simply change this split with this patch to allow i386 architectures to use up to 1Gb ram without enabling highmem. This is configurable if HIGHMEM is disabled.

Pour la date, il sufit de la modifier en live sur Ubuntu: http://www.gentoo.org/doc/fr/handbook/hand...l?part=1&chap=5

Le début de cette page t'explique pour la date.

Link to post
Share on other sites

Salut

C'est au niveau de la timezone il y a une astuce .

A un moment pendant l'install d'ubuntu il t'est demandé sur tu est a l'heure GMT .

Faut repondre non, puis selectionné la bonne zone de temps, c'est a dire EUROPE/Paris .

Sinon pour la Ram balance non un petit free .

Sur ma machine j'ai 512 de RAM ça donne ça au moment ou je t'ecris :

landromak@Ginkgo:~/qemu/redhat$ free
            total       used       free     shared    buffers     cached
Mem:        516356     391716     124640          0       9936     181544
-/+ buffers/cache:     200236     316120
Swap:       489940          0     489940

Donc je retrouve bien mes 512 de ram :)

a+

Link to post
Share on other sites
1- Sous XP, j'ai ma quantité de mémoire qui est correcte, c.a.d. 1024Mo. Par contre, sous Ubuntu, il ne m'en reste que 885... Attention, je précise que c'est le chiffre de la ram total que Ubuntu reconnait (terminal> top, tout ça...). Y aurait-il un bug ou bien une réserve qui se fait qque part ?

Il y a une solution simple, mais je te fait un texte de mini explication, mais en oubliant toute la technique avant

Alors, je te passe le blabla sur la gestion de la mémoire sous linux, mais disons qu'un noyau "basique" ne peut gerer plus de 4Go de ram... c'pas grave, il y a des astuces... 4 Go ? mais tu as beaucoup moins ? Ah oui, aussi, le noyau "vraiment de base" il ne peut pas reconnaitre plus de 886Mo deRAM, (en fait 32 bit c'est censé être 4G d'adresse (2³²) mais il y a 2 bits qui sont utiliséés pour autre chose on passe à 1G (2³°), et puis on pert encore de la place, je ne sais plus exactement pourquoi, et donc 886Mo) et tu voit 885, parce que le noyau doit dans ton cas utiliser quelque Mo, qui ne sont plus compatibilisés

Bon, la solution, c'est de regarder quels noyau sont disponibles, avec synaptics, je suppose que ça se fait par là, et de regarder dans les noms ou les descriptions après un noayu qui aurait "1Gb Low Memory Support" activé (tu peux aussi recompiler ton noyau, mais c'est plus simple d'en utiliser un déjà fait) C'est d'ailleurs étonant que Ubuntu n'utilise pas un tel noyau par défaut

edit : j'ai trouvé ce lien pour toi : (si tu parles un minimum l'anglais) http://www.ubuntu.com/support/documentatio...archterm=kernel

Link to post
Share on other sites
Wouhou, pas tous en même temps :ouioui:

utilité de ce post ? :transpi:

j'en profite pour poser une question aux pingouins ; la différence de valeur de mémoire , ça peut pas être lié au fait que sa carte graphique aurait de la mémoire dédiée sinon ? (je sais plus où j'avais lu ça)

(je dis pas que c'est la cas ici mais juste pour me confirmer/infirmer que ça peut arriver :fumer: )

Link to post
Share on other sites
utilité de ce post ? :ouioui:

Pourquoi tant de haine ??

(Et utilité du tiens ??) D'autant que ta question est un peu nulle...

Je faisait juste remarquer qu'on a été trois à repondre la même chose en même temps, c'est cool...

:transpi:

edit : quelle ambiance de merde sur ces forums :fumer:

Moi ça me fait plaisir d'aider des gens mais j'ai vraiment l'impression qu'ya des habitués de ce site qui n'aident personne et qui sont là juste pôur saper l'ambiance

Link to post
Share on other sites
j'en profite pour poser une question aux pingouins ; la différence de valeur de mémoire , ça peut pas être lié au fait que sa carte graphique aurait de la mémoire dédiée sinon ? (je sais plus où j'avais lu ça)

(je dis pas que c'est la cas ici mais juste pour me confirmer/infirmer que ça peut arriver :transpi: )

non non, là c'est bien un problème de 1Go lowmem/4Go highmem

Link to post
Share on other sites
Il s'agit d'un bug dans le kernel sur le 1 Go Ram, il suffit de recompiler le kernel en le patchant et tu auras 1024 Mb :)

Pas mal ce patch, parce que j'avais lu j'sais plus où que le fait d'activer l'option "High memory 4GB" augmentait les temps d'accés mémoire = pc plus lent :chinois:

Link to post
Share on other sites
Bonjour,

Je ne suis pas très sur de mes réponses, alors si quelqu'un peu me corriger.

1) Tu dis:

Tu dois surement avoir tes 1024 aussi sous ta Ubuntu, mais comme ton système en utilise une partie, alors t'en reste donc 885. Ca parait logique.

2) Regarde au niveau de ton Windows si ta localisation géographique est bien défini en France (Paris si tu en es proche).

Il me semble que sous "Linux" (en général), tu sois en synchronisation du temps via le serveur GMT, c'est pour ca que tu es l'heure. Je pense que ton soucis viens plus de Windows.

A+ :eeek2:

:D nan nan ! t'as pas bien lu mon message :incline: C'est la quantité totale non pas restante mais totale totale quoi !!

Et pour le problème horaire, non aucun rapoort avec XP puisque comme je l'ai également dit, avant le dual pas de lézard, mais là avec Ubuntu en dual, c'est XP ET LE BIOS qui sont décalés :incline:

Donc, pas de panique, j'ai mes réponses maintenant :transpi:

Link to post
Share on other sites

edit : quelle ambiance de merde sur ces forums :|

Moi ça me fait plaisir d'aider des gens mais j'ai  vraiment l'impression qu'ya des habitués de ce site qui n'aident personne et qui sont là juste pôur saper l'ambiance

Oulla keep cool ;)

il y a eu incompréhension mutuelle :D

l'aide de tous est la bienvenue :eeek2:

mais c'est vrai que dans les posts d'aide il faut éviter le plus possible les freeposts

ma solution : faire une partie constructve qui apporte quelque chose au sujet et une partie "libre" qui met l'ambiance dans le meme post :fumer: (*)

comme ca ca permet de dire des conneries sans se faire prendre par la police

:transpi:

Mais surtout faut le répéter à personne, hein, chut :incline:

Si tu trouves que des gens sappent l'ambiance, envoie moi un mp pour expliquer (meme si c'est moi qui est en cause ... ca peut m'arriver à l'insu de mon plein grè :incline: )

il y a toujours moyen de faire quelque chose, le plus souvent d'ailleurs les problèmes viennent d'incompréhension suite à une écriture trop rapide

(*) : Modèle déposé par lorinc et duke :8

mais réutilisable librement ...

Link to post
Share on other sites

<post>*

<partie_constructive>

Quand tu jettes un coup d'oeil ici tu vois que le décalage entre le tems UTC" (universel) et notre heure à nous est de 2h (comme toi...). Donc il te suffira surement de décocher "Utiliser UTC (ou un truc du genre) et rerégler à la bonne 'heure.

Autre chose normalement le linux n'a pas à toucher à l'heure de ton bios :eeek2:

Donc essaie aussi de désactiver "Synchroniser l'horloge système avec l'horloge matérielle à l'extinction" (encore une fois : ou un truc du genre :transpi: )

</partie_constructive>

<partie_libre>

(*) je brevette les balises :D

dsl j'ai mal choisit mes mots tout à l'heure :incline::incline:

c'est juste qu'on est sur un forum, donc des fois je me dis qu'ya des limites au policage :fumer:

Si vous voulez absolument que chaque topic se transforme en "tuto" faut plutot voir du coté des wikis d'ailleurs pourquoi pas un www.pcinpact.com/wiki (idée également brevettée) qui serait l'endroit parfait pour acceuillir les tutos de tuXXX (mais bon avec le nouveau design qui vient d'arriver faut pas trop en demander)

</partie_libre>

</post>

Link to post
Share on other sites

tout est affaire d'équlibre

- le gars qui vient cherché de l'aide a pas forcément envi de commentaires "inutiles" (bon la on s'en fout c'est :ouioui: , mais quand meme ... )

- les habitués en ont besoin, pour que ca ne soit pas trop mortel comme ambiance

Voila pourquoi il y a des topics plus libres (le bar, le topic à troll... etc). Il y a meme une partie blabla mais comme les linuxiens y vont pas... c'est pas la peine d'en parler

Evidement l'équilibre est pas toujours facile à trouver, la c'est clair c'était un peu éxagéré de te faire une remarque pour si peu :yes:

Bien sur toute remarque constructive concernant la modération ou autre sera toujours prise en considération, je le redit, mais s'il y ades trucs qui te dérange (ca vaut pour tout le monde), il suffit d'en parler avec un modo dédié de la section, moi à priori, vu que rem à re-disparu ( :craint: )

je transmettrais quelques coups de fouets à Scara de ta part :sm:

Voila pour la suite merci de poursuivre dans le bar, on arrète le :hs2: ici ;)

Sinon, je rejoint yoda, je pense pas que Phibee ait très envi de recompiler le noyau

Link to post
Share on other sites

Heu... recompiler ?

Pas tout de suite :craint: j'en suis loin !

Et puis comme dit, je suis un utilisateur de base.

Mais qui sait, si je me prend au jeu :yes:, et si j'ai le temps et l'energie, car entre mon taf, mes horaires, et le taf à la maison, bin, un minimum de bidouille le f'ra.

Sinon, pour les solutions, j'ai hate d'être ce soir afin de vérifier.

Mais le coup du BIOS, c'est rock'n'roll n'empêche. C'est seulement depuis que j'ai installé Ubuntu. Mais bon, y a pas mort d'homme non plus.

PS: duke... 2 claques :ouioui:

Link to post
Share on other sites

Comme expliqué depuis le début:

1- S'assurer que Linux n'utilise pas la fonction "heure CMOS ajusté au GMT"

2- S'assurer que si tu as une heure d'été que ce soit bien configuré (et non dans le BIOS)

3- Utilise un client ntp pour synchroniser ton heure sous Linux et sous Windows

Ça devrait fonctionner !

Link to post
Share on other sites

C'est bon, vous pouvez fermer ce topic les modos :pleure:

J'ai eu mes réponses. Et en plus, je vire Ubuntu :pleure: je me suis rendu compte que:

1- vu les lacunes que j'ai dans le domaine nunux, j'ai pas fini de me faire suer...

2- du coup, n'utiliser Ubuntu (ou autre) juste pour le oueb, bin... bof !

3- Mon domaine c'est l'audio, et malgré des logiciels qui semblent prometteurs (séquenceurs et synthe virtuels), les configurations de cartes sons et autres, c'est plus du tout mon hobby :pleure: et j'ai autre chose à faire que de perdre mon temps à paramètrer.

4- Vu toutes le modifs à faire, les modif de noyau machin, les lignes de commandes truc-muche et autres fenêtre de je ne sais quoi, c'est le bronx pour moi !

Mais cela n'enlève rien au "charme" de cette distri, mais dans mon cas, j'ai découvert, c'est bien, j'ai testé, c'est bien, les diverses communautés sont super sympa et rapide, mais bon, je n'irai pas plus loin ! C'est trop ésotérique pour moi.

Parce que se taper une lecture d'encyclopédie pour chaque install ou modif, non merci; j'ai passé l'âge :pleure: C'est une question de priorité et je choisis donc ma passion: la zic :pleure:

Encore merci pour votre aide :pleure:

:transpi:

Link to post
Share on other sites

×
×
  • Create New...