Jump to content

Archived

This topic is now archived and is closed to further replies.

SuperDindon

[Tuto] Speedtouch USB/330 avec Debian, Ubuntu, ...

Recommended Posts

Salut à tous !

Alors en fait le tuto va être très très light :chinois: parce qu'en fait toutes les infos se trouvent déjà ici, avec un guide d'installation très détaillé :

==> http://perso.wanadoo.fr/superdindon/speedtouch-ng/ <==

Il s'agit en fait d'un paquetage Debian ( le mien, pas tout à fait une coïncidence :incline: ), speedtouch-ng, qui vous posent quelques questions et se charge de la configuration avec ses gros bras

Il a été testé avec succès sur une Ubuntu Hoary, une Kubuntu, une Debian Sarge et une Debian testing fraîchement installées, et je pense que les autres distributions dérivées de Debian ( Knoppix, Kaella, etc. ) devraient supporter sans problème la paquetage

Il y a une différence majeure entre mon paquet et la très grande majorité des autres méthodes de configuration qu'on trouve encore sur le Web, c'est que mon paquetage tire bien plus parti des derniers noyaux ( 2.6.10 et plus ) qui peuvent charger eux-mêmes le firmware ( au lieu de passer par modem_run )

N'hésitez pas à poster des feedbacks, recommandations, demandes d'aide sur le topic, ça permettra de faire connaître le paquetage aux futurs nouveaux-venus ! :yes:

Share this post


Link to post
Share on other sites

Pour avoir passé dans le temps de nombreuses heures a installer ce **** de modem: merci pour ceux qui l'ont encore :)

Share this post


Link to post
Share on other sites

Ouai bah moi j'invisage de le changer... Desfois, il veut pas se reconnecter... Obliger de reboot parce qu'impossible de tout relancer.

Enfin, à mon avis c'est le script... ET modem_run.

Problème, j'ai une mandrake 10.1 community avec un kernel 2.6.8.1-10... Je peux trouver tes sources où ? :francais:

Share this post


Link to post
Share on other sites

heu le paquetage ne marche pas :francais: , sous Ubuntu, le fichier semble être endommagé, est ce normal??

:francais:

Share this post


Link to post
Share on other sites
Pour avoir passé dans le temps de nombreuses heures a installer ce **** de modem: merci pour ceux qui l'ont encore :)

Ils sont pas si mals que ça les Speedtouch 330 ( jamais eu de déconnection ), et ce sont pour le moment les modems USB les mieux supportés par Linux, mais c'est clair que les tutos sur le Web sont parlés dans une langue incompréhensible pour un débutant

Je peux trouver tes sources où ? langue.gif

si tu parles de la documentation que j'ai utilisé pour le paquetage, tout ou presque se trouve ici : http://www.linux-usb.org/SpeedTouch/

Share this post


Link to post
Share on other sites

Ah ce cher modem Speedtouch.... j'ai été obligé de le changer contre un Sagem avec un copain windowsien.... je sais pas combien de page de tuto j'ai imprimé pour essayer de l'installer.... mais bon c'était pour Mandrake 10.0, et à présent je suis sous Kubuntu...

Donc bonne chance à ceux qui ont encore ce modem, c'est sympa d'avoir fait un topic pour les aider SuperDindon.

Share this post


Link to post
Share on other sites
euh non, le format du fichier semble être non-reconnu :transpi:

sachant que je viens d'installer Ubuntu.

et c'est à dire quoi vérifier la signature :roule:?? pour le fichier que j'ai, c'est un .deb

:craint:

ah ok tu veux dire lorsque tu essaies de l'ouvrir sous Gnome ?

Ubuntu ne fournit pas d'installeur graphique pour les .deb, il faut que tu l'installes via la console avec :

$ sudo dpkg -i speedtouch-ng_1.0-4_all.deb

mais tout ça c'est déjà dit dans le guide d'installation de la page, lis-le avant tout :p

Share this post


Link to post
Share on other sites

toute façon j'aurai rien pigé packe c'est mon deuxième jour avec Linux, donc... :gne:

mais bon, on apprend petit à petit :byebye:

bon je vais voir tout ça.

:chinois:

Share this post


Link to post
Share on other sites
bah upgrade ta distrib ca seraplus simple non?

Pour le noyau oui, mais n'empêche que je doute d'une compatibilité avec le package .deb

@SuperDindon, non les codes sources. :chinois:

Share this post


Link to post
Share on other sites
toute façon j'aurai rien pigé packe c'est mon deuxième jour avec Linux, donc... :dd:

mais bon, on apprend petit à petit :gne:

bon je vais voir tout ça.

:chinois:

dans ce cas mon guide est taillé pour toi :byebye:

Share this post


Link to post
Share on other sites
Pour le noyau oui, mais n'empêche que je doute d'une compatibilité avec le package .deb

@SuperDindon, non les codes sources. :chinois:

pas un seul morceau d'éxecutable dans mon paquetage, en fait depuis les 2.6.10 le noyau et hotplug peuvent se passer de modem_run et cie, c'est beaucoup plus rapide et propre

Share this post


Link to post
Share on other sites

Ah je viens de les trouver, désolé. :chinois:

Il serait possible de mettre le lien plus en évidance stp ? :]

Share this post


Link to post
Share on other sites

même après avoir éxecuter la commande, rien ne se passe :D

j'ai téléchargé l'image d'installation très récessement, donc je crois que le noyau n'est pas aussi vieux que ça.

j'avoue que je suis un peu perdu, surtout que je dois redémarrer à chaque fois pour démarrer sous Ubuntu, et le refaire sous windows quand ça marche pas.

:p

Share this post


Link to post
Share on other sites
même après avoir éxecuter la commande, rien ne se passe :D

j'ai téléchargé l'image d'installation très récessement, donc je crois que le noyau n'est pas aussi vieux que ça.

j'avoue que je suis un peu perdu, surtout que je dois redémarrer à chaque fois pour démarrer sous Ubuntu, et le refaire sous windows quand ça marche pas.

:p

tu as quoi comme message en lançant la commande ?

Share this post


Link to post
Share on other sites

hmm c'est juste pas possible :D

m'enfin bon dans ce cas lances alors un terminal super-utilisateur ( depuis Applications/Outils Système ) et une fois dedans tapes cette commande :

dpkg -i speedtouch-ngTAB

( TAB ça complète le nom du fichier à ta place,

et il faut que speedtouch-ng_1.0-4_all.deb soit le répertoire courant, tu peux vérifier avec la commande "ls" )

suis le guide d'install aussi, ça te permettra peutêtre de mieux comprendre la manip

bon tout ça ça s'arrangera quand Debian et Ubuntu se décideront à inclure un installeur graphique :p

Share this post


Link to post
Share on other sites
Ah je viens de les trouver, désolé. :cartonrouge:

Il serait possible de mettre le lien plus en évidance stp ? :]

euh le code source ? :cartonrouge:

mon paquetage n'utilise aucun exécutable, sauf peut-être si tu parles de firmware-extractor ??

Share this post


Link to post
Share on other sites

tjs rien!!!

sachant que le fichier se trouve sur mon bureau.

sinon y a-t-il un autre fichier d'extension .tar.gz ??

ou bien un autre fichier installable graphiquement.

merci

:D

Share this post


Link to post
Share on other sites

mais euh rien c a dire ? rien du tout ? pas de message d'erreur ? le néant ?

bon je vais te faire quelques screens qui montrent pas-à-pas ce qu'il faut faire, mais quand même, c'est pas si compliqué :D

Share this post


Link to post
Share on other sites

installation-step-1.png

installation-step-2.png

là c'est possible qu'il te demande ton mot de passe et non celui de root, je crois que c'est comme ça que ça se passe pour les Ubuntus

installation-step-3.png

ils te reste plus qu'à répondre aux questions :

installation-step-4.png

vrai que c'est sans doute plus clair comme ça, je les ajouterai surement sur la page :D

Share this post


Link to post
Share on other sites

Bonjour,

j'ai suivi la méthode speedtouch-ng sur une MEPIS 3.3.1 mais mon modem ne fonctionne pas

Au démarrage, j'ai les lignes suivantes:

ADSL line is up (608 kbS down | 160 kbs up)

setting up networking: done

mais ensuite:

configuring networking interfaces: operation failed.

J'ai l'impression en fait que le module PPPOATM est absent...

Y a-t-il une solution ?

Merci !

Share this post


Link to post
Share on other sites
Bonjour,

j'ai suivi la méthode speedtouch-ng sur une MEPIS 3.3.1 mais mon modem ne fonctionne pas

Au démarrage, j'ai les lignes suivantes:

ADSL line is up (608 kbS down | 160 kbs up)

setting up networking: done

mais ensuite:

configuring networking interfaces: operation failed.

J'ai l'impression en fait que le module PPPOATM est absent...

Y a-t-il une solution ?

Merci !

Mmm alors d'abord je suis pas vraiment un crack de MEPIS, en fait je ne connais quasiment rien de cette distrib et tu es certainement le premier à tester mon paquetage dessus :arrow:

D'après les lignes que tu as quotés, le firmware est bien chargé et le modem synchronisé, reste plus que la connection PPP

Pour te donner la réponse il va falloir glaner quelques infos, mais au lieu de te poser des dizaines de questions sur ta config et te demander de taper autant de commandes, lances plutôt ce script ( avec sh speedtouch-diag ):

http://vds36626.nfrance.com/~superdindon/s...speedtouch-diag

il va générer un fichier contenant plein d'infos sur ton système, envoies le moi par mail et je pourrai surement te donner la solution dans mon prochain post

en ce qui concerne le module PPPoATM, il est normalement chargé au démarrage, tu peux vérifier avec :

lsmod | grep pppoatm

et sinon vérifies aussi tes identifiants dans /etc/ppp/chap-secrets

si tu veux en esssayer d'autres d'ailleurs lances cette commande en tant que root :

dpkg-reconfigure speedtouch-ng

m'enfin ton problème ne doit pas être bien compliqué, il ne reste certainement ps grand chose à faire pour te connecter :arrow:

Share this post


Link to post
Share on other sites

×
×
  • Create New...