Jump to content

Problème(s) avec Clé USB/Appareil Photo Numérique


Recommended Posts

Bonjour,

J'ai un appareil photo numérique, qui se détecte comme une clé usb.

Mais aussi, une clé usb (une vraie !)

Depuis quelques jours,

- Les périphériques USB ne sont pas toujours détectés (même en redémarrant !)

- Quand ils sont détectés, soit j'arrive dans un dossier vide (alors qu'il y a des données), soit 30secondes après ca plante.

Que faire ?

Link to post
Share on other sites
quelle est donc ta distrib ? ton wm (kde/gnme/autre) ?

si tu pouvais poster la fin de ton dmesg quand tu plug une clké, ça serait plus intéressant ;)

Ma distribution c'est la Mandriva Limited Edition 2005 (quel nom !)

Je suis sous KDE.

Quand je met mon Numérique (= clé usb), le résultat du dmesg ici

Link to post
Share on other sites

Salut

Normalement tu doit voir apparaitre des devices de type /dev/sda* ou /dev/sdb*

Sinon donne nous ton fstab .

As tu fait une mise a jour recement ?

Et donne nous le resultat d'un lsmod

merci

a+

Link to post
Share on other sites
Salut

Normalement tu doit voir apparaitre des devices de type /dev/sda* ou /dev/sdb*

Sinon donne nous ton fstab .

As tu fait une mise a jour recement ?

Et donne nous le resultat d'un lsmod

merci

a+

Alors, j'ai un /dev/sda et un sda1.

Tous les deux sont impossible à lire en utilisateur (droits)

Voila le fstab :

# This file is edited by fstab-sync - see 'man fstab-sync' for details
/dev/hda1 / ext3 defaults 1 1
/dev/hda6 /home ext3 defaults 1 2
/dev/hdc /mnt/cdrom iso9660 user,iocharset=iso8859-15,noauto,ro,exec 0 0
none /mnt/floppy supermount dev=/dev/fd0,fs=ext2:vfat,--,umask=0,iocharset=iso8859-15,sync,codepage=850 0 0
none /proc proc defaults 0 0
/dev/hda5 swap swap defaults 0 0
tmpfs /dev/shm tmpfs defaults 0 0

Et le résultat du lsmod :

Module                  Size  Used by
ppp_deflate             4800  1
zlib_deflate           22392  1 ppp_deflate
bsd_comp                5216  0
floppy                 54736  0
nls_iso8859-15          4288  0
nls_cp850               4544  0
vfat                   11200  0
fat                    35964  1 vfat
usb-storage            71168  0
ipt_limit               1760  2
raw                     6720  1
fglrx                 238908  7
md5                     3648  1
ipv6                  232320  21
rfcomm                 33692  0
l2cap                  20644  5 rfcomm
bluetooth              41380  4 rfcomm,l2cap
snd-seq-dummy           2596  0
snd-seq-oss            31584  0
snd-seq-midi-event      6208  1 snd-seq-oss
snd-seq                47472  5 snd-seq-dummy,snd-seq-oss,snd-seq-midi-event
snd-seq-device          6796  3 snd-seq-dummy,snd-seq-oss,snd-seq
snd-pcm-oss            49056  1
snd-mixer-oss          17248  2 snd-pcm-oss
snd-intel8x0           29216  2
snd-ac97-codec         75256  1 snd-intel8x0
snd-pcm                80776  3 snd-pcm-oss,snd-intel8x0,snd-ac97-codec
snd-timer              20324  2 snd-seq,snd-pcm
snd-page-alloc          7588  2 snd-intel8x0,snd-pcm
snd                    46980  9 snd-seq-oss,snd-seq,snd-seq-device,snd-pcm-oss,snd-mixer-oss,snd-intel8x0,snd-ac97-codec,snd-pcm,snd-timer
soundcore               7104  3 snd
lp                      9864  0
parport_pc             31652  1
parport                31624  2 lp,parport_pc
ipt_TOS                 1888  12
ipt_REJECT              5600  0
ipt_pkttype             1248  0
ipt_LOG                 6208  1
ipt_state               1376  1
ipt_multiport           2144  0
ipt_conntrack           1984  0
iptable_mangle          2080  1
ip_nat_irc              1568  0
ip_nat_tftp             1280  0
ip_nat_ftp              2272  0
iptable_nat            19068  3 ip_nat_irc,ip_nat_tftp,ip_nat_ftp
ip_conntrack_irc       70384  1 ip_nat_irc
ip_conntrack_tftp       3056  1 ip_nat_tftp
ip_conntrack_ftp       71344  1 ip_nat_ftp
ip_conntrack           37400  9 ipt_state,ipt_conntrack,ip_nat_irc,ip_nat_tftp,ip_nat_ftp,iptable_nat,ip_conntrack_irc,ip_conntrack_tftp,ip_conntrack_ftp
iptable_filter          2144  1
ip_tables              18176  11 ipt_limit,ipt_TOS,ipt_REJECT,ipt_pkttype,ipt_LOG,ipt_state,ipt_multiport,ipt_conntrack,iptable_mangle,iptable_nat,iptable_filter
ppp_async               9088  1
ppp_generic            24692  7 ppp_deflate,bsd_comp,ppp_async
slhc                    6176  1 ppp_generic
crc-ccitt               1664  1 ppp_async
af_packet              16232  2
eth1394                17160  0
tulip                  47840  0
forcedeth              16096  0
ide-cd                 36772  0
ohci1394               31076  0
ieee1394              292152  2 eth1394,ohci1394
loop                   13544  0
supermount             32660  1
amd64-agp               9800  1
agpgart                28264  2 fglrx,amd64-agp
cx88-blackbird         12420  0
cx8802                  7108  1 cx88-blackbird
firmware_class          7360  1 cx88-blackbird
cx88xx                 43284  2 cx88-blackbird,cx8802
i2c-algo-bit            8392  1 cx88xx
video-buf              16900  3 cx88-blackbird,cx8802,cx88xx
i2c-core               19028  2 cx88xx,i2c-algo-bit
btcx-risc               3848  2 cx8802,cx88xx
videodev                7264  2 cx88-blackbird,cx88xx
sd_mod                 15920  0
sata_nv                 5956  0
libata                 41572  1 sata_nv
scsi_mod              115784  3 usb-storage,sd_mod,libata
ehci-hcd               28648  0
ohci-hcd               19112  0
usbcore               106008  4 usb-storage,ehci-hcd,ohci-hcd
ext3                  123304  2
jbd                    48344  1 ext3

Je n'ai pas (encore) fait de mise à jour !

Link to post
Share on other sites
Quand je met mon Numérique (= clé usb), le résultat du dmesg ici

impossible d'en tirer quoi que ce soit avec tous ces logs de ppp

essaye de poster la sortie de

 $ grep -vi "ppp" /var/log/messages | tail -n 100

(changer le fichier si le log de syslog est à un autre endroit, mai à priori c'est ça)

Link to post
Share on other sites

Je pense que ce dmesg vous en dira plus :

usb 1-3: new full speed USB device using ohci_hcd and address 2
Initializing USB Mass Storage driver...
scsi4 : SCSI emulation for USB Mass Storage devices
usbcore: registered new driver usb-storage
USB Mass Storage support registered.
usb-storage: device found at 2
usb-storage: waiting for device to settle before scanning
 Vendor: Sony      Model: Sony DSC          Rev: 4.50
 Type:   Direct-Access                      ANSI SCSI revision: 00
SCSI device sdb: 249856 512-byte hdwr sectors (128 MB)
sdb: test WP failed, assume Write Enabled
sdb: assuming drive cache: write through
SCSI device sdb: 249856 512-byte hdwr sectors (128 MB)
sdb: test WP failed, assume Write Enabled
sdb: assuming drive cache: write through
/dev/scsi/host4/bus0/target0/lun0: p1
Attached scsi removable disk sdb at scsi4, channel 0, id 0, lun 0
usb-storage: device scan complete

En ce moment, l'appareil photo est bien détecté (/mnt/removable). Cependant les sous dossiers sont vides, alors qu'il y a des fichiers !

Edit : Quand je veux démonter l'appareil photo num, il me met périphérique occupé.

Que faire ?

Link to post
Share on other sites
Je pense que ce dmesg vous en dira plus :

usb 1-3: new full speed USB device using ohci_hcd and address 2
Initializing USB Mass Storage driver...
scsi4 : SCSI emulation for USB Mass Storage devices
usbcore: registered new driver usb-storage
USB Mass Storage support registered.
usb-storage: device found at 2
usb-storage: waiting for device to settle before scanning
 Vendor: Sony      Model: Sony DSC          Rev: 4.50
 Type:   Direct-Access                      ANSI SCSI revision: 00
SCSI device sdb: 249856 512-byte hdwr sectors (128 MB)
sdb: test WP failed, assume Write Enabled
sdb: assuming drive cache: write through
SCSI device sdb: 249856 512-byte hdwr sectors (128 MB)
sdb: test WP failed, assume Write Enabled
sdb: assuming drive cache: write through
/dev/scsi/host4/bus0/target0/lun0: p1
Attached scsi removable disk sdb at scsi4, channel 0, id 0, lun 0
usb-storage: device scan complete

moi ça donne plutôt ça :

usb 1-5: new high speed USB device using ehci_hcd and address 10
scsi7 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 10
usb-storage: waiting for device to settle before scanning
 Vendor:           Model: USB DISK Pro      Rev: 1.13
 Type:   Direct-Access                      ANSI SCSI revision: 00
SCSI device sdb: 250880 512-byte hdwr sectors (128 MB)
sdb: Write Protect is off
sdb: Mode Sense: 03 00 00 00
sdb: assuming drive cache: write through
SCSI device sdb: 250880 512-byte hdwr sectors (128 MB)
sdb: Write Protect is off
sdb: Mode Sense: 03 00 00 00
sdb: assuming drive cache: write through
sdb: sdb1
Attached scsi removable disk sdb at scsi7, channel 0, id 0, lun 0
Attached scsi generic sg1 at scsi7, channel 0, id 0, lun 0,  type 0
usb-storage: device scan complete

Link to post
Share on other sites
Quelle distribution utilises-tu ??

Gentoo, mais je ne pense pas que la différence vienne de la distribution, mais plutôt du noyau lui-même.

C'est vrai qu'il y a des différences. D'ù cela eut-il venir ?

Du noyau (sa configuration notamment).

Tu peux déjà essayer de mettre à jour le noyau mandrake. Et si ça ne suffit pas, en configurer/compiler un toi-même.

Link to post
Share on other sites
Gentoo, mais je ne pense pas que la différence vienne de la distribution, mais plutôt du noyau lui-même.

Du noyau (sa configuration notamment).

Tu peux déjà essayer de mettre à jour le noyau mandrake. Et si ça ne suffit pas, en configurer/compiler un toi-même.

Je suis débutant et je ne sais pas comment mettre à jour le noyau :francais:

Edit : Je viens de trouver comment mettre à jour le noyau : http://lea-linux.org/trucs/item.30.html

Cependant, je ne sais pas où trouver les sources !!!!

Link to post
Share on other sites
Essaye déjà en utilisant le gestionnaire de paquets de ta distribution

Ca me met que Tous les paquetages sont déjà installés

Juste une question : Quelle est la commande pour savoir quelle est la version de mon noyau ?

Quelle est la dernière version (stable) du noyau ?

Link to post
Share on other sites

à mon avis ça m'étonerais que tu arrive à résoudre plus de problemes qu'à en aporter en te lançant direct dans un changement de noyau... :byebye:

tu as quoi comme fichier relatifs à /dev/sdb ?

/dev/sdb

/dev/sdb1

/dev/sdb2

...

j'usqu'où ?

tu peux essayer de la monter à la main : mount -t vfat /dev/sdb /mnt/removable

(puis avec sdb1 si ça ne marche pas. ça vaut pas trop le coup d'aller plus loin que le 1)

essaye aussi avec -t fat et -t auto :roll:

et si ça marche, tu n'as plus qu'a rajouter la ligne supermount correspondante dans ton fstab :yes:

Link to post
Share on other sites

tu veux dire, ça a marché ?

tu as tapé la commande mount, et ça a marché ?

ensuite, tu as démonté le périphérique sans le démonter, et ça n'a plus marché...

umount -l /mnt/removable pour se sortir de la situation :fumer:

si ça marche à la main, suffit d'ajouter la ligne dans le fstab

Link to post
Share on other sites
tu veux dire, ça a marché ?

tu as tapé la commande mount, et ça a marché ?

ensuite, tu as démonté le périphérique sans le démonter, et ça n'a plus marché...

umount -l /mnt/removable pour se sortir de la situation ;)

si ça marche à la main, suffit d'ajouter la ligne dans le fstab

Je n'ai tapé aucune commande et ca a marcheé(ca arrive aléatoirement !)

En enlevant de l'usb, le dmesg met que :

usb 1-3: USB disconnect, address 2

Une fois remis (dans l'usb), rien ! :fumer:

Est-ce qu'il existe une comande pour re-scanner les ports usb ??

Link to post
Share on other sites
à mon avis ça m'étonerais que tu arrive à résoudre plus de problemes qu'à en aporter en te lançant direct dans un changement de noyau... ;)

tu as quoi comme fichier relatifs à /dev/sdb ?

/dev/sdb

/dev/sdb1

/dev/sdb2

...

j'usqu'où ?

tu peux essayer de la monter à la main : mount -t vfat /dev/sdb /mnt/removable

(puis avec sdb1 si ça ne marche pas. ça vaut pas trop le coup d'aller plus loin que le 1)

essaye aussi avec -t fat et -t auto :mdr:

et si ça marche, tu n'as plus qu'a rajouter la ligne supermount correspondante dans ton fstab :D

Alors, quand je remet l'appreil photo, le dmesg n'inscrit rien !!! (commme si je n'avais rien branché).

Après avoir remi l'appareil, j'ai uniquement sda et sda1 (je pense que c'est les deux partitions du DD).

Quand je les "monte", ce message s'affiche :

mount: type de sys. de fichiers erroné, option erronée, super bloc erroné sur /dev/sda,
      ou trop de systèmes de fichiers montés

Link to post
Share on other sites
impec, on progresse ;)

mount -t vfat /dev/sda1 /mnt/removable

ça devrait passer

Le même message s'affiche :

mount: type de sys. de fichiers erroné, option erronée, super bloc erroné sur /dev/sda1,
      ou trop de systèmes de fichiers montés

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...