Jump to content

Archived

This topic is now archived and is closed to further replies.

leon47

compil noyau et pb eth0

Recommended Posts

bonjour a tous,

je viens de compiler mon noyau en 2.6.11 pour une débian, j'ai suivi le tuto du forum (+1 -rem- pour ce bô tuto ^^ :D)

mais en bootant dessus, ma carte ethernet ne semble pas marcher :

/var/log/syslog :

May 12 15:38:25 servweb kernel: eth0: link up, 100Mbps, full-duplex, lpa 0xC1E1

May 12 15:38:43 servweb kernel: NETDEV WATCHDOG: eth0: transmit timed out

May 12 15:38:43 servweb kernel: eth0: Transmit timed out, status 0003, PHY status 782d, resetting...

May 12 15:38:43 servweb kernel: eth0: link up, 100Mbps, full-duplex, lpa 0xC1E1

May 12 15:38:59 servweb kernel: NETDEV WATCHDOG: eth0: transmit timed out

May 12 15:38:59 servweb kernel: eth0: Transmit timed out, status 0003, PHY status 782d, resetting...

pour ceux qui demanderont, ca marchait bien avant, debian sarge, noyau 2.6.8-2

voici le résultat du lspci :

0000:01:00.0 Ethernet controller: VIA Technologies, Inc. VT86C100A [Rhine] (rev 06)

la carte est détectée quand je fait églaement un ifconfig eth0, bonne @ip et tout ce qui va avec, mais incapable d'envoyer des données sur le rézo.

Je vous joint mon .config (c'est pour un serveur web et ftp, c'est pour ca qu'il y a certaines options manquantes :bravo: )

#

# Automatically generated make config: don't edit

# Linux kernel version: 2.6.11

# Wed May 11 09:04:43 2005

#

CONFIG_X86=y

CONFIG_MMU=y

CONFIG_UID16=y

CONFIG_GENERIC_ISA_DMA=y

CONFIG_GENERIC_IOMAP=y

#

# Code maturity level options

#

CONFIG_EXPERIMENTAL=y

# CONFIG_CLEAN_COMPILE is not set

CONFIG_BROKEN=y

CONFIG_BROKEN_ON_SMP=y

#

# General setup

#

CONFIG_LOCALVERSION=""

CONFIG_SWAP=y

CONFIG_SYSVIPC=y

CONFIG_POSIX_MQUEUE=y

CONFIG_BSD_PROCESS_ACCT=y

CONFIG_BSD_PROCESS_ACCT_V3=y

CONFIG_SYSCTL=y

# CONFIG_AUDIT is not set

CONFIG_LOG_BUF_SHIFT=14

CONFIG_HOTPLUG=y

CONFIG_KOBJECT_UEVENT=y

CONFIG_IKCONFIG=y

# CONFIG_IKCONFIG_PROC is not set

# CONFIG_EMBEDDED is not set

CONFIG_KALLSYMS=y

# CONFIG_KALLSYMS_EXTRA_PASS is not set

CONFIG_FUTEX=y

CONFIG_EPOLL=y

# CONFIG_CC_OPTIMIZE_FOR_SIZE is not set

CONFIG_SHMEM=y

CONFIG_CC_ALIGN_FUNCTIONS=0

CONFIG_CC_ALIGN_LABELS=0

CONFIG_CC_ALIGN_LOOPS=0

CONFIG_CC_ALIGN_JUMPS=0

# CONFIG_TINY_SHMEM is not set

#

# Loadable module support

#

CONFIG_MODULES=y

CONFIG_MODULE_UNLOAD=y

CONFIG_MODULE_FORCE_UNLOAD=y

CONFIG_OBSOLETE_MODPARM=y

# CONFIG_MODVERSIONS is not set

# CONFIG_MODULE_SRCVERSION_ALL is not set

CONFIG_KMOD=y

#

# Processor type and features

#

CONFIG_X86_PC=y

# CONFIG_X86_ELAN is not set

# CONFIG_X86_VOYAGER is not set

# CONFIG_X86_NUMAQ is not set

# CONFIG_X86_SUMMIT is not set

# CONFIG_X86_BIGSMP is not set

# CONFIG_X86_VISWS is not set

# CONFIG_X86_GENERICARCH is not set

# CONFIG_X86_ES7000 is not set

# CONFIG_M386 is not set

# CONFIG_M486 is not set

# CONFIG_M586 is not set

# CONFIG_M586TSC is not set

# CONFIG_M586MMX is not set

# CONFIG_M686 is not set

# CONFIG_MPENTIUMII is not set

# CONFIG_MPENTIUMIII is not set

# CONFIG_MPENTIUMM is not set

CONFIG_MPENTIUM4=y

# CONFIG_MK6 is not set

# CONFIG_MK7 is not set

# CONFIG_MK8 is not set

# CONFIG_MCRUSOE is not set

# CONFIG_MEFFICEON is not set

# CONFIG_MWINCHIPC6 is not set

# CONFIG_MWINCHIP2 is not set

# CONFIG_MWINCHIP3D is not set

# CONFIG_MCYRIXIII is not set

# CONFIG_MVIAC3_2 is not set

# CONFIG_X86_GENERIC is not set

# CONFIG_X86_EMU486 is not set

CONFIG_X86_CMPXCHG=y

CONFIG_X86_XADD=y

CONFIG_X86_L1_CACHE_SHIFT=7

CONFIG_RWSEM_XCHGADD_ALGORITHM=y

CONFIG_GENERIC_CALIBRATE_DELAY=y

CONFIG_X86_WP_WORKS_OK=y

CONFIG_X86_INVLPG=y

CONFIG_X86_BSWAP=y

CONFIG_X86_POPAD_OK=y

CONFIG_X86_GOOD_APIC=y

CONFIG_X86_INTEL_USERCOPY=y

CONFIG_X86_USE_PPRO_CHECKSUM=y

CONFIG_HPET_TIMER=y

# CONFIG_SMP is not set

# CONFIG_PREEMPT is not set

CONFIG_X86_UP_APIC=y

CONFIG_X86_UP_IOAPIC=y

CONFIG_X86_LOCAL_APIC=y

CONFIG_X86_IO_APIC=y

CONFIG_X86_TSC=y

CONFIG_X86_MCE=y

CONFIG_X86_MCE_NONFATAL=y

CONFIG_X86_MCE_P4THERMAL=y

# CONFIG_TOSHIBA is not set

# CONFIG_I8K is not set

# CONFIG_MICROCODE is not set

# CONFIG_X86_MSR is not set

# CONFIG_X86_CPUID is not set

#

# Firmware Drivers

#

# CONFIG_EDD is not set

CONFIG_NOHIGHMEM=y

# CONFIG_HIGHMEM4G is not set

# CONFIG_HIGHMEM64G is not set

# CONFIG_MATH_EMULATION is not set

CONFIG_MTRR=y

CONFIG_REGPARM=y

#

# Power management options (ACPI, APM)

#

# CONFIG_PM is not set

#

# ACPI (Advanced Configuration and Power Interface) Support

#

# CONFIG_ACPI is not set

#

# CPU Frequency scaling

#

# CONFIG_CPU_FREQ is not set

#

# Bus options (PCI, PCMCIA, EISA, MCA, ISA)

#

CONFIG_PCI=y

CONFIG_PCI_GOBIOS=y

# CONFIG_PCI_GOMMCONFIG is not set

# CONFIG_PCI_GODIRECT is not set

# CONFIG_PCI_GOANY is not set

CONFIG_PCI_BIOS=y

# CONFIG_PCI_MSI is not set

CONFIG_PCI_LEGACY_PROC=y

CONFIG_PCI_NAMES=y

# CONFIG_ISA is not set

# CONFIG_MCA is not set

# CONFIG_SCx200 is not set

#

# PCCARD (PCMCIA/CardBus) support

#

# CONFIG_PCCARD is not set

#

# PC-card bridges

#

#

# PCI Hotplug Support

#

# CONFIG_HOTPLUG_PCI is not set

#

# Executable file formats

#

CONFIG_BINFMT_ELF=y

# CONFIG_BINFMT_AOUT is not set

CONFIG_BINFMT_MISC=m

#

# Device Drivers

#

#

# Generic Driver Options

#

# CONFIG_STANDALONE is not set

CONFIG_PREVENT_FIRMWARE_BUILD=y

CONFIG_FW_LOADER=m

#

# Memory Technology Devices (MTD)

#

# CONFIG_MTD is not set

#

# Parallel port support

#

# CONFIG_PARPORT is not set

#

# Plug and Play support

#

#

# Block devices

#

# CONFIG_BLK_DEV_FD is not set

# CONFIG_BLK_CPQ_DA is not set

# CONFIG_BLK_CPQ_CISS_DA is not set

# CONFIG_BLK_DEV_DAC960 is not set

# CONFIG_BLK_DEV_UMEM is not set

# CONFIG_BLK_DEV_COW_COMMON is not set

# CONFIG_BLK_DEV_LOOP is not set

# CONFIG_BLK_DEV_NBD is not set

# CONFIG_BLK_DEV_SX8 is not set

# CONFIG_BLK_DEV_RAM is not set

CONFIG_BLK_DEV_RAM_COUNT=16

CONFIG_INITRAMFS_SOURCE=""

# CONFIG_LBD is not set

# CONFIG_CDROM_PKTCDVD is not set

#

# IO Schedulers

#

CONFIG_IOSCHED_NOOP=y

CONFIG_IOSCHED_AS=m

CONFIG_IOSCHED_DEADLINE=m

CONFIG_IOSCHED_CFQ=m

# CONFIG_ATA_OVER_ETH is not set

#

# ATA/ATAPI/MFM/RLL support

#

CONFIG_IDE=m

CONFIG_BLK_DEV_IDE=m

#

# Please see Documentation/ide.txt for help/info on IDE drives

#

# CONFIG_BLK_DEV_IDE_SATA is not set

# CONFIG_BLK_DEV_HD_IDE is not set

CONFIG_BLK_DEV_IDEDISK=m

# CONFIG_IDEDISK_MULTI_MODE is not set

CONFIG_BLK_DEV_IDECD=m

# CONFIG_BLK_DEV_IDETAPE is not set

# CONFIG_BLK_DEV_IDEFLOPPY is not set

# CONFIG_BLK_DEV_IDESCSI is not set

# CONFIG_IDE_TASK_IOCTL is not set

#

# IDE chipset support/bugfixes

#

# CONFIG_IDE_GENERIC is not set

# CONFIG_BLK_DEV_CMD640 is not set

CONFIG_BLK_DEV_IDEPCI=y

# CONFIG_IDEPCI_SHARE_IRQ is not set

# CONFIG_BLK_DEV_OFFBOARD is not set

CONFIG_BLK_DEV_GENERIC=m

# CONFIG_BLK_DEV_OPTI621 is not set

# CONFIG_BLK_DEV_RZ1000 is not set

CONFIG_BLK_DEV_IDEDMA_PCI=y

# CONFIG_BLK_DEV_IDEDMA_FORCED is not set

CONFIG_IDEDMA_PCI_AUTO=y

CONFIG_IDEDMA_ONLYDISK=y

# CONFIG_BLK_DEV_AEC62XX is not set

# CONFIG_BLK_DEV_ALI15X3 is not set

# CONFIG_BLK_DEV_AMD74XX is not set

# CONFIG_BLK_DEV_ATIIXP is not set

# CONFIG_BLK_DEV_CMD64X is not set

# CONFIG_BLK_DEV_TRIFLEX is not set

# CONFIG_BLK_DEV_CY82C693 is not set

# CONFIG_BLK_DEV_CS5520 is not set

# CONFIG_BLK_DEV_CS5530 is not set

# CONFIG_BLK_DEV_HPT34X is not set

# CONFIG_BLK_DEV_HPT366 is not set

# CONFIG_BLK_DEV_SC1200 is not set

# CONFIG_BLK_DEV_PIIX is not set

# CONFIG_BLK_DEV_NS87415 is not set

# CONFIG_BLK_DEV_PDC202XX_OLD is not set

# CONFIG_BLK_DEV_PDC202XX_NEW is not set

# CONFIG_BLK_DEV_SVWKS is not set

# CONFIG_BLK_DEV_SIIMAGE is not set

# CONFIG_BLK_DEV_SIS5513 is not set

# CONFIG_BLK_DEV_SLC90E66 is not set

# CONFIG_BLK_DEV_TRM290 is not set

# CONFIG_BLK_DEV_VIA82CXXX is not set

# CONFIG_IDE_ARM is not set

CONFIG_BLK_DEV_IDEDMA=y

# CONFIG_IDEDMA_IVB is not set

CONFIG_IDEDMA_AUTO=y

# CONFIG_BLK_DEV_HD is not set

#

# SCSI device support

#

CONFIG_SCSI=y

CONFIG_SCSI_PROC_FS=y

#

# SCSI support type (disk, tape, CD-ROM)

#

CONFIG_BLK_DEV_SD=y

# CONFIG_CHR_DEV_ST is not set

# CONFIG_CHR_DEV_OSST is not set

# CONFIG_BLK_DEV_SR is not set

# CONFIG_CHR_DEV_SG is not set

# CONFIG_CHR_DEV_SCH is not set

#

# Some SCSI devices (e.g. CD jukebox) support multiple LUNs

#

# CONFIG_SCSI_MULTI_LUN is not set

# CONFIG_SCSI_CONSTANTS is not set

# CONFIG_SCSI_LOGGING is not set

#

# SCSI Transport Attributes

#

CONFIG_SCSI_SPI_ATTRS=y

# CONFIG_SCSI_FC_ATTRS is not set

# CONFIG_SCSI_ISCSI_ATTRS is not set

#

# SCSI low-level drivers

#

CONFIG_BLK_DEV_3W_XXXX_RAID=y

# CONFIG_SCSI_3W_9XXX is not set

# CONFIG_SCSI_ACARD is not set

# CONFIG_SCSI_AACRAID is not set

# CONFIG_SCSI_AIC7XXX is not set

# CONFIG_SCSI_AIC7XXX_OLD is not set

# CONFIG_SCSI_AIC79XX is not set

# CONFIG_SCSI_DPT_I2O is not set

# CONFIG_SCSI_ADVANSYS is not set

# CONFIG_MEGARAID_NEWGEN is not set

# CONFIG_MEGARAID_LEGACY is not set

# CONFIG_SCSI_SATA is not set

# CONFIG_SCSI_BUSLOGIC is not set

# CONFIG_SCSI_CPQFCTS is not set

# CONFIG_SCSI_DMX3191D is not set

# CONFIG_SCSI_EATA is not set

# CONFIG_SCSI_EATA_PIO is not set

# CONFIG_SCSI_FUTURE_DOMAIN is not set

# CONFIG_SCSI_GDTH is not set

# CONFIG_SCSI_IPS is not set

# CONFIG_SCSI_INITIO is not set

# CONFIG_SCSI_INIA100 is not set

# CONFIG_SCSI_SYM53C8XX_2 is not set

# CONFIG_SCSI_IPR is not set

# CONFIG_SCSI_PCI2000 is not set

# CONFIG_SCSI_PCI2220I is not set

# CONFIG_SCSI_QLOGIC_ISP is not set

# CONFIG_SCSI_QLOGIC_FC is not set

# CONFIG_SCSI_QLOGIC_1280 is not set

# CONFIG_SCSI_DC395x is not set

# CONFIG_SCSI_DC390T is not set

# CONFIG_SCSI_NSP32 is not set

# CONFIG_SCSI_DEBUG is not set

#

# Multi-device support (RAID and LVM)

#

# CONFIG_MD is not set

#

# Fusion MPT device support

#

# CONFIG_FUSION is not set

#

# IEEE 1394 (FireWire) support

#

# CONFIG_IEEE1394 is not set

#

# I2O device support

#

# CONFIG_I2O is not set

#

# Networking support

#

CONFIG_NET=y

#

# Networking options

#

CONFIG_PACKET=m

CONFIG_PACKET_MMAP=y

# CONFIG_NETLINK_DEV is not set

CONFIG_UNIX=m

CONFIG_NET_KEY=m

CONFIG_INET=y

# CONFIG_IP_MULTICAST is not set

# CONFIG_IP_ADVANCED_ROUTER is not set

# CONFIG_IP_PNP is not set

# CONFIG_NET_IPIP is not set

# CONFIG_NET_IPGRE is not set

# CONFIG_ARPD is not set

CONFIG_SYN_COOKIES=y

CONFIG_INET_AH=m

CONFIG_INET_ESP=m

CONFIG_INET_IPCOMP=m

CONFIG_INET_TUNNEL=m

# CONFIG_IP_TCPDIAG is not set

# CONFIG_IP_TCPDIAG_IPV6 is not set

#

# IP: Virtual Server Configuration

#

# CONFIG_IP_VS is not set

# CONFIG_IPV6 is not set

CONFIG_NETFILTER=y

# CONFIG_NETFILTER_DEBUG is not set

#

# IP: Netfilter Configuration

#

# CONFIG_IP_NF_CONNTRACK is not set

# CONFIG_IP_NF_CONNTRACK_MARK is not set

# CONFIG_IP_NF_QUEUE is not set

CONFIG_IP_NF_IPTABLES=m

CONFIG_IP_NF_MATCH_LIMIT=m

CONFIG_IP_NF_MATCH_IPRANGE=m

# CONFIG_IP_NF_MATCH_MAC is not set

# CONFIG_IP_NF_MATCH_PKTTYPE is not set

# CONFIG_IP_NF_MATCH_MARK is not set

CONFIG_IP_NF_MATCH_MULTIPORT=m

CONFIG_IP_NF_MATCH_TOS=m

# CONFIG_IP_NF_MATCH_RECENT is not set

# CONFIG_IP_NF_MATCH_ECN is not set

# CONFIG_IP_NF_MATCH_DSCP is not set

# CONFIG_IP_NF_MATCH_AH_ESP is not set

# CONFIG_IP_NF_MATCH_LENGTH is not set

# CONFIG_IP_NF_MATCH_TTL is not set

# CONFIG_IP_NF_MATCH_TCPMSS is not set

# CONFIG_IP_NF_MATCH_OWNER is not set

# CONFIG_IP_NF_MATCH_ADDRTYPE is not set

# CONFIG_IP_NF_MATCH_REALM is not set

# CONFIG_IP_NF_MATCH_SCTP is not set

# CONFIG_IP_NF_MATCH_COMMENT is not set

# CONFIG_IP_NF_MATCH_HASHLIMIT is not set

CONFIG_IP_NF_FILTER=m

# CONFIG_IP_NF_TARGET_REJECT is not set

CONFIG_IP_NF_TARGET_LOG=m

CONFIG_IP_NF_TARGET_ULOG=m

CONFIG_IP_NF_TARGET_TCPMSS=m

# CONFIG_IP_NF_MANGLE is not set

# CONFIG_IP_NF_RAW is not set

# CONFIG_IP_NF_ARPTABLES is not set

CONFIG_XFRM=y

CONFIG_XFRM_USER=m

#

# SCTP Configuration (EXPERIMENTAL)

#

# CONFIG_IP_SCTP is not set

# CONFIG_ATM is not set

# CONFIG_BRIDGE is not set

# CONFIG_VLAN_8021Q is not set

# CONFIG_DECNET is not set

# CONFIG_LLC2 is not set

# CONFIG_IPX is not set

# CONFIG_ATALK is not set

# CONFIG_X25 is not set

# CONFIG_LAPB is not set

# CONFIG_NET_DIVERT is not set

# CONFIG_ECONET is not set

# CONFIG_WAN_ROUTER is not set

#

# QoS and/or fair queueing

#

# CONFIG_NET_SCHED is not set

# CONFIG_NET_CLS_ROUTE is not set

#

# Network testing

#

# CONFIG_NET_PKTGEN is not set

# CONFIG_NETPOLL is not set

# CONFIG_NET_POLL_CONTROLLER is not set

# CONFIG_HAMRADIO is not set

# CONFIG_IRDA is not set

# CONFIG_BT is not set

CONFIG_NETDEVICES=y

# CONFIG_DUMMY is not set

# CONFIG_BONDING is not set

# CONFIG_EQUALIZER is not set

# CONFIG_TUN is not set

#

# ARCnet devices

#

# CONFIG_ARCNET is not set

#

# Ethernet (10 or 100Mbit)

#

CONFIG_NET_ETHERNET=y

CONFIG_MII=y

# CONFIG_HAPPYMEAL is not set

# CONFIG_SUNGEM is not set

# CONFIG_NET_VENDOR_3COM is not set

#

# Tulip family network device support

#

# CONFIG_NET_TULIP is not set

# CONFIG_HP100 is not set

CONFIG_NET_PCI=y

# CONFIG_PCNET32 is not set

# CONFIG_AMD8111_ETH is not set

# CONFIG_ADAPTEC_STARFIRE is not set

# CONFIG_B44 is not set

# CONFIG_FORCEDETH is not set

# CONFIG_EEPRO100 is not set

# CONFIG_E100 is not set

# CONFIG_FEALNX is not set

# CONFIG_NATSEMI is not set

# CONFIG_NE2K_PCI is not set

# CONFIG_8139CP is not set

# CONFIG_8139TOO is not set

# CONFIG_SIS900 is not set

# CONFIG_EPIC100 is not set

# CONFIG_SUNDANCE is not set

# CONFIG_TLAN is not set

CONFIG_VIA_RHINE=m

# CONFIG_VIA_RHINE_MMIO is not set

#

# Ethernet (1000 Mbit)

#

# CONFIG_DL2K is not set

# CONFIG_E1000 is not set

# CONFIG_NS83820 is not set

# CONFIG_HAMACHI is not set

# CONFIG_YELLOWFIN is not set

# CONFIG_R8169 is not set

# CONFIG_SK98LIN is not set

# CONFIG_VIA_VELOCITY is not set

#

# Ethernet (10000 Mbit)

#

# CONFIG_IXGB is not set

# CONFIG_S2IO is not set

#

# Token Ring devices

#

# CONFIG_TR is not set

#

# Wireless LAN (non-hamradio)

#

# CONFIG_NET_RADIO is not set

#

# Wan interfaces

#

# CONFIG_WAN is not set

# CONFIG_FDDI is not set

# CONFIG_HIPPI is not set

# CONFIG_PPP is not set

# CONFIG_SLIP is not set

# CONFIG_NET_FC is not set

# CONFIG_SHAPER is not set

# CONFIG_NETCONSOLE is not set

#

# ISDN subsystem

#

# CONFIG_ISDN is not set

#

# Telephony Support

#

# CONFIG_PHONE is not set

#

# Input device support

#

CONFIG_INPUT=y

#

# Userland interfaces

#

CONFIG_INPUT_MOUSEDEV=y

CONFIG_INPUT_MOUSEDEV_PSAUX=y

CONFIG_INPUT_MOUSEDEV_SCREEN_X=1024

CONFIG_INPUT_MOUSEDEV_SCREEN_Y=768

# CONFIG_INPUT_JOYDEV is not set

# CONFIG_INPUT_TSDEV is not set

CONFIG_INPUT_EVDEV=m

# CONFIG_INPUT_EVBUG is not set

#

# Input I/O drivers

#

# CONFIG_GAMEPORT is not set

CONFIG_SOUND_GAMEPORT=y

CONFIG_SERIO=y

CONFIG_SERIO_I8042=y

# CONFIG_SERIO_SERPORT is not set

# CONFIG_SERIO_CT82C710 is not set

# CONFIG_SERIO_PCIPS2 is not set

CONFIG_SERIO_LIBPS2=y

# CONFIG_SERIO_RAW is not set

#

# Input Device Drivers

#

CONFIG_INPUT_KEYBOARD=y

CONFIG_KEYBOARD_ATKBD=y

# CONFIG_KEYBOARD_SUNKBD is not set

# CONFIG_KEYBOARD_LKKBD is not set

# CONFIG_KEYBOARD_XTKBD is not set

# CONFIG_KEYBOARD_NEWTON is not set

CONFIG_INPUT_MOUSE=y

CONFIG_MOUSE_PS2=m

# CONFIG_MOUSE_SERIAL is not set

# CONFIG_MOUSE_VSXXXAA is not set

# CONFIG_INPUT_JOYSTICK is not set

# CONFIG_INPUT_TOUCHSCREEN is not set

# CONFIG_INPUT_MISC is not set

#

# Character devices

#

CONFIG_VT=y

CONFIG_VT_CONSOLE=y

CONFIG_HW_CONSOLE=y

# CONFIG_SERIAL_NONSTANDARD is not set

#

# Serial drivers

#

CONFIG_SERIAL_8250=m

CONFIG_SERIAL_8250_NR_UARTS=4

# CONFIG_SERIAL_8250_EXTENDED is not set

#

# Non-8250 serial port support

#

CONFIG_SERIAL_CORE=m

CONFIG_UNIX98_PTYS=y

CONFIG_LEGACY_PTYS=y

CONFIG_LEGACY_PTY_COUNT=256

#

# IPMI

#

# CONFIG_IPMI_HANDLER is not set

#

# Watchdog Cards

#

# CONFIG_WATCHDOG is not set

CONFIG_HW_RANDOM=m

CONFIG_NVRAM=m

CONFIG_RTC=m

# CONFIG_GEN_RTC is not set

# CONFIG_DTLK is not set

# CONFIG_R3964 is not set

# CONFIG_APPLICOM is not set

# CONFIG_SONYPI is not set

#

# Ftape, the floppy tape device driver

#

# CONFIG_FTAPE is not set

# CONFIG_AGP is not set

# CONFIG_DRM is not set

# CONFIG_MWAVE is not set

# CONFIG_RAW_DRIVER is not set

# CONFIG_HANGCHECK_TIMER is not set

#

# I2C support

#

# CONFIG_I2C is not set

#

# Dallas's 1-wire bus

#

# CONFIG_W1 is not set

#

# Misc devices

#

# CONFIG_IBM_ASM is not set

#

# Multimedia devices

#

# CONFIG_VIDEO_DEV is not set

#

# Digital Video Broadcasting Devices

#

# CONFIG_DVB is not set

#

# Graphics support

#

# CONFIG_FB is not set

CONFIG_VIDEO_SELECT=y

#

# Console display driver support

#

CONFIG_VGA_CONSOLE=y

CONFIG_DUMMY_CONSOLE=y

#

# Sound

#

# CONFIG_SOUND is not set

#

# USB support

#

# CONFIG_USB is not set

CONFIG_USB_ARCH_HAS_HCD=y

CONFIG_USB_ARCH_HAS_OHCI=y

#

# NOTE: USB_STORAGE enables SCSI, and 'SCSI disk support' may also be needed; see USB_STORAGE Help for more information

#

#

# USB Gadget Support

#

# CONFIG_USB_GADGET is not set

#

# MMC/SD Card support

#

# CONFIG_MMC is not set

#

# InfiniBand support

#

# CONFIG_INFINIBAND is not set

#

# File systems

#

# CONFIG_EXT2_FS is not set

CONFIG_EXT3_FS=y

# CONFIG_EXT3_FS_XATTR is not set

CONFIG_JBD=y

# CONFIG_JBD_DEBUG is not set

# CONFIG_REISERFS_FS is not set

# CONFIG_JFS_FS is not set

#

# XFS support

#

# CONFIG_XFS_FS is not set

# CONFIG_MINIX_FS is not set

# CONFIG_ROMFS_FS is not set

# CONFIG_QUOTA is not set

CONFIG_DNOTIFY=y

# CONFIG_AUTOFS_FS is not set

CONFIG_AUTOFS4_FS=m

#

# CD-ROM/DVD Filesystems

#

CONFIG_ISO9660_FS=m

CONFIG_JOLIET=y

# CONFIG_ZISOFS is not set

CONFIG_UDF_FS=m

CONFIG_UDF_NLS=y

#

# DOS/FAT/NT Filesystems

#

# CONFIG_MSDOS_FS is not set

# CONFIG_VFAT_FS is not set

# CONFIG_NTFS_FS is not set

#

# Pseudo filesystems

#

CONFIG_PROC_FS=y

# CONFIG_PROC_KCORE is not set

CONFIG_SYSFS=y

# CONFIG_DEVFS_FS is not set

# CONFIG_DEVPTS_FS_XATTR is not set

CONFIG_TMPFS=y

# CONFIG_TMPFS_XATTR is not set

# CONFIG_HUGETLBFS is not set

# CONFIG_HUGETLB_PAGE is not set

CONFIG_RAMFS=y

#

# Miscellaneous filesystems

#

# CONFIG_ADFS_FS is not set

# CONFIG_AFFS_FS is not set

# CONFIG_ASFS_FS is not set

# CONFIG_HFS_FS is not set

# CONFIG_HFSPLUS_FS is not set

# CONFIG_BEFS_FS is not set

# CONFIG_BFS_FS is not set

# CONFIG_EFS_FS is not set

# CONFIG_CRAMFS is not set

# CONFIG_VXFS_FS is not set

# CONFIG_HPFS_FS is not set

# CONFIG_QNX4FS_FS is not set

# CONFIG_SYSV_FS is not set

# CONFIG_UFS_FS is not set

#

# Network File Systems

#

# CONFIG_NFS_FS is not set

# CONFIG_NFSD is not set

# CONFIG_SMB_FS is not set

# CONFIG_CIFS is not set

# CONFIG_NCP_FS is not set

# CONFIG_CODA_FS is not set

# CONFIG_AFS_FS is not set

#

# Partition Types

#

# CONFIG_PARTITION_ADVANCED is not set

CONFIG_MSDOS_PARTITION=y

#

# Native Language Support

#

CONFIG_NLS=m

CONFIG_NLS_DEFAULT="iso8859-1"

CONFIG_NLS_CODEPAGE_437=m

# CONFIG_NLS_CODEPAGE_737 is not set

# CONFIG_NLS_CODEPAGE_775 is not set

CONFIG_NLS_CODEPAGE_850=m

# CONFIG_NLS_CODEPAGE_852 is not set

# CONFIG_NLS_CODEPAGE_855 is not set

# CONFIG_NLS_CODEPAGE_857 is not set

# CONFIG_NLS_CODEPAGE_860 is not set

# CONFIG_NLS_CODEPAGE_861 is not set

# CONFIG_NLS_CODEPAGE_862 is not set

# CONFIG_NLS_CODEPAGE_863 is not set

# CONFIG_NLS_CODEPAGE_864 is not set

# CONFIG_NLS_CODEPAGE_865 is not set

# CONFIG_NLS_CODEPAGE_866 is not set

# CONFIG_NLS_CODEPAGE_869 is not set

# CONFIG_NLS_CODEPAGE_936 is not set

# CONFIG_NLS_CODEPAGE_950 is not set

# CONFIG_NLS_CODEPAGE_932 is not set

# CONFIG_NLS_CODEPAGE_949 is not set

# CONFIG_NLS_CODEPAGE_874 is not set

# CONFIG_NLS_ISO8859_8 is not set

# CONFIG_NLS_CODEPAGE_1250 is not set

# CONFIG_NLS_CODEPAGE_1251 is not set

# CONFIG_NLS_ASCII is not set

CONFIG_NLS_ISO8859_1=m

# CONFIG_NLS_ISO8859_2 is not set

# CONFIG_NLS_ISO8859_3 is not set

# CONFIG_NLS_ISO8859_4 is not set

# CONFIG_NLS_ISO8859_5 is not set

# CONFIG_NLS_ISO8859_6 is not set

# CONFIG_NLS_ISO8859_7 is not set

# CONFIG_NLS_ISO8859_9 is not set

# CONFIG_NLS_ISO8859_13 is not set

# CONFIG_NLS_ISO8859_14 is not set

CONFIG_NLS_ISO8859_15=m

# CONFIG_NLS_KOI8_R is not set

# CONFIG_NLS_KOI8_U is not set

CONFIG_NLS_UTF8=m

#

# Profiling support

#

# CONFIG_PROFILING is not set

#

# Kernel hacking

#

# CONFIG_DEBUG_KERNEL is not set

CONFIG_DEBUG_BUGVERBOSE=y

# CONFIG_FRAME_POINTER is not set

CONFIG_EARLY_PRINTK=y

# CONFIG_4KSTACKS is not set

CONFIG_X86_FIND_SMP_CONFIG=y

CONFIG_X86_MPPARSE=y

#

# Security options

#

# CONFIG_KEYS is not set

# CONFIG_SECURITY is not set

#

# Cryptographic options

#

CONFIG_CRYPTO=y

CONFIG_CRYPTO_HMAC=y

# CONFIG_CRYPTO_NULL is not set

# CONFIG_CRYPTO_MD4 is not set

CONFIG_CRYPTO_MD5=m

CONFIG_CRYPTO_SHA1=m

# CONFIG_CRYPTO_SHA256 is not set

# CONFIG_CRYPTO_SHA512 is not set

# CONFIG_CRYPTO_WP512 is not set

CONFIG_CRYPTO_DES=m

# CONFIG_CRYPTO_BLOWFISH is not set

# CONFIG_CRYPTO_TWOFISH is not set

# CONFIG_CRYPTO_SERPENT is not set

# CONFIG_CRYPTO_AES_586 is not set

# CONFIG_CRYPTO_CAST5 is not set

# CONFIG_CRYPTO_CAST6 is not set

# CONFIG_CRYPTO_TEA is not set

# CONFIG_CRYPTO_ARC4 is not set

# CONFIG_CRYPTO_KHAZAD is not set

# CONFIG_CRYPTO_ANUBIS is not set

CONFIG_CRYPTO_DEFLATE=m

# CONFIG_CRYPTO_MICHAEL_MIC is not set

# CONFIG_CRYPTO_CRC32C is not set

# CONFIG_CRYPTO_TEST is not set

#

# Hardware crypto devices

#

# CONFIG_CRYPTO_DEV_PADLOCK is not set

#

# Library routines

#

# CONFIG_CRC_CCITT is not set

CONFIG_CRC32=m

CONFIG_LIBCRC32C=m

CONFIG_ZLIB_INFLATE=m

CONFIG_ZLIB_DEFLATE=m

CONFIG_GENERIC_HARDIRQS=y

CONFIG_GENERIC_IRQ_PROBE=y

CONFIG_X86_BIOS_REBOOT=y

CONFIG_PC=y

merci et :D a ceux qui se pencheront sur mon problème

Ps: juste une question subsidiaire, est-il possible de trouver les patch pour "débianiser" un kernel officiel (www.kernel.org) ?

Link to post
Share on other sites

Essaye un autre noyau (disons... 2.6.8 kernel.org) avec la même config (enfin un petit make oldconfig entre les 2 quand même)

Si ça remarche, c'est un pb noyau... et il faudra attendre un 2.6.12 ou tester les 2.6.9 et 2.6.10

Link to post
Share on other sites

mais ... j'ai peur de tester un VRAI noyau ^^

bon, c parti mon kiki, compil de 2.6.8 officiel ...

je vous tiens au courant de ce qui se passe

sinon, quelqun sait si les patchs pour débianiser un kernel officiel sont dispo ?

Link to post
Share on other sites

kernel officiel ==> kernel provenant de www.kernel.org

je cherche ces patchs car debian ne fournit aparament pas la derniere version du kernel via apt, en gros je souhaiterai prendre le dernier kernel et le patcher pour le débianiser

merci pour le nom du paquet :)

Link to post
Share on other sites

Si tu veux un 2.6.11 debian, il faut avoir unstable dans tes sources.

$ apt-cache policy kernel-source-2.6.11
kernel-source-2.6.11:
 Installé : (aucun)
 Candidat : 2.6.11-3
Table de version :
    2.6.11-3 0
       990 http://ftp.fr.debian.org unstable/main Packages

Link to post
Share on other sites

il fournit que le .3, il y a de dispo le .9

vu que le PC qui devra recevoir ce noyau est le coeur du réseau (serveur qui centralise toute la compta et les notes des élèves) je veux un truc le plus à our et sécurisé possible :oups:

je m'en vais patcher le officiel des la semaine prochaine

mercia vous

Link to post
Share on other sites

Ouais mais plus vieux :)

Sinon tu pourrais montré ton /etc/network/interfaces et ton /etc/resolv.conf Il se pourrait qu'il y ait un prob de se niveau là, on ne sait jamais. Sur ma Debian Unstable (quand j'en avais encore une), j'avais toujours les derniers kernels et ça marchait (et aussi via-rhine)

Link to post
Share on other sites

je vous tien au courant des que j'ai fini mon install, j'ai décidé d'installer tout mes soft dessus et de tout paramétrer dessus avant de m'atteller à la compilation du noyau.

merci a vous

Link to post
Share on other sites

Mon resolv.conf

search EDULIP

nameserver 194.2.0.20

et mon interfaces :

# This file describes the network interfaces available on your system

# and how to activate them. For more information, see interfaces(5).

# The loopback network interface

auto lo

iface lo inet loopback

# The primary network interface

auto eth0

iface eth0 inet static

address 192.168.3.1

netmask 255.255.255.0

network 192.168.3.0

broadcast 192.168.3.255

gateway 192.168.3.90

# dns-* options are implemented by the resolvconf package, if installed

dns-nameservers 194.2.0.20

dns-search edulip

Link to post
Share on other sites

cela marchai tres bien comme ca avec l'ancien noyau 2.6.8-2

cela ne provient probablement pas de là

une fois le système passé sur le nouveau noyau, il m'es impossible de revenir a l'ancien ... si je reboot sur l'ancien noyau l'interface réseau ne marche plus :|:rhooo:

cela vien peut etre du fait qu'un module es recompilé et n'est pas compatible, j'ai bien di "pitète", je penses pas et ne croi pas ke cela vienne de là

Link to post
Share on other sites
une fois le système passé sur le nouveau noyau, il m'es impossible de revenir a l'ancien

hein? Là, j'ai pas capté. Quand tu bootes, tu as le choix entre ton nouveau kernel et l'ancien, une fois que tu as lancé ton Linux dessus, il t'est pas possible de switcher sans rebooter.

si je reboot sur l'ancien noyau l'interface réseau ne marche plus

Donc, ce n'est pas un problème kernel, car tes modules se trouvent dans /lib/modules/nom_du_kernel donc, ton nouveau kernel ne sait pas utilisé tes anciens modules et ton ancien kernel ne sait pas utilisé tes nouveaux modules.

Par contre, je ne vois toujorus pas l'intérêt de redéfinir tes dns dans interfaces quand tu les as (les mêmes, sauf cette histoire de casse) dans /etc/resolv.conf.

Autre question (si tu as répondu, désolé, pas envie de relire le topic), sais-tu pinger le serveur?

ping -c1  192.168.3.90

PS: fais attention à ton écriture il y a des restes des SMS-style :(

Link to post
Share on other sites
hein? Là, j'ai pas capté. Quand tu bootes, tu as le choix entre ton nouveau kernel et l'ancien, une fois que tu as lancé ton Linux dessus, il t'est pas possible de switcher sans rebooter.

débutant, mais pas ignorant ^^. avant de me lancer dans une compilation noyau, j'ai quand même acqui de bonnes bases sous Unix et plus particulièrement Linux.

Par contre, je ne vois toujorus pas l'intérêt de redéfinir tes dns dans interfaces quand tu les as (les mêmes, sauf cette histoire de casse) dans /etc/resolv.conf.

Aucun ... cela était fait de base par mon install ... je l'ai supprimé de mon fichier "interfaces"

Autre question (si tu as répondu, désolé, pas envie de relire le topic), sais-tu pinger le serveur?

ping -c1  192.168.3.90

effectivement ... j'ai répondu, ma carte réseau ne répondant pas au très célèbre "ifconfig eth0" ni "ifconfig" je ne peux donc pas pinger ma passerelle ni aucun autre pc d'ailleurs, un message me nargue en me mettant que ma carte est HS :

/var/log/syslog :

QUOTE

May 12 15:38:25 servweb kernel: eth0: link up, 100Mbps, full-duplex, lpa 0xC1E1

May 12 15:38:43 servweb kernel: NETDEV WATCHDOG: eth0: transmit timed out

May 12 15:38:43 servweb kernel: eth0: Transmit timed out, status 0003, PHY status 782d, resetting...

May 12 15:38:43 servweb kernel: eth0: link up, 100Mbps, full-duplex, lpa 0xC1E1

May 12 15:38:59 servweb kernel: NETDEV WATCHDOG: eth0: transmit timed out

May 12 15:38:59 servweb kernel: eth0: Transmit timed out, status 0003, PHY status 782d, resetting...

mais, avant de changer d'installer le kernel, j'y arrive très bien ... Ce PC me servant de serveur web (http et https) et ftps, il me faudrait un système fiable sur le réseau

PS: fais attention à ton écriture il y a des restes des SMS-style :(

Aïe, je m'en excuse ... je fais pourtant attention à ne aps faire trop de fautes, je promes de faire plus attention dorénavant ^^

Link to post
Share on other sites

En théorie je l'ai déja désactivé dans les paramêtres du noyau ...

cela ne devrait servir à rien de le re-désactiver, mais je testerai ca dès que j'aurai sauvegardé ma config actuelle sur un petit Ghost.

Link to post
Share on other sites

J'ai le même problème sur une Debian "Woody" avec noyau 2.6.11 "officiel" (pour reprendre les termes du monsieur).

NETDEV WATCHDOF: eth1 : transmit timed out

à répétition... (eth1 = carte pCI gigabit à puce realtek 8169)

Bizarre car eth0 (carte réseau Intel intégrée au chipset 440BX) n'a pas de problème...

entre 2 time out la connectio est cependnat établie correctement pendant quelques secondes (le serveur fait DHCP-routeur-firewall) et le PC client se connecte même au net pendant ce laps de temps.

Je pensais à un problème de configuration, mias je n'ai rien trouvé. Je vais tenter de changer la carte de slot PCI. Mais ça m'embête un peu je n'au que 2 port PCI et je voulais rajouter une seconde carte Gigabit PCI :pleure:

Je vais devoir acheter un switch à la place :chinois:

Link to post
Share on other sites
J'ai le même problème sur une Debian "Woody" avec noyau 2.6.11 "officiel" (pour reprendre les termes du monsieur).

NETDEV WATCHDOF: eth1 : transmit timed out

à répétition... (eth1 = carte pCI gigabit à puce realtek 8169)

Bizarre car eth0 (carte réseau Intel intégrée au chipset 440BX) n'a pas de problème...

entre 2 time out la connectio est cependnat établie correctement pendant quelques secondes (le serveur fait DHCP-routeur-firewall) et le PC client se connecte même au net pendant ce laps de temps.

Je pensais à un problème de configuration, mias je n'ai rien trouvé. Je vais tenter de changer la carte de slot PCI. Mais ça m'embête un peu je n'au que 2 port PCI et je voulais rajouter une seconde carte Gigabit PCI :transpi:

Je vais devoir acheter un switch à la place :zarb:

Je m'autocite pour dire que malgrès un changement de slot PCI le problème subsiste.

Je suis preneur de toute solution ;-)

Link to post
Share on other sites

Bon j'ai continuer mes recherche est il semble que mon cas soit un peu différent...

=> problème de module r8169

J'ai essayer pas mal de chose mais rien ne marche:

- changement de slot PCI

- changement d'IRQ

- noapic, no acpi ...

- patch du module r8169 + recompilation du noyau avec différent set de patch et des patch spéciaux pour ce module

- configuration d'iptables d'après différent tutoriaux ou exemple

Du cuop je veins de cmmander deux autres carte réseau 10/100 que je sais faire marcher (realtek 8139), car je n'ai pas l'utilité chez moi du Gigabit.

Du coup la carte Gigabit va retourner dans mon PC sous FC3 ou elle marche nickel malgrès que le noyau soit aussi un 2.6.11 :D

Link to post
Share on other sites
Du coup la carte Gigabit va retourner dans mon PC sous FC3 ou elle marche nickel malgrès que le noyau soit aussi un 2.6.11 :D

ça peut être une incompatibilité avec la CM...

Link to post
Share on other sites
ça peut être une incompatibilité avec la CM...

Oui je ne voit plus que ça (carte mère Compaq à chipset Intel 440BX plus toute jeune) avec aussi la probabilité que j'ai loupé quelque chose quelque part...

Link to post
Share on other sites

×
×
  • Create New...