Jump to content

Installation de linux Mandrake 10.1


Blacko

Recommended Posts

Bonjour à tous,

Je viens d,installer Linux Mandrake 10.1 Official, mais lorsque je démarre Linux rien n'apparait. L'écran reste noir au complet. Tandis qu'avec Windows, l'écran fonctionne. Donc, je ne sais pas quoi faire. Le hic, c'est que ma carte graphique est une Radeon 9700 128Mbits et lors de l'installation, il n'y a que 4 choix de Radeon dans ATI; Une RTadeon 8000, une fglrx, une fbdev et une atre sans attribus(radeonb tout cour). Donc, laquelle il faut que je choisisse pour que mon écran fonctionne et qu'elle ne soit pas tout noir?

Merci,

Blacko

P.S. Très beau site et forum!

Link to post
Share on other sites

Boujour,

Lors du chargement de LILO (le menu qui propose de choisir l'OS que tu veu démarré) sous MDk on trouve failsafe qui correspond a un mode sansechec.

Il ce lancerat en Ligne de commande.

Pour charger le menu de configuration tape

#drakeconf

(attention à la casse M n'est pas m)

Dans ce menu on y trouve DISPLAY qui te permettras de changé la configuration de l'affichage du serveur X dans ton cas le pilote de la carte video.

Il y'a une option test pour vérifié que la configuration marche.

Bonne chance :malade:

Link to post
Share on other sites

Mais l'autre fois, lors de l'intall, j'ai testé ma configuration, et à l'écran plein de couleurs sont apparus avec une fenêtre disant: Et-ce quela configuration est correcte? Je pensais que oui vu que je voyais le message. Alors, j'ai cliqué oui...

De plus, le pilote de ma carte vidéo, c'est lequel? (sachant que j,ai une radeon 9700 128Mbits)

Merci beaucoup,

Blacko

P.S. J,ai essayer de taper #drakeconf, mais lors du démarrage de mandrake en ligne de commande, je ne peut pas tapper, ce que j'écris ne s'affiche pas...

Link to post
Share on other sites

Avant de démarré une session de nombreux programme démarrent et ca peut bloqué là (CTRL+C peut arrété le programme en cour afin que le systéme suive sont cour ).

Vous avez attendu l'invite # (en failsafe le systéme doit directement démarré en root) ?

Si vous l'avez eu il me semble que le probléme du clavier est a resoudre en premier et peut étre lié à ton probléme.

On peut rien faire si on n'a pas le controle du systéme et le clavier c'est le minimum.

ps : le systéme linux ayant un systéme de droits évolué, on utilise par convention # pour indiqué le début de la ligne de commande en utilisateur root(droits total sur le systéme) et $ pour les autres utilisateur, il ne s'agit que d'une indication et donc ne doit pas étre taper.

Link to post
Share on other sites

ben avant de taper drakeconf, ( sans le # c'est juste là pour indiquer que tu es en ligne de commande ), faut pénétrer dans le système.

Pour ça il te dit : login:

puis password:

et là ce que tu tapes ne s'affiche pas c'est normal.

Link to post
Share on other sites
Vous avez attendu l'invite # (en failsafe le systéme doit directement démarré en root) ?

Non, lors du démarrage, il y a pleins de lignes qui s'affichent, comme NET, ACPI, PCI, ESR, checking, freeing... Mais à ACPI, ça bloque. dfonc, je ne peut pas attendre le #. De plus, lorsque je fais Ctrl+C, ça ne fait rien... Ça arrête tout de même à ACPI...

Finalement, je ne voit pas de login.

Merci encore,

Blacko

Link to post
Share on other sites

Bonsoir,

J'ai eu le même problème mais c'était avec une nVidia qui n'était pas reconnue.

Donc solution possible

redémarrer sur le cd 1 ou dvd

Choisir mise à jour pour ne pas faire une réinstallation complète

Lors du résumé final, dans configuration graphique, choisir "vesa" et faire test.

Redémarrer normalement

A+

Link to post
Share on other sites

Non, lors du démarrage, il y a pleins de lignes qui s'affichent, comme NET, ACPI, PCI, ESR, checking, freeing...  Mais à ACPI, ça bloque.  dfonc, je ne peut pas attendre le #.  De plus, lorsque je fais Ctrl+C, ça ne fait rien...  Ça arrête tout de même à ACPI...

Finalement, je ne voit pas de login.

Merci encore,

Blacko

Donc c'est surement ca le probléme et non pas l'affichage.

Lorce que LILO (le chargeur de démarrage) appuyer sur echap pour accédé à ca ligne de commande et entrez

linux acpi=off

Linux devrait alors ce charger mais sans le support acpi qui semble bloqué.

Lors du démarrage appuyer sur echap pour afficher les messages de démarrage pour voir là où il pourrait bloqué si la solution ne fonctionne pas.

Essayez aprés on verra comment le désactivé par défault dans LILO

Link to post
Share on other sites
Mais à ACPI, ça bloque.

si tu mets acpi comme mot clé de recherche tu devrais avoir 250 réponses à

ta question....Toujours la même le réponse hein :transpi:

tu devrais commencer par le guide du posteur linuxien

et enchainer sur mandrake et débuter avec linux

Link to post
Share on other sites
Lorce que LILO (le chargeur de démarrage) appuyer sur echap pour accédé à ca ligne de commande et entrez
linux acpi=off

Linux devrait alors ce charger mais sans le support acpi qui semble bloqué.

J'ai essaye ça, mais lorsque je fais linuxacpi=off, ça ne marche pas, ça dit no such image. Lorsuqe je fais seulement linux, linux se load automatiquement et je ne peut pas écricre acpi=off.

Alors, est-ce que je dois faire un espace entre linux et acpi? Comment écricre cette ligne de commande sionon?

Merci encore,

Blacko

Link to post
Share on other sites

Ok, merci!

Bon, laors je suis parvenu à entrer sous Linux grâce à la commande

linux acpi=off

Par contre, là je ne sais pas comment régler les problème du "acpi not found"...

Si quelqu'un voudrais bien m'aider,

Merci,

Blacko

Link to post
Share on other sites

sinon peut-être une solution en tuant X : Ctrl + Alt + Backspace quand l'écran est noir et que le disque a fini de gratter. Malheureuement le [x|k|g]dm a tendance à relancer X à chaque fois.

Sinon l'erreur est peut-être amont avec la tentative de passage en frame-buffer - n'ayant pas lilo installé je ne saurai te dire quel paramètre mettre pour ne pas demander le passage en FB...

néanmoins chez moi avec carte ATI, Gentoo et Grub la ligne ressemble à ça :

kernel /boot/bzImage-2.6.10-r7 root=/dev/md0 video=vesafb:ywrap,mtrr vga=0x31A splash=silent

et si je ne veux pas de démarrage graphique je mets juste

kernel /boot/bzImage-2.6.10-r7 root=/dev/md0

Link to post
Share on other sites
Ok, merci!

Bon, laors je suis parvenu à entrer sous Linux grâce à la commande

linux acpi=off

Par contre, là je ne sais pas comment régler les problème du "acpi not found"... 

Si quelqu'un voudrais bien m'aider, 

Merci,

Blacko

C'est normale

acpi=off

désactive l'acpi donc le systéme ne le trouve pas au démarrage.

Le but étant de récupéré le controle du systéme pour essayé de le corrigé.

Je te propose en attendant de crée une autre entré dans le menu lilo pour cela vat dans le menu systéme=>configurer=>configurer votre ordi.

Il te demandré ton mot de passe root.

Puis vat dans gestionnaire de démarrage(c'est la où on configure LILO sur MDK)

Tu as la possibilité de choisir ton systéme lancé par défault.

=== crée une nouvelle entrée =======

clique sur suivant puis édite l'entrée linux, clique sur avancé.

Copie l'ensemble de ses champs dans un éditeur, puis annulé.

clique sur ajouté, "linux" ok.

avancé puis recopie tout les champs(relectionne la même partition).

Aprés change le nom par exemple : linuxnoacpi

et le plus important rajoute dans les options passé au noyeau

acpi=off

.

puis ok

Comme cela au menu de démarrage on y trouverra cette entrée pour démarré sans l'acpi en attendant mieux. Pour la résolution du probléme en lui même, désolait mais ca dépasse mes conaissances actuel.

Bonne chance !!

Link to post
Share on other sites

:francais:

Bonjour Blacko, j'ai eu le même problème que vous : écran noir après installation complète de la Mandrake 10.1 officiel

Voici ce que j'ai fait pour m'en sortir.

1) Refaire l'installation avec le DVD ou les CD et choisir "mise à jour"

Au moment de configurer la carte graphique, choisir xorg (dernier de la liste) et vesa. Mettre 800x600 et 64000 couleurs. Même chose pour l'écran

2) Au démarrage de Lilo, faire comme ont dit certains. appuyez sur ECHAP

3) Puis tapez "linux acpi=off"

La mandrake devrait démarrer en petit format 800x600

4) Une fois sur votre page, KDE de préférence pour l'instant, cliquez sur l'étoile, puis sur système, puis sur configuration, enfin sur "configuration de l'ordinateur"

Là vous choisissez "gestionnaire de démarrage", puis vous DESACTIVEZ ACPI...

5) Enfin, vous reprenez, également sur la configuration de l'ordinateur, "matériel", "résolution de l'écran", vos paramètres : 1024 x 768 et 64000 couleurs ou plus...

Voilà. Ensuite, il faudra sans doute aller chercher un pilote sur internet... Mais alors là, bon courage, c'est un peu la galère.

Amitiés. Nicorazon.

Link to post
Share on other sites

Salut,

J'ai mis la resolution de mon ecran trop grande et la tout est etire et je ne voit rien. Comment faire pour reparer ca? Lilo fonctionne et je le vois, mais lorsqu'il faut que j'entre mon m. de p., tout est etire et je vois rien.

Merci,

Blacko

Link to post
Share on other sites

te préoccupe pas de ça, l'acpi permet de gérer l'énergie avancée (surtout utile pour les portables...)

sur un PC de bureau, apm suffit déjà... et il ne sert que pour dire au PC de s'éteindre quand on le lui dit...

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...