Jump to content

Archived

This topic is now archived and is closed to further replies.

noobietux

[Résolu] Problème de DNS

Recommended Posts

Bon c'est encore moi avec mes problemes :ouioui:

Ma connection ADSL marche nickel mais quelque fois, ou plutôt tout le temps maintenant, j'ai des problemes pour me connecter à certains sites (recherche du nom de domaine qui n'abouti pas ou connection refusée...).

Sur ce dans le mdk control center je met les DNS de mon FAI, je me reconnecte, vérifie que les ip du serveur DNS sont bonnes ---- ça marche...sauf qu'au bout d'un moment ça recommence et là horreur mandrake ma remis les DNS par défaut tout seul sans rien que lui demande.

J'essaye plusieurs fois, toujours la même chose, au bout d'un certain temps il me remet ces *** de DNS sans rien que je lui demande et résultat ça m'énerve.

A ce stade je me dit qu'éditer à la main /etc/resolv.conf doit être la bonne solution --- toujours pareil: il démarre la connection avec les bons DNS et au bout d'un moment il les vire tout seuls.

Je commence à désespérer car je vois pas trop de solutions

Link to post
Share on other sites

n'ayant jamais eu ce problème ni même jamais lu, je te dirais de faire un script en bash/perl et de la mettre dans cron. Ce script vérifierait toutes les X minutes si les DNS de /etc/resolv.conf correspondent à celle de ton FAI si oui, prochiane vérif si non, réécriture du fichier.

En attendant d'avoir de meilleures réponses, j'espère que ça t'aidera un peu

Link to post
Share on other sites
je te dirais de faire un script en bash/perl et de la mettre dans cron. Ce script vérifierait toutes les X minutes si les DNS de /etc/resolv.conf correspondent à celle de ton FAI si oui, prochiane vérif si non, réécriture du fichier.

C'est hors de ma portée je pense :chinois:

Merci quand même.

ps: si quelqu'un avait une idée sur ce qui change mes DNS ...

Link to post
Share on other sites

j'avais déja testé la solution de -rem- car je rencontrais le même problème eh bien le fichier était remplacé par je ne sais quel processus. ( ou alors j'avais mal appliqué les droits ... mais je ne pense pas )

sinon ... euh rien à proposer, dsl :transpi:

Link to post
Share on other sites

chez moi c'était dnsmasq qui faisait ce genre d"aneries.

une fois dégagé, m'embêtait plus ...

si tu fais un ls -la /etc/resolv.conf tu auras l'heure à laquelle la modif à été faite. En comparant avec la crontab tu verras si elle y est pour qqch. Sinon ps -faux | grep dns, tu verras peut-être un dnsmasq ou équivalent.

Link to post
Share on other sites

J'ai fait ta manip :

[root@localhost med]# ps -faux | grep dns

Warning: bad ps syntax, perhaps a bogus '-'? See http://procps.sf.net/faq.html

root    14061  0.0  0.1  1960  760 pts/1    S+  17:00  0:00                  \_ grep dns

root      6769  0.0  0.1  2368  852 ?        Ss  Dec14  0:00  \_ /usr/sbin/pppd pty /usr/sbin/pppoe -p /var/run/pppoe.conf-adsl.pid.pppoe -I eth0 -T 80 -U  -m 1412    noipdefault noauth default-asyncmap defaultroute hide-password nodetach usepeerdns mtu 1492 mru 1492 noaccomp noccp nobsdcomp nodeflate nopcomp novj novjccomp user *********@neuf.fr lcp-echo-interval 20 lcp-echo-failure 3

Je ne vois pas de dnsmasq.

Pour le reste je ne sais pas encore m'en servir, on verra plus tard.

Sinon j'ai suivi -rem- j'ai mis le resolv.conf en lecture pour le tout le monde c'est radical.

Merci à tous :incline:

Link to post
Share on other sites

Bon je remonte ce topic parceque c'est toujours pas réglé.

[root@localhost etc]# ps -faux | grep dns

Warning: bad ps syntax, perhaps a bogus '-'? See http://procps.sf.net/faq.html

root      7370  0.0  0.1  2368  908 ?        Ss  Dec23  0:00  \_ /usr/sbin/pppd pty /usr/sbin/pppoe -p /var/run/pppoe.conf-adsl.pid.pppoe -I eth0 -T 80 -U  -m 1412    noipdefault noauth default-asyncmap defaultroute hide-password nodetach usepeerdns mtu 1492 mru 1492 noaccomp noccp nobsdcomp nodeflate nopcomp novj novjccomp user ************@neuf.fr lcp-echo-interval 20 lcp-echo-failure 3

root    30318  0.0  0.1  1960  760 pts/0    S+  14:43  0:00  |                  \_ grep dns

Ca serait pas peerdns le fautif ?

Je précise que je ne sais absolument pas ce que je fait et que je n'ai aucune compétence pour comprendre ce message.

Link to post
Share on other sites

essayes de faire

lsof | grep /etc/resolv.conf

Cette commande te permettra de voir tous les processus utilisant ton fichier (mais malheureusement à l'instant T uniquement).

Si tu n'a pas lsof, essayes de l'installer (normalement dispo dans Mandrake, sinon :ouioui:

Link to post
Share on other sites

salut,

c'est cencé faire quoi

ps -faux | grep dns
?

parceque je comprends pas ... , pourquoi pas

ps -A |grep dns

?

puis comme dit -rem-

Ben en fait, si le fichier n'a que des droits de lecture ( 444 ), je ne vois pas comment le systeme peut l'effacer.

enfin bon .... :ouioui:

Link to post
Share on other sites
salut,

c'est cencé faire quoi  ?

Je ne sais pas c'est ce que l'on m'a suggéré de faire.

parceque je comprends pas ...

, pourquoi pas 

ps -A |grep dns

?

ça ne me retourne rien.

puis comme dit -rem-

j'ai essayé, ça fonctionne, mais a chaque reboot le probleme revient.

enfin bon ....  :ouioui:

Voila en fait le probleme

Link to post
Share on other sites

ps -A ==> donnes tous les process en cours de fonctionnement.

si l'on rajoute |grep dns ==> ca permet de trier que les applis qui contiennent 'dns'.

donc dans ton cas tu n'a aucun programme qui tourne qui contient les lettres 'dns'.

apres .... c'est sur que je sais pas pourquoi le fichier resolv.conf se fait effacer si tu lui as donné que des drois en lecture :| c'est un mistere ou alors tu te log en utilisateur 'root ' ce qu'il ne faut pas faire ..

:ouioui:

Link to post
Share on other sites
salut,

c'est cencé faire quoi  ?

parceque je comprends pas ... , pourquoi pas 

ps -A |grep dns

?

les manpages sont une source d'informationquasi inépuisable :D

une bonne habitude quand on te donne une commande que tu connais pas c'est de regarder son manpage

ici

$man ps

$man grep

si tu te demandes ce qu'est le |, il faudra regarder du coté de

man bash

(attention, longue lecture en perspective :transpi: )

bref en fait tu as toute la docummentation pour comprendre n'importe quelle commande qui te seras donnée

ah et puis quand ca "fait rien", en fait ca veut dire que ca a fait quelque chose :8

dans ce cas il affiche tous les processus en cours contenant "dns"

si ca donne rien c'est qu'il n'a rien trouvé

donc faut chercher ailleurs.

bon par contre pour ton probleme, j'ai pas d'idées donc je laisse les pro répondre :p

Link to post
Share on other sites

Il me sembela avoir déja vu se problème :D:transpi:

en fait sur la debian c'est pareil :8 , lorsque la connexion coupe ( ppp0 ou dhclient ) le serveur dhcp ( qui peut etre celui de ton fai ou ton routeur ou autre ) met à jour ton resolv.conf automatiquement en modifiant si necessaire ...

sous debian dans le fichier de config de la connexion adsl ( reste à savoir ou il se cache sous mandrake .. :p

# The following two options should work fine for most DSL users.

# Assumes that your IP address is allocated dynamically

# by your DSL provider...

noipdefault

# Try to get the name server addresses from the ISP.

#usepeerdns

# Use this connection as the default route.

# Comment out if you already have the correct default route installed.

defaultroute

##

personnelement j'ai mis en commentaire le usepeerdns, car sinon à chaque connexion il écrasait mon resolv.conf et du coup il utilisait plus le dns qui tournait sur mon serrveur ...

j'espere que c'est ça ....

Link to post
Share on other sites

×
×
  • Create New...