Jump to content

Archived

This topic is now archived and is closed to further replies.

$oolfly

Probleme installation drivers NVIDIA.

Recommended Posts

Salut @ tous !!!

============

J'ai télécharger les derniers drivers NVIDIA pour ma MX440, j'ai lu un tutorial sur Fedora-franace.org sur l'installation des drivers NVIDIA, et dans un premier temps, ils disent de désactiver le serveur X en tapant dans la console : # /sbin/telinit 3

l'ecran devient noir, et passe en mode texte, et la une liste de processus défile dont un qui échoue !!!!

voila l'erreur qui s'affiche :

"Démarrage de mpmpd : Kernel md modul does not support events [ECHEC]"

Voila, apprarement je ne peut pas installer mes drivers si le server X n'est pas désactiver, donc c'est pas la peine que je continu à essayer de les installer si j'ai deja des erreurs en désactivant X !!! :mdr:

Merci, @+ :fumer:

Share this post


Link to post
Share on other sites

ta as l'autre méthode qui conciste à désactiver le démarrage de X au démarrage du système justement.

(oui tu devrai rebooter mais bon)

dans un terminal

avec ton éditeur de texte favorie édite le fichier /etc/inittab

tu remplace la ligne id:5:initdefault: par id:3:initdefault:

reboot et voilà

quant l'installation est fini tu remet l'ancienne ligne. Bon c'est une méthode comme une autre... .

Share this post


Link to post
Share on other sites

C'est pas parce que ce service ne peux pas s'arrêter que X n'est plus là...

Ce service n'est qu'un des différents services qui s'arrêtent lors du passage du niveau 5 au 3...

Essaye... tu verra

Share this post


Link to post
Share on other sites

Si tu veux une méthode brutale mais qui doit marcher :

- Tu passes à une console avec Ctrl + Alt + 1 (par exemple)

- tu te log en root

- tu kill X avec : killall X

Et voilà, tu as une console sans X :D

Après tu lances le binaire NVidia comme indiqué.

Share this post


Link to post
Share on other sites
Si tu veux une méthode brutale mais qui doit marcher :

- Tu passes à une console avec Ctrl + Alt + 1 (par exemple)

- tu te log en root

ca oké mais apres pourquoi pas 'init 3', ca marche pas sur Fedora ??. Enfin si ca fonctionne je te conseille ca , puis quand t'as fini 'init 5' c'est tout.

:D

Share this post


Link to post
Share on other sites
Si tu veux une méthode brutale mais qui doit marcher :

- Tu passes à une console avec Ctrl + Alt + 1 (par exemple)

- tu te log en root

- tu kill X avec : killall X

Et voilà, tu as une console sans X :fumer:

Après tu lances le binaire NVidia comme indiqué.

Et si il y a gdm ou kdm qui s'occupe de relancer X, tu fait quoi?

Share this post


Link to post
Share on other sites

Salut,

Moi aussi je me suis mis dans la tete d'installer les drivers Nvidia, mais ca déconne.

J'ai beau avoir chargé les codes sources du Kernel de Mandrake 10.1 official, le processus d'installe me sort qu'il n'y a pas les bonnes sources du kernel ... :titia:

Je pige pas trop... D'autant que le "tout mode texte", ca ne facilite pas trop les choses...

Share this post


Link to post
Share on other sites

salut,

j'ai chercher a ce sujet et je me suis appercu qu'il y a une ligne de code a corriger dans le pilote si tu veux le compiler sur la mandrake 10.1.

dans /usr/src/nv/nv.c cherche PM_SAVE_STATE et remplace le par PM_SUSPEND_MEM ca doit etre vers la ligne 3697. apres ce ca doit fonctionner.

apres avoir fait l'intall qui la devrai etre ok, rajoutes 'nvidia' a la fin du fichier /etc/modprobe.preload

bon ensuite n'oublis pas de modifier la config de Xorg comme indique par nvivia.

la ou tu reboote ou alors tu charge le module nvidia (modprobe nvidia).

et tu relance X (startX / init 5).

@plucH

NB: la modif du code de nv.c ne viens PAS de moi et a ete trouvée en fesant des recherches sur GOOOOOOGLE.

Share this post


Link to post
Share on other sites

Oui j'ai aussi trouvé cette méthode, mais j'ai l'impression que je bloque sur un truc, parce que malgrés cette modif, l'install bloque toujours ...

Enfin je vais réessayer.

J'ai surtout pas envie de faire une grosse connerie...

Merci.

Share this post


Link to post
Share on other sites

quand tu boote avec grub (les liloteurs me suppléeront)

tu sélectionne (avec les flèches) ton entrée du menu

tu tape "e" comme edit

à la fin de la ligne "boot=" tu rajoute un espace et "2"

tu démarreras en runlevel 2, et là, ça métonnerait que X soit lancé à ce niveau :D

Share this post


Link to post
Share on other sites

Bon, j'ai réessayer et toujours le meme probleme avec le kernel, l'install me dit de vérifier qu'il correspond bien a ma version... pourtant, j'ai bien téléchargé la derniere version via Urpmi kernel-source

J'ai édité le le fichier NV.c en remplaçant PM_SAVE_STATE par PM_SUSPEND_MEM mais rien n'y fait... ca veut pas.

Il n'y aurait pas moyen d'utiliser des drivers non officiels, ne n'obligent pas a jongler avec tout ça pour avoir la 3D? (j'ai bien envie d'essayer Tuxx racer :francais: )

Share this post


Link to post
Share on other sites

2 truc,

1 verifier le lien symbolique linux dans /usr/src qui doit pointer les bonnes sources.

2 tu peut essayer ca .. sh NVIDIAxxx.xxx.run --add-this-kernel

puis sh NVIDIAxxx.xxx.run

:ouioui:

Share this post


Link to post
Share on other sites

Heuu je ne pige pas trop bien -newby inside- a quoi ca ressemble un "lien symbolique"?

Quel type de fichier?

Bon sinon, quand je tape Uname -r en konsole, le systeme me repond 2.6.8.1-10mdk

Mais, quand je cherche dans le dossier, je vois un dossier linux, un dossier linux-2.4.27-0.pre2.1mdk, et un dossier rpm.

Je sais pas trop a quoi sert tout ca...

Share this post


Link to post
Share on other sites

Merci Ouragan pour le lien... En effet les nom de fichiers sous nunux sont déroutant pour un windosien "de formation". Ca devrait me permettre de mieux piger l'architecture du truc. :pleure:

Share this post


Link to post
Share on other sites

Bon... Gronky tente d'installer les drivers Nvidia pour son Mandrake épisode 31495.

Suivant les differents conseils trouvés ici et ailleurs, ayant imprimé les divers aides (y compris les 2 ramettes de fichier texte de Nvidia) j'ai finalement installé les drivers.

MAIS... (ben oui, y a un "mais" sinon je vous tanerai pas avec ça)

Ca ne marche pas...

j'ai pourtant procédé comme tel:

# Uname -r

pour verifier la version du kernel

2.1.6.8mdk (je tape ca de memoire, la je suis sous windows :transpi: , vous allez comprendre pourquoi + loin)

# sh NVIDIA-Linux-x86-1.0-6111-pkg1.run --kernel-name:2.1.6.8mdk

La le truc s'installe ne signale pas de probleme.

Ensuite, je modifie le fichier le fichier Xorg.conf avec emac comme indiqué:

remplacement de "nv" par "nvidia"

Je sauvegarde.

je tape startX et la :

paf, x ne demarre pas... erreur de noyaux.

:p

se peut il que mon noyaux soit mal installé? pige plus rien là...

Share this post


Link to post
Share on other sites

juste une petite question :

as tu lancer le module 'nvidia' a la main avant de tester X ?

as tu modifier le fichier modprobe.preload ?

bon oké ca fait 2 questions :)

:D

Share this post


Link to post
Share on other sites

:pleure: ben je te l'avait ecris .....

apres avoir fait l'intall qui la devrai etre ok, rajoutes 'nvidia' a la fin du fichier /etc/modprobe.preload

bon ensuite n'oublis pas de modifier la config de Xorg comme indique par nvivia.

la ou tu reboote ou alors tu charge le module nvidia (modprobe nvidia).

et tu relance X (startX / init 5).

:yes: alors là, la marmotte elle met le chocolat dans le papier d'alu. :smack:

:-D

Share this post


Link to post
Share on other sites
au passage, ne pas avoir X ne t'empeche pas d'aller sur PCI : il y a links, lynx, etc... :craint:

Share this post


Link to post
Share on other sites

J'ai encore essayer, en tentant de lancer le module Nvidia, mais il me sort Nvidia module not found...

J'avais bien sur modifié le xorg.conf comme indiqué.

J'ai l'impression que le probleme vient du kernel qui semble differer de ce que m'affiche Uname -r

Je crois que je vais abandonner.

Share this post


Link to post
Share on other sites

Bon, je prends le problème en cours, mais je suis pas tout...

Gronky, quel kernel as-tu? Quel kernel-source as-tu installé?

Bon, pour voir quels packages sont installés, tu peux regarder avec la suppression de paquetages dans le menu K - configuration (enfin qqch comme ça, désolé d'être impréci mais je n'ai pas de Mandrake). De toute manière, tu as une interface graphique donc tu pourras voir ça facilement.

Share this post


Link to post
Share on other sites

par rapport au module de nvidia, c'est relativement simple :

si quand tu tapes lsmod (ou /sbin/lsmod sous mdk, car /sbin n'est pas dans le PATH)

tu devrais voir apparaître agpgart ET le_nom_du_module_qui_gere_l_agp ET nvidia

si ce n'est pas le cas, c'est qu'il faut que tu les recharges avec soit insmod soit avec modprobe (which is cleverer -dixit le man :francais: )

(encore que peut-être que le driver nvidia gere tout seul l'agp, auquel cas, il te faut juste nvidia dans la liste des modules loadés)

Share this post


Link to post
Share on other sites

×
×
  • Create New...