Jump to content

Archived

This topic is now archived and is closed to further replies.

Blacksad

obtenir une addresse ip du dhcp sous debian

Recommended Posts

Bonjour,

je viens d'installer un poste linux.

Il doit faire parti d'un domaine avec server DHCP où sont déja connectés une 30aine de PC.

J'ai installé la débian du cd de la 3.3 de Knoppix.

Losrque je configure mon réseau sous linux, impossible de contacter le server dhcp.

Que faire pour qu'il trouve le dhcp et qu'il obtienne une adresse ip ?

mon fichier /etc/network/interfaces :

auto eth0

iface eth0 inet dhcp

quand j'essai la commande /etc/init.d/network restart

rien ne se passe, il ne connait pas "network" :/

#dhclient eth0 <-- marche pas non plus

les cablages sont corrects, j'ai un XP d'installé dessus et lui se connecte bien au domaine et obtient son ip nikel

quand je lance dhcp3d ou pump voici ce que j'obtiens

"Failed to connect to localhost:bootpc : network is unreachable"

une idée ? bon courage

Merci

Link to post
Share on other sites

je peux lui attribuer une ip statique mais cela ne fait rien du tout :/

iface eth0 inet static

address 192.168.106.2

netmask 255.255.255.0

gateway 192.168.105.206

c'est de cette manière que je le met en static mais ça ne donne rien,

pour le ifconfig -a et le ifup je v voir

Link to post
Share on other sites

voici la carte réseau telle qu'elle est détectée :

VIA VT 6102 Rhine-II at 0xee001000 donc je pense que de ce coté c bon.

Voici le contenu exact de mon fichier interfaces :

auto lo eth0

iface lo inet loopback

iface eth0 inet dhcp

rien de plus

résultat de :

$ifup eth0

ifup: interface eth0 already configured

$dhcpd3

not configured to listen on any interfaces

$ifconfig -a

eth0 Lien Encap:Ethernet HWaddr 00:30:1b:27:29:2e

BROADCAST MULTICAST MTU:1500 METRIC:1

RX Packets:0 errors:0 dropped:0 overruns:0 frames:0

TX Packets:0 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 lg file transmission:100

RX bytes:0 (0.0 b) TX Bytes:0 (0.0 b)

interruptions:16 Adresse de base:0x5000

Link to post
Share on other sites

alors :

$ifdown eth0 && ifup eth0

Operation failed

et depuis ifup eth0 découle sur un Operation failed systématiquement.

$dmesg | grep lo0 <--- rien | $dmesg | grep lo <--- config du pc aucun pb

$dmesg | grep eth0

eth0: VIA VT6102 Rhine-II at 0xee001000, 00:30:1b:27:29:2e, IRQ16

eth0: MII PMY Found at address 1, status 0x786d advertising 05e1 link 45e1

eth0: Setting full-duplex based on mII #1 link partner capability of 45e1

eth0: Setting full-duplex based on mII #1 link partner capability of 45e1

(je reprends mes recherches 14h :) eat time)

Link to post
Share on other sites

tu pourrais essayer avec un gentoo live cd, en bootant sur le noyau 2.6 au demarrage stp pour voir ?

Si elle non plus ne detecte rien, y a un pb dans ton truc. Deja, knoppix + debian, je suppose que le pb vient de toi ou de ton reseau, gentoo confirmera.

Link to post
Share on other sites

Enfin bon ton serveur de messagerie sera pas en DHCP, sinon tu vas avoir quelques problèmes :)

Je diagnostiquerai plutôt un pb réseau : vérifie :

- le câble

- les loupiottes sur le switch

- le duplex sur le switch

- avec une carte réseau PCI classique et bien supportée (genre 3Com ou EE100)

je reproduis un pb du genre en débranchant mon câble réseau, alors ...

si c'est un noyau custom :

Device Drivers -> Block devices -> <M> Network block device support ?

Link to post
Share on other sites

Il sera serveur de messagerie mais pas dhcp, il aura une ip attribuée par le dhcp, mais bon la n'est pas mon pb :bravo: ,

il faut savoir que sur cette meme machine est installé windows XP, avec windows je me logue au domaine sans aucune difficultés :pciwin: .

donc le problème ne vient pas de mes branchements :ouioui:

Link to post
Share on other sites

×
×
  • Create New...