Jump to content

Archived

This topic is now archived and is closed to further replies.

MissZaza

Problème de login avec Mandrake 10.0

Recommended Posts

Salut,

J'ai un petit problème avec Mandrake 10.0. Je ne peux plus ouvrir de session utilisateur, seule celle de root s'ouvre. :yes:

Quand j'essaye de me logger avec un nom utilisateur, j'ai un message me disant que la session a duré moins 10 secondes (en effet, je ne l'ai même pas vu s'ouvrir!!), qu'il sagit d'un problème d'installation ou d'espace disque.

Pour l'espace disque, c'est pas possible mais pour l'installation...

Dans le détail de l'erreur, y'a:

Warning : Unable to read ICE authority file.

Je suppose qu'il doit y avoir un rapport...

Je précise que tout ceci m'arrive après la tentative d'installation d'un réseau local et l'installation d'un serveur Samba.

J'attends vos réponses chers experts linuxiens!!

Share this post


Link to post
Share on other sites

tu ouvre ta session en mode graphique? parce que dans ce cas c'est possible que tu n'es pas assez d'espace pour créer les fichiers nécéssaire au démarrage d'une session X (ou bien un manque de droit).

essaye dans une console (alt+F1)

su nom_d_utilisateur

et regarde si tu peux te logger comme ça.

Share this post


Link to post
Share on other sites

Ok j'ai fais ce que lorinc dit.

En mode console pas de problème pour se logger.

Il faudrait donc que je désactive le mode graphique au démarrage ?

Comment régler le problème ?

Share this post


Link to post
Share on other sites

non, ça ne serre a rien de desactiver X du demarrage, ce qu'il faut, c'est :

- verifer qu'il y a suffisament de place dans /home/nom_de_l_utilisateur (et notament les quotas...)

-vérifier les droits en écriture dans ce dossier.

Share this post


Link to post
Share on other sites

Et comment on sait s'il y a assez d'espace, il faut combien?

Les quotas? C'est quoi exactement?

Je vais essayer de trouver des infos là-dessus.

Merci pour tes réponses Lorinc.

Share this post


Link to post
Share on other sites

pour la place, c'est juste de quoi écrire un fichier texte (le mien fait 3,7ko)

et pour les quotas, petit tuto mandrake , ce sujet esst pas trop mal fait (j'ai pas eu le temps d'explorer la partie sur les quotas, mais il me semble que ca y etait)

sinon, vérifie les droit dans ce repertoire (ca m'est déjà arriver de pas avopr de droit en ecriture sur ma home... :pleure: )

Share this post


Link to post
Share on other sites

Bon j'ai regardé tout semble correct.

Là je suis perdue :francais:

Est-ce que cela peut venir de la config de samba ?

A part ça j'ai rien fais d'autre, donc je vois pas...

Solution ultime, comment désinstaller la mandrake avec un multi-boot Linux/Win sans que cela plante le PC ?

Si quelqu'un a une autre idée, je suis preneuse.

Share this post


Link to post
Share on other sites

tu peux regarder le fichier /var/log/XFree86.0.log et copier/coller les message d'erreur ( (EE) )

parce que pas question de desinstaller linux ... :francais:

Share this post


Link to post
Share on other sites

Y'a pas de message d'erreur dans ce fichier !!!!

Donc pas possible de les copier/coller :francais:

Une autre idée peut-être ?

Merci pour ton dévouement à ma cause, Lorinc.

Share this post


Link to post
Share on other sites

Bonsoir,

j'imagine que tu utilises kde, essaye de lancer une autre wm, par exemple icewm.

Pour ce faire, quand tu es dans le terminal, tape "startx --icewm".

Si icewm n'est pas installé, tapes au préalable "su" [entrée] => ton mdp [entrée] => puis "urpmi icewm".

A oui, pour voir la place dont tu disposes, tapes "df -h".

Si la place est ok, que ça fonctionne sous icewm, supprimes le repertoire de kde : tape "rm -rf /home/toto/.kde" ( bien sur remplace toto par ton nom d'utilisateur).

Bonne chance !

Share this post


Link to post
Share on other sites

Y'aurait-il des fichiers cachés sous Linux ? Pas de fichier home/user/.xsession-errors !!!

Non j'utilise gnome, j'ai essayé avec icewn, miracle je peux me logger!!

Donc il faut que je supprime le répertoire de gnome ?

et puis je réinstalle l'environnement avec un update ?

Share this post


Link to post
Share on other sites

Non j'utilise gnome

Ah, tout s'explique :ouioui: (bouh le :ouioui: )

les fichiers cachés sont des fichiers qui commence simplement par un point

si tu vois aucun fichier commençant par un point, c normal, ils sont cachés :keskidit:

doit y avoir une option dans nautilus pour ça (genre afficher les fichiers cachés... :keskidit: )

sinon, ben ouais, vire le repertoire .gnome1 (les autre, on s'en fout), mais tu pers toutes tes préférences (remarque t'en avait peut-être pas)

mais ça m'étonnerais fort que tu soit obligé de reinstaller gnome.

dans le pire des cas, ben oui, vire gnome avec drakconf, vire qd même le .gnome1 (qui contient p-e des erreurs...) et reinstalle le tout...

Share this post


Link to post
Share on other sites

OK je crois que là vous avez trouvé la solution.

Juste une dernière question, y'a 2 répertoires : .gnome et .gnome2.

Pour ma culture Linux (qui en a bien besoin), pourquoi y'en a 2.

Share this post


Link to post
Share on other sites

sinon, le fichier de log des erreurs (si c'est pas ~/.xsession-errors ) est ~/.gnome-errors

si tout marche, alors, c ok.

je suis pas sur mais je crois que .gnome date de gnome 1 et que .gnome2 a été rajouté à la version 2 , les 2 restant bien évidement fonctionnels. il ont du faire ça opur faciliter le debug et pour ne pas surcharger le premier repertoire (mais je peux dire une connerie, aussi :keskidit: )

il me semble que c pareil pour kde...

Share this post


Link to post
Share on other sites

Pour l'espace disque, il me reste 20Go pour /home, cela doit suffire :keskidit:

J'ai supprimé le répertoire .gnome et j'ai retenté : y'a toujours le problème.

Dans le fichier .xsessions-errors, voilà ce qu'il y a :

/etc/X11/gdm/PreSession/Default: Registering your session with wtmp and utmp

/etc/X11/gdm/PreSession/Default: running: /usr/bin/X11/sessreg -a -w /var/log/wtmp -u /var/run/utmp -x "/var/lib/gdm/:0.Xservers" -h "" -l ":0" "invite"

/etc/X11/gdm/Xsession: Beginning session setup...

/etc/X11/gdm/Xsession: Setup done, will execute: /usr/bin/ssh-agent -- /etc/X11/xdm/Xsession

which: no galeon in (/bin:/usr/bin:/usr/bin/X11:/usr/X11R6/bin:/usr/local/bin:/opt/X11R6/bin:/usr/bin:/usr/games:/home/invite/bin)

** (gnome-session:4767): WARNING **: Unable to read ICE authority file: /home/invite/.ICEauthority

Cela vous inspire-t-il ?

Share this post


Link to post
Share on other sites

ah bah oui, fallait le dire tout de suite, ça avance beaucoup plus :chinois:

quand tu demarre, tu va sur une console, et tu regarde si il y est:

ls -l .ICEauthority

et surtout, tu regarde les droit, normalement, il doit t'appartenir et être en rw pour toi

si ce n'est pas le cas, tu le renomme

su
mv ./.ICEauthority ./.ICEauthority_backup

car normalement il est créé à chaque demarrage d'une session X

(le supprime pas qd même)

et là, miracle (enfin j'espère... :sm: )

Share this post


Link to post
Share on other sites

Est ce que tu as un fichier .ICEauthority dans ton home ?

Essaye en invité de taper dans une console :

$ ls -la ~

Si il y a quelque chose, vérifie que tu as les droits dessus.

S'il n'y a rien essaye de le créer (toujours dans la console)

$ touch .ICEauthority ~

Sinon, c'est peut être un problème d'install XFree.

Comment liste-on des paquets sous mandrake ? :sm:

Share this post


Link to post
Share on other sites

:sm:

Merci beaucoup Lorinc, le problème est résolu en faisant ce que tu dis.

Je peux enfin ouvrir ma session utilisateur.

Cela peut venir de quoi?

Que je fasse encore la même connerie (au moins j'aurai la soluce !) :chinois:

Share this post


Link to post
Share on other sites

j'imagine que tu t'es déjà ouvert une session avec gnome et que tu as lancé une appli graphique en root...

ce qui a eu pour effet de changer la proprieté de .ICEauthority vers root...

resultat, au demarrage suivant, tu ne peut pas l'effacer (t'as pas les droits...) et tu ne peux pas le lire (pas de droits non plus, mais de toute façon, il est obsolete...)

conclusion, faut jamais faire de su dans une console de X, il faut faire su -

(l'idée c'est qu'il faut changer d'environement, et notament $ICEAUTHORITY qui contient le repertoire ou se situ .ICEauthority , repertoire que l'on peut changer, si on ne veut pas avoir de probleme du genre...)

Share this post


Link to post
Share on other sites

Salut les gens!

j ai un pb jvien d installé mandrake 10.0 hier ca marchai jetia sur le bureau nikel et se matin en le demarrant il me demande un login alors je rentre le login utilisateur maais apré ca veu pas allez plus loin il me demande une commande ke j ignore étant un gors nubi de linux :( pliz need help

:bouletdujour:

________

- Carte mère MSI K8T Neo-FIS2R

- Processeur AMD Athlon 64 3000+ (64 bits)

- Mémoire 2x512 Mo DDR PC3200 samsung

- Carte Vidéo SAPPHIRE ATI RADEON 9800 Pro 128Mo 256bits

- Graveur DVD 8x Pioneer

- Disque dur IDE 120Go 7200T

Share this post


Link to post
Share on other sites

j ai un pb jvien d installé mandrake 10.0 hier ca marchai jetia sur le bureau nikel et se matin en le demarrant il me demande un login alors je rentre le login utilisateur maais apré ca veu pas allez plus loin il me demande une commande ke j ignore étant un gors nubi de linux :( pliz need help

On a deja décrit clairment la politique de nos forums par rapport au style sms. Merci de corriger ce message pour qu'il soit rédigé dans un francais normal. Je ne demande pas des phrases dignes de molieres ni des alexandrins, ni meme un sans faute, les fautes d'orthographe pouvant dépendre de beaucoup de chose, mais je demande juste a ce que le style sms soit banni.

Je supprimerai ce post s'il n'est pas corrigé, comme nous en avons convenu entre modos et admins. Merci aux inpactiens d'attendre la correction de ce post pour répondre.

Share this post


Link to post
Share on other sites

je réponds ici, car tu en parles, mais c'est un peu hors sujet. donc une ptite parenthese de ma part.

Avec d'autres modos actifs, nous avons convenus ensembles que les messages du style sms seront supprimés, et leurs auteurs avertis par mp. On va appliquer ca en douceur bien entendu, mais en cas extreme ca pourra etre le cas. Donc, ici, je prefere demander a l'auteur de modifier le style de son message, afin que tout soit ok, et l'ambiance reste bonne. Cela profitera a tout le monde, et le posteur découvrira ptet qu'il a un clavier azerty et non "1 2 3 4 5 6 7 8 9".

Share this post


Link to post
Share on other sites

Rem : oublies pas : ortho : :iloveyou:

:roll:

C'est vrai que mettre le ICe-Authority dans le home, accélère le démarrage, mais si on le met dans le /tmp, ça résoud ce genre de pb ...

Share this post


Link to post
Share on other sites

×
×
  • Create New...