Jump to content

[RESOLU] Problèmes de son nforce2 + kernel 2.6.7


Arofarn

Recommended Posts

Les Problèmes:

Depuis que j'ai mis à jour le kernel vers le 2.6.7. , le son est devenu une espèce de bouilli de bruit infame.

Pour info donc:

- distro: Fedora Core 2 avec toutes les dernières mise à jour

- carte mère NF7-S rev 1.x

- driver son ALSA intel i81x (enfin quelques chose s'approchant)

Contrairement à d'autre qui n'ont absoluement pas de son, le miens est complèment pourri, comme si queluq'un crachit dasn un micro au moindre son :francais:

Si quelqu'un à une solution je suis preneur, sinon je vais m'acheté un SB Live! 5.1...

2e soucis pas de codec MP3 sous Fedora core 2 à cause de problèm de licence...

Les Solutions:

Pour le son qui crache:

- Dans le panneau de configuration de KDE, désactivé le système son. Ca ne désactive pas les sons du systèmes, mais ça enlève une couche logicielle (l'aRts discute avec OSS ou ALSA).

ALSA (obligatoire avec le nForce 2 avec un kernel 2.6.x) est utilisé directement par les diférents logiciel. Le driver ALSA pour le nforce2 est le snd-intel8x0 car les driver nvaudio ne fonctionne pas avec les nouveaux noyaux :pleure:

- Dans un "mixer de son" (Kmix, alsa-mixer...): désactiver ou diminuer les volumes des antrées (Mic, Line-In...) jusqu'à disparition des grésillements. Pour "optimiser, si vous ne voulez pas tout déactiver lancer xmms ou un autre player avec de la musique et vous entendrez tout de suite quelles entrées posent problème (chez moi l'entrée "Video")

Merci à Sandeman et remy.harel :mad:

Pour les codecs mp3:

Pour des problème de licences il n'y a pas de codec mp3 dans la distro Fedora ni sur les serveurs yum officel de Fedora.

 # yum install xmms-mp3

renvoie donc un message d'erreur comme quoi il ne connais pas ce package.

Pour remedier au problèmes, il faut ajouter de nouveau serveurs pour yum. En root, il faut éditer le fichier /etc/yum.conf, et rajouter par exemple les paramètre du serveur de Freshrpms sous les paramètre des serveur officel ( [base], [fedora-stable-fc2], ...) :

[freshrpms]
name=Fedora Linux $releasever - $basearch - freshrpms
baseurl=http://ayo.freshrpms.net/fedora/linux/$releasever/$basearch/freshrpms
gpgcheck=1

Il faut aussi charger la clef d'authentification de freshrpms:

 # rpm --import http://freshrpms.net/packages/RPM-GPG-KEY.txt

Maintenant, reste plus qu'à installer le plugins mp3 pour xmms:

 # yum install xmms-mp3

Voilà, mainenant c'est parti pour écouter vos MP3 sans problèmes :up:

Link to post
Share on other sites

Avant il y avait le noyau par défaut dans la distro Fedora Core 2 (2.6.5 je crois)

Sandeman> je vais tenter ça entre midi :mad:

Autre problème annxe, concernant le son: ou est-ce qu'on peut trouver les codec mp3 pour la fedora core 2 (il ne sont pas dedasn pour des problème de licence proprio :francais: )

Link to post
Share on other sites

pour ton pb de son, tu as kde ? dans ce cas, sous kde, tu decoche enable sound system, kde veut gerer le son, notamment avec arts par defaut. Il faut le remettre a sa place et lui rappeller que le son, c'est n'est pas a une interface graphique d'y toucher ! :mad:

Link to post
Share on other sites

Salut,

Franchement ... ben achètes une SB Live 5.1 ! ^^.

Pas cher , de très bonne facture, et rien à voir avec ces chips intégrés.

A part mes portables, tous mes PCs ont une SB (64 ISA, SB Live pour la plus part) et je n'ai jamais regrété leurs achats. (Hélas sur mes 2 portables, j'ai deux chipsets intel pour le son, et ... bof quoi ... même pour l'ICH5, ...).

Dernière en date, celle pour ma soeur. Elle s'était acheté un casque, et avec sa carte son intégrée, ça grésillé tout le temps. Depuis qu'elle a sa SB, plus de problème.

De plus les SB sont très bien reconnu, quel que soit le système (bon j'avoue que NT4 avec une SB Live, ça passe moyen ^^).

Bon, ça ne résoult pas ton problème.

Chez moi, si je mets le son trop fort, ça finit par grésillé méchant (alors que sous Win, pas de problème, le son reste bon). Enfin ça, c'était avant d'avoir reçut de nouveaux modules (drivers) pour cette carte. (MAJ Noyau).

D'un coup, mon portable (HP ZD7009ea) a cessé de freezer, et le son est devenue beaucoup plus limpide en haut volume. (Ben oui, après avoir reçut tellement de mails concernant les problème sur la partie sonore de l'ICH5, nos amis codeurs du libre se sont bien acharnés dessus :mad: ).

Bon, reste que sur mon autre portable (ICH4, Dell D600) le son esst vraiment ... surtout s'il va trop fort. Mais c'est pareil sous Win, alors ...

Essaye différent réglages et de volumes avec le mixeur.

Bon courage,

Guile.

Link to post
Share on other sites

petite parenthèse, niveau carte son les plus balèzes en terme de connerie, c'est Asus qui met un chipset C-Media qui ne supporte pas le SMP sur une carte bipro (i.e. mon ASUS A7M-266D).

Bilan des courses, dès que tu lance un jeu sous 2000, si t"as pas brandouillé grave ton boot (changer de VM et de NTOSKRNL, si, si ...) bah ... BSOD au premier son IRQ_NOT_LESS_OR_EQUAL ...

M'a suffit de mettre une excellente Fortissimo 2 (de chez Carrefour :) ) pour résoudre le pb ... mais c'est con de griller un slot PCI pour ça ...

+1 sur le son pourri du D600 :) enceintes externes sur la station d'accueil, y'a que ça de vrai ...

Link to post
Share on other sites

De plus les SB sont très bien reconnu, quel que soit le système

Ben de toutes facons n'importe quelle distrib c'est le meme noyau a la base... :pleure: lol, nan nan j'avais bien compris, mais il n'y a pas d'autre systeme que linux mes amis !

c'est vrai que le emu10k1 c'est chouette, et sous linux, tu redecouvres ta carte graphique !

EDT : carte son put*** , pas carte graphique evidemment !! :mad:

:francais:

Link to post
Share on other sites

Ben de toutes facons n'importe quelle distrib c'est le meme noyau a la base... ;) lol, nan nan j'avais bien compris, mais il n'y a pas d'autre systeme que linux mes amis !

c'est vrai que le emu10k1 c'est chouette, et sous linux, tu redecouvres ta carte graphique !

:francais:

l'emu10k1 fait aussi carte graphique, trop fort :up:8):-D

(tu voulais dire carte son je pari :mad: )

Bon ben je vais investir dasn un petite SB live! 5.1 (28€ à 500m de chez moi, magazin ouvert entre midi: je crois que c'est négociable :8 )

Et dire que ma première SB 5.1, je l'ai revendu l'an denier à mon frangin pour 10€, parce qu sous windows a tout niveau le SoundStorm était équivalent voir mieux que la SB Live5.1 et ça me faisait gagner un slot PCI

Maintenant, retour aux sources...

AAAAHHHH! le bon vieux temps :pleure:

Link to post
Share on other sites

Re,

Heu, je vais probablement dire une connerie mais ... soundstorm -> NVidia ?

Que viens faire le intel i81x dedans ?

Si c'est bien une NVidia, va sur leur site et dl les drivers pour ta carte son.

Bizarre que la Fedora reconnaisse cela comme du intel i81x (surtout du i81x, du 8X0 c'est mieux ^^).

Sinon, ben ... pas taper.

Link to post
Share on other sites
Re,

Heu, je vais probablement dire une connerie mais ... soundstorm -> NVidia ?

Que viens faire le intel i81x dedans ?

Si c'est bien une NVidia, va sur leur site et dl les drivers pour ta carte son.

Bizarre que la Fedora reconnaisse cela comme du intel i81x (surtout du i81x, du 8X0 c'est mieux ^^).

Sinon, ben ... pas taper.

Tout le problème vient justement que les drivers nvidia actuels pour les nforce sous linux sont incompatibles avec les noyaux 2.6.x. . Du coup le driver ALSA qui marche avec le nforce est ce fameux intel-8x0 ou 81x je ne sais plus.

Je pense qu'il doit correspondre au minimal requis pour le standart AC'97, ce qui est vraiment dommage avec un nforce 2 (pas de 5.1, de 3D dans les jeux, de midi ...)

D'ailleurs sous MDK 10.0, c'était pire ne n'ai eu du son qu'entre le premier reboot et le second... ensuite plus rien quoi que je fasse :transpi::fou:

Et oui SoundStorm c'est la carte son nVidia des nForces...

Donc je vais acheter une SB 5.1 comme ca non seuleument j'aurias un son correct, mais aussi le support des autres options :ouioui:

Link to post
Share on other sites

Sinon sur mon NF7-s v1.x

Donc Nforce2 aussi, impossible à avoir du son potable avec les versions 1.0.4, et 1.0.5 d'Alsa

Je n'ai pas encore testé la 1.0.5a ni la 1.0.6rc2.

Pour l'instant je reste sur la version 1.0.4rc2 qui marche pas trop mal.

Link to post
Share on other sites
Autre problème annxe, concernant le son: ou est-ce qu'on peut trouver les codec mp3 pour la fedora core 2 (il ne sont pas dedasn pour des problème de licence proprio :pleure: )

Salut !

Un petit yum install xmms-mp3 devrait faire l'affaire :yes:

Link to post
Share on other sites
Moi j'avais ça, avec un pb de masse combiné au fait que l'entrée Mic était sélectionnée et à fond ... un p'tit coup d'alsamix et hop ...

Merci c'était ça, juste besoin de baisser le volume de l'entrée video (?)

Pour les mp3 je reçoit ce message:

# yum install xmms-mp3
Gathering header information file(s) from server(s)
Server: Fedora Core 2 - i386 - Base
Server: Fedora Core 2 - i386 - Released Updates
Finding updated packages
Downloading needed headers
Cannot find a package matching xmms-mp3
No actions to take

?

Link to post
Share on other sites

en effet, j'ai trouver des adresse de server pour yum et j'ai trouver xmms-mp3.

Maintenat j'ai un message d'erreur de PGP key...

Je verrais ce soir en rentrant du taf pour résoudre ce dernier problème :incline:

Link to post
Share on other sites

Oui il me semble..; il n'arrive pas à authentifier ou ne trouve pas les donnée pour le faire...

Je verrais le message exact ce soir :incline: , je suis parti n coup de vent un peu à la bourre pour le boulot

Link to post
Share on other sites
remy.harel  Ecrit le 10-08-2004 14:36:42

  ben n'etant pas expert suse, je ne sais pas trop, mais apparement il n'y a pas de paquet nomme xmms-mp3 sur ton mirroir....

Juste pour cela. Pourquoi parlais-tu de la SuSE ? Il est sous Fedora, et il utilise yum, sur un mirroir pour fedora, donc ...

Ha ! Il faut être un expert SuSE pour régler les problèmes de la Fedora :keskidit:

Bon, ben je dois probablement avoir la réponse :cdmalades:

@+,

Guile.

Link to post
Share on other sites

Voilà je suis rentrer. le message d'erreur:

Downloading Packages
Getting xmms-mp3-1.2.10-2.2.p.1.fc2.fr.i386.rpm
xmms-mp3-1.2.10-2.2.p.1.f 100% |=========================|  85 kB    00:00
warning: rpmts_HdrFromFdno: V3 DSA signature: NOKEY, key ID e42d547b
Error: Could not find the GPG Key necessary to validate pkg /var/cache/yum/freshrpms/packages/xmms-mp3-1.2.10-2.2.p.1.fc2.fr.i386.rpm
Error: You may want to run yum clean or remove the file:
/var/cache/yum/freshrpms/packages/xmms-mp3-1.2.10-2.2.p.1.fc2.fr.i386.rpm
Error: You may also check that you have the correct GPG keys installed

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...