Jump to content

debian : install usb 2.0 & carte son creative


ramouz

Recommended Posts

Bonjour a tous,

Voila j'ai installé une debian tout fonctionne nickel :) j'ai recompiler en 2.6.7 allégé, il me reste maintenant a configurer un hdd maxtor de 200 go en usb 2.0 et une carte son creative audigy2 ZS et je ne sais vraiment pas comment faire ...

J'ai comme carte mere une msi 848P.

merci d'avance pour votre aide

Link to post
Share on other sites

usb 2.0

activer le support de l'usb dans le noyau, ainsi que mass storage support.

une carte son creative audigy2

C'est un emu10k1 non ? Dans ce cas, mettre en module dans le noyau alsa, et dans alsa -> pci devices mettre emu10k1 ( audigy etc... ) en module. Ensuite, apt-get install alsa-base alsamixer alsa-sources , puis tu vas dans /usr/src. Tu as normallement un alsa-driver.tar.bz2

tar jxf alsa-driver.tar.bz2

un repertoire module, est cree contenant un sous repertoire alsa-driver...

cd modules/alsa-driver

./configure && make && make install

( tu peux faire un export sur la variable concernant ta carte son afin de ne pas tout recompiler, mais ca marche pas trop mal sans ).

normallement c'est ok. Penses a activer l'emulation oss pour certaines applis le necessitant ( certains jeux a ma connaissance ).

Voila, j'espere que c'etait clair ! :ouioui:

Welcome to the real world ramouz

EDT :PAr defaut, le son sous alsa est coupe, donc apres ton reboot, alsamixer pour le regler, mais je te conseille alsamixergui ( apt-get install ) qui est plus pratique... LE son est sur off par defaut ! Paniques pas !

Link to post
Share on other sites

C'est un emu10k1 non ? Dans ce cas, mettre en module dans le noyau alsa, et dans alsa -> pci devices mettre emu10k1 ( audigy etc... ) en module. Ensuite, apt-get install alsa-base alsamixer alsa-sources , puis tu vas dans /usr/src. Tu as normallement un alsa-driver.tar.bz2

qd je lance l'apt-get install alsa ....

il ne trouve rien :francais::francais:

Link to post
Share on other sites

apt-get update && apt-cache search alsa

pour voir ce qu'il trouve, s'il trouve toujours rien, ben ton sources.list doit etre mauvais...

=> cat /etc/apt/sources.list

Ma workstation au travail est une red hat, donc, je n'ai pas forcement les noms des paquets debian a proximite... .quand je donne un nom, c'est parfois un nom approximatif, il ne faut pas hesiter a chercher un peu a cote... :pleure:

Link to post
Share on other sites

Bon c ok pour la apt-get :)

j'ai fait ca : apt-get install alsa-base alsamixergui alsa-source

mais quand je lance :

rvH:/usr/src/modules/alsa-driver# ./configure && make && make install

j'ai ca comme error :D:keskidit:

make[2]: Leaving directory `/usr/src/modules/alsa-driver/usb'

make[1]: Leaving directory `/usr/src/modules/alsa-driver'

make -C /lib/modules/2.6.7/build SUBDIRS=/usr/src/modules/alsa-driver/kbuild modules

make[1]: Entering directory `/usr/src/kernel-source-2.6.7'

CC [M] /usr/src/modules/alsa-driver/kbuild/../isa/gus/interwave-stb.o

In file included from /usr/src/modules/alsa-driver/alsa-kernel/isa/gus/interwave-stb.c:2,

from /usr/src/modules/alsa-driver/isa/gus/interwave-stb.c:1:

/usr/src/modules/alsa-driver/alsa-kernel/isa/gus/interwave.c:87: error: `isapnp' undeclared here (not in a function)

/usr/src/modules/alsa-driver/alsa-kernel/isa/gus/interwave.c:87: error: `isapnp' undeclared here (not in a function)

/usr/src/modules/alsa-driver/alsa-kernel/isa/gus/interwave.c:87: error: `isapnp' undeclared here (not in a function)

/usr/src/modules/alsa-driver/alsa-kernel/isa/gus/interwave.c:87: error: `isapnp' undeclared here (not in a function)

/usr/src/modules/alsa-driver/alsa-kernel/isa/gus/interwave.c:87: error: initializer element is not constant

/usr/src/modules/alsa-driver/alsa-kernel/isa/gus/interwave.c:87: error: (near initialization for `__param_arr_isapnp.elem')

make[4]: *** [/usr/src/modules/alsa-driver/kbuild/../isa/gus/interwave-stb.o] Error 1

make[3]: *** [/usr/src/modules/alsa-driver/kbuild/../isa/gus] Error 2

make[2]: *** [/usr/src/modules/alsa-driver/kbuild/../isa] Error 2

make[1]: *** [_module_/usr/src/modules/alsa-driver/kbuild] Error 2

make[1]: Leaving directory `/usr/src/kernel-source-2.6.7'

make: *** [compile] Error 2

merci pour l'aide a+

Link to post
Share on other sites
Voila j'ai installé une debian tout fonctionne nickel :) j'ai recompiler en 2.6.7 allégé,
activer le support de l'usb dans le noyau, ainsi que mass storage support.

recompile direct ton noyau en y mettant deja le support alsa pour ta carte son

Sa devrait etre plus simple.

Alsa-source c'est surtout utile pour mettre a jour son pilote

Pour le disque dur-usb

rajoute aussi l'emulation scsi , ce n'est peut etre pas ogligatoire mais

sa peut servir aussi sinon pas de /dev/sd** (celui que j'emprunte en a besoin)

Link to post
Share on other sites

ajoute aussi l'emulation scsi , ce n'est peut etre pas ogligatoire mais

+1 si, car les periph usb sous linux sont associes a des periph scsi.

Pour alsa base, c'est la maniere propre de faire.... :keskidit:

=> ramouz

gcc --version pour verifier ton gcc actuel

cat /proc/version pour verifier celui avec lequel le noyau a ete compile....

ps: je ne sais pas si tu l'as, mais on fait tjs un lien /usr/src/linux qui pointe vers les sources du repertoire contenant les sources du noyau actuel, pour ton cas :

ln -s /usr/src/kernel-source-2.6.7 /usr/src/linux

Link to post
Share on other sites

Bonjour a tous,

gcc --version

gcc (GCC) 3.3.4 (Debian 1:3.3.4-3)

Copyright © 2003 Free Software Foundation, Inc.

This is free software; see the source for copying conditions. There is NO

warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

cat /proc/version

Linux version 2.6.7 (root@rvH) (gcc version 3.3.4 (Debian 1:3.3.4-3)) #1 Tue Jul 27 18:04:18 CEST 2004

ca apparament c'est ok

j'ai fait le lien :

ln -s /usr/src/kernel-source-2.6.7 /usr/src/linux

mais j'ai toujours le meme probleme au moment du :

./configure && make && make install

make[3]: Leaving directory `/usr/src/modules/alsa-driver/usb/usx2y'

DUMMY

make[2]: Leaving directory `/usr/src/modules/alsa-driver/usb'

make[1]: Leaving directory `/usr/src/modules/alsa-driver'

make -C /lib/modules/2.6.7/build SUBDIRS=/usr/src/modules/alsa-driver/kbuild modules

make[1]: Entering directory `/usr/src/kernel-source-2.6.7'

CC [M] /usr/src/modules/alsa-driver/kbuild/../isa/gus/interwave-stb.o

In file included from /usr/src/modules/alsa-driver/alsa-kernel/isa/gus/interwave-stb.c:2,

from /usr/src/modules/alsa-driver/isa/gus/interwave-stb.c:1:

/usr/src/modules/alsa-driver/alsa-kernel/isa/gus/interwave.c:87: error: `isapnp' undeclared here (not in a function)

/usr/src/modules/alsa-driver/alsa-kernel/isa/gus/interwave.c:87: error: `isapnp' undeclared here (not in a function)

/usr/src/modules/alsa-driver/alsa-kernel/isa/gus/interwave.c:87: error: `isapnp' undeclared here (not in a function)

/usr/src/modules/alsa-driver/alsa-kernel/isa/gus/interwave.c:87: error: `isapnp' undeclared here (not in a function)

/usr/src/modules/alsa-driver/alsa-kernel/isa/gus/interwave.c:87: error: initializer element is not constant

/usr/src/modules/alsa-driver/alsa-kernel/isa/gus/interwave.c:87: error: (near initialization for `__param_arr_isapnp.elem')

make[4]: *** [/usr/src/modules/alsa-driver/kbuild/../isa/gus/interwave-stb.o] Error 1

make[3]: *** [/usr/src/modules/alsa-driver/kbuild/../isa/gus] Error 2

make[2]: *** [/usr/src/modules/alsa-driver/kbuild/../isa] Error 2

make[1]: *** [_module_/usr/src/modules/alsa-driver/kbuild] Error 2

make[1]: Leaving directory `/usr/src/kernel-source-2.6.7'

make: *** [compile] Error 2

:transpi::fou:

a+ et merci pour votre aide

Link to post
Share on other sites
j'ai recompiler en 2.6.7 allégé
usr/src/modules/alsa-driver/alsa-kernel/isa/gus/interwave.c:87: error: `isapnp' undeclared here (not in a function)

/usr/src/modules/alsa-driver/alsa-kernel/isa/gus/interwave.c:87: error: `isapnp' undeclared here (not in a function)

/usr/src/modules/alsa-driver/alsa-kernel/isa/gus/interwave.c:87: error: `isapnp' undeclared here (not in a function)

/usr/src/modules/alsa-driver/alsa-kernel/isa/gus/interwave.c:87: error: `isapnp' undeclared here (not in a function)

/usr/src/modules/alsa-driver/alsa-kernel/isa/gus/interwave.c:87: error: initializer element is not constant

/usr/src/modules/alsa-driver/alsa-kernel/isa/gus/interwave.c:87: error: (near initialization for `__param_arr_isapnp.elem')

make[4]: *** [/usr/src/modules/alsa-driver/kbuild/../isa/gus/interwave-stb.o] Error 1

make[3]: *** [/usr/src/modules/alsa-driver/kbuild/../isa/gus] Error 2

make[2]: *** [/usr/src/modules/alsa-driver/kbuild/../isa] Error 2

make[1]: *** [_module_/usr/src/modules/alsa-driver/kbuild] Error 2

make[1]: Leaving directory `/usr/src/kernel-source-2.6.7'

make: *** [compile] Error 2

T'as du supprimer le support du bus isa quand t'a configurer ton noyau et tu le paie

maintenant.

A moins d'une option a passer ou un makefile a modifié , t'est bon pour un nouveau noyau. :transpi:

Link to post
Share on other sites

Bon voila :) g recompile rmon noyau en mettant :

Device Drivers --->

Sound --->

<M> Sound card support x x

x x Advanced Linux Sound Architecture ---> x x

x x Open Sound System --->

<M> Advanced Linux Sound Architecture x x

x x <M> Sequencer support x x

x x <M> Sequencer dummy client x x

x x <M> OSS Mixer API x x

x x <M> OSS PCM (digital audio) API x x

x x [*] OSS Sequencer API x x

x x [*] Verbose printk x x

x x [*] Debug x x

x x [*] Debug memory x x

x x [*] Debug detection x x

x x Generic devices ---> x x

x x ISA devices ---> x x

x x PCI devices ---> x x

x x ALSA USB devices --->

et dans pci devices

<M> EMU10K1 (SB Live! & Audigy, E-mu APS)

make-kpkg --revision=1.0 kernel-image

dpkg --install ../kernel-image-2.6.7_1.0_i386.deb

un reboot et ca va toujours pas :/

Link to post
Share on other sites

maintenant que ton noyau est configure correctement, reprends la procedure que je t'ai donne au debut... a partir des sources alsa... :

rvH:/usr/src/modules/alsa-driver# ./configure && make && make install

Link to post
Share on other sites

le ./configure est ok

mais au make j'ai toujours la meme erreur :

CC [M] /usr/src/modules/alsa-driver/kbuild/../isa/gus/gus_sample.o

CC [M] /usr/src/modules/alsa-driver/kbuild/../isa/gus/gus_simple.o

CC [M] /usr/src/modules/alsa-driver/kbuild/../isa/gus/gus_instr.o

CC [M] /usr/src/modules/alsa-driver/kbuild/../isa/gus/gusclassic.o

CC [M] /usr/src/modules/alsa-driver/kbuild/../isa/gus/gusextreme.o

CC [M] /usr/src/modules/alsa-driver/kbuild/../isa/gus/gusmax.o

CC [M] /usr/src/modules/alsa-driver/kbuild/../isa/gus/interwave-stb.o

In file included from /usr/src/modules/alsa-driver/alsa-kernel/isa/gus/interwave-stb.c:2,

from /usr/src/modules/alsa-driver/isa/gus/interwave-stb.c:1:

/usr/src/modules/alsa-driver/alsa-kernel/isa/gus/interwave.c:87: error: `isapnp' undeclared here (not in a function)

/usr/src/modules/alsa-driver/alsa-kernel/isa/gus/interwave.c:87: error: `isapnp' undeclared here (not in a function)

/usr/src/modules/alsa-driver/alsa-kernel/isa/gus/interwave.c:87: error: `isapnp' undeclared here (not in a function)

/usr/src/modules/alsa-driver/alsa-kernel/isa/gus/interwave.c:87: error: `isapnp' undeclared here (not in a function)

/usr/src/modules/alsa-driver/alsa-kernel/isa/gus/interwave.c:87: error: initializer element is not constant

/usr/src/modules/alsa-driver/alsa-kernel/isa/gus/interwave.c:87: error: (near initialization for `__param_arr_isapnp.elem')

make[4]: *** [/usr/src/modules/alsa-driver/kbuild/../isa/gus/interwave-stb.o] Error 1

make[3]: *** [/usr/src/modules/alsa-driver/kbuild/../isa/gus] Error 2

make[2]: *** [/usr/src/modules/alsa-driver/kbuild/../isa] Error 2

make[1]: *** [_module_/usr/src/modules/alsa-driver/kbuild] Error 2

make[1]: Leaving directory `/usr/src/kernel-source-2.6.7'

make: *** [compile] Error 2

rvH:/usr/src/modules/alsa-driver#

et j'ai bien activer le support isa dans mon kernel :

[*] PCI support x x

x x PCI access mode (Any) ---> x x

x x [ ] Legacy /proc/pci interface x x

x x [*] PCI device name database x x

x x [*] ISA support x x

x x [ ] EISA support

:(

Link to post
Share on other sites

est tu sur d'avoir bien redemarer sur le bon noyau ( le nouveau) ?

Tu l'a bien choisit au demarage ?

fait plutot sa quand tu compile ton noyau

make-kpkg --revision=1.0 kernel-image --append_to_version test1

et ainsi tu te retrouve avec un

kernel-image-2.6.7-test1-1.0_i386.deb qui va t'installer

/boot/vmlinuz-2.6.7-test1

/lib/modules/2.6.7-test1

Tu configure lilo/grub

et ainsi tu est sur de savoir sur quel noyau tu boot et tu peut les collectionner en

mettant test2 test3 .... au moment du make-kpkg .

(penser a garder les sources correspondant au kernel sinon , en cas de besoin faut tout

recompiler)

Link to post
Share on other sites

T'as du supprimer le support du bus isa quand t'a configurer  ton noyau et tu le paie

maintenant.

A moins d'une option a passer ou un makefile a modifié , t'est bon pour un nouveau noyau.  :menfin:

pour ca le support isa

et heu oui je pensa a 99 % que je boot sur mon nouveau kernel mais qd je test avec --append_to_version test1

il me dit ca :

rvH:/usr/src/linux# make-kpkg --revision=1.0 kernel-image --append_to_version test1

/usr/bin/make -f /usr/share/kernel-package/rules real_stamp_image

make[1]: Entering directory `/usr/src/kernel-source-2.6.7'

The changelog says we are creating 2.6.7, but I thought the version is 2.6.7test1

make[1]: *** [real_stamp_image] Error 1

make[1]: Leaving directory `/usr/src/kernel-source-2.6.7'

make: *** [kernel-image-deb] Error 2

rvH:/usr/src/linux#

Link to post
Share on other sites

Il faut sauvegarder ton /usr/src/.config

cd /usr/src/linux

cp .config test1

nettoyer les sources

make mrproper

remettre le .config (ou le refaire/modifié avec make menuconfig)

cp test1 .config

puis

make-kpkg --revision=1.0 kernel-image --append_to_version test1

Link to post
Share on other sites

j'ai fait tout ca mais j'ai tjs le message d'erreur ... decicement c'est pas easy easy :/

make[1]: Leaving directory `/usr/src/kernel-source-2.6.7'

echo done > stamp-kernel-configure

echo done > stamp-configure

/usr/bin/make -f /usr/share/kernel-package/rules real_stamp_image

make[1]: Entering directory `/usr/src/kernel-source-2.6.7'

The changelog says we are creating 2.6.7, but I thought the version is 2.6.7test1

make[1]: *** [real_stamp_image] Error 1

make[1]: Leaving directory `/usr/src/kernel-source-2.6.7'

make: *** [kernel-image-deb] Error 2

rvH:/usr/src/linux#

Link to post
Share on other sites

make[1]: *** [real_stamp_image] Error 1

Aie, pas de chance... voila mon ami real stamp image error...

C'est un noyau venant de kernel.org ou de debian ? Prends un debian pour limiter cela. Tu peux aussi t'en tirer generallement en faisant un make clean avant de recompiler le noyau proprement....

Link to post
Share on other sites

ou alors faut faire

make-kpkg clean a la place de make clean (il doit pas tout tout nettoyer :roll: )

ou alors plus simple (peu etre :chinois: ) :

tu supprime usr/src/kernel-source-2.6.7 et tu redecompresse les sources

tu lui colle le .config et tu recommence.

ou alors vraiment tres simple :-D

apt-get install kernel-image-2.6.7-*

kernel-image-2.6.7-1-386 (Linux kernel image for version 2.6.7 on 386.)

kernel-image-2.6.7-1-686 ( Linux kernel image for version 2.6.7 on PPro/Celeron/PII/PIII/PIV.)

kernel-image-2.6.7-1-686-smp ( Linux kernel image for version 2.6.7 on PPro/Celeron/PII/PIII/PIV SMP.)

kernel-image-2.6.7-1-k7 ( Linux kernel image for version 2.6.7 on AMD K7.)

kernel-image-2.6.7-1-k7-smp ( Linux kernel image for version 2.6.7 on AMD K7 SMP.)

et au moins la sa marchera :deux::chinois:

:chinois:

Link to post
Share on other sites

ça m'a lair pas trop mal configuré... mais tout est en module !!!

Donc il faut tout charger (modules pour emu10k1, mais aussi oss, etc...)

et puis, normalement, il y a des "alsa-utils" (ou un truc dans le genre...)

et au moins lancer "alsamixer"... pour mettre le son à 50% sans "mute" partout

Link to post
Share on other sites

ou alors plus simple (peu etre  ) :

tu supprime usr/src/kernel-source-2.6.7 et tu redecompresse les sources

tu lui colle le .config et tu recommence.

Ouais, c'est une excellente alternative, rapide, et sure.

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...