Jump to content
Dark26

Le Linux BAR - Discussion de tout et de rien

Recommended Posts

Là comme ça, je doute qu'il y ait un soft réellement efficace sous Linux pour récupérer des données sur du NTFS après un formatage, mais ça coûte rien d'essayer !

Share this post


Link to post
Share on other sites
photorec et testimage devraient pouvoir le faire.

+1 Et testdisk meme en cas de formatage rapide...A moins que ce soit de multipass tu peut quand meme recuperer

Share this post


Link to post
Share on other sites

Merci pour toutes vos réponses.

Je suis en train de travailler dessus, mais j'ai quelques soucis : SysrescueCD me permet bien d'accéder aux données, mais je ne trouve pas de logiciels dans le livecd me permettant de lancer une récupération des données formatées ?

Pour testdisk/photorec/testimage, ce sont des logiciels à lancer. Or, je n'ai pas accès physiquement au disque dur (ordinateur portable, impossibilité de démonter) et je ne veux pas démarrer sur le windows installé (sur la partition dont je veux essayer de récup des données) pour ne pas empirer les choses.

Je ne peux pas non plus booter sur un disque externe, l'ordinateur ne gère pas le boot sur USB... Je ne vois donc que le liveCD linux ! Je continue de chercher. Si j'ai mal compris quelque chose dans vos solutions merci de m'aiguiller dans le droit chemin !

Edit : ok j'ai compris, photorec et testdisk sont fournis avec le livecd sysrescueCD

Edit2 : c'est bon, la récupération est en cours. Merci pour votre aide.

Share this post


Link to post
Share on other sites

Enfin sur Linux depuis deux jours :p

Suite à un énième non fonctionnement de ma carte TV sous Windows, et pas du tout envie de passer à 7, j'ai décidé de me remettre à nunux et de m'y accrocher, résultat ma carte TV fonctionne au quart de tours (bon quelques problème avec l'audio dans les chaines TNT HD mais rien d'insurmontable je pense ) c'est beau et propre, rapide, intuitif, bref pour le moment j'aime assez :D

Share this post


Link to post
Share on other sites

Peux-tu nous préciser quelle distro tu as choisi ? Quelle carte TV ?

Sinon, de mon côte, toujours des soucis avec Debian (testing)... j'essaie d'installer le driver Nvidia avec module-assistant, mais la compilation échoue.

Seulement au moment où j'ai l'écran d'erreur, si j'appuie sur une des touches directionnelles (pour faire défiler le log) module-assistant s'arrête ...

Y a-t-il un autre moyen de voir l'erreur ?

Share this post


Link to post
Share on other sites

idem repassé sous kubuntu j'ai du désactiver les effets du burreau (domage) -clignotements intempestifs-

la je cherche un plasmoide radio...rien trouvé :( pour le reste j'ai enfin réussi a me dépatouiller de mes précédents soucis content ^^

Share this post


Link to post
Share on other sites

Bonjour tout le monde.

Je fais un passage vite fait pour une question.

Je souhaite passé sur Mandriva en KDE, mais je vois que les version One ne sont qu'en 32 bits, je voudrais savoir si il est possible d'enlever la limitte de Ram ?

Car sinon il reste la version Free x64 mais n'a pas de pilote proprio et disons que je ne suis pas encore une bête de guerre Linuxien :francais:

Merci d'avance.

Share this post


Link to post
Share on other sites

y a bien le mode PAE , mais doit y avoir des bugs. :up:

Mais je sais pas, 4Go, c'est bien ce que tu as non ?

Share this post


Link to post
Share on other sites
Oui j'ai 4 Go et un CPU athlon 64x2 6000+ ( c'est le pc qui est dans ma sign en config 1 )

alors normalement, les 4Go seront pris en charge en totalité.

Share this post


Link to post
Share on other sites

4Gb seront geres *en tout*

donc, modulo la ram de ton chip graphique (et probablement d'autres conneries)

meme si c'est pour pas grand chose (quoiqu'on voit de plus en plus de CG embarquant 1Gb de DDR), il vaut mieux s'emmerder a mettre un PAE.

ou sinon, envisager de sauter le pas pour le 64b

c'est pas 'parfait', mais sur une utilisation courrante, on ne remarque pas la difference

quelque soit la distrib, on se retrouve plus ou moins avec ce meme probleme: des connards distribuent pas leurs sources

dans ces cas-la, on regarde quels lib sont manquantes, et on va installer `lib32-$lib'

apres, mandriva, c'est peut-etre pas le bon exemple, avec cette histoire de driver proprios...

t'as une idee de quels perifs auraient besoin de ces drivers ?

Share this post


Link to post
Share on other sites

Le pilote proprio sera uniquement pour la carte graphique, car en version Mandriva Free edition 64, il reconnait le Gpu en HD 2xxx ( alors que j'ai une HD 4830 )

Du coups il est impossible d'utiliser les effet de Compiz.

Sinon actuellement je suis sous Linux Mint 8 Helena 64 Bits et Windows 7 Pro 64 bits.

Donc en gros j'aurais voulu remplacer Mint 8 ( Gnome ) pour une Mandriva en KDE ( j'ai test Mint en KDE mais il laisse une impression de non fini ).

@ouragan : justement il voit que j'ai 3.8 Go en Ram quand je suis en version 32 Bits ( que ça sois Mandriva et Ubuntu ) Donc sois j'utilise le PAE si j'ai pas de solution, Sois je cherche une autre Dristro :dd:

Share this post


Link to post
Share on other sites

pour le principe, un coup de propagande :

ArchLinux, ca troue le cul

plutot light

un arriere gout de BSD

simple sans etre "user-friendly"

je sais pas ce que ca donne avec KDE (allergique), mais gnome+compiz en 64b (6Gb de ram) tourne parfaitement

par contre, nvidia, je ne sais pas ce que donnent les driver catalyst, mais ca a l'air documente sur le wiki

Share this post


Link to post
Share on other sites

Oui pourquoi pas, d'ailleurs en parlent d'arch linux, existe t'il une installe version graphique ?

car j'ai un Cd d'arch mais l'installation ce fait en ligne de commande -_-'

Sinon pour Gnome + Compiz ça fonctionne super bien aussi mais uniquement sur LinuxMint ( j'ai test sur Ubuntu 9.10 mais il bug direct, pourtant Mint est basé sur Ubuntu )

Sinon merci pour les renseignements il me reste à lire les Wiki pour avoir plus d'info.

Edit : je me lance dans l'installation d'ArchLinux, j'ai du me planter dans le Grub il me dit Error Grub ou un truc de ce genre, va falloire que je regarde ou je me suis viander :dd:

Share this post


Link to post
Share on other sites

Excellent choix ^^

bon courrage

j'ai decouvert "recemment", j'ai pas cherche a voir les differents installeurs

d'autant plus que celui en console est particulierement bien concu

exception faite de la gestion des disques

je sais plus trop comment j'en etait arrive la

j'avais du retourner sur une etape d'une section precedente (les connaisseurs comprendront)

en voulant poursuivre, en revenant ou je m'etais arrete, ou en reprenant juste apres mon erreur, pas moyen, l'installeur etait pomme

mais globalement, si tu fais tout bien dans l'ordre, tout va bien se passer

pour le grub error, donne nous plus de details

peut-etre est-ce le disque de boot mal indique (hd1,0 au lieu de hd0,0, ou inversement) ?

il y a une chose qu'on peut reprocher a arch, c'est qu'il a tendance a pas toujours loader ses perifs dans le meme ordre

il y a des manips pour les forcer/fixer, mais quand on fait pas attention, ca fait des surprises.

comme sur ma gate, qui apres un reboot, s'est mise a filtrer mon reseau local sortant...

(

au passage, la solution:

mv /etc/udev/rules.d/75-persistent-net-generator.rules.optional /etc/udev/rules.d/75-persistent-net-generator.rules

reboot

....

mv /etc/udev/rules.d/75-persistent-net-generator.rules /etc/udev/rules.d/75-persistent-net-generator.rules.optional

et ca bougera plus

)

quoi qu'il en soit, peut-etre le media d'installation a-t-il ete pris en compte dans l'enumeration des perifs, et ton disque ne serait maintenant plus a la meme position dans cette liste

et dernier conseil:

shm est automatiquement monte avec la moitie de ta ram. tu peux modifier ca dans le fstab

et quand t'as de la ram en masse, monter /tmp dessus, c'est cadeau, meme remarque pour la taille

dans ton fstab, remplace les /dev/toto par /dev/disk/by-uuid/[uuid], ca evitera de monter les disques aleatoirement (d'autant plus genant quand c'est / qu'il retrouve plus...)

devpts						/dev/pts	devpts	defaults	0	0
shm						/dev/shm	tmpfs	nodev,nosuid,size=1024M	0	0
tmpfs						/tmp		tmpfs	size=1024M	0	0
UUID=6df938ed-9f5c-44b0-966d-d19b688307ae	/		ext4	defaults	0	1
UUID=649e4f86-ad70-43ab-aa7a-0510fef3a020	/home		ext4	defaults	0	1
#UUID=f78f5471-802e-4246-8c23-ae83ef3a55b0	/mnt/ovrflw	ext4	defaults	0	1
UUID=bef395ca-f10c-48e5-b9df-17dc4092a2e1	/mnt/videos	ext4	defaults	0	1
UUID=30a5e93a-dcd5-40ca-81bf-1491ffff5f4d	/mnt/storge	ext4	defaults	0	1
UUID=931f83d9-cec9-4190-bf6d-909439284e4f	/mnt/vrtual	ext4	defaults	0	1

Share this post


Link to post
Share on other sites

quand je redémarre l'ordi, il met Grub error 22.

donc je dois utiliser le cd Arch pour pouvoir aller sur Windows 7.

donc je pense que le MRB à pris un coups, d'ailleurs l'ordi ne veut plus boot le DVD de windows 7 :keskidit:

donc je pense que je vais devoir formater entièrement le disque dur, installer Windows 7 et ensuite Arch ( Windows 7 pour jouer et regarder la TV )

je vais redonner plus d'info demain.

merci Mephisto

EDIT : J'ai fais un formatage, installer Win 7, divisier le Hdd en 2, installer Arch sur la partition libre, le Grub à bien fonctionner mais j'ai encore du me tromper car cette fois si, j'ai pas Windows qui apparait dans la liste.

Je vais ouvrir un sujet sur le forum pour ne pas pollué le bar. :keskidit:

Share this post


Link to post
Share on other sites

Xorg 1.8 passé officiellement sur dépôt testing de Archlinux, donc comme j'ai une Nvidia et bien désactivation de testing :chinois:

Mais si ça intéresse des gens sur archlinux de tester, pourquoi pas donner leurs impressions.

Share this post


Link to post
Share on other sites

Voilà les drivers Nvidia avec le support xorg 1.8 étant arrivé, je suis passé donc a ce fameux Xorg 1.8.

Bien sur plus de clavier azerty mais suffit de découvrir un peu comment configurer Xorg pour se rendre compte que c'est un vrai régale et me revoilà avec un clavier azerty.

Share this post


Link to post
Share on other sites

j'ai cru comprendre qu'ils avaient *enfin* vire hal ?! :ouioui:

effectivement, au premier lancement, doit y avoir de la conf a reprendre

par contre, devicekit, je l'ai deja vu installe, mais j'ai aucune idee de comment ca tourne

en quoi c'est sence etre 'mieux' que hal ?

Share this post


Link to post
Share on other sites

Perso j'ai encore HAL parce que certains programmes l'utilise encore.

Par contre je sais pas trop pour devicekit parce que finalement c'est surtout le fait que Xorg tourne avec udev du noyau. J'ai pas encore utilisé devicekit donc je peux rien dire la dessus.

Share this post


Link to post
Share on other sites

je poste ici ça pourra peut être servir à quelqu'un :transpi:

Pour mon serveur j'utilise un "bond" ou teaming, histoire de coupler 2 carte réseaux gigabits pour avoir 2 fois plus de bande passante.

soit 2 carte avec disons comme address mac aa:aa:aa:aa et la deuxième bb:bb:bb:bb

on va créé une carte réseau virtuelle ( bond0) qui va donc regouper les 2 cartes réseaux et prendre une des 2 adresse mac soit par exemple aa:aa:aa:aa.

cette action va donner la même address au 2 cartes, soit aa:aa:aa:aa

ça fonctionne!!!!

sauf qu'au redemarrage --> plus rien de fonctionne... :incline:

en effet, je ne sais pas comment le linux se débrouille :p , mais il change en "dur" l'adresse ip des cartes réseaux. Et donc au reboot les 2 cartes ont encore la même adresse mac :D , et du coup udev qui par défaut se base sur ça pour différencier les cartes réseaux, n'en trouve qu'une :transpi: au lieu de 2

il faut donc modifier le fichier /etc/udev/rules.d/70-persistent-net.rules, pour forcer udev à detecter les cartes réseaux, non pas via l'adresse mac, mais plutôt avec le bus détecté dans le kernel

SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", KERNELS=="0000:06:00.0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"

SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", KERNELS=="0000:08:00.0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth1"

SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:a0:c9:d1:65:91", ATTR{type}=="1", KERNEL=="eth*", NAME="eth2"

dans mon exemple j'ai laissé la troisième carte réseau avec l'adresse mac, car elle ne fait pas partie du bond, et ne pose donc pas de problème.

voila.

Share this post


Link to post
Share on other sites

Maj de compiz aujourd'hui sur Archlinux et c'est le drame :

* Detected Session: unknown
* Searching for installed applications...
* NVIDIA on Xorg detected, exporting: __GL_YIELD=NOTHING
* Using the GTK Interface
* Starting Compiz
... executing: compiz --replace --sm-disable --ignore-desktop-hints ccp
compiz (core) - Error: Plugin 'core' has ABI version '20090619', expected ABI version '20091102'.

compiz (ccp) - Error: InitObject failed
compiz (core) - Error: Couldn't activate plugin 'ccp'
compiz (core) - Error: Plugin 'core' has ABI version '20090619', expected ABI version '20091102'.

compiz (ccp) - Error: InitObject failed
compiz (core) - Error: Couldn't activate plugin 'ccp'

ça fonctionne plus, je vais attendre de voir, si d'autre personne on se soucis et peut être une maj supplémentaire.

Je sais pas si cela a un rapport avec la maj du noyau et des drivers nvidia [testing].

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...