Jump to content

Archived

This topic is now archived and is closed to further replies.

mjean-pierre

Help Dns Please!

Recommended Posts

Salut a tous, voila voilou je suis sur fedora 1 et je voudrai configurer mon dns.

le prob c qu'il y a bien longtemp que g configurer un dns donc je me rapel plus rien :brice::kill: en effet j'etais sur la redhat9 qui fonctionnait super bien et g voulu me mettre sur la fedora 1 avant de me mettre sur la 2. moi la 9 une fois configurer je n'y est plus touché y a bien longtemp. Maintenant je suis bloquer :kimouss::transpi:

je me rapel plus de rien galère g les boules un vrai trou noir!

voici donc mes fichiers.

/etc/host

127.0.0.1 localhost localhost.localdomain localhost

192.168.2.2 mamachine mamachine.mondomaine.net

/etc/resolv.conf

nameserver 127.0.0.1

/etc/named.conf

//generated by named-bootconf.pl

option {

directory "/var/named";

/*

* bla bla bla

* bla bla bla

// query-source address * port 53 ;

version "SECRET" ;

}

// a caching only nameserver config

zone "." IN {

type hint ;

file "named.ca";

} ;

zone "O.O.127.in-addr.arpa"

{

type master;

file "O.O.127.in-addr.arpa"

};

/var/named/0.0.127.in-addr.arpa.zone

$TTL 86400

localhost. IN SOA localhost root (

5 ; serial

28800 ; refresh

14400 ; retry

3600000 ; expire

86400 ; ttl

)

localhost. IN NS localdomain

comprend plus rien g tout oublier :p il est vrai que ca fait deja 2 ans la derniere fois que g mis les mains dedans.

svp si qq'un peut m'aider se serai super sympas merci d'avance!!

Share this post


Link to post
Share on other sites

Moi , je te dirait de lacher fedora 1 et de passer directe a fedora 2,

car sa ne doit pas etre pour rien qu'ils ont sortie une nouvelle version.

De plus , j'ai cru comprendre que l'on ne peut pas passer de fc1 a fc2 sans tout formater.

(upgrade impossible ou tres deconseillé )

sinon , je suis sous debian:

/etc/host:

127.0.0.1 localhost localhost.localdomain fuckingpc

# The following lines are desirable for IPv6 capable hosts

# (added automatically by netbase upgrade)

::1 ip6-localhost ip6-loopback

fe00::0 ip6-localnet

ff00::0 ip6-mcastprefix

ff02::1 ip6-allnodes

ff02::2 ip6-allrouters

ff02::3 ip6-allhosts

/etc/resolv.conf

search

nameserver 212.27.39.134

nameserver 213.228.0.23

/etc/named.conf

j'ai pas sa moi

/etc/hostname

fuckingpc

mais , je n'ai pas de passerelle comme toi ,apparament.

Share this post


Link to post
Share on other sites

he bien merci pour ta réponse bien que ca ne m'avance pas réellement je continue tj a cherche dans les meandres du trou noir.

merci a +

Share this post


Link to post
Share on other sites

tu veux configurer un serveur DNS ou juste les DNS d'un client reseau ?

Share this post


Link to post
Share on other sites

le server dns de la fedora 1 bref comme je faisait sur la rh9 si j'arrive a tou faire sur la f1 comme sur la rh9 alors j'efface tout et je passe a la f2.

si tu peut m'aider merci par avance

Share this post


Link to post
Share on other sites

en fait je me servait de la rh9 comme passerel et comme firewall server webmail https et je l'ataquai sous ssh. maintenant g pris hier la decision de passer a la fedora et donc apres les sauvegardes g tout kc pour y mettre la f1 mais le dns m'enrapel plus :roll: donc je continue a installer mon https et mon webmail en attendant que cela me reviene!

Share this post


Link to post
Share on other sites

Tu es sur que c'est le DNS qui merde ? pas le NAT plutot ?

Share this post


Link to post
Share on other sites

yes quand je fais un named-checkconf il me dit que tout va bien

et quand je fais un nslookup il me dit

>127.0.0.1

server: 127.0.0.1

address: 127.0.0.1#53

** server can't find 1.0.0.127.in-addr.arpa: servfail

>

Share this post


Link to post
Share on other sites

ifconfig -a

eth0 et eth1 normal avec ce qu'ils on recu et envoyer

lo normal aussi avec rx et tx normal et aucune error pas de collisions bref normal

netstat -ar

192.168.2.0 * 255.255.255.0 u o o o eth1

192.168.1.0 * 255.255.255.0 u o o o eth0

169.254.0.0 * 255.255.0.0 u o o o eth0

127.0.0.0 * 255.0.0.0 u o o o lo

voila msieur!

Share this post


Link to post
Share on other sites

normal que tu n'aies pas de passerelle par defaut ? ( je sais, le pb ne vient pas de la...)

ping mamachine donne quoi ? Nom inconnu ?

Share this post


Link to post
Share on other sites

ping 127.0.0.1 ok

ping mamachine ok

oui pas de passerel maintenant je suis au stade de la configuration pour l'instant

je pencherai plus sur un prob de conf des fichiers de zones non?

quand pense tu?

Share this post


Link to post
Share on other sites

J'en pense que c'est un probleme plutot interessant, ca change du ./configure qui merde en disant que gcc n'est pas la bonne version et l'utilsateur lambda qui demande quel est le pb, sans vouloir etre mechant.

/etc/resolv.conf

search

nameserver 212.27.39.134

nameserver 213.228.0.23

Pourquoi search ?? Ca n'a rien a faire ici je pense. Moi je le virerais.

De plus, si tu n'as pas de passerelle par defaut, il ne sait pas trouver la route qui mene a tes serveurs dns ( 212.27.39.134 et 213.228.0.23 ). En effet, d'apres netstat -ar, ton linux sait aller sur les reseaux :

192.168.2.x

192.168.1.x

169.254.x.x

127.0.0.1

Mais il ne connait en aucun cas 212.x.x.x Il faut donc ajouter une passerelle par defaut ( Default Gateway ) sur la carte qui te relie au reseau qui contient ces serveurs. :-D

Share this post


Link to post
Share on other sites

ben la je croit que tu a eu un loupé mon ami car moi je n'est pas de passerel comme je te l'es dit precedement car c sur la fedora que je veut mettre mon dns pour le faire tourné en interne :-D

c zaverel qui a ecrit ca pour me répondre regarde bien!

Share this post


Link to post
Share on other sites

tu aurais donc un DNS internet, par ton FAI, et un local, pour tes 3 ordis locaux ??? C'est tordu la..., ou j'ai loupe qq chose....

Share this post


Link to post
Share on other sites

attend je t'explique mon ami, g un petit rezo en interne celui ci utilise ma fedora comme serveur dns comme webmail et https puis comme passerel. quand une requete interne demande le www mon dns interne "la fedora" me redirection sur le dns externe du FAI voila. ai-je bien expliqué? :fou:

Share this post


Link to post
Share on other sites

oui. Le mieux, est d'avoir un fichier configure sur chaque client avec les nom des machines ( /etc/hosts ) et un seul DNS sur tous les postes, celui de ton FAI. Lorsqu'un client voudra acceder a un nom qu'il ne connait pas, il ira chercher le DNS du FAI et utilisera la passerelle par defaut pour sortir, ta fedora. On est sur la meme longueur d'ondes ou je suis a cote de la plaque ?

Share this post


Link to post
Share on other sites

:transpi::D a coté ca c la solution la plus simple moi ce que je veut c quand je fais un nslookup sur ma fedora et que je lui demande par exemple 127.0.0.1j'aimerai qu'il me fasse la conversion de nom son boulot quoi qu'il me trouve localhost.

alors que la il me répond

>127.0.0.1

server: 127.0.0.1

address: 127.0.0.1#53

** server can't find 1.0.0.127.in-addr.arpa: servfail

:fou:

Share this post


Link to post
Share on other sites


[-------]$ nslookup 127.0.0.1
Note:  nslookup is deprecated and may be removed from future releases.
Consider using the `dig' or `host' programs instead.  Run nslookup with
the `-sil[ent]' option to prevent this message from appearing.
Server:         *******
Address:        ******#53

1.0.0.127.in-addr.arpa  name = localhost.0.0.127.in-addr.arpa.

[--------]$

hihihihi :fou:

Share this post


Link to post
Share on other sites

:fou: aller soit sympas c quoi la conf des fichiers? je vais etre obliger de rester 3 plombe s sur se meme probl et le pire c que je savais faire jusqu'a la rh9.

bah c pas grave on vas si remetre 3 plombes on va bien trouvé? dison que ca m'aurai fait gagné du temp quoi c claire :D

bien alors :transpi: ?

Share this post


Link to post
Share on other sites

en fait j'utilise un client, je n'ai pas acces au serveur DNS, car c'est enorme notre reseau ( 10 000 clients ). Sur mon poste, j'ai donc qq noms specifiques dans le /etc/hosts et un /etc/resolv.conf avec un search <nom de notre domaine> suivi du nom des serveurs DNS, sur le reseau local.

Et le client a evidemment une passerelle par defaut de configuree, pour pouvoir aller chercher ces adresses.

Share this post


Link to post
Share on other sites

ok donc la conf du server dns lui meme sur la fedora tu c pas?

ben tampis je vais cherche :transpi:

merci quand meme de m'avoir repondu c sympas!

Share this post


Link to post
Share on other sites

Je pense que ce qu'il veut faire, c'est une sorte de DNS cache ...

...un PC qui est considérée comme serveur DNS, donc quand on demande une IP à partir d'un nom, si c'est dans son domaine, elle renvoie direct, sinon, elle va demander au DNS web et le donne...

ça permet de limiter la BP internet...

Déjà il faut configurer le serveur DNS ... :transpi:

Share this post


Link to post
Share on other sites

×
×
  • Create New...