Jump to content

Archived

This topic is now archived and is closed to further replies.

green

Suse 9.1

Recommended Posts

J'ai téléchargé Suse 9.1 personal (1 seul CD) pour voir.

Bon l'installation se passe assez lentement par rapport à Mandrake mais tout se passe bien, j'ai pas le choix des paquets (c'est une version de démo en quelque sorte).

Par défaut, Suse voulait s'installer sur hda7 qui est le /home de Mandrake 10, il a fallu un peu lutter pour lui imposer autre chose à savoir hda2, enfin on y arrive.

La swap est prise en hda6.

Déception pas de MPlayer et pas de lecture dvd cryptés ou non , bon ça peut s'arranger, pas grave...

Le kernel est : 2.6.4-52-default et pppd est installé (c'est déjà ça !).

J'ai un modem ECi : je tente de l'installer avec le tar.gz hélas au ./configure on me fait savoir qu'il manque "make"... (donc gcc ?) ou alors c'est une histoiire de PATH ?

Alors j'installe le rpm, Yast se met en route, c'est bon il n'y a pas de dépendances (ouf).

Le PATH de Suse n'est pas celui de Mdk, pour appeler 'eciconf.sh' je dois d'abord aller sur: /usr/local/bin et taper ./eciconf.sh (ou modifier le PATH).

Hélas, on me dit qu'il manque tk...donc pas d'interface graphique, tant pis...

Alors je tape ./eciconftxt.sh et je remplis les champs en mode texte.OK.

Pour Suse, il faut modifier le fichier /usr/local/bin/startmodem pour que ça fonctionne (sur Mandrake pas la peine) alors j'ai pensé à kwrite comme éditeur...

Evidemment le chemin de celui-ci n'est pas standard ni dans le PATH de root et c'est /opt/kde3/bin (!).

Et à chaque fois il refuse de s'exécuter pour la raison suivante :

"Xlib : connection to ":0.0" refused by server - Xlib : protocol not specified-cannot connect ...etc ...

Je me dis installons le driver Nvidia pour voir :

Le fichier à modifier sur Suse n'est pas XF86Config-4 mais XF86Config, mais peu imorte ça marche.

Il n'y a pas Tuxracer d'installé mais glxgears marche.OK.

Par contre, j'ai toujours le même message quand je tape : #cd /opt/kde3/bin

#./kwrite

Et je ne peux donc pas modifier le fichier 'startmodem', je sais je peux utiliser vi mais celà ne me dira pas pourquoi kwrite ne marche pas ...

Que dois je faire pour que kwrite veuille bien s'afficher ?

J'AI PAS ETE TROP LONG ?

SORRY..;

:chinois:

Link to post
Share on other sites

Ce qui est bizarre, c'est que je peux lancer kwrite en console (ça s'affiche à l'écran) si je suis en simple user, mais pas en root donc ...

Le brestois remu pas d'idée ?

Link to post
Share on other sites

ben normalement, le root n'est pas sensé utiliser kwrite... :francais:

Le "su" pose quelque fois des problèmes de ce genre...

Si tu veux vraiment utiliser kwrite, logge toi dans une vraie console, lance un serveur X avec startx, puis export DISPLAY=":1" (si c'est en plus du :0), et /opt/kde3/bin/kwrite

Link to post
Share on other sites

Salut,

Effectivement, SuSE ne propose que le premier CD en ISO sur son site. Ensuite tu peux récupérer tous les paquets vi le net. (Ce qui peut être très problématique par exemple si tu as besoin de certians paquets pour pouvoir te connecter au net. Mais normallement le 1er CD contient tout ce qu'il faut)

Pour utiliser kwrite en tant que root, tu tapes :

> xhost+ (en tant qu'utilisateur) (pas taper, je sais que c'est pas super sécur et qu'il y a "sudo" ou autre, mais pour une manip ou deux :incline:)

# /opt/kde3/bin/kwrite

Pour MPlayer et tout ce qu'il faut pour lire les DVDs cryptés ou pour avoir n'importe quels codecs, utilses APT4RPM, après avec un apt-get ou synaptic, tu récupèreras ce que tu veux.

Dans le path de root, il n'y a que ce que root est sencé utiliser pour l'administration (donc pas de kwrite ^^)

Pour tous ce qui ne te parait pas standart, tu veux dire pas comme sur la Mandrake ?

SuSE respecte la norme LSB, c'est tout. Mandrake va y venir dans peux de temps (SuSE est l'une des premières, sinon la première, à utliser le /media et d'autre trucs en provenance de cette norme)

Si tu as d'autres questions, n'hésites pas :chinois:

Link to post
Share on other sites

Des questions ? allons-y alors...merci X-Guardian.

Tout d'abord il y a un site indiqué ici :

http://forums.the-myos.net/index.php?showtopic=33

et qui permet à partir du cd unique Suse Personal de passer à une Suse proche de la PRO.

j'ai commencé à télécharger différentes choses comme gcc, mozilla,totem,xchat,tuxracer,d4x et j'en passe ...

Donc :

1°)Connais tu d'autres sites que je pourrais rajouter à celui-ci ?

Avec celui que j'ai il n'y a pas Mplayer ni ce qu'il faut pour lire un dvd même non crypté.J'ai pourtant installé libdvdnav et libdvdplay mais ça ne suffit pas.

Comment fait YAST quand il a sur 2 sources distantes 2 rpms de génération différente et que tu lui demandes d'installer le paquet ?

2°)Comment faut-il s'y prendre pour garder sur le disque dur les rpms téléchargés ? (équivalent de urpmi --noclean)

Car je compte mettre Suse sur une autre partition maintenant que je l'ai essayée et j'ai pas envie de tout retélécharger...

3°)Où je peux trouver synaptic, APT4RPM ?

Ca change quoi par rapport à YAST qui a l'air très bien, du moment qu'on lui donne une source de rpms et qu'il trouve les dépendances, comme urpmi quoi...

4°)J'ai 2 partitions windows : hda1 NTFS et hdb4 : FAT32 et sous Suse je vois sous /windows 4 partitions : c, C, d et D ????

5°)Enfin quand j'insère ma clé usb, contrairement à Mandrake aucun icône n'apparait sur le bureau.

J'ai trouvé sous /media un usb-storage avec plein de numéros mais quand je clique desssus ça plante lamentablement...

6°)Donc je tape en user : > xhost+ et en root : /opt/kde3/bin/kwrite ?

Que fais exactement la commande xhost+ ?

TUXXX : tu pourrais être plus explicite, j'ai rien compris :oops:

Désolé pour toutes ces questions, je suis un habitué de Mandrake et Suse c'est un peu différent quand même, j'aime bien les deux.

Il faudra que je vérifie si la lecture des xvid se passe normalement car sous Suse 9, ça saccadait à mort :pleure: alors que sous Mdk c'était nickel. :transpi:

Link to post
Share on other sites

Sinon pour mon histoire de kwrite, j'aurai pu déplacer en console et en root le fichier startmodem sur mon dossier personnel, appeler kwrite en mode graphique, modifier startmodem (là j'ai droit) et puis de nouveau en console en root remettre startmodem là d'où il vient...

C'est un peu tordu quand même, non ?

Link to post
Share on other sites

en root : chmod 777 [path]/startmodem

puis tu modifie...

Mais bon, je te conseille quand même de te familiariser avec vi(m) qui marche tout le temps (su, ssh, etc...), ou bien à la limite gvim qui marche en tant que root aussi...

Pour ton problème, sinon il faut faire :

->soit un "xhost +" qui permet à tout le monde de voir ce que tu fait mais aussi de pouvoir lancer ensuite n'importe quelle appli sur ce serveur X... (c'est pas beau...)

->soit lancer un nouveau serveur X en faisant "X :1", "export DISPLAY=:1", et ensuite kwrite... (c'est plus sécurisé...)

...sinon il y a une autre manière encore, c'est d'utiliser ssh avec l'option "-X" pour le X tunelling:

"ssh -X root@localhost", "kwrite ..." (mais il faut avoir ssh...)

...enfin bref, tout ça parce que tu ne veux pas utiliser vi pour modifier 3 lignes...

Link to post
Share on other sites

...enfin bref, tout ça parce que tu ne veux pas utiliser vi pour modifier 3 lignes...

Non, non j'ai utilisé VI que je connais un peu, comme j'ai dû un jour installer le driver NVIDIA , il a bien bien fallu m'y intéresser ... un peu ... je sais il est puissant etc ... mais j'ai du mal quand même à pas le trouver non convivial.

CECI N'EST PAS UN TROLL.

soit lancer un nouveau serveur X en faisant "X :1", "export DISPLAY=:1", et ensuite kwrite... (c'est plus sécurisé...)

?? Comment tu fais ça ? je tape "X :1" et "export DISPLAY=:1" où ?

Et cela veut dire quoi ?

C'est plus sécurisé ?? Je risque quelquechose en modifiant un fichier sous Suse, j'avoue que je n'y comprends rien toutes ces précautions pour quelquechose qui paraît anodin...

J'aimerai bien comprendre la logique du truc . :transpi:

Link to post
Share on other sites

Re,

Merci pour l'info concernant le site (MAJ SuSE Perso -> SuSE Pro), ça va en aidé plus d'un. Moi je m'en fous j'ai les packs pas loin et le DVD à coté de mon PC ^^

1°)Connais tu d'autres sites que je pourrais rajouter à celui-ci ?

Non, je n'utilse pas Yast pour mettre à jour mes packages. Juste YOU pour les MAJ de sécurités et le noyau.

Pour le reste, j'utilise apt4rpm (il permet d'installer des rpm avec les commandes et la gestion de apt)

Si tu vas voir mon tuto, tu sauras comment l'installer et l'utiliser ;)

2°)Comment faut-il s'y prendre pour garder sur le disque dur les rpms téléchargés ? (équivalent de urpmi --noclean)

Car je compte mettre Suse sur une autre partition maintenant que je l'ai essayée et j'ai pas envie de tout retélécharger...

Yast mets tous les packages dans /var/lib/YaST2/you/ Sauvegardes tous ce qui est à l'intérieur. Il te suffira de les rajouter plus tard dans ta nouvelle install. Quand tu lanceras YOU, il vérifiera dans ce répertoire si tu ne contient pas déjà les MAJ. Dans ce cas, il ne les téléchargera pas.

Pour apt, les mises à jour seront dans /var/cache/apt/

3°)Où je peux trouver synaptic, APT4RPM ?

Ca change quoi par rapport à YAST qui a l'air très bien, du moment qu'on lui donne une source de rpms et qu'il trouve les dépendances, comme urpmi quoi...

Synaptic sera installer de base avec apt (tout est dans le tuto).

Avec APT4RPM tu peux facilement mettre à jour toute ta distrib (une ligne, apt, un clique, synaptic ^^), et la liste regroupe les principaux ftp regroupant des paquets pour SuSE.

Si tu trouves un moyen de faire cela avec Yast, je suis preneur ^^

4°)J'ai 2 partitions windows : hda1 NTFS et hdb4 : FAT32 et sous Suse je vois sous /windows 4 partitions : c, C, d et D ????

Tu remarquers sous konqueror, que les petits "c" et "d", je crois, ont une petite flèche en bas de leurs icônes. (A moinns que ce ne soit "C" et "D" ...) Ce sont justes des raccourcis. C'est la même chose ^^.

Moi je ne les ai pas, j'avais appelé autrement mes partitions windows (respetivement /WinXP et /Jeux)

5°)Enfin quand j'insère ma clé usb, contrairement à Mandrake aucun icône n'apparait sur le bureau.

J'ai trouvé sous /media un usb-storage avec plein de numéros mais quand je clique desssus ça plante lamentablement...

Ces numéros sont justes le code d'identifcation de ta clé. C'est un numéro unique si je ne me trompe pas. (montage subfs :mad2:)

Pour l'icône, tu fait un clique droit sur le bureau -> Configurer le bureau -> Comportement -> Icone des périphériques

Pour le plantage, tu pourrais me donnais des détails. Chez moi, j'ai un jukebox, un appareil photo, un graveur DVD externe. Je n'ai pas de problème avec le montage de ces périphs.

6°)Donc je tape en user : > xhost+ et en root : /opt/kde3/bin/kwrite ?

Que fais exactement la commande xhost+ ?

Youps ... je me suis trompé, c'est "xhost +" et non pas "xhost+". J'ai tappé trop vite ^^·

Pour les détails, tuXXX te l'a expliqué.

Pour la sécurité, tu fais un "xhost +", ta commande, "xhost -" et tout est redevenu normal.

"xhost +" authorise tout le monde à voir ce que tu fais sur ton PC (En gros n'importe qui avec un vnc/ssh, pourrait t'observer) mais cela te permet de lancer des applis graphiques avec root.

"xhost -" n'authorise à accéder à ton interface graphique que les personnes qu'il connaît, à l'aide d'un login et d'un mot de passe, et root n'a pas le droit de lancer des applis graphique (konqueror, kwrite, ...).

Bref "xhost +" c'est une commande qui peut te dépanner de temps à autre. Rapide à taper et rapide à annuler avec "xhost -"(tu rappelles la fonction, tu remplaces le + par un -)

Sinon, vi n'est certes pas très user-friendly au premier abord, mais c'est comme tout dans linux (pas tapper :mdr:). Une fois que tu as l'habitude, tu ne peux plus t'en passer.

Pour les codecs, tu veras avec apt4rpm, chez moi, j'arrive à lire n'importe quel fichier contenant de la vidéo ou de la musique. (Je suis un fan d'anime, et les fansubs utilsent différents codecs pour la compression).

Link to post
Share on other sites

J'ai vraiment l'impression de n'y rien comprendre ...bon je me calme...sinon je retourne sous Mandrake là au moins je maitrise.Bon , il faut un début à tout...

1°)Dis moi si je me trompe mais APT4RPM c'est nécessaire pour utiliser apt get sous Suse c'est ça ?

Sinon j'ai du mal à voir le lien entre les deux...

Sous Debian c'est intégré d'office donc pas besoin de APT4RPM ...enfin c'est ce que je me dis ...

2°)Configurer le bureau -> Comportement -> Icone des périphériques

J'ai pas accès tout est grisé...

3°)"Yast mets tous les packages dans /var/lib/YaST2/you/ Sauvegardes"

cd /var/lib/YaST2/you/ Sauvegardes

ls

config cookies mnt scripts settings youlog youservers

Il me semble que j'ai rien ... j'ai pourtant installer des rpms hier à partir du site cité dans le forum en anglais.

4°)j'ai pas docbook4...c'est indispensable ?

Je comprends pas trop à quoi servent les 3 autres d'ailleurs dans ta doc.

Ca me parait compliqué tout ça par rapport à Mandrake.

Je suis un boulet...allez j'essaie de nouveau la clé...je te tiens au courant...

PS : autre problème : sous Mandrake ou Windows quand je file sur le site :

http://www.irlmeier.de/bird.swf

j'ai l'image et le son sous n'importe quel browser, sous Suse juste l'image avec Mozilla , avec Konqueror c'est bon.J'ai le plugin flash je précise.

;)

Link to post
Share on other sites

Re,

1°) J'utilise apt4rpm étant donnée que je n'arrive pas à demander à Yast de se connecter sur les bons serveurs afin de récupérer les rpms.

2°) Vi, heu tu as coché la 1er Case qui permet de tous dégriser ? ...

"Afficher les icônes des périphériques : "

3°) Apparement le chemin que je t'ai donné ne concerne que les fichiers installés via Yast Online Update. Je vais regarder où Yast pourrait bien mettre les fichiers dont tu me parles.

4°) Lorsque je fais une install des fichiers permettant d'installer apt4rpm, ces 4 paquets me sont demandés en tant que dépendances.

Je précise que c'est par rapport à une install standart de la SuSE 9.1 Pro. (5CDs ou 1DVD)

Comme tu fais cela par rapport au 1er CD de la version perso, il est possible qu'il y ai d'autre paquet que tu devras installer en plus pour régler les dépendances avec les paquets nécessaires à apt4rpm.

Sinon, zarbe ton prob, je viens de tester la page que tu m'as donné (merci :transpi: c'est trop drôle comme truc ^^) avec firefox, et je n'ai aucun problème.

J'ai installé mozilla 1.7 pour voir et pas de prob non plus.

Là je peux pas trop t'aider :/ Mis à part te dire que normallement ça devrait marcher (sutout si konqueror y arrive aussi)

@+ et n'hésite pas !

Guile.

PS : Si tu as msn ou jabber tu peux m'appeler :eeek2:

Link to post
Share on other sites

2°) Ok il fallait cocher ... green : -1 ...

Donc il y a un icône qui apparait bien à l'insertion de la clé (ça met longtemps par rapport à Mdk).Je clique dessus et il n'y a rien de détecté !

Je me mets en console en root, je tape : mnt /media

ls

cd usb-storage-C33 ...etc ...

Et là pareil il ne détecte rien, il affiche même pas le résultat d'ailleurs...il semble chercher...

J'ai remarqué que sous Mandrake quand j'insère la clé aussitôt /etc/fstab est complété, sous Suse le fichier ne subit aucune transformation.

Par contre, dans /etc/mtab la clé est reconnue ...

Et puis tout d'un coup j'ai un message comme quoi un nouveau disque dur a été détecté et on me demande si je veux l'ouvrir avec kfmclient (connais pas) alors je mets oui mais ça ne change strictement rien ...

Link to post
Share on other sites

Re,

Pour le /etc/fstab, c'est normal. Tu as une ligne avec subfs qui gère tous les périph à chaud comme les clés USB (oui c'est aussi une nouveauté, qui n'est peut-être pas dans la mandrake)

Il mets un peu de temps car il scanne le périphérique avant de le monter (un peu comme sous win, il recherche si il y a des images, des vidéos, des musiques, ...). Une fois le scan fini, konqueror l'ouvre (kfmclient).

Par contre, là tu me fais peur ! Si il ne trouve rien, c'est que soit il n'y a rien (sic !), soit il n'arrive pas à lire les données.

Essayes par exemple d'appuyer plusieurs fois sur F5 ou d'écrire dessus.

Essayes aussi en tant que root de faire un

# chmod 777 /media/usb-storage-C33...

Sinon, c'est quoi la marque de la clé ? la capacité ? Le format du fichier (Fat32 ? NTFS ?!?!)

Si tu n'arrives toujours pas à la lire, sauvegardes tes données, reformates là en fat32 et réessayes.

@+,

Guile.

PS : Au paasge mets ton système à jour, peut-être que ce problème a déjà été résolut par un patch. On ne sais jamais.

Link to post
Share on other sites

Ok je vois ça à midi.

Il y a bien qqchose sur la clé, Mandrake le détecte presque instantanément (des pps et des photos).

C'est du FAT 32 (vfat).

Subfs n'existe pas sous mandrake, mais bon ça marche bien sans, peut-être pour la 10.1 en septembre ?

Je vais essayer ce que tu me suggères.

C'est dommage, j'aurai bien vu Suse chez moi aux côtés de Mandrake...enfin rien n'est perdu...je lâche pas ...

Peut-être que le contenu du seul CD Suse ne suffit-il pas pour lire les clés ?, mais bon dans ce cas ça fait beaucoup de restrictions quand même, le mec qui a pas internet ne pourrra rien faire avec une distrib-démo qui lit pas les xvid, les divx, les dvd, qui n'intègre pas pas gcc etc ...

Globalement quand même ça me parait compliqué par rapport à Mandrake, j'ai un peu de mal, il y a pour le moment des problèmes (clé, flash) auxquels je n'avais jamais été confronté, mais bon c'est comme ça qu'on apprend...

Je te tiens au courant, en tout cas merci pour tout, sympa. :francais:

Link to post
Share on other sites

Salut,

Surtout n'oublie pas de mettre ta distrib à jour avec Yast Online Update (YOU).

(C'est un problème qui est peut-être déjà réglé)

Le but de ce CD est juste de démarré puis de faire le reste des installs via le net.

On pourrais comparer cela une net-install de Debian.

Enfin, c'est mon avis.

@+ et bonne chance :francais:

Guile.

[HS] C'est moi, ou il y a un problème avec l'heure des postes ? [/HS]

Link to post
Share on other sites

J'ai lu entre les lignes vite fait vos posts....

Ben, ce que j'en tire comme conclusion, c'est que je n'ai jamais installe Suse et je ne suis pas pret de le faire. Ca a l'air assez mal fait, i.e. loin de la vraie hierarchie de fichier Unix ( x BSD, Debian etc.... ) et en plus y a des tas de conneries. Je ne vois pas pourquoi root n'aurait pas le droit de faire qq applications qu'elle soit. Au contraire, root peut faire absolument tout ce qu'il veut sur tous les fichiers du systeme. donc executer tous les fichiers, meme si c'est fortement deconseille.

Je vais pas revenir sur tout, mais qd je vois un topic Suse green, j'ai pas tendance a me precipite dessus, desole !

Une precision, attention avec le xhost+, ca autorise l'acces a tous le monde sur la machine tout de meme, vaut mieux preciser le nom de la machine ( voire l'adresse ip ) que l'on autorise a se logger sur la machine, sinon c'est un trou de securite beant.

Vi est indispensable. installes Vim, c'est deja nettement plus conviviale.

Pour la clef usb, faut voir plus en detail, mais en general, si dans le noyau le pilote concernant le type de ta clef usb est mis ( ce qui doit etre fait dans une distribution grand public comme Suse ), il suffit de la monter :

mount -t vfat /dev/sda1 /<repertoire que tu veux, genre /clef²>

ensuite ben ls -lh /clef et tu verras tes fichiers.

Si jamais il ne trouve rien, branches ta clef, puis mail moi le fichier de log de boot, je regarderais si il la detecte ou non et je 'indiquerais alors quoi faire.

Enfin, pour ocnclure, si j'ai bien compris, on ne peut pas telecharger Suse pour l'installer de maniere classique ? J'entends le premier cd full, iso ?

Link to post
Share on other sites

Yop remy,

SuSE n'est pas mal fait, il respecte la norme LSB. Ne t'inquiète pas, il a de forte chance que la prochaine debian soit faite ainsi ^^. C'est juste que la Woody date un peu.

Pour root, il ne peut pas lancer d'appli graphique par défault sur la session d'un utilisateur (ce qui est pareil sous debian si je ne m'abuse). Dans son path par défault, root n'a pas les chemins lui permettant de lancer certaines applis sous X11 comme konqueror, kwrite (bref pas mal de log commençant par k :kimouss:). (je pense même que c'est la même chose sous debian).

Et pour finir, oui root peut tout faire et lancer n'importe quoi.

Je te conseille de l'essayer, c'est intéressant.

Link to post
Share on other sites
Ca a l'air assez mal fait, i.e. loin de la vraie hierarchie de fichier Unix ( x BSD, Debian etc.... )

+1

Une precision, attention avec le xhost+, ca autorise l'acces a tous le monde sur la machine tout de meme, vaut mieux preciser le nom de la machine ( voire l'adresse ip ) que l'on autorise a se logger sur la machine, sinon c'est un trou de securite beant.

+1, moi je dis qu'il vaut mieux faire ssh -X root@localhost quand c'est la merde :kimouss:

Pour la clef USB, moi je brache la clé usb (en même temps, ça me l'indique dans /var/log/messages), je fait mount /dev/sda(1? je sais plus...) /mnt/usb et c bon!

Link to post
Share on other sites

Re,

le problème avec le subfs, c'est que les périphériques externes ne sont plus appelé/monté par sdaX.

/dev/sdaX ne sera utilisé que pour les périph scsi.

Les changements arrivent mes amis :kimouss:

Pour info, la 9.0 à la même structure qu'une Debian Woody, mis à part pour le /media.

C'est la Woody qui est en retard, v'là tout :transpi:

/me court très vite avant de me faire frapper par des utilsateurs de la Debian ou de Gentoo ^^

Link to post
Share on other sites

:non::non::francais:

Ben je sais pas, mais perso je trouve pratique d'utiliser /dev/sdaX pour les clés usb...

Au moins c'est facile...

'fin bref, je pense que avec hotplug, il doit y avoir moyen de faire la même chose que subfs... ('faut que je vois ça...)

...et puis bon, comparer à une debian woody, ça va pas, non?

debian woody est toujours dépassée....

Link to post
Share on other sites


×
×
  • Create New...