Jump to content

[Résolu] Problème avec explorateur windows


Recommended Posts

Posted (edited)

Bonjour,

[Système d'exploitation Windows 10 Pro]

Je viens vers vous, car je rencontre un problème
1/ J'ai installé la mise à jour de VLC
2/ Lorsque je souhaite accéder à un DOSSIER exemple " Compta " ou autre, tous mes DOSSIER s'ouvre avec VLC et non plus avec l'explorateur de Windows
3/ J'ai désinstallé VLC puis fais un ménage registre ect... afin de supprimer tous se que VLC aurait pu laisser.
4/ J'ai redémarrer la machine.
5/ J'ai essayé d’accéder à mon dossier " Compta " et là aucun soucis mon dossier apparait normalement dans l'explorateur de Windows.
6/ J'ai essayé avec divers dossier cela marche normalement

Donc je me suis dis, vu que c'est revenu normal je vais réinstaller VLC

Ben après réinstallation le problème est de nouveau présent.

J'ai fais : Démarrer > Paramètres > Applications > Applications par défaut > Réinitialiser pour restaurer les valeurs par défaut recommandées par Microsoft > Redémarrer
Résultat : rien à changer
J'ai également tester le logiciel rstassociations mais rien à changer après un redémarrage.
J'ai ouvert VLC : Outils > Préférences > Réinitialiser les paramètres mais rien à changer

Je ne sais, si c'est lui qui à fait quelque choses mais y a quelques temps j'avais utilisé Q-Dir mais je ne m'en sert plus.

 

Je vous en remercie d'avance pour votre aide.

Bien cordialement.

 

Edited by Scorpio
Link to comment
Share on other sites

As-tu essayé de faire un clic droit sur le fichier en question?

Tu auras sûrement le choix du programme pour l'ouvrir à nouveau avec l'explorateur il faut choisir dans le menu : "ouvrir avec >"

Link to comment
Share on other sites

Bonjour,

Merci pour vos réponses

Si on fais une clique droit, non on a pas ouvrir avec (voir fichier joint)
Sur quel site ai-je récupérer VLC? Site de l'éditeur ICI version Windows 64Bits
 

clicd.png

Link to comment
Share on other sites

On dirait que tu as VLC comme application par défaut pour les répertoires. 

Peux-tu exporter ce que tu as dans la base de registres dans HKEY_CLASSES_ROOT\Directory\ et HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Directory\ (avec les sous-dossiers)?

Et vérifie que tu n'as rien dans HKEY_CLASSES_ROOT qui n'aurait pas de nom ou "." comme nom, ainsi que dans HKEY_LOCAL_MACHINE\SOFTWARE\Classes

Link to comment
Share on other sites

Bonsoir,

ci-joint les deux fichiers
HKEY_CLASSES_ROOT\Directory\
HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Directory

Il y a 4 heures, brice.wernet a écrit :

Et vérifie que tu n'as rien dans HKEY_CLASSES_ROOT qui n'aurait pas de nom ou "." comme nom, ainsi que dans HKEY_LOCAL_MACHINE\SOFTWARE\Classes


Dans HKEY_CLASSES_ROOT\. 
Nom de la clé :          HKEY_CLASSES_ROOT\.
Nom de la classe :        <Sans classe>
Heure de dernière écriture :   25/03/2021 - 15:58

 

Dans HKEY_LOCAL_MACHINE\SOFTWARE\Classes j'ai " * " mais pas " . "

Merci de votre aide

HKEY_CLASSES_ROOT-Directory.txt HKEY_LOCAL_MACHINE-SOFTWARE-Classes-Directory.txt

Link to comment
Share on other sites

Il y a 2 heures, Scorpio a écrit :

Dans HKEY_CLASSES_ROOT\. 

Nom de la clé :          HKEY_CLASSES_ROOT\.
Nom de la classe :        <Sans classe>
Heure de dernière écriture :   25/03/2021 - 15:5

Je n'ai rien vu dans les exports "Directory".

Par contre, ton HKCR\. est douteux.

Pour confirmer que c'est lui le problème:

  • Créer un dossier avec une extension (mondossier.dir)
  • Voir si le phénomène se produit avec ce répertoire

--> Si le phénomène ne se produit pas, l'entrée dans la base de registre est une/la cause.

Il faut donc réparer en 2 étapes:

  • Exporter la clé HKEY_CLASSES_ROOT\. par sécurité
  • L'effacer

Si tu veux être sûr de ne pas te tromper dans la manip, voici  deux lignes de commande (à lancer en admin):

  • Exporter dans sauvegarde.reg
reg EXPORT HKCR\. sauvegarde.reg
Citer

 

  • Supprimer
reg DELETE HKCR\.

 

Link to comment
Share on other sites

Ok, alors essaye ceci: enregistre le fichier suivant en .REG et fusionne le (ça rétablit la valeur par défaut correcte sur les deux clés):

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\Directory\shell]
@="none"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Directory\shell]
@="none"

 

Oups: vieux topic (11 ans): VLC opens when click a folder - The VideoLAN Forums

Je n'avais qu'une partie de la solution, il faut aussi le faire sur "Drive" d'après la dernière réponse.

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\Directory\shell]
@="none"

[HKEY_CLASSES_ROOT\Drive\shell]
@="none"

Et un reboot.

 

Ce n'est pas la faute de VLC, mais d'un logiciel précédent qui a supprimé la valeur par défaut.

Link to comment
Share on other sites

rebonjour,

Un grand merci, car tous remarche normalement après une modification et redémarrage.

Je ne met pas la faute sur VLC mais plus à Q-dir car c'est le seul logiciel utilisé.

Mais cela peut-être trompeur car quand :
on désinstalle VLC le double clic marcher normalement pour l'ouverture des dossiers
on réinstalle VLC cela pose problème.

J'espère que lors de la prochaine MàJ de VLC je n'aurais pas se soucis.

 

Encore Merci et si sa peut aider d'autre personnes c'est super.

Cordialement
Scorpio.

Link to comment
Share on other sites

  • Scorpio changed the title to [Résolu] Problème avec explorateur windows

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...