Jump to content

PC qui ne s'éteint pas toujours - Debian 10.5


Recommended Posts

Bonjour,

 

Sur une fresh install debian 10.5, sans aucune personnalisation particulière, sur un Lenovo E480 tout basique, j'ai un bug réccurrent: le PC freeze régulièrement sans s'éteindre quand je lui demande de se mettre en veille ou de s'éteindre.

Aucun périphérique externe connecté, BIOS paramétré en mode bon père de famille par défaut.

Ca me gêne, car depuis des années j'ai l'habitude de mettre en veille mes laptops quand je ferme le capot - mais dans le cas de cet ordi je me suis retrouvé avec le PC tout chaud dans la sacoche et la batterie vidée plusieurs fois. Du coup, je dois attendre que le PC soit réellement éteint pour le ranger, ou l'éteindre de force.

J'ai passé le PC en Linux car j'ai du matériel récent qui n'est pas tout à fait compatible avec Windows (une carte électronique chinoise dont les outils sous Windows sont un peu bâclés). Je n'ai pas encore installé tout le bin's (j'ai juste chargé platform.io).

 

Comment est-ce que je peux diagnostiquer ce genre de problème sous Linux?

Merci,

Link to post
Share on other sites
Il y a 1 heure, brice.wernet a écrit :

Comment est-ce que je peux diagnostiquer ce genre de problème sous Linux?

Le mieux est de faire un message sur le forum debian. Tu auras plus de personnes qui s'y connaissent.

Par contre, tu as essayé de faire une réinstallation de ton système?

Link to post
Share on other sites

Re, je viens aux nouvelles. As-tu résolu ton souci ou tu as le nez dans les tests de scripts maugréant sur ma possible mauvaise piste car ça plante encore plus qu'avant.

Edited by Chromosome3
Link to post
Share on other sites
  • 4 weeks later...

Maintenant, il freeze en marche 😞

Pas de log bien sûr, pas moyen de switcher vers la console texte.

Bref, grrrrr. Test mémoire OK, test SSD RAS. Je le reproduis assez facilement (1x /3) en copiant 65Go du NVMe vers le NVMe tout en scannant des fichiers via le WIFI. Mais surtout sur batterie (très difficile à reproduire sur secteur)

J'ai réessayé sous Windows (du coup je suis en multiboot maintenant): jamais de problème.

C'est agaçant. Je suis agacé.

Link to post
Share on other sites

Je n'installe jamais de debian. Les pilotes non free sont relou à installer.  J'ai fait une installe de Debian pour une amie. Quelle galère.

Debian c'est bien en serveur mais pas en client. Ubuntu c'est top, enfin, je préfère Mint ou du Arch Linux (Manjaro).

Sérieux format tout et passe sur Mint.

Link to post
Share on other sites

Je crois que je vais devoir y passer. J'utilise debian parce que je maîtrise un minimum les scripts de config, les sécu, et ça colle à mon serveur (je centralise les fichiers de mise à jour).

Mais bon, je peux installer un Mint et mettre un conteneur deb pour le dev. De toutes façons je bosse surtout sur des conteneurs.

--- Mais argh, Mint est gtk/gnome, moi je suis QT/Kde, c'est un cas de conscience ---

En même temps, j'ai contacté les supports Lenovo et Kingston. Le support Lenovo m'a envoyé sur les roses - c'est pas du Windows, le support Kingston a bien essayé mais ils ont moins d'arguments pour dire que leur stockage n'est certifié que Windows 🙂 

J'avais quitté Linux à cause d'un problème similaire sur Ubuntu 12, 8 ans plus tard je retombe sur un problème proche et je n'ai toujours aucun moyen de diagnostiquer 😞 

Et franchement, j'ai pas des PC exotiques: que de la plateforme Intel basique.

Edited by brice.wernet
Link to post
Share on other sites

Re,

 

Lors du plantage les touches magique permettent de faire un crashdump, c'est alt + imprim écran + c qui permet ça si bien sûr l'OS n'est pas planté jusqu'à la moëlle.

 

As tu tenté, sait on jamais d'installer les drivers graphiques (si tu es en intel HD 620) des backports.

Link to post
Share on other sites

Quand tu dis freeze, c'est le PC qui ne s'éteint pas, ou carrément tout le système qui bloque ?

Si c'est un blocage complet, ça peut être un problème de driver (la mise en veille est un processus complexe). Tu peux essayer de voir si tu as toujours le même problème avec un noyau plus récent. Pour ça tu peux installer le noyau depuis le dépôt backports comme expliqué sur cette réponse Stack Exchange.

Link to post
Share on other sites

@brice.wernet, regardes si ton proc n'est pas un baytrail de chez intel. Car ils ont des soucis en occurrence avec cette architecture. Alors si c'est le cas, tu es bon pour retourner sous windows; car cela fait au moins 6 ou 7 ans qu'ils essayent de chercher une solution. Les noyaux se succèdent et ça freeze toujours.

C'est les processeurs pentium mobile "baytrail" qui posent problème.

edit: je ne sais pas, je viens de regarder la fiche produit et je me suis trompé de modèle, sorry... 😶

Edited by ceric64
Link to post
Share on other sites
  • 2 weeks later...

Bon, suite et fin j'espère:

  • J'ai voulu vérifier que le SSD n'avait pas de mise à jour. Malheureusement, c'est un Kingston -> passage par Windows
    • Tout ça pour ça: RAS pas de mise à jour (déjà à jour)
  • J'ai laissé debian, mais j'ai installé le kernel 5.8 via les backports. Je ne suis pas fan, mais c'est pas un serveur

Depuis, RAS. J'ai quand même regagné un peu en autonomie (avant: 5h30, maintenant 6h/6h30 - ça reste en retrait de Windows: 7h30) - je verrai plus tard.

Link to post
Share on other sites

L'important c'est de ne plus freezer. Tu lui reproches quoi au kernel 5.8 des backports ? Au pire tu compiles un noyau aux oignons le temps que debian arrive en 5.8 la distrib sera sur Bulleye^^

Sur la stable je suis en 4.19 je sais plus quoi de mémoire (post après session jeu sur Windows, PoE ne veut plus fonctionner sur linux, flemme de vérifier).

 

Si ça reste stable et tout en 5.8, je suis preneur de retours.

Edited by Chromosome3
Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...