Jump to content
Arcy

[RESOLU] Partage Samba et droits d'écriture

Recommended Posts

Posted (edited)

Bonjour,

Au début de mon passage sous Linux (<3), j'avais choisi de faire une VM "Windows", avec tous les programmes qui ne sont pas compatibles Linux (pas de Wine ni de version dédiée).

Ca a bien fonctionné ... jusqu'au jour où j'ai réinstallé Linux, perdant au passage la configuration des VM de Virt-Manager. Bref, j'ai abandonné.

Et il y a quelques jours, j'ai cherché à me refaire de nouveau une VM mais en corrigeant les premiers défauts grâce au partage réseau : les données importantes restent dans leurs dossiers sous Linux, et les programmes Windows (VM) y accèdent via Samba.

Actuellement (et avec quelques arrachages de cheveux), le partage fonctionne mais seulement en lecture !

J'ai crée un utilisateur spécial partage, attribué un masque plutôt permissif pour l'écriture des fichiers et dossiers mais OSEF, que de la lecture.

Le partage dans /etc/samba/smb.conf

[monDossier]
        path = /home/arcy/Documents/Bases de données/monDossier
        writeable = yes
        browseable = yes
        valid users = userPartage
        create mask = 0660
        directory mask = 0660
        write list = userPartage

L'utilisateur de partage a été crée avec useradd et smbpasswd et il est membre du groupe sambashare.

Si vous avez une idée ...

 

😉

Edited by Arcy

Share this post


Link to post
Share on other sites

Salut,

As-tu vérifié les permissions du dossier en question ? Il faut que le propriétaire et le groupe soit au moins user-du-home et sambashare.

Si par exemple tu as comme propiro du home toto et groupe toto et que userPartage est membre de sambashare ça refusera carrément l'accès au partage.

Share this post


Link to post
Share on other sites

Bien vu !

Citer

Propriétaire : Voir et modifier
Groupe : Voir et modifier
Autres : Voir

Utilisateur : arcy
Groupe : arcy

Du coup, il faut que je (arcy) me mette dans le groupe sambashare pour que le partage puisse se faire en écriture ?

J'ai une boite "Droits d'accès avancés", je vais voir si je peux m'en servir pour autoriser partage à accéder en écriture (c'est une interface plus proche de celle de Windows).

Share this post


Link to post
Share on other sites
Posted (edited)

En théorie si arcy est déjà propriétaire et groupe du dossier ça devrait marcher.

Mais c'est vrai qu'il y avait une subtilité (tu utilises openmediavault ?) où il fallait cocher 2 fois lecture/lecture sur le dossier et le partage.

Perso, je fais tout en ligne de commande, même si j'ai utilisé un temps des distri spécial NAS, plus conviviales à l'utilisation.

Edited by renaud07

Share this post


Link to post
Share on other sites

Salut,

J'avais la même piste d'appartenance au groupe. Mais j'ai vu un autre détail: depuis samba 4, il faut utiliser pdbedit au lieu de smbpasswd

 

Mais je ne pratique pas samba depuis des années...

Share this post


Link to post
Share on other sites
Il y a 11 heures, renaud07 a écrit :

Mais c'est vrai qu'il y avait une subtilité (tu utilises openmediavault ?) où il fallait cocher 2 fois lecture/lecture sur le dossier et le partage.

Nop, je suis sous Kubuntu 18.04

Il y a 7 heures, brice.wernet a écrit :

J'avais la même piste d'appartenance au groupe. Mais j'ai vu un autre détail: depuis samba 4, il faut utiliser pdbedit au lieu de smbpasswd

J'ai vu la même chose pour pdbedit sauf que j'ai crée mon utilisateur de partage avec smbpasswd et je parviens bien à m'y connecter depuis Windows ...

Bref, j'ai pas encore fait la manip' pour les droits, je m'en occupe dés que j'ai le temps.

Share this post


Link to post
Share on other sites

Voilà ce qui a été fait :

  • Propriétaire du dossier : arcy:sambashare (groupe commun entre moi et userPartage)
  • Placement du chmod -R +x et chmod -R 1777 sur le dossier partagé
  • Ajout du paramètre ntlm auth = yes dans smb.conf et choix de l'option Sécurité réseau : niveau d'authentification LAN Manager = Envoyer uniquement une réponse NTLM version 2. Refuser LM et NTLM sur W10 (source : https://community.spiceworks.com/topic/2148301-samba-4-and-windows-10-file-sharing)
  • J'ai retenté la création de l'utilisateur avec smbpasswd -a userPartage et pdbedit -a userPartage.
  • J'ai arrêté le pare-feu.

Je parviens bien à accéder au dossier réseau (sous W10) avec le compte linux dédié mais pour écrire ou créer un fichier/dossier, il me réclame toujours une autorisation.

Share this post


Link to post
Share on other sites
Posted (edited)

Personne n'a d'idée ?

:pleure:

Edited by Arcy

Share this post


Link to post
Share on other sites
Posted (edited)

Hello,

 

Je viens de faire l'essai chez moi, j'avais pas activé sur Windows 10 l'accès aux partages par flemme et inutilité, mas pour voir suite à ce poste, et tout fonctionne, création et suppression de fichiers. je te mets ma config smb plus tard.

 

A+

 

Pour info, pour me co, j'ai utilisé, l'icône réseau, connecter lecteur réseau, cocher "se connecter à l'aide d'informations différentes".

remplissage du champs ""\\adresse IP\homes"

puis co au partage avec "utilisateur déclaré" puis "mdp"

 

Je vais manger et regarde ça ce soir

Edited by Chromosome3

Share this post


Link to post
Share on other sites

Re,

 

Voici ma conf, par contre le coup de la VM qui va piocher sur la machine hôte, vu que je fais pas de VM^^, la dernière que j'ai testée remonte à mes robes et était pour la gloire.

Citer

#
# Sample configuration file for the Samba suite for Debian GNU/Linux.
#
#
# This is the main Samba configuration file. You should read the
# smb.conf(5) manual page in order to understand the options listed
# here. Samba has a huge number of configurable options most of which
# are not shown in this example
#
# Some options that are often worth tuning have been included as
# commented-out examples in this file.
#  - When such options are commented with ";", the proposed setting
#    differs from the default Samba behaviour
#  - When commented with "#", the proposed setting is the default
#    behaviour of Samba but the option is considered important
#    enough to be mentioned here
#
# NOTE: Whenever you modify this file you should run the command
# "testparm" to check that you have not made any basic syntactic
# errors.

#======================= Global Settings =======================

[global]

## Browsing/Identification ###
   client max protocol = SMB3
   client min protocol = SMB2

# Change this to the workgroup/NT-domain name your Samba server will part of
   workgroup = WORKGROUP (ton groupe de travail)

#### Networking ####

# The specific set of interfaces / networks to bind to
# This can be either the interface name or an IP address/netmask;
# interface names are normally preferred
    interfaces = 127.0.0.1 eth0

# Only bind to the named interfaces and/or networks; you must use the
# 'interfaces' option above to use this.
# It is recommended that you enable this feature if your Samba machine is
# not protected by a firewall or is a firewall itself.  However, this
# option cannot handle dynamic or non-broadcast interfaces correctly.
   bind interfaces only = no

 

#### Debugging/Accounting ####
# This tells Samba to use a separate log file for each machine
# that connects
   log file = /var/log/samba/log.%m

# Cap the size of the individual log files (in KiB).
   max log size = 1000

# We want Samba to only log to /var/log/samba/log.{smbd,nmbd}.
# Append syslog@1 if you want important messages to be sent to syslog too.
   logging = file

# Do something sensible when Samba crashes: mail the admin a backtrace
   panic action = /usr/share/samba/panic-action %d


####### Authentication #######

# Server role. Defines in which mode Samba will operate. Possible
# values are "standalone server", "member server", "classic primary
# domain controller", "classic backup domain controller", "active
# directory domain controller".
#
# Most people will want "standalone server" or "member server".
# Running as "active directory domain controller" will require first
# running "samba-tool domain provision" to wipe databases and create a
# new domain.
   server role = standalone server

   obey pam restrictions = yes

# This boolean parameter controls whether Samba attempts to sync the Unix
# password with the SMB password when the encrypted SMB password in the
# passdb is changed.
   unix password sync = yes

# For Unix password sync to work on a Debian GNU/Linux system, the following
# parameters must be set (thanks to Ian Kahan <<kahan@informatik.tu-muenchen.de> for
# sending the correct chat script for the passwd program in Debian Sarge).
   passwd program = /usr/bin/passwd %u
   passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .

# This boolean controls whether PAM will be used for password changes
# when requested by an SMB client instead of the program listed in
# 'passwd program'. The default is 'no'.
   pam password change = yes

# This option controls how unsuccessful authentication attempts are mapped
# to anonymous connections
   map to guest = bad user

########## Domains ###########

#
# The following settings only takes effect if 'server role = primary
# classic domain controller', 'server role = backup domain controller'
# or 'domain logons' is set
#

# It specifies the location of the user's
# profile directory from the client point of view) The following
# required a [profiles] share to be setup on the samba server (see
# below)
;   logon path = \\%N\profiles\%U
# Another common choice is storing the profile in the user's home directory
# (this is Samba's default)
#   logon path = \\%N\%U\profile

# The following setting only takes effect if 'domain logons' is set
# It specifies the location of a user's home directory (from the client
# point of view)
;   logon drive = H:
#   logon home = \\%N\%U

# The following setting only takes effect if 'domain logons' is set
# It specifies the script to run during logon. The script must be stored
# in the [netlogon] share
# NOTE: Must be store in 'DOS' file format convention
;   logon script = logon.cmd

# This allows Unix users to be created on the domain controller via the SAMR
# RPC pipe.  The example command creates a user account with a disabled Unix
# password; please adapt to your needs
; add user script = /usr/sbin/adduser --quiet --disabled-password --gecos "" %u

# This allows machine accounts to be created on the domain controller via the
# SAMR RPC pipe.  
# The following assumes a "machines" group exists on the system
; add machine script  = /usr/sbin/useradd -g machines -c "%u machine account" -d /var/lib/samba -s /bin/false %u

# This allows Unix groups to be created on the domain controller via the SAMR
# RPC pipe.  
; add group script = /usr/sbin/addgroup --force-badname %g

############ Misc ############

# Using the following line enables you to customise your configuration
# on a per machine basis. The %m gets replaced with the netbios name
# of the machine that is connecting
;   include = /home/samba/etc/smb.conf.%m

# Some defaults for winbind (make sure you're not using the ranges
# for something else.)
;   idmap config * :              backend = tdb
;   idmap config * :              range   = 3000-7999
;   idmap config YOURDOMAINHERE : backend = tdb
;   idmap config YOURDOMAINHERE : range   = 100000-999999
;   template shell = /bin/bash

# Setup usershare options to enable non-root users to share folders
# with the net usershare command.

# Maximum number of usershare. 0 means that usershare is disabled.
#   usershare max shares = 100

# Allow users who've been granted usershare privileges to create
# public shares, not just authenticated ones
   usershare allow guests = yes

#======================= Share Definitions =======================

[homes]
   comment = Home Directories
   path = /ducouptonchemindepartagehein
   browseable = yes
   guest ok = no

# By default, the home directories are exported read-only. Change the
# next parameter to 'no' if you want to be able to write to them.
   read only = no

# File creation mask is set to 0700 for security reasons. If you want to
# create files with group=rw permissions, set next parameter to 0775.
   create mask = 0774 (je mettrais ça dans ton cas pour commencer, à affiner)

# Directory creation mask is set to 0700 for security reasons. If you want to
# create dirs. with group=rw permissions, set next parameter to 0775.
   directory mask = 0774 (je mettrais ça dans ton cas pour commencer, à affiner)

# By default, \\server\username shares can be connected to by anyone
# with access to the samba server.
# The following parameter makes sure that only "username" can connect
# to \\server\username
# This might need tweaking when using external authentication schemes
   valid users = user1, user2 (il faut qu'ils soient déclarés sur la machine hôte avec un simple adduser, le --no-create-home fonctionne)

# Un-comment the following and create the netlogon directory for Domain Logons
# (you need to configure Samba to act as a domain controller too.)
;[netlogon]
;   comment = Network Logon Service
;   path = /home/samba/netlogon
;   guest ok = yes
;   read only = yes

# Un-comment the following and create the profiles directory to store
# users profiles (see the "logon path" option above)
# (you need to configure Samba to act as a domain controller too.)
# The path below should be writable by all users so that their
# profile directory may be created the first time they log on
;[profiles]
;   comment = Users profiles
;   path = /home/samba/profiles
;   guest ok = no
;   browseable = no
;   create mask = 0600
;   directory mask = 0700

[printers]
   comment = All Printers
   browseable = no
   path = /var/spool/samba
   printable = yes
   guest ok = no
   read only = yes
   create mask = 0700

# Windows clients look for this share name as a source of downloadable
# printer drivers
[print$]
   comment = Printer Drivers
   path = /var/lib/samba/printers
   browseable = yes
   read only = yes
   guest ok = no
# Uncomment to allow remote administration of Windows print drivers.
# You may need to replace 'lpadmin' with the name of the group your
# admin users are members of.
# Please note that you also need to set appropriate Unix permissions
# to the drivers directory for these users to have write rights in it
;   write list = root, @lpadmin

J'avais galéré avec les différentes versions de Samba entre Ubuntu, Raspbian, Debian et Windows, à aller voir en tête de fichier, du coup j'avais zappé de configurer Windows à aller sur le partage, mais ça fonctionne pour moi. Y'a plus qu'à attendre le retour.

 

A+

Edited by Chromosome3

Share this post


Link to post
Share on other sites

perso, j'ai un partage depuis Debian vers W10 et ma conf est toute bête:
 

[global]
        workgroup = SAMBA
        security = user
        passdb backend = tdbsam
[downloads]
        comment = Downloads
        path = /srv/nfs4/downloads
        browseable = Yes
        writable = Yes
        public = Yes
        create mask = 0666
        directory mask = 0777
        force user = minikea

le partage est du coup lisible en anaonyme et en écriture si ouvert avec le compte samba minikea avec le bon password. pas de ntlm auth

  • Like 1

Share this post


Link to post
Share on other sites

Je comprend pas ce qui foire alors.

Je vais revérifier le fichier de conf, il doit forcément avoir une merde dedans.

Share this post


Link to post
Share on other sites

@Minikea

On 29/05/2020 at 00:13, Minikea a écrit :

perso, j'ai un partage depuis Debian vers W10 et ma conf est toute bête:
 


[global]
        workgroup = SAMBA
        security = user
        passdb backend = tdbsam
[downloads]
        comment = Downloads
        path = /srv/nfs4/downloads
        browseable = Yes
        writable = Yes
        public = Yes
        create mask = 0666
        directory mask = 0777
        force user = minikea

le partage est du coup lisible en anaonyme et en écriture si ouvert avec le compte samba minikea avec le bon password. pas de ntlm auth

Bon c'est sûr c'est plus succinct^^, j'ai la version pas full options mais pas très loin (sinon c'est le triple^^) et commentée et finalement peu de choses sont activées, mais bon autant être précis et vu comment j'avais galéré à configurer tout mon bazar, j'ai 2 pi et ma machine qui ont des partages accessibles par 3 pi (celui en plus y a accès par le kodi sur recalbox, les autres en partage croisés ainsi que ma machine en dual boot), le Kodi de la box et accessoirement par mon vieil eeepc en debian et un vieil ibook G4 sous ubuntu 16.04. L'accès se fait bêtement par les noms d'utilisateurs déclarés sur chaque partage. Le truc à l'époque était/est ? les histoires de versions de samba incompatibles entre elles avec l'histoire de smbv1 déactivé toussa, mais pas à jour sur tout les OS, bref une chierie, d'où le

## Browsing/Identification ###
   client max protocol = SMB3
   client min protocol = SMB2

 

en tête de fichier, chose qui a peut être évolué depuis l'élaboration de ma conf, j'ai vu passer un samba 4 pdbedit par l'ami Brice Wernet (qui est plus pointu que moi sans aucun doute), en tout cas ça fonctionne comme je l'entend.

 

On va voir comment Arcy s'en sort

Share this post


Link to post
Share on other sites

J'ai pas encore fait l'essai (des invités à la maison :dd:) mais l'effet est immédiat après avoir redémarrer les services smbd et winbindd ?

Share this post


Link to post
Share on other sites

Vi, quand tu relances, ça relit le smb.conf et applique les changements.


Édit : en farfouillant, Windows n'a pas smb v4. Source

Edited by Chromosome3
info supplémentaire

Share this post


Link to post
Share on other sites
On 29/05/2020 at 00:13, Minikea a écrit :

perso, j'ai un partage depuis Debian vers W10 et ma conf est toute bête:
 


[global]
        workgroup = SAMBA
        security = user
        passdb backend = tdbsam
[downloads]
        comment = Downloads
        path = /srv/nfs4/downloads
        browseable = Yes
        writable = Yes
        public = Yes
        create mask = 0666
        directory mask = 0777
        force user = minikea

le partage est du coup lisible en anaonyme et en écriture si ouvert avec le compte samba minikea avec le bon password. pas de ntlm auth

Bon, en reprenant cette config, ça a marché, j'ai pu créer un fichier.

Du coup, j'ai voulu rajouter les options valid user et write list pour voir : plus possible d'écrire.
Je commente ces deux options : toujours pas possible d'écrire.
Je retire les options : pas possible d'écrire.
Je redémarre la VM : idem
Je change le nom du partage : ça fonctionne ...
Je remet l'ancien nom : ça fonctionne plus ...

Je change pour un nouveau nom de partage et je remet les options qui déconnaient plus haut : ça fonctionne.

Bref, Windows doit conserver de son coté mes autorisations pour chaque partage et jamais les mettre à jour.

Edited by Arcy

Share this post


Link to post
Share on other sites

oui tout à fait. il faut faire un

net use /delete

sur le partage pour pouvoir le réutiliser avec un nom d'utilisateur (ou du moins des informations d'identification) différentes.

Share this post


Link to post
Share on other sites

Après plusieurs tentatives, ça fonctionne toujours.

J'ai pas tenté ta solution @Minikea, je veux pas foutre plus le bordel que ça :transpi:

Merci pour vos interventions 😉

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...