Jump to content
Nozalys

[Résolu] Virtualbox: virtualisation non détectée

Recommended Posts

Posted (edited)

Bonjour,

J'essaie en vain d'utiliser Virtualbox, mais celui-ci n'accepte plus aucune VM que j'avais créée avant la réinstallation totale de mon système il y a environ 1 an.

Quand je veux démarrer une VM j'ai l'erreur suivante : VMMR0_DO_NEM_INIT_VM failed // "VT-x is not available (VERR_VMX_NO_VMX)" // Error code E_FAIL (0x80004005)

  • J'ai vérifié dans le BIOS, les options de virtualisation sont pourtant bien activées, voici quelques-uns des paramètres dans la section CPU Features du BIOS :
    • Hyper-Threading: enabled
    • Active Processor Cores: all
    • Limit CPUID Maximum: disabled
    • Intel Virtualization Tech: enabled
    • Intel VT-D Tech: enabled
    • Hardware Prefetcher: enabled
    • Adjust Cache Line Prefetch: enabled
    • CPU AES Instructions: enabled
    • Intel Adaptive Thermal Monitor: enabled
    • Intel C-State: auto
    • C1E Support: disabled
    • Package C State Limit: auto
    • CFG Lock: enabled
    • SW Guard Extensions (SGX): software controlled
  • J'ai suivi un conseil répété à plusieurs endroits sur le web, j'ai désactivé la fonctionnalité Hyper-V de Windows
  • J'ai suivi d'autres conseils comme réduire le nombre de CPU et de RAM alloué à la VM
  • J'ai testé avec 4 types d'O.S. VM : Windows XP, Windows 7, Windows 10, Ubuntu, ainsi qu'avec une nouvelle VM, donc vide.
  • Je suis sous Windows 10 1909 avec un core i7-7700K, 32 GB de RAM, sur une MSI Z270 gaming M5 et ça fonctionnait avant de réinstaller WIndows
  • VirtualBox ne me laisse pas cocher la case "Activer VT-x/AMD-V imbriqué" qui est grisée, dans les paramètres processeur de mes VM.
  • La différence comparé à la situation avant réinstall, c'est que j'ai maintenant un compte admin et mon compte user, pour améliorer la sécurité. Ceci dit, même quand je lancer VirtualBox en mode administrateur, les VM ne démarrent pas.

 

Quelqu'un a-t-il une idée du problème ?

Merci,

Nozalys

 

 

Edited by Nozalys
résolu+faute

Share this post


Link to post
Share on other sites

Ton Windows est peut-être en mode hyperviseur. Un seul programme peut utiliser être hyperviseur avec VT-d et tout le toutim. Si c'est Windows, VirtualBox ne peut pas le faire.

C'est notamment activé si tu as activé Hyper-V, WSL 2 ou installé Visual studio pour faire du dev mobile. Comme tu dis que tu as un jour activé Hyper-V ça a pu rester.

 

Lance bcdedit et cherche la ligne "hypervisorlaunchtype":

  • Auto signifie que Windows fera de son mieux pour démarrer en mode hyperviseur
  • Off signifie que Windows n'est pas en mode hyperviseur (et donc que c'est dispo pour un autre système de virtu)

 

C:\WINDOWS\system32>bcdedit

Gestionnaire de démarrage Windows
---------------------------------
identificateur          {bootmgr}
device                  partition=\Device\HarddiskVolume2
path                    \EFI\Microsoft\Boot\bootmgfw.efi
description             Windows Boot Manager
locale                  fr-FR
inherit                 {globalsettings}
badmemoryaccess         Yes
default                 {current}
...
nx                      OptIn
bootmenupolicy          Standard
hypervisorlaunchtype    Auto

Pour le désactiver:

  • bcdedit /set hypervisorlaunchtype off
  • reboot

Mais c'est vrai que c'est la plaie si tu as parfois besoin d'avoir l'hyperviseur Windows (genre pour WSL2).

Share this post


Link to post
Share on other sites

Waou, merci ! Tu as résolu mon problème. :yes:

Ça fait environ 2 mois que je tourne en rond et je n'ai jamais croisé, dans mes recherches, quelqu'un parler de bcdedit...

En l’occurrence, sur mon PC perso, je ne fais pas de dév, donc pas de VS, et je n'utilise pas WSL... qui n'est pas activé non plus.

Share this post


Link to post
Share on other sites

depuis la 1803 de W10 c'est sensé marcher ensemble cf ce tuto

https://www.informatiweb.net/tutoriels/informatique/11-virtualisation/281--virtualbox-6-0-utiliser-virtualbox-et-hyper-v-simultanement-grace-a-l-api-d-hyper-v.html

mais effectivement ici vu qu'il est sur W7 c'est surement ça le problème

si tu veux vérifier que vt-d est disponible et activé correctement en hardware lance cpu-z et tu devrais voir que tu as VT-x

Share this post


Link to post
Share on other sites
Il y a 1 minute, ashlol a écrit :

mais effectivement ici vu qu'il est sur W7 c'est surement ça le problème

Ah, désolé, j'ai fait une erreur dans mon sujet -c'est corrigé-, je ne suis pas sous Win 7 mais sous Windows 10 bien évidement, en 1909. Du coup ça aurait dû fonctionner sans modification spéciale

Share this post


Link to post
Share on other sites

si tu suis le tuto que j'ai linké avec virtualbox 6.0.14 tu peux choisir paravirtualisation hyper-v comme option donc utilisera les API hyper-v donc il faut garder hyper-v et notamment la plateforme de l'hyperviseur windows d'activé dans les fonctionalités supplémentaire de windows. Comme cela ça te permet d'utiliser les deux mais virtualbox sera un peu plus lent mais fonctionnera.

Ici vu que t'avais désactivé hyper-v normalement c'est bien ce qu'il faut faire pour le libérer et pour pas que windows l'utilise mais ici en auto windows continue de l'utiliser comme l'a indiqué brice. Donc si tu n'utilise que virtualbox tu peux rester comme ça avec hyper-v désactivé mais si un jour tu veux utiliser hyper-v ou wsl(2) il te faudra faire comme cela.

Share this post


Link to post
Share on other sites
Il y a 3 minutes, Nozalys a écrit :

Ah, désolé, j'ai fait une erreur dans mon sujet -c'est corrigé-, je ne suis pas sous Win 7 mais sous Windows 10 bien évidement, en 1909. Du coup ça aurait dû fonctionner sans modification spéciale

Je confirme: tu n'es pas le seul pour lequel ça ne fonctionne pas. Mais il me semble qu'il faut changer un paramètre de Windows dans les stratégies de sécurité locale pour que ça puisse fonctionner (en tout cas pour VMWare, je ne suis pas grand fan de VirtualBox)

Par ailleurs le changelog de VirtualBox 6.1 indique qu'il y a eu une correction pour pouvoir lancer des VM au travers de Hyper-V.

Share this post


Link to post
Share on other sites
Il y a 11 minutes, brice.wernet a écrit :

Par ailleurs le changelog de VirtualBox 6.1 indique qu'il y a eu une correction pour pouvoir lancer des VM au travers de Hyper-V.

C'est à n'y rien comprendre, car j'utilise VirtualBox 6.1.2, donc ça aurait dû fonctionner sur ma "fresh install" quand j'avais Hyper-V + hypervisorlaunchtype=Auto + les VM de VBox configurées sur "paravirtualisation hyper-V".

En tout cas, la nouvelle situation me convient, et si je souhaite utiliser un jour WSL2, je sais où venir chercher l'information 🙂

Share this post


Link to post
Share on other sites

il y a bien une manip à faire comme indiqué dans le tuto il faut activer "plateforme de l'hyperviseur windows" dans les fonctionnalités supplémentaire de windows car ce n'est pas activé par defaut.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...