Jump to content
Sisko83

Problème Installe Linux Ubuntu/Mint

Recommended Posts

Je vais te faire un mini tuto, puisque personne au RV

 

Si t'es sur Debian (elle avait l'air de démarrer et au moins d'arriver à l'écran de login (sinon il faut que tu démarre en mode recovery), surtout tu ne lances pas de GUI, tu passes en mode terminal en tapant ctrl + alt + F1.

 

Les guillemets seront pour les commandes, on les tape pas hein

Tu as un joli terminal ou tu tapes ton login et mdp, puis tu tapes "su" puis entrée et tu rentres le mdp root. te voilà en Root, car tout va se faire en root

 

Maintenant on tape "apt update" on valide puis "apt upgrade" on valide, ça met à jour l'OS. Puis on tape "nano /etc/apt/sources.list"

 

Tu auras ça à peu de choses près, en jaune ce qu'il faut de similaire :

#

# deb cdrom:[Debian GNU/Linux 10.0.0 _Buster_ - Official amd64 NETINST 20190706-10:23]/ buster main

#deb cdrom:[Debian GNU/Linux 10.0.0 _Buster_ - Official amd64 NETINST 20190706-10:23]/ buster main

deb http://deb.debian.org/debian/ buster main contrib non-free
deb-src http://deb.debian.org/debian/ buster main contrib non-free

deb http://security.debian.org/debian-security buster/updates main contrib non-free
deb-src http://security.debian.org/debian-security buster/updates main contrib non-free

# buster-updates, previously known as 'volatile'
deb http://deb.debian.org/debian/ buster-updates main
deb-src http://deb.debian.org/debian/ buster-updates main

# This system was installed using small removable media
# (e.g. netinst, live or single CD). The matching "deb cdrom"
# entries were disabled at the end of the installation process.
# For information about how to configure apt package sources,
# see the sources.list(5) manual.
deb http://repository.mein-neues-blog.de:9000/ /

 

on sauvegarde avec la commande qui va bien en faisant ctrl + X (il demandera si tu veux sauvegarder)

 

Puis  "apt update && apt upgrade"

ensuite on installe les firmware "apt install firmware-linux-nonfree"

 

pour ta carte graphique, j'ai cru comprendre que tu avais une 1070 nvidia

"apt -y install nvidia-detect" tu auras une bafouille de check de ta carte, regarde si ça te semble bon puis "apt install nvidia-driver", ça installe et une fois fini on reboot "systemctl reboot"

 

On va ensuite attendre le retour de manip voir si ça roule

Si ça fonctionne ; Freecad et Repetier-host sont dans les dépôts de debian, donc parfaitement installables sans avoir à les compiler et roulez jeunesse

 

Edited by Chromosome3

Share this post


Link to post
Share on other sites

Pour plus d’explication. Debian utilise que des paquets/logiciels libre.  Pour les drivers spécifique (carte wifi/carte graphique), l'installation est à faire toi même.


PS  : Maintenant à l'installation de débian, il te demande si tu veux installer des pilotes non libre pour la carte wifi.
PS2 : Ubuntu/Mint doivent avoir les pilotes de Nvidia dans leurs dernière distribution.

 

 

Share this post


Link to post
Share on other sites

Merci beaucoup pour toutes ces infos et le mini tuto.

Encore désolé mais hier c'était pas gérable. Je test tout ça en rentrant tout à l'heure et je vous tiens au courant.

Merci encore.

Share this post


Link to post
Share on other sites

C'est quoi tes bugs ?

 

T'es sur quel environnement graphique ?

 

Il y a sans doute quelques réglages et autres à peaufiner. Ma dernière nvidia sur linux etait une Geforce 2 mx^^. Il faut scruter dans un premier temps les messages d'erreur au démarrage.

Share this post


Link to post
Share on other sites

Ben déjà le "trancheur" marche pas dans RépétierHost et ensuite c'est des petits blocage genre je peut pas cliquer sur une croix pour fermer un truc.

ENV: cinnamon si je ne me trompe pas.

Edited by SiskoKorobase

Share this post


Link to post
Share on other sites

Pour repetier host ou freecad je suis hors de mon champ de compétences, sur ce que j'ai lu repetier host demande un peu de configuration.

Pour cinnamon, idem, j'utilise Kde sur mon pc principal mais je le conseillerai pas sur clé usb car c'est un environnement un peu "lourd". J'ai lxde sur raspbian et Xfce sur un eeepc hors d'âge qui sont très adaptés aux configs légères asthmatique donc très légère et véloce, c'est ce que je mettrai sur un OS sur clé USB.

 

Ton cinnamon fonctionne correctement hors utilisation imprimante 3D ?

 

J'ai jamais utilisé Cinnamon, ni Mate ; j'ai plus mis mes doigts poilus sur gnome et donc ses dérivés depuis bien 10 ans hors tests à l'arrache ; mais j'accroche pas, les goûts et les couleurs^^.

Si le tuto à rempli son rôle et que tu as un OS exploitable, on est déjà pas mal. Il doit se réadapter pour Ubuntu ou mint, sans peut être avoir à toucher au source list ; à voir. On a au moins la clé de tes soucis.

 

Share this post


Link to post
Share on other sites

Ok je retiens pour les environnements , perso j'ai pris Cinnamon par défaut mais j'ai aussi l'habitude de Xfce et Mate.

Mon Debian fonctionne mais il est capricieux par moment surtout pour fermer des choses via la croix.

Pour RepetierHost j'ai bidouillé un truc et ça fonctionne par contre je n'ai plus la précision en 0.3 mm du coup je suis passé en 0.5 mais ça ne m'arrange pas vu que le but était de passer en 0.1

Pas grave je vais continuer à bidouiller le bouzin, toute façon y'a que comme ça qu'on apprend, puis Linux c'est pas mon dada mais je commence vraiment à me dire que je vais tout convertir (sauf peut être Steam et mes games).

Share this post


Link to post
Share on other sites

En tout cas l'imprimante tourne, j'ai déjà imprimé trois pièces pour l'instant , j'ai pas le réglage que je souhaite mais ça tourne et elle à plus parkinson.

Share this post


Link to post
Share on other sites

J'ai jamais eu de soucis sous Mate.

" Mon Debian fonctionne mais il est capricieux par moment surtout pour fermer des choses via la croix. " --> Réinstalle ton débian. xD



 

Share this post


Link to post
Share on other sites
Il y a 6 heures, trOmAtism a écrit :

J'ai jamais eu de soucis sous Mate.

" Mon Debian fonctionne mais il est capricieux par moment surtout pour fermer des choses via la croix. " --> Réinstalle ton débian. xD



 

Je viens de le faire et j'ai testé aussi avec Ubuntu dernière version, même problème de fermeture de programme.

L'imprimante 3D fonctionne plutôt bien à part le "trancheur" qui part en vrille par moment (testé avec Slic3R et CuraEngine).

A mon avis c'est du Hardware qui pose problème mais lequel ?

Share this post


Link to post
Share on other sites

Si sur windows, tu n'as pas de problème.  Et qu'il y a que sur linux qui freeze a un certain, tu dois avoir quelques chose qui ne fonctionne pas bien.

Sous linux, fait-il la même chose à blanc? C'est à dire juste après l'installation et sans installation de pilote (a part la cg).

Share this post


Link to post
Share on other sites

dmesg ne t'avance pas?

Si tu as des lags, ça peut être entre autres:

  • le logiciel qui pilote la fréquence CPU (soit trop lent sur le "ondemand" soit à l'inverse un problème lié à un overclock?)
  • soit de la synchro entre chipset/périphériques, là d'habitude dmesg est ton ami...

D'un autre côté, en utilisant sur clé USB il y a très régulièrement des lags, sauf à avoir une bonne clé sur un bon port isolé (pas d'autre périphérique sur le contrôlleur, et pas un contrôleur type "hub" en bout de chaîne sur la carte mère comme celui parfois "dédié" clavier/souris)

  • Like 1

Share this post


Link to post
Share on other sites

Une question bête : as-tu laissé dans ta partition une place pour l'efi ou uefi car sans cette partition ta distribution ne pourra pas se lancer.

Autre indice si ton proc est un "baytrail" (intel) passe ton chemin toute installation d'un système linux freeze quoi qu'il arrive car malheureusement intel reconnait des erreurs dans l'élaboration de cette architecture.

Edited by ceric64

Share this post


Link to post
Share on other sites
On 27/11/2019 at 20:12, brice.wernet a écrit :

dmesg ne t'avance pas?

Si tu as des lags, ça peut être entre autres:

  • le logiciel qui pilote la fréquence CPU (soit trop lent sur le "ondemand" soit à l'inverse un problème lié à un overclock?)
  • soit de la synchro entre chipset/périphériques, là d'habitude dmesg est ton ami...

D'un autre côté, en utilisant sur clé USB il y a très régulièrement des lags, sauf à avoir une bonne clé sur un bon port isolé (pas d'autre périphérique sur le contrôlleur, et pas un contrôleur type "hub" en bout de chaîne sur la carte mère comme celui parfois "dédié" clavier/souris)

Bonjour,

Pas trouvé de solution même en suivant toutes les étapes et recommandations/bidouillages.

Changé de clé, de port Usb, testé avec un DD neuf, avec ou sans overclock, reset du Bios, Pilote non-free........ect.

Il y a 12 heures, ceric64 a écrit :

Une question bête : as-tu laissé dans ta partition une place pour l'efi ou uefi car sans cette partition ta distribution ne pourra pas se lancer.

Autre indice si ton proc est un "baytrail" (intel) passe ton chemin toute installation d'un système linux freeze quoi qu'il arrive car malheureusement intel reconnait des erreurs dans l'élaboration de cette architecture.

Mon Cpu est un Haswell donc logiquement c'est Ok et la partition Uefi est bien présente.

En attendant de pouvoir trouver une alim et Cg pas chère pour monter un configue dédié , j'ai contourné (oui c'est moche) en repassant mon imprimante 3D sous Windows et là pas de problème.

Merci encore pour votre aide et le temps passé à me répondre.

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×
×
  • Create New...