Jump to content
asusien

bsod à répetition windows 10

Publications recommandées

On 20/01/2019 at 13:44, asusien a écrit :

Petit soucis, l’utilitaire de microsoft m’a mis la version 1509 -je ne peux même pas activer le bureau à distance !!!!!- 

Je relisais le fil. Windows 1509 sur une carte mère en Ryzen, je te conseille de réinstaller fissa une version plus contemporaine du matériel. Les patchs de 2017 pour la gestion d'énergie étaient de mémoire bien utiles et je doute que tous les patchs dédiés à AMD soient applicables sur une version de Windows de 2015.

Pas de bureau à distance -> tu n'a pas installé la pro mais la familiale.

--> Si tu es sûr d'avoir une licence pro, il va falloir passer par DISM pour changer d'édition - attention si tu n'es pas sûr de ton édition il faudra tout réinstaller, il n'y a pas de retour possible. (DISM /ONLINE /Set-TargetEditions puis DISM /ONLINE /Set-Edition:xxxx)

As-tu réussi à installer les pilotes NVidia?

Partager cette publication


Link to post
Share on other sites

Non, concernant les pilotes. Par sécurité, ce soir,  je réinstallerai mon win 10 et mettrai à jour mon post en conséquence. Mon support usb a été fait samedi, inutile de le refaire. Je vais format mon SSD puis installer win.

Modifié par asusien

Partager cette publication


Link to post
Share on other sites

J'ai aussi tiqué sur les UWD et j'ai trouvé cela: https://www.techpowerup.com/250415/psa-nvidia-installer-cannot-continue-on-windows-october-2018-update-and-how-to-fix-it

En ce moment nous sommes en période de transition entre les anciens pilotes et les nouveaux pilotes UWD. Chez Intel c'est relativement clair, on choisi de mettre les UWD. Visiblement pour NVidia c'est moins clair: NVidia fourni des pilotes "ancienne archi" et Windows installe des pilotes "nouvelle archi". Or, Windows ne sait pas remplacer des pilotes "nouveaux" par des "anciens"...

Dans ce cas, ce serait bien la 1809 et non la 1509 que tu as téléchargé. Et tu vas bien t'amuser pour installer les pilotes NVidia... et je ne serai pas d'une grande aide, je garde toujours les pilotes intégrés à Windows.

Une piste toutefois: avoir les pilotes NVidia sous la main et les installer avant que Windows n'aille chercher ses propres pilotes via windows update. Donc installer windows ans support réseau et n'activer le réseau qu'après avoir mis le pilotes. Sur un malentendu, ça peut marcher.

Partager cette publication


Link to post
Share on other sites
Il y a 5 heures, brice.wernet a écrit :

Une piste toutefois: avoir les pilotes NVidia sous la main et les installer avant que Windows n'aille chercher ses propres pilotes via windows update. Donc installer windows ans support réseau et n'activer le réseau qu'après avoir mis le pilotes. Sur un malentendu, ça peut marcher. 

Windows Update n'hésitera pas à revenir à une version antérieure d'un Nvidia ou autre s'il n'est pas au courant de l'existence de la version que l'on vient d'installer, peu importe QUAND/COMMENT la nouvelle version a été installée. Il m'a fait cela plus d'une fois, me faisant rager autant de fois. Cela fait qu'après chaque format, j'active DenyDeviceIDs Protocol, cf mon post plus avant. J'ignore pour les UWD mais je doute que Microsoft ait changé sa vaseuse logique de fonctionnement.

Mais en lisant cela je me demande si l'ordinateur portable hors-service devant moi avec une 940MX ne serait pas touché par un pilote nouvelle génération foireux : pas d'image une fois Windows chargé... du jour au lendemain. Le matériel est opérationnel d'après un Live USB avec les outils requis. Ou alors c'est juste une MAJ qui a encore foiré, comme d'habitude.

Toute installation convenable de Windows 10 NECESSITE DenyDeviceIDs. Vous vous arracherez bien moins les cheveux, je vous le garantis. Rien ne vaut la mise à jour manuelle des pilotes sur l'automatique.

Modifié par TheKillerOfComputer

Partager cette publication


Link to post
Share on other sites

J'ai installé trois fois ce soir, trois soucis différent -dont un bsod ; je change de méthode et retelecharge une iso  de la 1803 -la 1809 me fait peur - que je décompresserai moi même pour faire une usb bootable. je reformaterai mon ssd et repartirai sur une base propre en faisant une installe en débranchant tout mes autres disques satas et périphériques 

Je comprends beaucoup mieux mes soucis à présent. L'origine n'est donc pas une panne matériel comme le disait mes premiers bsod (ram incompatible ou défectueuse). 

 

@Thekillerofcomputer : en cherchant un peu on peut voir qu'il faut créer un clé dans ; 

  • HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\DeviceInstall\Restrictions\DenyDeviceIDs\DenyDeviceIDsRetroactive

 

Value Type REG_DWORD
Enabled Value 1
Disabled Value 0

Peux-tu me confirmer cela ? C'est sûrement la solution à mes soucis à faire au premier moment de l'ouverture de l'explorateur.

 

Encore merci à vous je vois le bout du tunnel 😉

 

Edit :

PS : ce que j'avais avec le pilote du 15/01/2019  (que je ne devrais plus avoir avec la nouvelle iso, je verrai demain)

nvi.PNG.6b97e131f90004936facd718a9c36bd8.PNG

Modifié par asusien

Partager cette publication


Link to post
Share on other sites
Il y a 2 heures, TheKillerOfComputer a écrit :

Windows Update n'hésitera pas à revenir à une version antérieure d'un Nvidia ou autre s'il n'est pas au courant de l'existence de la version que l'on vient d'installer, peu importe QUAND/COMMENT la nouvelle version a été installée. 

Ca ne m'est jamais arrivé avec une carte graphique, mais je n'utilise que les pilotes Windows - pour des raisons de compatibilité. Notamment dans les portables: les pilotes NVidia/AMD/Intel nous mettent bien en garde de n'installer que les pilotes du constructeur… qui sont parfois mal packagés! 

Par contre ça m'est arrivé avec des périphériques USB "noname", dont les identifiants me paraissaient douteux. Aucun pilote ne fonctionnait, je forçait un pilote compatible d'après les identifiants de compatibilité, et Windows me sortait un autre pilote après une update. Mais ça a été très rare et avec deux périphériques bas de gamme: carte Wifi et webcam. Je n'en n'ai pas voulu à Ms, car même sous Linux ils ne fonctionnaient que par intermittence.

Il y a 40 minutes, asusien a écrit :

PS : ce que j'avais avec le pilote du 15/01/2019  (que je ne devrais plus avoir avec la nouvelle iso, je verrai demain)

 

Clairement le message décrit par ceux qui se sont retrouvé avec un pilote UWD - malheureusement pour toi, si tu as des BSOD, tu as un problème relativement grave. Avec une utilisation quotidienne e plusieurs ordis, je n'ai pas eu de BSOD à part avec un CPU mort...

Partager cette publication


Link to post
Share on other sites
Il y a 14 heures, asusien a écrit :

@Thekillerofcomputer : en cherchant un peu on peut voir qu'il faut créer un clé dans ; 

  • HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\DeviceInstall\Restrictions\DenyDeviceIDs\DenyDeviceIDsRetroactive

 

Value Type REG_DWORD
Enabled Value 1
Disabled Value 0

Peux-tu me confirmer cela ? C'est sûrement la solution à mes soucis à faire au premier moment de l'ouverture de l'explorateur.

Je crois que la seule fois que j'ai activé cette clé, ça a causé la suppression des pilotes déjà installés du fait justement du rétroactif, donc même les miens installés manuellement...

Si le pilote UWD Nvidia s'est installé après avoir débranché le câble réseau, activé DenyDeviceIDs, et fait le reboot requis... c'est que soit la carte vidéo n'a pas été bien intégré dans la liste (mauvais numéro copié ? c'est vrai que le lien que j'avais mis est en anglais, il faut copier les valeurs de la section "Numéros d'identification du matériel" de chaque périphérique concerné), soit peut-être que dans le cas des pilotes UWD alors la GPO est ignorée (ce ne serait pas la première fois qu'une stratégie est rendue inutile sans aucune indication contraire). Ou alors peut-être faut-il aussi activer la stratégie Ne pas inclure les pilotes dans les mises à jour (lien) mais en principe elle est ignorée depuis 2017.

Il y a 13 heures, brice.wernet a écrit :

Ca ne m'est jamais arrivé avec une carte graphique, mais je n'utilise que les pilotes Windows - pour des raisons de compatibilité. Notamment dans les portables: les pilotes NVidia/AMD/Intel nous mettent bien en garde de n'installer que les pilotes du constructeur… qui sont parfois mal packagés!

Ça m'a contraint à reformater pas mal de fois juste pour trouver les stratégies utilisables permettant de le stopper dans son élan. Je ne suis pas le seul à avoir subi cela à en croire Internet.

Ou alors j'ai toujours eu la malchance d'avoir un pilote que Microsoft ne connaissait pas... Ou ce dernier a simplement considéré qu'il fallait désactiver toutes les stratégies relatives au bloquage des updates de pilotes, sauf DenyDeviceIDs. Tout le monde doit avoir les derniers selon eux  alors que comme beaucoup je suis un adepte du "on ne touche pas à un système informatique qui fonctionne"...

J'ai aussi parfois l'impression que Windows sépare les concepts de 1ère installation d'un périphérique et celle de mise à jour d'un pilote. Il faudrait que je teste ça... mais formater régulièrement c'est pénible à force...

Modifié par TheKillerOfComputer

Partager cette publication


Link to post
Share on other sites

J'ai format le disque dur et install directement la 1803 depuis l'usb; installé mes drivers sans problème et apparemment sa marche ; à voir avec le temps. (les version 17** de W10, ne doivent plus supportés les derniers drivers de certains constructeurs. Pourquoi? forcer les gens à monté en version....)

 

 

Modifié par asusien

Partager cette publication


Link to post
Share on other sites
il y a une heure, asusien a écrit :

J'ai format le et install directement la 1803 depuis l'usb; installé mes drivers sans problème et apparemment sa marche ; à voir avec le temps. (les version 17** de W10, ne doivent plus supportés les derniers drivers de certains constructeurs. Pourquoi? forcer les gens à monté en version....)

Windows 10 permet encore de faire tourner des ordis qui ont plus de 10ans. Microsoft fait évoluer son infrastructure de pilotes pour avancer sur un noyau plus général - surtout j'imagine pour préparer le passage à ARM au lieu de X86 et unifier certaines options présentes dans les panneaux de contrôle de chaque fabricant.

Dans le cas des pilotes NVidia, NVidia propose uniquement un pilote "ancienne formule" et Microsoft un "nouvelle formule". Le rollback "automatique" n'est pas supporté, il faut le faire manuellement. C'est parfaitement justifiable dans le cadre d'un changement d'infra de pilotes, et considérant le bazar que les pilotes des fabricant peut mettre dans Windows (je n'utilise jamais de pilote de fabricant à cause de cela et de la lourdeur qu'ils entraîne - comme monopoliser 300Mo de RAM juste pour afficher une icône en bas à droite et gérer des options qui existent déjà sous Windows par ailleurs).

-> C'est un problème de synchro des équipes. Soit Microsoft a sorti le pilote UWD trop tôt, soit NVidia est en retard pour la publication.

-> C'est pas un complot pour forcer les gens à changer de PC. D'ailleurs, le 1809 marche toujours très bien sur mon Core 2 Duo et sur un autre portable avec dont la carte graphique n'est plus supportée par le fabricant depuis Vista...

Partager cette publication


Link to post
Share on other sites

Je reviens après plusieurs jours d'utilisation. 

Les bsod continu : SYSTEM_SERVICE_EXCEPTION

Après des lectures sur des forums en anglais, ce bsod serait dû à des mise à jour windows qui merde avec les CPU AMD. 

Si quelqu'un à le même soucis que moi, voici les KB qu'il faut (à vérifier) désinstaller

-2778344 

-2805940

- 2799494

- 2790655

- 2778344

- 2803676 
 

Je testerai et mettrai ce jour ce post en conséquence. 

 

 

Partager cette publication


Link to post
Share on other sites

Veuillez vous connecter pour commenter

Vous serez en mesure de laisser un commentaire après vous être connecté



Se connecter dès maintenant

×