Jump to content

Switch qui perd le débit?


Recommended Posts

Bonjour,

Ma connexion réseau me permet d'avoir du ~715mb/s. Pas de problème... jusqu'à un certain point où mon débit chute à ~80mb/s.

Ce n'est pas la connexion internet: si je branche un pc directement à la box, j'ai le débit. Il s'agit d'un switch sur le chemin réseau: le je redémarre et hop, le débit revient... jusqu'à ce qu'il chute à nouveau.

J'ai changé de switch. Et rebelote! Même problème.

Mon réseau suit ce chemin:

Box => Routeur (c'est mon DHCP, mon réseau interne reste up même si je change d'opérateur ou de box) => Switch (consoles, mediacenter, tv,...) => mur => Switch (dispatche dans les pièces, il est au niveau du DTI, c'est lui qui merde) => Switch 1 (bureau) => Switch 2 (buereau) => Brassage => PCs

Pfiou! Oui, c'est un peu moisi au niveau du bureau avec les 2 switch, mais il y a 2 zones de PC... Oui, oui, je suis un particulier, pas une PME 😄

 

Bref, c'est le switch DTI qui merde, mais je ne vois pas de raison à ça. Un switch, ok, il a défaut, il déconne (il était vieux mais en Gb). Un deuxième neuf idem. C'est soit que je suis maudit, soit il y a une cause externe.

A noter: le switch DTI est enfermé dans le compteur électrique.

 

Avez-vous des pistes, rencontré déjà un tel souci?

 

Merci d'avance

Edited by HPact
Link to comment
Share on other sites

Comme il est peu probable que 2 switchs soient défaillants (pas impossible, cependant), je suspecte plus un goulot d'étranglement entre les switchs.

Exemple si ton PC charge à 800Mb mais qu'un autre appareil en aval essaie aussi de charger, et bien ton lien entre les switch est partagé par exemple 50/50, et ton débit tombe à 400, ainsi de suite.

Il suffit selon ta description de démarrer un netflix et pouf le bureau se content des miettes, surtout si tu as un QoS pour prioriser le média.

Link to comment
Share on other sites

  • 3 weeks later...

De retour après des congés... Merci pour vos réponses.

Alors, pour isoler le problème, c'est simple: j'ai débranché tout le reste, il ne restait plus sur le réseau que mon PC. Débit moisi => Reboot switch => Débit ok. Après quelques temps pouf, chute du débit. J'ai testé le reboot des autres éléments (routeur/switchs) sans aucun effet sur le débit. J'ai même bypassé les 2 switchs du bureau (en me branchant directement sur la prise murale) sans succès.

Mon switch actuel: D-link DGS-108

Le seul switch manageable est le "bureau 2". Je regarderais à nouveau ce soir.

Link to comment
Share on other sites

Donc avec Box => Routeur => Switch (consoles, mediacenter, tv,...) => mur => PC , tu continuais à avoir le problème ?

Si oui il faudrait passer à l'étape :
a) Box => Routeur => Switch (consoles, mediacenter, tv,...) => PC et si ça ne fonctionne toujours pas
b) Box => Routeur => PC

Link to comment
Share on other sites

Si on fait la synthèse de tes tests, c'est entre le switch média et la prise murale du côté switch DTI que ton soucis est.

Alors, soit ce sont les fils, soit les prises mâles ou femelles. Test de confirmation : faire un nouveau câble Cat5 flottant et brancher le switch DTI au switch média directement.

 

Link to comment
Share on other sites

Première hypothèse: cablage/isolation car ce que tu décrit ressemble à un port d'un switch qui se renégocie en 100Mb/s au lieu de 1Gb/s suite à un évènement (qualité de signal).

--> il faut vérifier que tout est configuré en Gb de bout en bout

--> une fois le lien identifié:  vérifier les prises, changer les cables.

Pour vérifier:

  • Commencer par le plus simple: quand le débit chute, regarde le débit maxi théorique du lien réseau sur l'ordi dans les caractéristiques ethernet, le perfmon ou "wmic NIC where NetEnabled=true get Name, Speed". Si c'est 100Mb/s, c'est entre le PC et le switch que ça se passe.
  •  Ensuite vérifier la config des ports au niveau des switch, et checker les logs des switchs s'il y en a

Pour réparer:

  •  Changer le cable si possible pour voir si ça résout le problème (parfois inverser des cables peut aider si c'est un "ajustement" des prises qui est défaillant)
  •  changer de prise niveau switch si c'est possible
  •  Vérifier les prises murales si ce n'est toujours pas résolu
  •  non recommandé: forcer les prise au Gb sur les switchs
  •  Problème: c'est long car c'est intermittent...

 

Link to comment
Share on other sites

Le PC indique toujours 1Gb/s sur le lien.

 

Merci pour vos réponses. Je vais revendre l'appart d'ici quelques mois, donc, je ne vais pas me prendre la tête, un reboot par semaine, c'est pas la mort. La maison qu'on va faire construire sera prévue à la base pour éviter les multi-switchs comme ça.

Link to comment
Share on other sites

Au cas où quelqu'un ayant un problème similaire passerait par ici sachez qu'il existe des testeurs de câble RJ45.

L'appareil est en deux parties, tu en met une partie à chaque bout et le boitier te donne les infos du câble : affaiblissement du signal, si des brins sont sectionnés, etc... 

Link to comment
Share on other sites

J'ai un testeur basique qui vérifie uniquement que tout les brins fonctionnent (ce qui est mon cas). Je cherchais un truc pas cher pour tester le bon fonctionnement des câbles que je monte. Vu les distances, l'affaiblissement est loin d'être ma préoccupation, bien que l'oxydation du câble pourrait augmenter cet affaiblissement je pense.

Link to comment
Share on other sites

Oui mais si ton câble est court (- de 50m) et que tu as un fort affaiblissement on peut en déduire que le câble est pincé quelque part dans le mur.

Dans ce cas, cet appareil te permet de vérifier ce cas de figure.

Note : l'appareil coûte cher (si c'est pour une seule utilisation).

Link to comment
Share on other sites

Oui, le prix m'a refroidi pour avoir le top...

La possibilité d'un pincement n'est pas inexistante: j'ai fait passer le RJ45 dans la gaine du RJ11 moi-même, et certains passages étaient très tendu, il a fallu tirer fort sur l'aiguille. Donc je pense qu'il y a au moins un coude un peu hard quelque part sur le chemin du câble qui va au bureau. Je vais tester en mettant un autre câble en extérieur qui va courir de ce switch au bureau.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...